- Fix biuld with clang

- Add LICENSE
- Support staging

PR:		ports/184904
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
Pawel Pekala 2013-12-24 14:42:35 +00:00
parent 13168778aa
commit caca19fd67
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=337357
4 changed files with 37 additions and 14 deletions

View file

@ -9,22 +9,27 @@ MASTER_SITES= SAVANNAH CENKES
MAINTAINER= ports@FreeBSD.org
COMMENT= Compresses text to human readable output
NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|g++|${CXX}|;s|-O2|${CFLAGS}|' \
${WRKSRC}/${MAKEFILE}
LICENSE= GPLv2 # (or later)
MAN1= ${PORTNAME}.1
MLINKS= ${PORTNAME}.1 humanunzip.1
PLIST_FILES= bin/${PORTNAME} bin/humanunzip
PORTDOCS= CHANGELOG README TODO
PLIST_FILES= bin/humanunzip bin/humanzip \
man/man1/humanunzip.1.gz man/man1/humanzip.1.gz
post-patch:
@${REINPLACE_CMD} -e \
's|g++|$${CXX}| ; \
s|-O2|$${CFLAGS}|' ${WRKSRC}/${MAKEFILE}
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/human*zip ${PREFIX}/bin/
@${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
.ifndef NOPORTDOCS
@${INSTALL} -d ${DOCSDIR}/
@cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
.endif
.for i in humanzip humanunzip
(cd ${WRKSRC} && ${INSTALL_PROGRAM} ${i} ${STAGEDIR}${PREFIX}/bin)
.endfor
(cd ${WRKSRC} && ${INSTALL_MAN} humanzip.1 \
${STAGEDIR}${MAN1PREFIX}/man/man1)
${LN} -sf humanzip.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/humanunzip.1
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
(cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
.endfor
.include <bsd.port.mk>

View file

@ -0,0 +1,10 @@
--- humanunzip.cpp.orig
+++ humanunzip.cpp
@@ -22,6 +22,7 @@
#include <fstream>
#include <sstream>
#include <vector>
+#include <unistd.h>
#include <sys/stat.h>
#include "humanzip.h"

View file

@ -0,0 +1,9 @@
--- humanzip.cpp.orig
+++ humanzip.cpp
@@ -24,6 +24,7 @@
#include <getopt.h>
#include <vector>
#include <iomanip>
+#include <unistd.h>
#include <sys/stat.h>
#include "humanzip.h"

View file

@ -9,5 +9,4 @@ print size of documents. Humanzip does not explictly try to reduce the
size of the file as measured in bytes, although this usually happens
incidentally.
Author: Matthew Strait
WWW: http://savannah.nongnu.org/projects/humanzip/