- Fix MASTER_SITES.

- Unbreak on 5.x.

PR:		ports/78363
Submitted by:	Johan van Selst <johans@stack.nl>
Approved by:	pav (mentor)
This commit is contained in:
Florent Thoumie 2005-03-03 16:04:25 +00:00
parent 66916a8e8d
commit cb086cceb9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=130276
2 changed files with 13 additions and 8 deletions

View file

@ -9,7 +9,8 @@ PORTNAME= larbin
PORTVERSION= 2.6.3
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.sourceforge.net/pub/sourceforge/larbin/
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A powerful HTTP crawler with an easy interface
@ -17,20 +18,13 @@ COMMENT= A powerful HTTP crawler with an easy interface
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
makedepend:${X_IMAKE_PORT}
BROKEN= Unfetchable
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
PATCH_WRKSRC= ${WRKSRC}/src
MAKE_ARGS= CXX=${CXX}
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
BROKEN= "Does not compile on FreeBSD >= 5.x"
.endif
post-patch:
@${SED} -e 's,CC=,CC?=,' -e 's,CFLAGS=-O3,CFLAGS+=,' < \
${WRKSRC}/adns/Makefile > ${WRKSRC}/adns/Makefile.new

View file

@ -0,0 +1,11 @@
--- adns/internal.h.orig Thu Mar 3 16:00:32 2005
+++ adns/internal.h Thu Mar 3 16:02:10 2005
@@ -567,7 +567,7 @@
} parsedomain_flags;
adns_status adns__parse_domain(adns_state ads, int serv, adns_query qu,
- vbuf *vb, parsedomain_flags flags,
+ vbuf *vb, adns_queryflags flags,
const byte *dgram, int dglen, int *cbyte_io, int max);
/* vb must already have been initialised; it will be reset if necessary.
* If there is truncation, vb->used will be set to 0; otherwise