* Don't do patch + sed for PREFIX-related changes, just use sed in one pass
* Update to Makefile COMMENT * Take advantage of pkg-message to hit both ports and package installs * Thanks to work done by winter to make ispell do reasonable things when invoked as 'spell', properly define the speller for pico, and add a default speller for the pine.conf. The reason for the latter is to take advantage of the (arguably) superior behavior of ispell when files are piped to it. * Do to the speller updates, grow a dependency on ispell and bump the revision. * Add readme and copyright to portdocs
This commit is contained in:
parent
21cd0c2b8c
commit
cb53c632e8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=76941
8 changed files with 53 additions and 248 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= pine
|
||||
PORTVERSION= 4.53
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= mail news
|
||||
MASTER_SITES= ftp://ftp.cac.washington.edu/pine/ \
|
||||
http://mirror.sit.wisc.edu/pub/net/mail/pine/ \
|
||||
|
@ -19,6 +20,9 @@ MASTER_SITES= ftp://ftp.cac.washington.edu/pine/ \
|
|||
DISTNAME= pine${PORTVERSION}
|
||||
|
||||
MAINTAINER= DougB@FreeBSD.org
|
||||
COMMENT= PINE(tm) -- a Program for Internet News & Email
|
||||
|
||||
RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
|
||||
|
||||
# Define "WITH_LDAP" to include ldap support.
|
||||
# If the ldap port is installed somewhere other than /usr/local, define
|
||||
|
@ -49,16 +53,16 @@ pre-fetch:
|
|||
.endif
|
||||
|
||||
post-patch:
|
||||
.for file in doc/pine.1 pine/init.c pine/pine.hlp pine/mailcap.c \
|
||||
pine/osdep/os-bsf.h
|
||||
@${CP} ${WRKSRC}/${file} ${WRKSRC}/${file}.presed
|
||||
@${SED} -e "s:@@PREFIX@@:${PREFIX}:g" ${WRKSRC}/${file}.presed > \
|
||||
${WRKSRC}/${file}
|
||||
.endfor
|
||||
@for i in ${WRKSRC}/doc/tech-notes.txt \
|
||||
${WRKSRC}/doc/tech-notes/*.html ; do \
|
||||
@for i in ${WRKSRC}/README ${WRKSRC}/doc/pine.1 \
|
||||
${WRKSRC}/doc/tech-notes.txt ${WRKSRC}/doc/tech-notes/*.html \
|
||||
${WRKSRC}/pico/osdep/os-bsf.h \
|
||||
${WRKSRC}/pine/init.c ${WRKSRC}/pine/mailcap.c \
|
||||
${WRKSRC}/pine/osdep/os-bsf.h ${WRKSRC}/pine/pine.hlp ; do \
|
||||
${CP} $$i $$i.presed ; \
|
||||
${SED} -e "s:/usr/local/lib/:${PREFIX}/etc/:g" \
|
||||
${SED} -e "s:/usr/local/etc/:${PREFIX}/etc/:g" \
|
||||
-e "s:/usr/local/lib/:${PREFIX}/etc/:g" \
|
||||
-e "s:@@PREFIX@@:${PREFIX}:g" \
|
||||
-e "s:/usr/local/pine.conf:${PREFIX}/etc/pine.conf:g" \
|
||||
$$i.presed > $$i ; \
|
||||
done
|
||||
.if defined(WITH_LDAP)
|
||||
|
@ -80,6 +84,8 @@ do-install:
|
|||
.if !defined(NOPORTDOCS)
|
||||
${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} ${DOCSDIR} \
|
||||
${DOCSDIR}/tech-notes
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/CPYRIGHT ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/brochure.txt ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/tech-notes.txt ${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/tech-notes/*.html ${DOCSDIR}/tech-notes
|
||||
|
@ -89,10 +95,6 @@ post-install:
|
|||
${PREFIX}/bin/pine -P ${PREFIX}/etc/pine.conf -conf >${WRKSRC}/pine.conf
|
||||
${INSTALL_DATA} ${WRKSRC}/pine.conf ${PREFIX}/etc/pine.conf
|
||||
|
||||
@${ECHO_MSG}
|
||||
@${ECHO_MSG} "***************************************************************************"
|
||||
@${ECHO_MSG} "*** To use pgp with Pine, take a look at the mail/pine-pgp-filters port ***"
|
||||
@${ECHO_MSG} "***************************************************************************"
|
||||
@${ECHO_MSG}
|
||||
@${CAT} pkg-message
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,22 +1,5 @@
|
|||
*** pine/osdep/os-bsf.h.orig Thu Oct 8 00:51:40 1998
|
||||
--- pine/osdep/os-bsf.h Tue Feb 9 20:15:18 1999
|
||||
***************
|
||||
*** 74,80 ****
|
||||
default-composer-hdrs or customized-hdrs to get at it. Instead of
|
||||
defining NEVER_ALLOW_CHANGING_FROM, an easier way of preventing From
|
||||
changing is to put the feature "no-allow-changing-from" in the
|
||||
! /usr/local/lib/pine.conf.fixed file.
|
||||
----*/
|
||||
/* #define NEVER_ALLOW_CHANGING_FROM */
|
||||
|
||||
--- 74,80 ----
|
||||
default-composer-hdrs or customized-hdrs to get at it. Instead of
|
||||
defining NEVER_ALLOW_CHANGING_FROM, an easier way of preventing From
|
||||
changing is to put the feature "no-allow-changing-from" in the
|
||||
! @@PREFIX@@/etc/pine.conf.fixed file.
|
||||
----*/
|
||||
/* #define NEVER_ALLOW_CHANGING_FROM */
|
||||
|
||||
*** pine/osdep/os-bsf.h.orig Tue Feb 6 17:30:45 2001
|
||||
--- pine/osdep/os-bsf.h Wed Mar 5 05:30:16 2003
|
||||
***************
|
||||
*** 87,93 ****
|
||||
NOTE: You'll also have to make sure the appropriate osdep/postreap.*
|
||||
|
@ -35,24 +18,16 @@
|
|||
|
||||
|
||||
***************
|
||||
*** 160,167 ****
|
||||
|
||||
|
||||
/*----- System-wide config file ----------------------------------------*/
|
||||
! #define SYSTEM_PINERC "/usr/local/lib/pine.conf"
|
||||
! #define SYSTEM_PINERC_FIXED "/usr/local/lib/pine.conf.fixed"
|
||||
|
||||
|
||||
|
||||
--- 160,167 ----
|
||||
|
||||
|
||||
/*----- System-wide config file ----------------------------------------*/
|
||||
! #define SYSTEM_PINERC "@@PREFIX@@/etc/pine.conf"
|
||||
! #define SYSTEM_PINERC_FIXED "@@PREFIX@@/etc/pine.conf.fixed"
|
||||
|
||||
|
||||
*** 203,208 ****
|
||||
--- 203,210 ----
|
||||
#define DF_KBLOCK_PASSWD_COUNT "1"
|
||||
#define DF_REMOTE_ABOOK_HISTORY "3"
|
||||
|
||||
+ #define DF_SPELLER "@@PREFIX@@/bin/ispell"
|
||||
+
|
||||
/*----------------------------------------------------------------------
|
||||
The default printer when pine starts up for the first time with no printer
|
||||
----*/
|
||||
***************
|
||||
*** 268,274 ****
|
||||
8
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
*** pico/osdep/os-bsf.h.orig Wed Feb 7 14:53:26 2001
|
||||
--- pico/osdep/os-bsf.h Thu Sep 27 23:56:53 2001
|
||||
--- pico/osdep/os-bsf.h Wed Mar 5 04:24:00 2003
|
||||
***************
|
||||
*** 153,159 ****
|
||||
*** 153,165 ****
|
||||
/*
|
||||
* Place where mail gets delivered (for pico's new mail checking)
|
||||
*/
|
||||
|
@ -9,7 +9,13 @@
|
|||
|
||||
/*
|
||||
* What and where the tool that checks spelling is located. If this is
|
||||
--- 153,159 ----
|
||||
* undefined, then the spelling checker is not compiled into pico.
|
||||
*/
|
||||
! #define SPELLER "/usr/bin/spell"
|
||||
|
||||
#ifdef MOUSE
|
||||
#define XTERM_MOUSE_ON "\033[?1000h" /* DECSET with parm 1000 */
|
||||
--- 153,165 ----
|
||||
/*
|
||||
* Place where mail gets delivered (for pico's new mail checking)
|
||||
*/
|
||||
|
@ -17,3 +23,9 @@
|
|||
|
||||
/*
|
||||
* What and where the tool that checks spelling is located. If this is
|
||||
* undefined, then the spelling checker is not compiled into pico.
|
||||
*/
|
||||
! #define SPELLER "@@PREFIX@@/bin/spell"
|
||||
|
||||
#ifdef MOUSE
|
||||
#define XTERM_MOUSE_ON "\033[?1000h" /* DECSET with parm 1000 */
|
||||
|
|
|
@ -1,57 +0,0 @@
|
|||
*** pico/display.c.orig Fri Jun 19 20:19:53 1998
|
||||
--- pico/display.c Mon Jul 13 01:36:38 1998
|
||||
***************
|
||||
*** 77,83 ****
|
||||
{"^X", "Exit", KS_EXIT}, {"^J", "Justify", KS_JUSTIFY},
|
||||
{"^W", "Where is", KS_WHEREIS}, {"^V", "Next Pg", KS_NEXTPAGE},
|
||||
{"^U", NULL, KS_NONE},
|
||||
! #ifdef SPELLER
|
||||
{"^T", "To Spell", KS_SPELLCHK}
|
||||
#else
|
||||
{"^D", "Del Char", KS_NONE}
|
||||
--- 77,83 ----
|
||||
{"^X", "Exit", KS_EXIT}, {"^J", "Justify", KS_JUSTIFY},
|
||||
{"^W", "Where is", KS_WHEREIS}, {"^V", "Next Pg", KS_NEXTPAGE},
|
||||
{"^U", NULL, KS_NONE},
|
||||
! #if defined(SPELLER) && !defined(__FreeBSD__)
|
||||
{"^T", "To Spell", KS_SPELLCHK}
|
||||
#else
|
||||
{"^D", "Del Char", KS_NONE}
|
||||
*** pico/ebind.h.orig Sat Feb 28 02:10:31 1998
|
||||
--- pico/ebind.h Mon Jul 13 01:36:39 1998
|
||||
***************
|
||||
*** 145,151 ****
|
||||
{CTRL|'O', filewrite},
|
||||
{CTRL|'P', backline},
|
||||
{CTRL|'R', insfile},
|
||||
! #ifdef SPELLER
|
||||
{CTRL|'T', spell},
|
||||
#endif /* SPELLER */
|
||||
{CTRL|'U', yank},
|
||||
--- 145,151 ----
|
||||
{CTRL|'O', filewrite},
|
||||
{CTRL|'P', backline},
|
||||
{CTRL|'R', insfile},
|
||||
! #if defined(SPELLER) && !defined(__FreeBSD__)
|
||||
{CTRL|'T', spell},
|
||||
#endif /* SPELLER */
|
||||
{CTRL|'U', yank},
|
||||
*** pico/main.c.orig Tue Apr 21 20:28:08 1998
|
||||
--- pico/main.c Mon Jul 13 01:36:39 1998
|
||||
***************
|
||||
*** 66,72 ****
|
||||
{ F9, (CTRL|'K')},
|
||||
{ F10, (CTRL|'U')},
|
||||
{ F11, (CTRL|'C')},
|
||||
! #ifdef SPELLER
|
||||
{ F12, (CTRL|'T')}
|
||||
#else
|
||||
{ F12, (CTRL|'D')}
|
||||
--- 66,72 ----
|
||||
{ F9, (CTRL|'K')},
|
||||
{ F10, (CTRL|'U')},
|
||||
{ F11, (CTRL|'C')},
|
||||
! #if defined(SPELLER) && !defined(__FreeBSD__)
|
||||
{ F12, (CTRL|'T')}
|
||||
#else
|
||||
{ F12, (CTRL|'D')}
|
|
@ -1,57 +0,0 @@
|
|||
--- pine/pine.hlp.orig Fri Aug 17 11:11:25 2001
|
||||
+++ pine/pine.hlp Fri Sep 28 00:29:20 2001
|
||||
@@ -528,9 +528,9 @@
|
||||
executable <Unix search path>/pine
|
||||
persnl cfg ~/.pinerc
|
||||
except cfg ~/.pinercex
|
||||
- global cfg /usr/local/lib/pine.conf
|
||||
- fixed cfg /usr/local/lib/pine.conf.fixed
|
||||
- local help /usr/local/lib/pine.info
|
||||
+ global cfg @@PREFIX@@/etc/pine.conf
|
||||
+ fixed cfg @@PREFIX@@/etc/pine.conf.fixed
|
||||
+ local help @@PREFIX@@/etc/pine.info
|
||||
|
||||
interrupted ~/.pine-interrupted-mail
|
||||
debug ~/.pine-debugN
|
||||
@@ -543,7 +543,7 @@
|
||||
sentmail# ~/mail/sent-mail
|
||||
mailcap# ~/.mailcap + /etc/mailcap
|
||||
+ /usr/etc/mailcap + /usr/local/etc/mailcap
|
||||
- mimetypes# ~/.mime.types + /etc/mime.types + /usr/local/lib/mime.types
|
||||
+ mimetypes# ~/.mime.types + /etc/mime.types + @@PREFIX@@/etc/mime.types
|
||||
|
||||
news-spool varies across Unix flavors, e.g. /usr/spool/news or /var/news
|
||||
active-news varies across Unix flavors, e.g. /usr/lib/news/active
|
||||
@@ -1001,9 +1001,9 @@
|
||||
this link now to send a message to it:<BR>
|
||||
<A HREF="X-Pine-Gripe:_LOCAL_ADDRESS_?local"><!--#echo var="_LOCAL_FULLNAME_"--></A><P>
|
||||
<!--chtml endif-->
|
||||
-<!--chtml if [ -r /usr/local/lib/pine.info ]-->
|
||||
+<!--chtml if [ -r @@PREFIX@@/etc/pine.info ]-->
|
||||
<HR WIDTH="75%">Local Support Contacts:<P>
|
||||
-<!--#include file="/usr/local/lib/pine.info"-->
|
||||
+<!--#include file="@@PREFIX@@/etc/pine.info"-->
|
||||
<HR WIDTH="75%">
|
||||
<!--chtml endif-->
|
||||
<P>
|
||||
@@ -1091,7 +1091,7 @@
|
||||
<OL>
|
||||
<LI> <A HREF="#intro">Introduction</A>
|
||||
<LI> <A HREF="#pine_help">Pine Help</A>
|
||||
-<!--chtml if [ -r /usr/local/lib/pine.info ]-->
|
||||
+<!--chtml if [ -r @@PREFIX@@/etc/pine.info ]-->
|
||||
<LI> <A HREF="#local_support">Local Support Contacts</A>
|
||||
<!--chtml endif-->
|
||||
<LI> <A HREF="#giving_cmds">Giving Commands in Pine</A>
|
||||
@@ -1201,9 +1201,9 @@
|
||||
at your site.)
|
||||
|
||||
|
||||
-<!--chtml if [ -r /usr/local/lib/pine.info ]-->
|
||||
+<!--chtml if [ -r @@PREFIX@@/etc/pine.info ]-->
|
||||
<H2><A NAME="local_support">Local Support Contacts</A></H2>
|
||||
-<!--#include file="/usr/local/lib/pine.info"-->
|
||||
+<!--#include file="@@PREFIX@@/etc/pine.info"-->
|
||||
<!--chtml endif-->
|
||||
|
||||
<H2><A NAME="giving_cmds">Giving Commands in Pine</A></H2>
|
|
@ -1,27 +0,0 @@
|
|||
*** doc/pine.1.orig Fri Jun 22 16:47:06 2001
|
||||
--- doc/pine.1 Fri Sep 28 00:29:20 2001
|
||||
***************
|
||||
*** 329,339 ****
|
||||
.br
|
||||
/etc/mime.types System-wide file ext. to MIME type mapping
|
||||
.br
|
||||
! /usr/local/lib/pine.info Local pointer to system administrator.
|
||||
.br
|
||||
! /usr/local/lib/pine.conf System-wide configuration file.
|
||||
.br
|
||||
! /usr/local/lib/pine.conf.fixed Non-overridable configuration file.
|
||||
.br
|
||||
/tmp/.\\usr\\spool\\mail\\xxxx Per-folder mailbox lock files.
|
||||
.br
|
||||
--- 329,339 ----
|
||||
.br
|
||||
/etc/mime.types System-wide file ext. to MIME type mapping
|
||||
.br
|
||||
! @@PREFIX@@/etc/pine.info Local pointer to system administrator.
|
||||
.br
|
||||
! @@PREFIX@@/etc/pine.conf System-wide configuration file.
|
||||
.br
|
||||
! @@PREFIX@@/etc/pine.conf.fixed Non-overridable configuration file.
|
||||
.br
|
||||
/tmp/.\\usr\\spool\\mail\\xxxx Per-folder mailbox lock files.
|
||||
.br
|
|
@ -1,44 +0,0 @@
|
|||
*** pine/mailcap.c.orig Wed Nov 18 20:00:15 1998
|
||||
--- pine/mailcap.c Thu Feb 11 23:43:54 1999
|
||||
***************
|
||||
*** 61,67 ****
|
||||
|
||||
Mime types makes mime assign attachment types according
|
||||
to file name extensions found in a system wide file
|
||||
! ``/usr/local/lib/mime.types'' and a user specific file
|
||||
``~/.mime.types'' . These files specify file extensions
|
||||
that will be connected to a mime type.
|
||||
*******************************************************
|
||||
--- 61,67 ----
|
||||
|
||||
Mime types makes mime assign attachment types according
|
||||
to file name extensions found in a system wide file
|
||||
! ``@@PREFIX@@/etc/mime.types'' and a user specific file
|
||||
``~/.mime.types'' . These files specify file extensions
|
||||
that will be connected to a mime type.
|
||||
*******************************************************
|
||||
***************
|
||||
*** 96,106 ****
|
||||
#define MC_PATH_SEPARATOR ':'
|
||||
#define MC_USER_FILE NULL
|
||||
#define MC_STDPATH \
|
||||
! ".mailcap:/etc/mailcap:/usr/etc/mailcap:/usr/local/etc/mailcap"
|
||||
#define MT_PATH_SEPARATOR ':'
|
||||
#define MT_USER_FILE NULL
|
||||
#define MT_STDPATH \
|
||||
! ".mime.types:/etc/mime.types:/usr/local/lib/mime.types"
|
||||
#endif /* !DOS */
|
||||
|
||||
#ifdef _WINDOWS
|
||||
--- 96,106 ----
|
||||
#define MC_PATH_SEPARATOR ':'
|
||||
#define MC_USER_FILE NULL
|
||||
#define MC_STDPATH \
|
||||
! ".mailcap:/etc/mailcap:/usr/etc/mailcap:@@PREFIX@@/etc/mailcap"
|
||||
#define MT_PATH_SEPARATOR ':'
|
||||
#define MT_USER_FILE NULL
|
||||
#define MT_STDPATH \
|
||||
! ".mime.types:/etc/mime.types:@@PREFIX@@/etc/mime.types"
|
||||
#endif /* !DOS */
|
||||
|
||||
#ifdef _WINDOWS
|
|
@ -1,11 +1,12 @@
|
|||
--- pine/init.c.orig Wed Nov 29 09:57:56 2000
|
||||
+++ pine/init.c Mon Dec 18 02:40:53 2000
|
||||
@@ -370,7 +370,7 @@
|
||||
|
||||
/*----------------------------------------------------------------------
|
||||
These are the variables that control a number of pine functions. They
|
||||
-come out of the .pinerc and the /usr/local/lib/pine.conf files. Some can
|
||||
+come out of the .pinerc and the @@PREFIX@@/etc/pine.conf files. Some can
|
||||
be set by the user while in Pine. Eventually all the local ones should
|
||||
be so and maybe the global ones too.
|
||||
--- pine/init.c.orig Wed Mar 5 05:11:10 2003
|
||||
+++ pine/init.c Wed Mar 5 05:21:57 2003
|
||||
@@ -1463,6 +1463,9 @@
|
||||
GLO_NORM_FORE_COLOR = cpystr(colorx(DEFAULT_NORM_FORE));
|
||||
GLO_NORM_BACK_COLOR = cpystr(colorx(DEFAULT_NORM_BACK));
|
||||
#endif
|
||||
+#ifdef DF_SPELLER
|
||||
+ GLO_SPELLER = cpystr(DF_SPELLER);
|
||||
+#endif
|
||||
|
||||
/*
|
||||
* Default first value for addrbook list if none set.
|
||||
|
|
Loading…
Reference in a new issue