- Update to 0.59_beta9
This commit is contained in:
parent
f7d921b4bb
commit
cb5972c770
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=282804
7 changed files with 44 additions and 3444 deletions
|
@ -6,69 +6,74 @@
|
|||
#
|
||||
|
||||
PORTNAME= openlierox
|
||||
DISTVERSION= 0.57_beta8
|
||||
PORTREVISION= 5
|
||||
DISTVERSION= 0.59_beta9
|
||||
CATEGORIES= games
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/OpenLieroX%200.57%20Beta8
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/OpenLieroX%20${DISTVERSION:C/_/%20/}
|
||||
DISTNAME= OpenLieroX_${DISTVERSION}.src
|
||||
|
||||
MAINTAINER= amdmi3@FreeBSD.org
|
||||
COMMENT= Extremely addictive realtime worms shoot-em-up
|
||||
|
||||
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
|
||||
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
|
||||
boost_signals.4:${PORTSDIR}/devel/boost-libs \
|
||||
curl.6:${PORTSDIR}/ftp/curl \
|
||||
alut.1:${PORTSDIR}/audio/freealut
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_SDL= sdl image
|
||||
USE_GNOME= libxml2
|
||||
MAKE_JOBS_SAFE= yes
|
||||
USE_OPENAL= yes
|
||||
|
||||
CFLAGS+= -I${LOCALBASE}/include/libxml2
|
||||
CXXFLAGS+= -I${LOCALBASE}/include/libxml2
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
CXXFLAGS+= -I${LOCALBASE}/include
|
||||
|
||||
USE_CMAKE= yes
|
||||
CMAKE_ARGS= -DHAWKNL_BUILTIN=YES \
|
||||
-DLIBZIP_BUILTIN=YES
|
||||
-DLIBZIP_BUILTIN=YES \
|
||||
-DBREAKPAD=NO \
|
||||
-DSYSTEM_DATA_DIR="${DATADIR}"
|
||||
|
||||
WRKSRC= ${WRKDIR}/OpenLieroX
|
||||
|
||||
PORTDOCS= *
|
||||
PORTDATA= *
|
||||
|
||||
PLIST_FILES= bin/openlierox \
|
||||
share/applications/openlierox-openlierox.desktop \
|
||||
share/pixmaps/OpenLieroX.svg
|
||||
PLIST_DIRSTRY= share/applications
|
||||
|
||||
OPTIONS= DEDICATED_ONLY "Build dedicated server only" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_DEDICATED_ONLY)
|
||||
BROKEN= does not build
|
||||
CMAKE_ARGS+= -DDEDICATED_ONLY=YES
|
||||
.else
|
||||
USE_XORG+= x11
|
||||
USE_SDL+= mixer
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
@${FIND} ${WRKSRC} -name "._*" -delete
|
||||
@cd ${WRKSRC} && ${MKDIR} bin
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|sys/dir.h|dirent.h|' \
|
||||
${WRKSRC}/src/main.cpp ${WRKSRC}/include/FindFile.h
|
||||
@${REINPLACE_CMD} -e 's|DATADIR|"${DATADIR}"|' \
|
||||
${WRKSRC}/src/main.cpp
|
||||
@${REINPLACE_CMD} -e 's|EXEC_PROGRAM.*OLXVER)|SET(OLXVER "${DISTVERSION}")|' \
|
||||
${WRKSRC}/CMakeLists.txt
|
||||
@${REINPLACE_CMD} -e 's|-mt||; s|EXEC_PROGRAM.*OLXVER)|SET(OLXVER "${DISTVERSION}")|; \
|
||||
s|/usr/local|${LOCALBASE}|' ${WRKSRC}/CMakeOlxCommon.cmake
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/openlierox ${PREFIX}/bin
|
||||
${MKDIR} ${DATADIR}
|
||||
cd ${WRKSRC}/share/gamedir && ${COPYTREE_SHARE} . ${DATADIR}
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/openlierox ${PREFIX}/bin/
|
||||
${MKDIR} ${PREFIX}/share/applications
|
||||
${INSTALL_DATA} ${WRKSRC}/share/openlierox-openlierox.desktop \
|
||||
${PREFIX}/share/applications
|
||||
${PREFIX}/share/applications/
|
||||
${INSTALL_DATA} ${WRKSRC}/share/OpenLieroX.svg \
|
||||
${PREFIX}/share/pixmaps
|
||||
|
||||
${PREFIX}/share/pixmaps/
|
||||
.if !defined(NOPORTDATA)
|
||||
${MKDIR} ${DATADIR}
|
||||
cd ${WRKSRC}/share/gamedir && ${COPYTREE_SHARE} . ${DATADIR}/
|
||||
.endif
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}
|
||||
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (OpenLieroX_0.57_beta8.src.tar.bz2) = 0dd9c624a5d6a804f354263327dd4052f3b4d464b90e318e6255ec12d70077a8
|
||||
SIZE (OpenLieroX_0.57_beta8.src.tar.bz2) = 49121319
|
||||
SHA256 (OpenLieroX_0.59_beta9.src.tar.bz2) = a5c05cca11f44d22d3f9af832c13dd55a9a0309e9f80a0e6b5d2bcb9fca160ac
|
||||
SIZE (OpenLieroX_0.59_beta9.src.tar.bz2) = 100913507
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- libs/hawknl/src/nlinternal.h.orig 2008-08-31 03:59:14.000000000 +0400
|
||||
+++ libs/hawknl/src/nlinternal.h 2008-10-13 00:15:18.000000000 +0400
|
||||
@@ -28,7 +28,7 @@
|
||||
/* for malloc and free */
|
||||
#include <stdlib.h>
|
||||
#ifndef MACOSX
|
||||
-#include <malloc.h>
|
||||
+#include <stdlib.h>
|
||||
#endif
|
||||
|
||||
/* Windows CE does not have time.h functions */
|
|
@ -1,41 +0,0 @@
|
|||
--- src/client/Sounds.cpp.orig 2008-10-07 17:54:58.000000000 +0400
|
||||
+++ src/client/Sounds.cpp 2008-10-13 04:19:09.000000000 +0400
|
||||
@@ -144,36 +144,15 @@
|
||||
if(SoundSystemAvailable) return true;
|
||||
SoundSystemAvailable = false;
|
||||
|
||||
- if(getenv("SDL_AUDIODRIVER"))
|
||||
- printf("SDL_AUDIODRIVER=%s\n", getenv("SDL_AUDIODRIVER"));
|
||||
-#if !defined(WIN32) && !defined(MACOSX)
|
||||
- if(!getenv("SDL_AUDIODRIVER")) {
|
||||
- printf("SDL_AUDIODRIVER not set, setting to ALSA\n");
|
||||
- putenv((char*)"SDL_AUDIODRIVER=alsa");
|
||||
- }
|
||||
-#endif
|
||||
-
|
||||
-initSoundSystem:
|
||||
-
|
||||
// HINT: other SDL stuff is already inited, we don't care here
|
||||
if( SDL_InitSubSystem(SDL_INIT_AUDIO) != 0 ) {
|
||||
printf("InitSoundSystem: Unable to initialize SDL-sound: %s\n", SDL_GetError());
|
||||
- if(getenv("SDL_AUDIODRIVER")) {
|
||||
- printf("trying again with SDL_AUDIODRIVER unset\n");
|
||||
- unsetenv("SDL_AUDIODRIVER");
|
||||
- goto initSoundSystem;
|
||||
- } else
|
||||
- return false;
|
||||
+ return false;
|
||||
}
|
||||
|
||||
if(Mix_OpenAudio(rate, AUDIO_S16, channels, buffers)) {
|
||||
printf("InitSoundSystem: Unable to open audio (SDL_mixer): %s\n", Mix_GetError());
|
||||
- if(getenv("SDL_AUDIODRIVER")) {
|
||||
- printf("trying again with SDL_AUDIODRIVER unset\n");
|
||||
- unsetenv("SDL_AUDIODRIVER");
|
||||
- goto initSoundSystem;
|
||||
- } else
|
||||
- return false;
|
||||
+ return false;
|
||||
}
|
||||
|
||||
int allocChanNum = Mix_AllocateChannels(1000); // TODO: enough?
|
13
games/openlierox/files/patch-src-common-FindFile.cpp
Normal file
13
games/openlierox/files/patch-src-common-FindFile.cpp
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- ./src/common/FindFile.cpp.orig 2010-02-17 19:59:26.000000000 +0300
|
||||
+++ ./src/common/FindFile.cpp 2011-10-01 19:06:16.000000000 +0400
|
||||
@@ -456,6 +456,10 @@
|
||||
AddToFileList(&basesearchpaths, "${HOME}/OpenLieroX");
|
||||
AddToFileList(&basesearchpaths, ".");
|
||||
AddToFileList(&basesearchpaths, "${BIN}");
|
||||
+#elif defined(__FreeBSD__)
|
||||
+ AddToFileList(&basesearchpaths, "${HOME}/.OpenLieroX");
|
||||
+ AddToFileList(&basesearchpaths, ".");
|
||||
+ AddToFileList(&basesearchpaths, SYSTEM_DATA_DIR);
|
||||
#else // all other systems (Linux, *BSD, OS/2, ...)
|
||||
AddToFileList(&basesearchpaths, "${HOME}/.OpenLieroX");
|
||||
AddToFileList(&basesearchpaths, ".");
|
|
@ -1,11 +0,0 @@
|
|||
--- src/main.cpp.orig 2008-10-10 01:21:19.000000000 +0400
|
||||
+++ src/main.cpp 2008-10-13 04:20:11.000000000 +0400
|
||||
@@ -134,6 +134,8 @@
|
||||
// Main entry point
|
||||
int main(int argc, char *argv[])
|
||||
{
|
||||
+ chdir(DATADIR);
|
||||
+
|
||||
printf(GAMENAME " " LX_VERSION " is starting ...\n");
|
||||
#ifdef DEBUG
|
||||
printf("HINT: This is a DEBUG build.\n");
|
File diff suppressed because it is too large
Load diff
Loading…
Reference in a new issue