Cleanup after removal of libexecinfo from ports.

PR:		220271
Submitted by:	mat (review), Yasuhiro KIMURA (PR)
Sponsored by:	Absolight
Differential Revision:	https://reviews.freebsd.org/D11488
This commit is contained in:
Mathieu Arnold 2017-09-22 10:48:57 +00:00
parent b71796d585
commit cb9a2b582c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=450353
38 changed files with 42 additions and 90 deletions

View file

@ -34,7 +34,7 @@
+LOPT=${LDFLAGS} -g -Wl,-E -o
+LOPT_SO=${LDFLAGS} -g -shared -o
+
+LIBS=${PTHREAD_LIBS} -L$(QTLIB) -lQtGui -lQtCore -lQtXml -lQtNetwork -lQtSql -lQtDesigner -lrt -lm -lcrypt -lz -L$(LOCALBASE)/lib -lexecinfo
+LIBS=${PTHREAD_LIBS} -L$(QTLIB) -lQtGui -lQtCore -lQtXml -lQtNetwork -lQtSql -lQtDesigner -lrt -lm -lcrypt -lz -lexecinfo
+
+.PHONY: install
+install:

View file

@ -23,7 +23,7 @@ CONFIGURE_ARGS= --without-memcached \
--without-sphinx-build \
--enable-libmemcachedprotocol
LIBS+= -L${LOCALBASE}/lib -lexecinfo
LIBS+= -lexecinfo
CXXFLAGS+= -D__STDC_CONSTANT_MACROS -pthread
OPTIONS_DEFINE= DEBUG DTRACE MEMASLAP SASL

View file

@ -59,7 +59,6 @@ CMAKE_ARGS+= -DINSTALL_DOCDIR="share/doc/mariadb" \
-DWITH_LIBEDIT=0 \
-DWITH_SSL=${OPENSSLBASE} \
-DWITH_LIBWRAP=1 \
-DEXECINFO_ROOT=${LOCALBASE} \
-DCOMPILATION_COMMENT="FreeBSD Ports"
DATADIR= ${PREFIX}/share/mysql

View file

@ -90,7 +90,6 @@ CMAKE_ARGS+= -DINSTALL_DOCDIR="share/doc/mysql" \
-DWITH_LIBWRAP=1 \
-DWITH_SSL=${OPENSSLBASE} \
-DKRB5_CONFIG=${KRB5CONFIG} \
-DEXECINFO_ROOT=${LOCALBASE} \
-DCOMPILATION_COMMENT="FreeBSD Ports"
DATADIR= ${PREFIX}/share/mysql

View file

@ -93,7 +93,6 @@ CMAKE_ARGS+= -DINSTALL_DOCDIR="share/doc/mysql" \
-DCURSES_CURSES_LIBRARY="/usr/lib/libcurses.so" \
-DCURSES_FORM_LIBRARY="/usr/lib/libform.so" \
-DCURSES_CURSES_LIBRARY="/usr/lib/libncurses.so" \
-DEXECINFO_ROOT="${LOCALBASE}" \
-DICONV_LIBRARIES="${ICONV_LIB_PATH}" \
-DKRB5_CONFIG="${KRB5CONFIG}" \
-DCURSES_NCURSES_LIBRARY="${NCURSESLIB}/libncurses.so" \

View file

@ -46,7 +46,6 @@ CMAKE_ARGS+= -DINSTALL_DOCDIR="share/doc/mysql" \
-DWITH_UNIT_TESTS=0 \
-DWITH_LIBWRAP=1 \
-DWITH_SSL=yes \
-DEXECINFO_ROOT=${LOCALBASE} \
-DCOMPILATION_COMMENT="FreeBSD Ports"
DATADIR= ${PREFIX}/share/mysql

View file

@ -58,8 +58,7 @@ LDFLAGS+= -Wl,-E
USES+= tcl:build
.endif
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lpthread -lm -lexecinfo
LDFLAGS+= -lpthread -lm -lexecinfo
CONFLICTS?= redis-3.*

View file

@ -47,8 +47,7 @@ LDFLAGS+= -Wl,-E
USES+= tcl:build
.endif
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lpthread -lm -lexecinfo
LDFLAGS+= -lpthread -lm -lexecinfo
CONFLICTS?= redis-devel-3.*

View file

@ -16,8 +16,7 @@ GH_ACCOUNT= twitter
USES= autoreconf libtool
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
LDFLAGS+= -lexecinfo
PLIST_FILES= sbin/nutcracker \
man/man8/nutcracker.8.gz \

View file

@ -41,8 +41,8 @@ CONFIGURE_ARGS= --with-readline\
--with-layout=freebsd\
--datadir="${PREFIX}"\
--localstatedir="${PREFIX}"
CPPFLAGS+= -std=gnu89 ${IODBC_CPPFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
CPPFLAGS+= -std=gnu89 ${IODBC_CPPFLAGS}
LDFLAGS+= -lexecinfo
MAKE_ENV= PATH=${LOCALBASE}/bin:${PATH}\
ISQL=isql-vt
USE_RC_SUBR= virtuoso

View file

@ -32,8 +32,7 @@ SUB_LIST+= USERS=${USERS} GROUPS=${GROUPS}
CONFIGURE_ARGS+=--with-lib-prefix=${LOCALBASE} --with-boost=${LOCALBASE} \
--localstatedir=/var/db/${PORTNAME} --enable-static
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
LDFLAGS+= -lexecinfo
OPTIONS_DEFINE= DRIZZLE MEMCACHED PGSQL SQLITE MYSQL HIREDIS TOKYOCAB
OPTIONS_DEFAULT=SQLITE

View file

@ -31,8 +31,7 @@ SUB_LIST+= USERS=${USERS} GROUPS=${GROUPS}
CONFIGURE_ARGS+=--with-lib-prefix=${LOCALBASE} --with-boost=${LOCALBASE} \
--localstatedir=/var/db/${PORTNAME} --enable-static
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
LDFLAGS+= -lexecinfo
OPTIONS_DEFINE= DRIZZLE MEMCACHED PGSQL SQLITE MYSQL HIREDIS TOKYOCAB
OPTIONS_DEFAULT=SQLITE

View file

@ -28,8 +28,7 @@ USES= compiler gmake libtool
USE_LDCONFIG= yes
TEST_TARGET= check
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lexecinfo
LIBS+= -lexecinfo
OPTIONS_DEFINE= DOCS
OPTIONS_DEFAULT=PAGE8K ALIGN16

View file

@ -16,7 +16,7 @@ LIB_DEPENDS= libpcsclite.so:devel/pcsc-lite
USES= alias autoreconf gmake libtool pathfix pkgconfig
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
LDFLAGS+= -lexecinfo
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
PORTDOCS= *

View file

@ -25,8 +25,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-compile-optim=no
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
LDFLAGS+= -lexecinfo
OPTIONS_DEFINE= DOCS

View file

@ -44,12 +44,6 @@ CMAKE_ARGS= -DDATADIR:STRING="share/${PORTNAME}" \
WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
.if exists(/usr/lib/libexecinfo.so)
LEI_PREFIX= /usr
.else
LEI_PREFIX= ${LOCALBASE}
.endif
# Do not exctract bundled copies of header files for 3rd-party packages:
EXTRACT_AFTER_ARGS=--no-same-owner --no-same-permissions --exclude ${WRKSRC:T}/include
@ -101,7 +95,7 @@ post-patch:
${WRKSRC}/rts/System/Sync/FPUCheck.cpp
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/rts/build/cmake/*.cmake
@${REINPLACE_CMD} -e 's|execinfo|${LEI_PREFIX}/lib/libexecinfo.so|' \
@${REINPLACE_CMD} -e 's|execinfo|/usr/lib/libexecinfo.so|' \
${WRKSRC}/rts/CMakeLists.txt \
${WRKSRC}/rts/builds/dedicated/CMakeLists.txt
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \

View file

@ -19,8 +19,7 @@ USES= gmake pkgconfig tar:tgz
MAKE_ENV= METHANE_FLAGS="${CPPFLAGS}" METHANE_LIBS="${LIBS}"
MAKE_JOBS_UNSAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lexecinfo
LIBS+= -lexecinfo
DATADIR= ${PREFIX}/share/methane

View file

@ -29,9 +29,7 @@ USES= compiler:c++11-lang gettext gmake jpeg openal:soft pkgconfig \
python:build tar:bzip2
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-release --target-os=freebsd
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lpthread -L${LOCALBASE}/lib -lexecinfo
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -lpthread -lexecinfo
DATADIR= share/${PORTNAME}
SUB_FILES= pkg-message

View file

@ -90,10 +90,6 @@ LLVM40_VARS= LLVM_CONFIG=llvm-config40 \
.include <bsd.port.pre.mk>
.if !exists(/usr/lib/libexecinfo.so)
CONFIGURE_ARGS+= --with-opt-dir "${LOCALBASE}"
.endif
.if ${ARCH} == "sparc64"
BROKEN= Does not compile on sparc64
.elif ${ARCH} == "amd64"

View file

@ -49,10 +49,10 @@ EXECINFO_DESC= Build with libexecinfo support
.include <bsd.port.options.mk>
post-patch:
.if ${PORT_OPTIONS:MEXECINFO} || exists(${LOCALBASE}/lib/libexecinfo.so)
@${REINPLACE_CMD} 's|-lm |-lm -L${LOCALBASE}/lib -lexecinfo |' \
.if ${PORT_OPTIONS:MEXECINFO}
@${REINPLACE_CMD} 's|-lm |-lm -lexecinfo |' \
${WRKSRC}/src/audacious/Makefile
@${REINPLACE_CMD} 's|-laudcore|-laudcore -L${LOCALBASE}/lib -lexecinfo|' \
@${REINPLACE_CMD} 's|-laudcore|-laudcore -lexecinfo|' \
${WRKSRC}/audacious.pc.in
.endif
${REINPLACE_CMD} -e 's| $${MFLAGS}||g' \

View file

@ -44,10 +44,10 @@ EXECINFO_DESC= Build with libexecinfo support
.include <bsd.port.options.mk>
post-patch:
.if ${PORT_OPTIONS:MEXECINFO} || exists(${LOCALBASE}/lib/libexecinfo.so)
@${REINPLACE_CMD} 's|-lm |-lm -L${LOCALBASE}/lib -lexecinfo |' \
.if ${PORT_OPTIONS:MEXECINFO}
@${REINPLACE_CMD} 's|-lm |-lm -lexecinfo |' \
${WRKSRC}/src/audacious/Makefile
@${REINPLACE_CMD} 's|-laudcore|-laudcore -L${LOCALBASE}/lib -lexecinfo|' \
@${REINPLACE_CMD} 's|-laudcore|-laudcore -lexecinfo|' \
${WRKSRC}/audacious.pc.in
.endif
${REINPLACE_CMD} -e 's| $${MFLAGS}||g' \

View file

@ -76,13 +76,8 @@ CFLAGS+= -fno-omit-frame-pointer
#MAKE_ENV+= ARCH=x86_64
#CONFIGURE_ENV+= ARCH=x86_64
.endif
.if !exists(/usr/lib/libexecinfo.so)
CMAKE_ARGS+= -DLIBEXECINFO_INCLUDE_DIR=${LOCALBASE}/include
CMAKE_ARGS+= -DLIBEXECINFO_LIBRARY_DIR=${LOCALBASE}/lib/libexecinfo.so
.else
CMAKE_ARGS+= -DLIBEXECINFO_INCLUDE_DIR=/usr/include
CMAKE_ARGS+= -DLIBEXECINFO_LIBRARY_DIR=-lexecinfo
.endif
# We haven't ALSA(Never) & Aften(Yet) on FreeBSD
CMAKE_ARGS+= -DARTS:BOOL=OFF -DALSA:BOOL=OFF -DAFTEN:BOOL=OFF

View file

@ -48,8 +48,8 @@ SUB_LIST+= TVHUSER="${TVHUSER}" \
CONFIGURE_ENV+= PLATFORM=freebsd
CONFIGURE_ARGS+=--disable-dvbscan --disable-zlib --disable-hdhomerun_static \
--disable-bintray_cache --disable-ffmpeg_static --disable-pie
CFLAGS+= -I${LOCALBASE}/include -Wno-conversion -Wno-int-to-pointer-cast
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo -lssl -lcrypto -lz
CFLAGS+= -Wno-conversion -Wno-int-to-pointer-cast
LDFLAGS+= -lexecinfo -lssl -lcrypto -lz
OPTIONS_DEFINE= AVAHI DVBCSA HDHOMERUN INOTIFY TRANSCODING XMLTV
OPTIONS_DEFAULT=DVBCSA HDHOMERUN INOTIFY

View file

@ -49,7 +49,7 @@ CONFIGURE_ENV= FCFLAGS="${FFLAGS}" \
.if ${FFLAGS} == "-O"
FFLAGS= -O2
.endif
LDFLAGS+= -lpthread -L${LOCALBASE}/lib -lexecinfo
LDFLAGS+= -lpthread -lexecinfo
MAKE_ENV= CCACHE_DISABLE=yes PACKAGE=${PORTNAME}
NOCCACHE= yes

View file

@ -21,8 +21,7 @@ CONFIGURE_ARGS= --without-libungif \
--without-libjpeg \
--disable-ui-gtk
CFLAGS+= -I/usr/include -I${LOCALBASE}/include
LDFLAGS+= -lncurses -L${LOCALBASE}/lib -lexecinfo -pthread
LDFLAGS+= -lncurses -lexecinfo -pthread
OPTIONS_DEFINE= ASPELL OPENSSL
OPTIONS_DEFAULT= OPENSSL

View file

@ -28,8 +28,7 @@ SHEBANG_FILES= backends/test/helpers/search-name.sh \
USE_GNOME= glib20 intltool introspection
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lexecinfo
LIBS+= -lexecinfo
CONFIGURE_ARGS+=--with-security-framework=polkit \
--localstatedir=/var \
--disable-static \

View file

@ -20,11 +20,7 @@ GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf aclocal autoheader
ACLOCAL_ARGS+= -I ${WRKSRC}/infrastructure/m4
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
.if exists(/usr/lib/libexecinfo.so)
LDFLAGS+= -lexecinfo
.endif
LDFLAGS+= -L${OPENSSLLIB} -lexecinfo
MAKE_JOBS_UNSAFE=yes

View file

@ -13,8 +13,7 @@ LICENSE= GPLv2
RUN_DEPENDS= lsof:sysutils/lsof
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lexecinfo
LIBS+= -lexecinfo
CONFIGURE_ARGS= --enable-unicode
USES= autoreconf libtool ncurses

View file

@ -50,12 +50,6 @@ PLIST_SUB+= FULLVERSION=${PORTVERSION} \
MIDVERSION=${PORTVERSION:R} \
MINVERSION=${PORTVERSION:R:R}
.if exists(/usr/lib/libexecinfo.so)
LOC_EXECINFO= /usr/lib/libexecinfo.so
.else
LOC_EXECINFO= ${LOCALBASE}/lib/libexecinfo.so
.endif
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPHP}
@ -91,7 +85,7 @@ BUILD_DEPENDS+= swig2.0:devel/swig20
.endif
post-patch:
${REINPLACE_CMD} -e 's|%%LIBEXECINFO%%|${LOC_EXECINFO}|' \
${REINPLACE_CMD} \
-e 's|FreeBSD|${OPSYS}|g' ${WRKSRC}/CMakeLists.txt
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/cmake_modules/FindPHP5.cmake

View file

@ -18,7 +18,7 @@
+# execinfo
+#
+IF(FREEBSD)
+ SET(requiredlibs ${requiredlibs} "%%LIBEXECINFO%%")
+ SET(requiredlibs ${requiredlibs} "/usr/lib/libexecinfo.so")
+ENDIF(FREEBSD)
+
+#

View file

@ -18,8 +18,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ssl --without-pmshell --without-atheos --without-fb
CFLAGS+= -Wno-error=return-type
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
LDFLAGS+= -lexecinfo
CONFLICTS= links-[0-9]*

View file

@ -38,7 +38,7 @@ GYP_DEFINES+= \
system_include_path_httpd=${LOCALBASE}/include/apache22 \
system_include_path_apr=${LOCALBASE}/include/apr-1 \
system_include_path_aprutil=${LOCALBASE}/include/apr-1 \
system_include_path_execinfo=${LOCALBASE}/include \
system_include_path_execinfo=/usr/include \
include_dirs=${LOCALBASE}/include
SUB_FILES+= mod_spdy.conf

View file

@ -1,10 +1,12 @@
FIXME: this feels a bit silly now.
--- base/base.gypi.org 2012-03-31 16:28:56.347804000 +0900
+++ base/base.gypi 2012-03-31 17:03:22.470770534 +0900
@@ -7,6 +7,7 @@
'variables': {
'base_target': 0,
'chromium_root': '<(DEPTH)/third_party/chromium/src',
+ 'system_include_path_execinfo%': '%%LOCALBASE%%/include',
+ 'system_include_path_execinfo%': '/usr/include',
},
'target_conditions': [
# This part is shared between the targets defined below. Only files and

View file

@ -56,10 +56,6 @@ PLIST_SUB+= GNOME=""
PLIST_SUB+= GNOME="@comment "
.endif
.if !exists(/usr/lib/libexecinfo.so)
STATIC_LIBEXECINFO= ${LOCALBASE}/lib/libexecinfo.a
.endif
post-extract:
${CP} ${FILESDIR}/monitor_bsd.xpm \
${WRKSRC}/afterstep/desktop/icons/xml/monitor-bsd.xpm
@ -85,9 +81,6 @@ post-patch:
@${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},g' \
${WRKSRC}/${f}
.endfor
@${REINPLACE_CMD} \
-e 's,%%STATIC_LIBEXECINFO%%,${STATIC_LIBEXECINFO},g' \
${WRKSRC}/configure
.if exists(${PREFIX}/share/gnome/wm-properties)
pre-install:

View file

@ -5,7 +5,7 @@
if test "x$enable_staticlibs" = "xyes"; then
- AFTERBASE_LIB="../../libAfterBase/libAfterBase.a"
+ AFTERBASE_LIB="../../libAfterBase/libAfterBase.a %%STATIC_LIBEXECINFO%%"
+ AFTERBASE_LIB="../../libAfterBase/libAfterBase.a
AFTERIMAGE_LIB="../../libAfterImage/libAfterImage.a"
AFTERSTEP_LIB="../../libAfterStep/libAfterStep.a"
AFTERCONF_LIB="../../libAfterConf/libAfterConf.a"
@ -14,7 +14,7 @@
LIBINSTALL="install.cyg"
else
- AFTERBASE_LIB="../../libAfterBase/libAfterBase.so"
+ AFTERBASE_LIB="../../libAfterBase/libAfterBase.so %%STATIC_LIBEXECINFO%%"
+ AFTERBASE_LIB="../../libAfterBase/libAfterBase.so
AFTERIMAGE_LIB="../../libAfterImage/libAfterImage.so"
AFTERSTEP_LIB="../../libAfterStep/libAfterStep.so"
AFTERCONF_LIB="../../libAfterConf/libAfterConf.so"
@ -23,7 +23,7 @@
fi
-AFTERBASE_STATIC_LIB="../../libAfterBase/libAfterBase.a"
+AFTERBASE_STATIC_LIB="../../libAfterBase/libAfterBase.a %%STATIC_LIBEXECINFO%%"
+AFTERBASE_STATIC_LIB="../../libAfterBase/libAfterBase.a
AFTERIMAGE_STATIC_LIB="../../libAfterImage/libAfterImage.a"
AFTERSTEP_STATIC_LIB="../../libAfterStep/libAfterStep.a"
AFTERCONF_STATIC_LIB="../../libAfterConf/libAfterConf.a"

View file

@ -4,7 +4,7 @@
+execinfo_libs="-L%%LOCALBASE%%/lib -lexecinfo"
+execinfo_libs="-lexecinfo"
+LIBS="$execinfo_libs $LIBS"
for ac_func in backtrace_symbols_fd backtrace_symbols backtrace
do

View file

@ -5,7 +5,7 @@
LIBS_PRIVATE = ../libAfterConf/libAfterConf.a ../libAfterStep/libAfterStep.a\
- ../libAfterImage/libAfterImage.a ../libAfterBase/libAfterBase.a
+ ../libAfterImage/libAfterImage.a ../libAfterBase/libAfterBase.a -L%%LOCALBASE%%/lib -lexecinfo
+ ../libAfterImage/libAfterImage.a ../libAfterBase/libAfterBase.a -lexecinfo
LIB_INCS= afterconf.h

View file

@ -5,10 +5,10 @@
AFTERBASE_C=
if test "x$have_x" != "xyes" -a "x$have_gif" = "xyes"; then
- AFTERIMAGE_LIBS="$AFTERIMAGE_LIBS -lAfterBase"
+ AFTERIMAGE_LIBS="$AFTERIMAGE_LIBS -lAfterBase -L%%LOCALBASE%%/lib -lexecinfo"
+ AFTERIMAGE_LIBS="$AFTERIMAGE_LIBS -lAfterBase -lexecinfo"
else
- AFTERIMAGE_LIBS="-lAfterBase $AFTERIMAGE_LIBS"
+ AFTERIMAGE_LIBS="-lAfterBase -L%%LOCALBASE%%/lib -lexecinfo $AFTERIMAGE_LIBS"
+ AFTERIMAGE_LIBS="-lAfterBase -lexecinfo $AFTERIMAGE_LIBS"
fi
if test -r "../libAfterBase/astypes.h"; then
AFTERIMAGE_APPS_LIBS="-L../ -L../../libAfterBase -lAfterImage $AFTERIMAGE_LIBS"