Fix build on amd64 (add -fPIC). Respect CFLAGS. Switch to tcl/tk 8.4.

Bump PORTREVISION.

Approved by:	maintainer
This commit is contained in:
Kris Kennaway 2004-03-06 12:08:50 +00:00
parent f4617b04c3
commit cba7dc1bc7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=103095
2 changed files with 7 additions and 18 deletions

View file

@ -7,13 +7,14 @@
PORTNAME= dirdiff
PORTVERSION= 1.2
CATEGORIES= sysutils
PORTREVISION= 1
CATEGORIES= sysutils tcl84 tk84
MASTER_SITES= ftp://samba.org/pub/paulus/
MAINTAINER= grog@FreeBSD.Org
COMMENT= A graphical diff tool
BUILD_DEPENDS= tclsh8.2:${PORTSDIR}/lang/tcl82
RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
BUILD_DEPENDS= tclsh8.4:${PORTSDIR}/lang/tcl84
RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
.include <bsd.port.mk>

View file

@ -1,23 +1,11 @@
diff -wur dirdiff-1.2/Makefile work/dirdiff-1.2/Makefile
--- Makefile Wed Mar 14 15:10:19 2001
+++ work/dirdiff-1.2/Makefile Mon May 7 15:39:30 2001
--- Makefile.orig Tue Mar 13 20:40:19 2001
+++ Makefile Fri Mar 5 04:55:10 2004
@@ -6,7 +6,7 @@
INSTALL=install
# You may need to change the -I arguments depending on your system
-CFLAGS=-O3 -I/usr/include/tcl8.3/ -I/usr/include/tcl
+CFLAGS=-O2 -I/usr/local/include/tcl -I/usr/local/include/tcl8.2/
+CFLAGS+=-fPIC -I/usr/local/include/tcl8.4/
all: filecmp.so.0.0
diff -wur dirdiff-1.2/dirdiff work/dirdiff-1.2/dirdiff
--- dirdiff Wed Mar 14 15:00:41 2001
+++ work/dirdiff-1.2/dirdiff Mon May 7 15:41:35 2001
@@ -1,6 +1,6 @@
#!/bin/sh
# Tcl ignores the next line \
-exec wish "$0" -- "${1+$@}"
+exec wish8.2 "$0" -- "${1+$@}"
# Copyright (C) 1999-2001 Paul Mackerras. All rights reserved.
# This program is free software; it may be used, copied, modified