Support OPTIONS framework and add a patch to fix configure script (patch submitted upstream)
PR: ports/106031 Submitted by: Diane Bruce <db@db.net> (maintainer)
This commit is contained in:
parent
50a85abe89
commit
cbefddefbb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=178840
2 changed files with 45 additions and 1 deletions
|
@ -7,6 +7,7 @@
|
|||
|
||||
PORTNAME= tlf
|
||||
PORTVERSION= 0.9.30
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= comms hamradio
|
||||
MASTER_SITES= http://www.wwns.com/tlf/ \
|
||||
http://sharon.esrac.ele.tue.nl/pub/linux/ham/tlf/
|
||||
|
@ -15,9 +16,22 @@ DIST_SUBDIR= ${PORTNAME}
|
|||
MAINTAINER= db@db.net
|
||||
COMMENT= Amateur Radio curses based logging program
|
||||
|
||||
USE_AUTOTOOLS= autoconf:259 libtool:15 aclocal:19 automake:19
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
|
||||
--libdir="${LOCALBASE}/lib"
|
||||
CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
|
||||
OPTIONS= HAMLIB "Use hamlib" ON
|
||||
|
||||
MAN1= tlf.1
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if !defined(WITHOUT_HAMLIB)
|
||||
LIB_DEPENDS+= hamlib:${PORTSDIR}/comms/hamlib
|
||||
CONFIGURE_ARGS+= --enable-hamlib
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-hamlib
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
30
comms/tlf/files/patch-configure.in
Normal file
30
comms/tlf/files/patch-configure.in
Normal file
|
@ -0,0 +1,30 @@
|
|||
--- configure.in.orig Wed Apr 5 03:22:01 2006
|
||||
+++ configure.in Tue Nov 21 14:23:37 2006
|
||||
@@ -8,6 +8,10 @@
|
||||
AC_PROG_INSTALL
|
||||
AC_PROG_AWK
|
||||
|
||||
+CPPFLAGS="-I${includedir}"
|
||||
+LDFLAGS="-L${libdir}"
|
||||
+LIBS="-L${libdir} ${LIBS}"
|
||||
+
|
||||
# Checks for header files.
|
||||
AC_HEADER_STDC
|
||||
AC_CHECK_HEADERS([fcntl.h stdlib.h string.h sys/ioctl.h unistd.h])
|
||||
@@ -22,6 +26,7 @@
|
||||
#AC_CHECK_LIB(hamlib,main,,AC_MSG_ERROR([Hamradio control libraries (hamlib) not found! ABORTED!]))
|
||||
#AC_CHECK_HEADERS(hamlib/rig.h hamlib/riglist.h,,AC_MSG_ERROR([hamlib header(s) not found! ABORTED]))
|
||||
|
||||
+
|
||||
dnl Check if we want to link the Hamradio control libraries (hamlib)
|
||||
AC_ARG_ENABLE([hamlib],
|
||||
[ --enable-hamlib Add support for hamradio control libraries],
|
||||
@@ -33,7 +38,7 @@
|
||||
[wanthamlib=false])
|
||||
|
||||
if test "x${wanthamlib}" != "xfalse"; then
|
||||
- AC_CHECK_LIB(hamlib,main,,AC_MSG_ERROR([Hamradio control libraries not found...]))
|
||||
+ AC_CHECK_LIB(hamlib,rig_init,,AC_MSG_ERROR([Hamradio control libraries not found...]))
|
||||
AC_CHECK_HEADERS(hamlib/rig.h,,AC_MSG_ERROR([Hamlib headers not found...]))
|
||||
AC_DEFINE([WANT_HAMLIB], 1, [Want Hamlib])
|
||||
echo "enabling hamlib support"
|
Loading…
Reference in a new issue