liblastfm is a collection of libraries to help you integrate Last.fm services
into your rich desktop software. It depends on Qt 4.4. WWW: http://github.com/mxcl/liblastfm/tree/master PR: 135347 Submitted by: Matt Tosto <datahead4@gmail.com>
This commit is contained in:
parent
06be2cc63e
commit
cc02ac7ea8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=235518
6 changed files with 91 additions and 0 deletions
|
@ -369,6 +369,7 @@
|
|||
SUBDIR += libmp3splt
|
||||
SUBDIR += libmpcdec
|
||||
SUBDIR += libmpd
|
||||
SUBDIR += liblastfm
|
||||
SUBDIR += libmtp
|
||||
SUBDIR += libmusicbrainz
|
||||
SUBDIR += libmusicbrainz3
|
||||
|
|
35
audio/liblastfm/Makefile
Normal file
35
audio/liblastfm/Makefile
Normal file
|
@ -0,0 +1,35 @@
|
|||
# New ports collection makefile for: liblastfm
|
||||
# Date created: Wed Jan 1 00:48:58 EST 2006
|
||||
# Whom: Matt Tosto <datahead4@gmail.com>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= liblastfm
|
||||
PORTVERSION= 0.2.1
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://cdn.last.fm/src/
|
||||
|
||||
MAINTAINER= datahead4@gmail.com
|
||||
COMMENT= Collection of libraries to help integrate Last.fm services
|
||||
|
||||
LIB_DEPENDS= samplerate.1:${PORTSDIR}/audio/libsamplerate \
|
||||
fftw3f.5:${PORTSDIR}/math/fftw3-float \
|
||||
mad.2:${PORTSDIR}/audio/libmad
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_RUBY= yes
|
||||
USE_GMAKE= yes
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= corelib xml network sql gui qtestlib \
|
||||
qmake_build moc_build rcc_build uic_build
|
||||
HAS_CONFIGURE= yes
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
post-extract:
|
||||
${FIND} ${WRKSRC}/admin -type f | ${XARGS} \
|
||||
${REINPLACE_CMD} -e 's|\#\!\/usr\/bin\/ruby|\#\!\/usr\/local\/bin\/ruby|'
|
||||
|
||||
.include <bsd.port.mk>
|
3
audio/liblastfm/distinfo
Normal file
3
audio/liblastfm/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (liblastfm-0.2.1.tar.bz2) = c849a5122f833090184c1a496350dcbc
|
||||
SHA256 (liblastfm-0.2.1.tar.bz2) = a8f816c5b1c624052912afd06351bbb29f876339ee216f5f2fec81740f09fdf9
|
||||
SIZE (liblastfm-0.2.1.tar.bz2) = 86083
|
17
audio/liblastfm/files/patch-configure
Normal file
17
audio/liblastfm/files/patch-configure
Normal file
|
@ -0,0 +1,17 @@
|
|||
--- configure.orig 2009-04-20 20:20:03.000000000 -0500
|
||||
+++ configure 2009-04-20 21:12:07.000000000 -0500
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/bash
|
||||
+#!/bin/sh
|
||||
|
||||
source admin/utils.bash
|
||||
|
||||
@@ -97,7 +97,7 @@
|
||||
case `uname` in
|
||||
Darwin)
|
||||
[ $STATIC_LINK_3RDPARTIES_ON_MAC ] || other_args="CONFIG -= app_bundle";;
|
||||
- Linux)
|
||||
+ Linux | FreeBSD)
|
||||
other_args="CONFIG += warn_off";;
|
||||
*)
|
||||
#Windows, hopefullly
|
4
audio/liblastfm/pkg-descr
Normal file
4
audio/liblastfm/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
|||
liblastfm is a collection of libraries to help you integrate Last.fm services
|
||||
into your rich desktop software. It depends on Qt 4.4.
|
||||
|
||||
WWW: http://github.com/mxcl/liblastfm/tree/master
|
31
audio/liblastfm/pkg-plist
Normal file
31
audio/liblastfm/pkg-plist
Normal file
|
@ -0,0 +1,31 @@
|
|||
include/lastfm/UrlBuilder
|
||||
include/lastfm/Fingerprint
|
||||
include/lastfm/CompleteFingerprint
|
||||
include/lastfm/RadioStation
|
||||
include/lastfm/RadioTuner
|
||||
include/lastfm/Audioscrobbler
|
||||
include/lastfm/Scrobble
|
||||
include/lastfm/ScrobblePoint
|
||||
include/lastfm/Track
|
||||
include/lastfm/MutableTrack
|
||||
include/lastfm/Mbid
|
||||
include/lastfm/Artist
|
||||
include/lastfm/Album
|
||||
include/lastfm/FingerprintId
|
||||
include/lastfm/Playlist
|
||||
include/lastfm/Tag
|
||||
include/lastfm/User
|
||||
include/lastfm/AuthenticatedUser
|
||||
include/lastfm/Xspf
|
||||
include/lastfm/WsAccessManager
|
||||
include/lastfm/WsError
|
||||
include/lastfm/WsKeys
|
||||
include/lastfm/WsRequestBuilder
|
||||
include/lastfm/WsReply
|
||||
include/lastfm/WsDomElement
|
||||
include/lastfm/global.h
|
||||
lib/liblastfm.so
|
||||
lib/liblastfm.so.0
|
||||
lib/liblastfm.so.0.2
|
||||
lib/liblastfm.so.0.2.1
|
||||
@dirrm include/lastfm
|
Loading…
Reference in a new issue