fix pkg-plist
PR: 32623 Submitted by: Ports Fury
This commit is contained in:
parent
b3427beff1
commit
cc2ab76018
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=51242
3 changed files with 53 additions and 22 deletions
|
@ -8,32 +8,36 @@
|
|||
|
||||
PORTNAME= GiNaC
|
||||
PORTVERSION= 1.0.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= math
|
||||
MASTER_SITES= ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/ \
|
||||
http://www.ginac.de/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= cln.2:${PORTSDIR}/math/cln
|
||||
|
||||
USE_BZIP2= yes
|
||||
LIB_DEPENDS= cln:${PORTSDIR}/math/cln
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
USE_GMAKE= yes
|
||||
USE_NEWGCC= yes
|
||||
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
|
||||
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib" \
|
||||
MAKEINFO="makeinfo --no-split"
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= ginsh.1 viewgar.1 ginac-config.1
|
||||
MAN1= ginac-config.1 ginsh.1 viewgar.1
|
||||
|
||||
post-extract:
|
||||
@${RM} -f ${WRKSRC}/doc/tutorial/ginac.info*
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e "s,sstream,strstream,g" ${WRKSRC}/configure
|
||||
.for file in numeric.cpp tostring.h
|
||||
@${PERL} -pi -e "s,sstream,strstream,g ; \
|
||||
s,stringstream,strstream,g" ${WRKSRC}/ginac/${file}
|
||||
.for file in configure ginac/numeric.cpp ginac/tostring.h
|
||||
@${PERL} -pi -e 's|sstream|strstream|g ; \
|
||||
s|stringstream|strstream|g' ${WRKSRC}/${file}
|
||||
.endfor
|
||||
|
||||
pre-build:
|
||||
@(cd ${WRKSRC} ; \
|
||||
${LN} -sf ${PREFIX}/bin/libtool)
|
||||
@${PERL} -pi -e 's|-release \$$\(LT_RELEASE\)||g' \
|
||||
${WRKSRC}/ginac/Makefile.in
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
32
math/GiNaC/files/patch-ltmain.sh
Normal file
32
math/GiNaC/files/patch-ltmain.sh
Normal file
|
@ -0,0 +1,32 @@
|
|||
--- ltmain.sh.orig Thu Nov 22 23:00:08 2001
|
||||
+++ ltmain.sh Fri Dec 7 23:34:47 2001
|
||||
@@ -1043,14 +1043,14 @@
|
||||
# These systems don't actually have a C library (as such)
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
test "X$arg" = "X-lc" && continue
|
||||
;;
|
||||
esac
|
||||
elif test "X$arg" = "X-lc_r"; then
|
||||
case $host in
|
||||
- *-*-openbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd*)
|
||||
# Do not include libc_r directly, use -pthread flag.
|
||||
continue
|
||||
;;
|
||||
@@ -4210,10 +4210,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if /usr/bin/false ; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
|
@ -5,9 +5,9 @@ include/ginac/add.h
|
|||
include/ginac/archive.h
|
||||
include/ginac/assertion.h
|
||||
include/ginac/basic.h
|
||||
include/ginac/constant.h
|
||||
include/ginac/clifford.h
|
||||
include/ginac/color.h
|
||||
include/ginac/constant.h
|
||||
include/ginac/ex.h
|
||||
include/ginac/expair.h
|
||||
include/ginac/expairseq.h
|
||||
|
@ -39,16 +39,11 @@ include/ginac/tensor.h
|
|||
include/ginac/tinfos.h
|
||||
include/ginac/version.h
|
||||
include/ginac/wildcard.h
|
||||
@dirrm include/ginac
|
||||
@unexec install-info --delete %D/info/ginac.info %D/info/dir
|
||||
info/ginac.info
|
||||
info/ginac.info-1
|
||||
info/ginac.info-2
|
||||
info/ginac.info-3
|
||||
info/ginac.info-4
|
||||
info/ginac.info-5
|
||||
@exec install-info %D/info/ginac.info %D/info/dir
|
||||
lib/libginac.a
|
||||
lib/libginac.so
|
||||
lib/libginac-1.0.so.0
|
||||
lib/libginac.so.0
|
||||
share/aclocal/ginac.m4
|
||||
@dirrm include/ginac
|
||||
|
|
Loading…
Reference in a new issue