IO::Interface adds object-methods to IO::Socket objects to allow
them to get and set operational characteristics of network interface cards, such as IP addresses, net masks, and so forth. It is useful for identifying runtime characteristics of cards, such as broadcast addresses, and finding interfaces that satisfy certain criteria, such as the ability to multicast. PR: ports/26876
This commit is contained in:
parent
c4e3d79cbc
commit
cc63125ef5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=42007
7 changed files with 66 additions and 0 deletions
|
@ -226,6 +226,7 @@
|
|||
SUBDIR += p5-Archie
|
||||
SUBDIR += p5-Cflow
|
||||
SUBDIR += p5-Frontier-RPC
|
||||
SUBDIR += p5-IO-Interface
|
||||
SUBDIR += p5-Mon
|
||||
SUBDIR += p5-Net
|
||||
SUBDIR += p5-Net-DNS
|
||||
|
|
22
net/p5-IO-Interface/Makefile
Normal file
22
net/p5-IO-Interface/Makefile
Normal file
|
@ -0,0 +1,22 @@
|
|||
# New ports collection makefile for: net/p5-IO-Interface
|
||||
# Date created: 26 April 2001
|
||||
# Whom: Anton Berezin <tobez@tobez.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= IO-Interface
|
||||
PORTVERSION= 0.94
|
||||
CATEGORIES= net perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= IO
|
||||
PKGNAMEPREFIX= p5-
|
||||
|
||||
MAINTAINER= tobez@tobez.org
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
|
||||
MAN3= IO::Interface.3
|
||||
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
|
||||
|
||||
.include <bsd.port.mk>
|
1
net/p5-IO-Interface/distinfo
Normal file
1
net/p5-IO-Interface/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (IO-Interface-0.94.tar.gz) = 3488c7120239b1f257728793f092d903
|
24
net/p5-IO-Interface/files/patch-OSIOCGIFCONF
Normal file
24
net/p5-IO-Interface/files/patch-OSIOCGIFCONF
Normal file
|
@ -0,0 +1,24 @@
|
|||
--- Interface.xs.orig Wed Apr 25 15:45:43 2001
|
||||
+++ Interface.xs Wed Apr 25 15:47:13 2001
|
||||
@@ -13,6 +13,12 @@
|
||||
#include <sys/sockio.h>
|
||||
#endif
|
||||
|
||||
+#ifdef OSIOCGIFCONF
|
||||
+#define MY_SIOCGIFCONF OSIOCGIFCONF
|
||||
+#else
|
||||
+#define MY_SIOCGIFCONF SIOCGIFCONF
|
||||
+#endif
|
||||
+
|
||||
#ifdef PerlIO
|
||||
typedef PerlIO * InputStream;
|
||||
#else
|
||||
@@ -581,7 +587,7 @@
|
||||
croak("Couldn't malloc buffer for ioctl: %s",strerror(errno));
|
||||
ifc.ifc_len = len;
|
||||
ifc.ifc_buf = buf;
|
||||
- if (ioctl(PerlIO_fileno(sock),SIOCGIFCONF,&ifc) < 0) {
|
||||
+ if (ioctl(PerlIO_fileno(sock),MY_SIOCGIFCONF,&ifc) < 0) {
|
||||
if (errno != EINVAL || lastlen != 0)
|
||||
XSRETURN_EMPTY;
|
||||
} else {
|
1
net/p5-IO-Interface/pkg-comment
Normal file
1
net/p5-IO-Interface/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Perl extension for access to network card configuration information
|
9
net/p5-IO-Interface/pkg-descr
Normal file
9
net/p5-IO-Interface/pkg-descr
Normal file
|
@ -0,0 +1,9 @@
|
|||
IO::Interface adds object-methods to IO::Socket objects to allow
|
||||
them to get and set operational characteristics of network interface
|
||||
cards, such as IP addresses, net masks, and so forth. It is useful
|
||||
for identifying runtime characteristics of cards, such as broadcast
|
||||
addresses, and finding interfaces that satisfy certain criteria,
|
||||
such as the ability to multicast.
|
||||
|
||||
-Anton
|
||||
<tobez@tobez.org>
|
8
net/p5-IO-Interface/pkg-plist
Normal file
8
net/p5-IO-Interface/pkg-plist
Normal file
|
@ -0,0 +1,8 @@
|
|||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/IO/Interface.pm
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Interface/.packlist
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Interface/Interface.bs
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Interface/Interface.so
|
||||
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Interface/autosplit.ix
|
||||
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Interface
|
||||
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO 2>/dev/null || true
|
||||
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/IO 2>/dev/null || true
|
Loading…
Reference in a new issue