Update to 0.8.7.

PR:		31847
Submitted by:	maintainer
This commit is contained in:
Anton Berezin 2001-11-18 22:48:04 +00:00
parent eee478834b
commit ccd489da95
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=50199
3 changed files with 7 additions and 21 deletions

View file

@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= libesmtp
PORTVERSION= 0.8.6
PORTREVISION= 2
PORTVERSION= 0.8.7
CATEGORIES= mail
MASTER_SITES= http://www.stafford.uklinux.net/libesmtp/ \
http://www.tobez.org/download/port-mirrors/mail/libesmtp/ \
@ -21,17 +20,15 @@ USE_AUTOCONF= yes
USE_LIBTOOL= yes
LIBTOOLFILES= ${WRKSRC}/aclocal.m4 ${WRKSRC}/libltdl/aclocal.m4
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
# require-all-recipients is required for Balsa-1.2.x
CONFIGURE_ARGS= --enable-require-all-recipients \
--enable-etrn \
# require-all-recipients (implied by enable-all) is required for Balsa-1.2.x
CONFIGURE_ARGS= --enable-all \
--disable-ltdl-install
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure.in
pre-build:
@${CP} ${WRKSRC}/libltdl/libtool ${WRKSRC}/libtool

View file

@ -1 +1 @@
MD5 (libesmtp-0.8.6.tar.bz2) = 2b0faec540e606109535f6ba76f3a45b
MD5 (libesmtp-0.8.7.tar.bz2) = e42722f24a5f8cfe250e3c9c3b64cd0a

View file

@ -1,11 +0,0 @@
--- headers.c Wed Oct 17 00:16:54 2001
+++ headers.c.new Fri Oct 19 08:58:56 2001
@@ -688,7 +688,7 @@
if ((print = action->print) == NULL)
print = print_string;
cat_reset (&message->hdr_buffer, 0);
- (*print) (message, message->current_header);
+ (*print) (message, info->hdr);
header = cat_buffer (&message->hdr_buffer, len);
}
}