- Update phonon, phonon-gstreamer and phonon-xine to 4.4.4.

- Update phonon-vlc to 0.3.2.
This commit is contained in:
Alberto Villa 2011-03-25 10:14:53 +00:00
parent 6951a4e268
commit ccd7c5cb51
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=271645
20 changed files with 114 additions and 345 deletions

View file

@ -5,11 +5,12 @@
# $FreeBSD$
PORTNAME= phonon
PORTVERSION= 4.4.2
PORTVERSION= 4.4.4
CATEGORIES= multimedia kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${PHONON_BRANCH}/${PORTNAME}/${PORTVERSION}/
MASTER_SITE_SUBDIR= ${PHONON_BRANCH}/${PORTNAME}/${PORTNAME}-backend${PKGNAMESUFFIX}/${PORTVERSION}/src
PKGNAMESUFFIX= -gstreamer
DISTNAME= ${PORTNAME}-backend${PKGNAMESUFFIX}-${PORTVERSION}
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
@ -36,17 +37,11 @@ CMAKE_ARGS+= -DWITH_Alsa:BOOL=OFF
IGNORE= conflicts with Qt4 phonon. Please, deinstall qt4-phonon-gst and set WITH_KDE_PHONON to continue
.endif
post-patch:
#fix finding automoc when PREFIX is not matched KDE4_PREFIX
${REINPLACE_CMD} -e 's|NO_DEFAULT_PATH|${KDE4_PREFIX} NO_DEFAULT_PATH|' \
${PATCH_WRKSRC}/cmake/FindAutomoc4.cmake
pre-configure:
${REINPLACE_CMD} -e '/phonon.pc/s|pkgconfig|../libdata/pkgconfig|' \
-e 's|{QT_INCLUDES}|{QT_INCLUDES} ${LOCALBASE}/include|'\
${REINPLACE_CMD} -e 's|{QT_INCLUDES}|{QT_INCLUDES} ${LOCALBASE}/include|'\
${PATCH_WRKSRC}/CMakeLists.txt
pre-install:
pre-su-install:
${MKDIR} ${QT_PLUGINDIR}/phonon_backend
post-install:

View file

@ -1,3 +1,2 @@
MD5 (KDE/phonon-4.4.2.tar.bz2) = d9eab28383783261254f1cef3b92a3fa
SHA256 (KDE/phonon-4.4.2.tar.bz2) = f1404c3f326201b382c26ba37f2d885d30bc71ba5fd8e1479afb632f92d93486
SIZE (KDE/phonon-4.4.2.tar.bz2) = 629193
SHA256 (KDE/phonon-backend-gstreamer-4.4.4.tar.bz2) = 5696eadfab929bede4b04991e35291317571b8584b3c5fa6cdb158052fd3909e
SIZE (KDE/phonon-backend-gstreamer-4.4.4.tar.bz2) = 87242

View file

@ -1,50 +0,0 @@
--- ./CMakeLists.txt.orig 2009-01-22 11:20:44.000000000 +0300
+++ ./CMakeLists.txt 2009-02-21 01:22:42.000000000 +0300
@@ -127,12 +127,12 @@
try_run(_run_result _compile_result ${CMAKE_BINARY_DIR} ${_source_file} CMAKE_FLAGS "${_include_dirs}")
- if(NOT _compile_result)
- message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
- endif(NOT _compile_result)
- if(_run_result)
- message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
- endif(_run_result)
+# if(NOT _compile_result)
+# message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
+# endif(NOT _compile_result)
+# if(_run_result)
+# message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
+# endif(_run_result)
if (GCC_IS_NEWER_THAN_4_2)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")
@@ -255,8 +255,8 @@
endif(APPLE)
-add_subdirectory(phonon)
-add_subdirectory(includes)
+#add_subdirectory(phonon)
+#add_subdirectory(includes)
if (Q_WS_MAC AND BUILD_PHONON_QT7)
add_subdirectory(qt7)
endif (Q_WS_MAC AND BUILD_PHONON_QT7)
@@ -266,12 +266,12 @@
if (Q_WS_X11)
add_subdirectory(gstreamer)
- add_subdirectory(xine)
+# add_subdirectory(xine)
endif (Q_WS_X11)
-if(NOT WIN32) # pkgconfig file
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc @ONLY)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
-endif(NOT WIN32)
+# if(NOT WIN32) # pkgconfig file
+# configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc @ONLY)
+# install(FILES ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc DESTINATION ${LIB_INSTALL_DIR}/../libdata/../libdata/../libdata/../libdata/../libdata/pkgconfig)
+# endif(NOT WIN32)
macro_display_feature_log()

View file

@ -1,73 +0,0 @@
--- ./cmake/FindPhonon.cmake.orig 2009-02-21 01:19:39.000000000 +0300
+++ ./cmake/FindPhonon.cmake 2009-02-21 01:19:39.000000000 +0300
@@ -0,0 +1,70 @@
+# Find libphonon
+# Once done this will define
+#
+# PHONON_FOUND - system has Phonon Library
+# PHONON_INCLUDES - the Phonon include directory
+# PHONON_LIBS - link these to use Phonon
+# PHONON_VERSION - the version of the Phonon Library
+
+# Copyright (c) 2008, Matthias Kretz <kretz@kde.org>
+#
+# Redistribution and use is allowed according to the terms of the BSD license.
+# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
+
+macro(_phonon_find_version)
+ file(READ "${PHONON_INCLUDE_DIR}/phonon/phononnamespace.h" _phonon_header LIMIT 5000 OFFSET 1000)
+ string(REGEX MATCH "define PHONON_VERSION_STR \"(4\\.[0-9]+\\.[0-9a-z]+)\"" _phonon_version_match "${_phonon_header}")
+ set(PHONON_VERSION "${CMAKE_MATCH_1}")
+ message(STATUS "Phonon Version: ${PHONON_VERSION}")
+endmacro(_phonon_find_version)
+
+find_package(PkgConfig)
+PKG_CHECK_MODULES(PKG_PHONON phonon)
+
+if(PHONON_FOUND)
+ # Already found, nothing more to do except figuring out the version
+ _phonon_find_version()
+else(PHONON_FOUND)
+ if(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
+ set(PHONON_FIND_QUIETLY TRUE)
+ endif(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
+
+ # As discussed on kde-buildsystem: first look at CMAKE_PREFIX_PATH, then at the suggested PATHS (kde4 install dir)
+ find_library(PHONON_LIBRARY NAMES phonon PATHS ${PKG_PHONON_LIBRARY_DIRS} ${KDE4_PREFIX}/lib ${KDE4_LIB_INSTALL_DIR} ${QT_LIBRARY_DIR} NO_SYSTEM_ENVIRONMENT_PATH NO_CMAKE_SYSTEM_PATH)
+ # then at the default system locations (CMAKE_SYSTEM_PREFIX_PATH, i.e. /usr etc.)
+ find_library(PHONON_LIBRARY NAMES phonon)
+
+ find_path(PHONON_INCLUDE_DIR NAMES phonon/phonon_export.h PATHS ${PKG_PHONON_INCLUDE_DIRS} ${KDE4_PREFIX}/include ${KDE4_INCLUDE_INSTALL_DIR} ${QT_INCLUDE_DIR} ${INCLUDE_INSTALL_DIR} NO_SYSTEM_ENVIRONMENT_PATH NO_CMAKE_SYSTEM_PATH)
+ find_path(PHONON_INCLUDE_DIR NAMES phonon/phonon_export.h)
+
+ if(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
+ set(PHONON_LIBS ${phonon_LIB_DEPENDS} ${PHONON_LIBRARY})
+ set(PHONON_INCLUDES ${PHONON_INCLUDE_DIR}/KDE ${PHONON_INCLUDE_DIR}/phonon ${PHONON_INCLUDE_DIR})
+ set(PHONON_FOUND TRUE)
+ _phonon_find_version()
+ else(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
+ set(PHONON_FOUND FALSE)
+ endif(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
+
+ if(PHONON_FOUND)
+ if(NOT PHONON_FIND_QUIETLY)
+ message(STATUS "Found Phonon: ${PHONON_LIBRARY}")
+ message(STATUS "Found Phonon Includes: ${PHONON_INCLUDES}")
+ endif(NOT PHONON_FIND_QUIETLY)
+ else(PHONON_FOUND)
+ if(Phonon_FIND_REQUIRED)
+ if(NOT PHONON_INCLUDE_DIR)
+ message(STATUS "Phonon includes NOT found!")
+ endif(NOT PHONON_INCLUDE_DIR)
+ if(NOT PHONON_LIBRARY)
+ message(STATUS "Phonon library NOT found!")
+ endif(NOT PHONON_LIBRARY)
+ message(FATAL_ERROR "Phonon library or includes NOT found!")
+ else(Phonon_FIND_REQUIRED)
+ message(STATUS "Unable to find Phonon")
+ endif(Phonon_FIND_REQUIRED)
+ endif(PHONON_FOUND)
+
+
+ mark_as_advanced(PHONON_INCLUDE_DIR PHONON_LIBRARY PHONON_INCLUDES)
+endif(PHONON_FOUND)

View file

@ -1,15 +1,10 @@
--- ./gstreamer/CMakeLists.txt.orig 2008-11-24 20:12:02.000000000 +0300
+++ ./gstreamer/CMakeLists.txt 2009-02-21 01:19:39.000000000 +0300
@@ -16,9 +16,12 @@
project(phonon-gstreamer)
include(ConfigureChecks.cmake)
+find_package(Phonon)
+
--- ./gstreamer/CMakeLists.txt.orig 2010-11-24 21:26:19.000000000 +0300
+++ ./gstreamer/CMakeLists.txt 2010-11-27 00:44:31.334007404 +0300
@@ -19,6 +19,7 @@
if (BUILD_PHONON_GSTREAMER)
include_directories(
${CMAKE_CURRENT_BINARY_DIR}
+ ${PHONON_INCLUDES}
${GSTREAMER_INCLUDE_DIR}
${GLIB2_INCLUDE_DIR}
${LIBXML2_INCLUDE_DIR}
${CMAKE_CURRENT_BINARY_DIR}
+ ${PHONON_INCLUDES}
${GSTREAMER_INCLUDE_DIR}
${GSTREAMER_PLUGIN_VIDEO_INCLUDE_DIR}
${GSTREAMER_PLUGIN_AUDIO_INCLUDE_DIR}

View file

@ -0,0 +1,35 @@
--- gstreamer/mediaobject.cpp
+++ gstreamer/mediaobject.cpp
@@ -31,6 +31,7 @@
#include <QtCore/QEvent>
#include <QtCore/QFile>
#include <QtCore/QLibrary>
+#include <QtCore/QPointer>
#include <QtCore/QStringList>
#include <QtCore/QTimer>
#include <QtCore/QVector>
@@ -244,10 +245,11 @@ void MediaObject::pluginInstallationResult(GstInstallPluginsReturn result)
void MediaObject::pluginInstallationDone(GstInstallPluginsReturn result, gpointer userData)
{
- MediaObject *mediaObject = static_cast<MediaObject*>(userData);
- Q_ASSERT(mediaObject);
- qRegisterMetaType<GstInstallPluginsReturn>("GstInstallPluginsReturn");
- QMetaObject::invokeMethod(mediaObject, "pluginInstallationResult", Qt::QueuedConnection, Q_ARG(GstInstallPluginsReturn, result));
+ QPointer<MediaObject> *that = static_cast<QPointer<MediaObject>*>(userData);
+ if (*that) {
+ qRegisterMetaType<GstInstallPluginsReturn>("GstInstallPluginsReturn");
+ QMetaObject::invokeMethod(*that, "pluginInstallationResult", Qt::QueuedConnection, Q_ARG(GstInstallPluginsReturn, result));
+ }
}
#endif // PLUGIN_INSTALL_API
@@ -268,7 +270,7 @@ void MediaObject::installMissingCodecs()
details[1] = NULL;
GstInstallPluginsReturn status;
- status = gst_install_plugins_async(details, ctx, pluginInstallationDone, this);
+ status = gst_install_plugins_async(details, ctx, pluginInstallationDone, new QPointer<MediaObject>(this));
gst_install_plugins_context_free(ctx);
if (status != GST_INSTALL_PLUGINS_STARTED_OK) {

View file

@ -1,4 +1,10 @@
lib/kde4/plugins/phonon_backend/phonon_gstreamer.so
share/icons/hicolor/32x32/apps/phonon-gstreamer.png
share/icons/hicolor/22x22/apps/phonon-gstreamer.png
share/icons/hicolor/128x128/apps/phonon-gstreamer.png
share/icons/hicolor/16x16/apps/phonon-gstreamer.png
share/icons/hicolor/48x48/apps/phonon-gstreamer.png
share/icons/hicolor/scalable/apps/phonon-gstreamer.svgz
share/kde4/services/phononbackends/gstreamer.desktop
@dirrmtry share/kde4/services/phononbackends
@dirrmtry lib/kde4/plugins/phonon_backend

View file

@ -6,12 +6,12 @@
#
PORTNAME= phonon
PORTVERSION= 0.3.1
CATEGORIES= multimedia kde
PORTVERSION= 0.3.2
CATEGORIES= multimedia kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/phonon-backend-vlc/${PORTVERSION}/src
MASTER_SITE_SUBDIR= ${PHONON_BRANCH}/${PORTNAME}/${PORTNAME}-backend${PKGNAMESUFFIX}/${PORTVERSION}/src
PKGNAMESUFFIX= -vlc
DISTNAME= phonon-backend-vlc-${PORTVERSION}
DISTNAME= ${PORTNAME}-backend${PKGNAMESUFFIX}-${PORTVERSION}
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
@ -19,6 +19,7 @@ COMMENT= The VLC backend for Phonon
LIB_DEPENDS= vlc.7:${PORTSDIR}/multimedia/vlc
PHONON_BRANCH= stable
USE_BZIP2= yes
USE_CMAKE= yes
USE_KDE4= kdehier automoc4 kdeprefix
@ -27,4 +28,12 @@ QT_COMPONENTS= dbus phonon \
qmake_build moc_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
PLIST_SUB+= QT_PREFIX=${QT_PREFIX}
pre-su-install:
${MKDIR} ${QT_PLUGINDIR}/phonon_backend
post-install:
${LN} -sf ${PREFIX}/lib/kde4/plugins/phonon_backend/phonon_vlc.so ${QT_PLUGINDIR}/phonon_backend/libphonon_vlc.so
.include <bsd.port.mk>

View file

@ -1,2 +1,2 @@
SHA256 (KDE/phonon-backend-vlc-0.3.1.tar.bz2) = 462e0a558f732480769ce0a2f307798a39252e35f4d2b7e57f77dc7cc5a0739c
SIZE (KDE/phonon-backend-vlc-0.3.1.tar.bz2) = 61370
SHA256 (KDE/phonon-backend-vlc-0.3.2.tar.bz2) = 0fb5c22a9131dcc78b83fc2d35217fe6a5d1f5d8f98113e464ce17c50c7b5f44
SIZE (KDE/phonon-backend-vlc-0.3.2.tar.bz2) = 52391

View file

@ -2,3 +2,6 @@ lib/kde4/plugins/phonon_backend/phonon_vlc.so
share/kde4/services/phononbackends/vlc.desktop
@dirrmtry share/kde4/services/phononbackends
@dirrmtry lib/kde4/plugins/phonon_backend
@cwd %%QT_PREFIX%%
%%QT_PLUGINDIR_REL%%/phonon_backend/libphonon_vlc.so
@dirrmtry %%QT_PLUGINDIR_REL%%/phonon_backend

View file

@ -5,11 +5,12 @@
# $FreeBSD$
PORTNAME= phonon
PORTVERSION= 4.4.2
PORTVERSION= 4.4.4
CATEGORIES= multimedia kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${PHONON_BRANCH}/${PORTNAME}/${PORTVERSION}/
MASTER_SITE_SUBDIR= ${PHONON_BRANCH}/${PORTNAME}/${PORTNAME}-backend${PKGNAMESUFFIX}/${PORTVERSION}/src
PKGNAMESUFFIX= -xine
DISTNAME= ${PORTNAME}-backend${PKGNAMESUFFIX}-${PORTVERSION}
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
@ -29,12 +30,7 @@ QT_COMPONENTS= gui dbus xml phonon \
PLIST_SUB+= QT_PREFIX=${QT_PREFIX}
post-patch:
#fix finding automoc when PREFIX is not matched KDE4_PREFIX
${REINPLACE_CMD} -e 's|NO_DEFAULT_PATH|${KDE4_PREFIX} NO_DEFAULT_PATH|' \
${WRKSRC}/cmake/FindAutomoc4.cmake
pre-install:
pre-su-install:
${MKDIR} ${QT_PLUGINDIR}/phonon_backend
post-install:

View file

@ -1,3 +1,2 @@
MD5 (KDE/phonon-4.4.2.tar.bz2) = d9eab28383783261254f1cef3b92a3fa
SHA256 (KDE/phonon-4.4.2.tar.bz2) = f1404c3f326201b382c26ba37f2d885d30bc71ba5fd8e1479afb632f92d93486
SIZE (KDE/phonon-4.4.2.tar.bz2) = 629193
SHA256 (KDE/phonon-backend-xine-4.4.4.tar.bz2) = 3d0ea02144f7309b9277dc05bc3c7f3235203110e3d310d25fde645075dd5396
SIZE (KDE/phonon-backend-xine-4.4.4.tar.bz2) = 94556

View file

@ -1,51 +0,0 @@
--- ./CMakeLists.txt.orig 2009-01-22 11:20:44.000000000 +0300
+++ ./CMakeLists.txt 2009-02-21 01:22:42.000000000 +0300
@@ -127,12 +127,12 @@
try_run(_run_result _compile_result ${CMAKE_BINARY_DIR} ${_source_file} CMAKE_FLAGS "${_include_dirs}")
- if(NOT _compile_result)
- message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
- endif(NOT _compile_result)
- if(_run_result)
- message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
- endif(_run_result)
+# if(NOT _compile_result)
+# message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
+# endif(NOT _compile_result)
+# if(_run_result)
+# message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
+# endif(_run_result)
if (GCC_IS_NEWER_THAN_4_2)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")
@@ -255,8 +255,8 @@
endif(APPLE)
-add_subdirectory(phonon)
-add_subdirectory(includes)
+#add_subdirectory(phonon)
+#add_subdirectory(includes)
if (Q_WS_MAC AND BUILD_PHONON_QT7)
add_subdirectory(qt7)
endif (Q_WS_MAC AND BUILD_PHONON_QT7)
@@ -265,13 +265,13 @@
endif (Q_WS_WIN)
if (Q_WS_X11)
- add_subdirectory(gstreamer)
+# add_subdirectory(gstreamer)
add_subdirectory(xine)
endif (Q_WS_X11)
-if(NOT WIN32) # pkgconfig file
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc @ONLY)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
-endif(NOT WIN32)
+# if(NOT WIN32) # pkgconfig file
+# configure_file(${CMAKE_CURRENT_SOURCE_DIR}/phonon.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc @ONLY)
+# install(FILES ${CMAKE_CURRENT_BINARY_DIR}/phonon.pc DESTINATION ${LIB_INSTALL_DIR}/../libdata/../libdata/../libdata/../libdata/../libdata/pkgconfig)
+# endif(NOT WIN32)
macro_display_feature_log()

View file

@ -1,73 +0,0 @@
--- ./cmake/FindPhonon.cmake.orig 2009-02-21 01:19:39.000000000 +0300
+++ ./cmake/FindPhonon.cmake 2009-02-21 01:19:39.000000000 +0300
@@ -0,0 +1,70 @@
+# Find libphonon
+# Once done this will define
+#
+# PHONON_FOUND - system has Phonon Library
+# PHONON_INCLUDES - the Phonon include directory
+# PHONON_LIBS - link these to use Phonon
+# PHONON_VERSION - the version of the Phonon Library
+
+# Copyright (c) 2008, Matthias Kretz <kretz@kde.org>
+#
+# Redistribution and use is allowed according to the terms of the BSD license.
+# For details see the accompanying COPYING-CMAKE-SCRIPTS file.
+
+macro(_phonon_find_version)
+ file(READ "${PHONON_INCLUDE_DIR}/phonon/phononnamespace.h" _phonon_header LIMIT 5000 OFFSET 1000)
+ string(REGEX MATCH "define PHONON_VERSION_STR \"(4\\.[0-9]+\\.[0-9a-z]+)\"" _phonon_version_match "${_phonon_header}")
+ set(PHONON_VERSION "${CMAKE_MATCH_1}")
+ message(STATUS "Phonon Version: ${PHONON_VERSION}")
+endmacro(_phonon_find_version)
+
+find_package(PkgConfig)
+PKG_CHECK_MODULES(PKG_PHONON phonon)
+
+if(PHONON_FOUND)
+ # Already found, nothing more to do except figuring out the version
+ _phonon_find_version()
+else(PHONON_FOUND)
+ if(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
+ set(PHONON_FIND_QUIETLY TRUE)
+ endif(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
+
+ # As discussed on kde-buildsystem: first look at CMAKE_PREFIX_PATH, then at the suggested PATHS (kde4 install dir)
+ find_library(PHONON_LIBRARY NAMES phonon PATHS ${PKG_PHONON_LIBRARY_DIRS} ${KDE4_PREFIX}/lib ${KDE4_LIB_INSTALL_DIR} ${QT_LIBRARY_DIR} NO_SYSTEM_ENVIRONMENT_PATH NO_CMAKE_SYSTEM_PATH)
+ # then at the default system locations (CMAKE_SYSTEM_PREFIX_PATH, i.e. /usr etc.)
+ find_library(PHONON_LIBRARY NAMES phonon)
+
+ find_path(PHONON_INCLUDE_DIR NAMES phonon/phonon_export.h PATHS ${PKG_PHONON_INCLUDE_DIRS} ${KDE4_PREFIX}/include ${KDE4_INCLUDE_INSTALL_DIR} ${QT_INCLUDE_DIR} ${INCLUDE_INSTALL_DIR} NO_SYSTEM_ENVIRONMENT_PATH NO_CMAKE_SYSTEM_PATH)
+ find_path(PHONON_INCLUDE_DIR NAMES phonon/phonon_export.h)
+
+ if(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
+ set(PHONON_LIBS ${phonon_LIB_DEPENDS} ${PHONON_LIBRARY})
+ set(PHONON_INCLUDES ${PHONON_INCLUDE_DIR}/KDE ${PHONON_INCLUDE_DIR}/phonon ${PHONON_INCLUDE_DIR})
+ set(PHONON_FOUND TRUE)
+ _phonon_find_version()
+ else(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
+ set(PHONON_FOUND FALSE)
+ endif(PHONON_INCLUDE_DIR AND PHONON_LIBRARY)
+
+ if(PHONON_FOUND)
+ if(NOT PHONON_FIND_QUIETLY)
+ message(STATUS "Found Phonon: ${PHONON_LIBRARY}")
+ message(STATUS "Found Phonon Includes: ${PHONON_INCLUDES}")
+ endif(NOT PHONON_FIND_QUIETLY)
+ else(PHONON_FOUND)
+ if(Phonon_FIND_REQUIRED)
+ if(NOT PHONON_INCLUDE_DIR)
+ message(STATUS "Phonon includes NOT found!")
+ endif(NOT PHONON_INCLUDE_DIR)
+ if(NOT PHONON_LIBRARY)
+ message(STATUS "Phonon library NOT found!")
+ endif(NOT PHONON_LIBRARY)
+ message(FATAL_ERROR "Phonon library or includes NOT found!")
+ else(Phonon_FIND_REQUIRED)
+ message(STATUS "Unable to find Phonon")
+ endif(Phonon_FIND_REQUIRED)
+ endif(PHONON_FOUND)
+
+
+ mark_as_advanced(PHONON_INCLUDE_DIR PHONON_LIBRARY PHONON_INCLUDES)
+endif(PHONON_FOUND)

View file

@ -1,19 +1,13 @@
--- ./xine/CMakeLists.txt.orig 2009-01-08 17:47:18.000000000 +0300
+++ ./xine/CMakeLists.txt 2009-02-21 01:19:39.000000000 +0300
@@ -27,6 +27,7 @@
endif (NOT _OFFT_IS_64BIT)
endif (UNIX)
@@ -88,9 +88,7 @@
SET(XINEWIDGET_FOUND FALSE)
endif(XCB_FOUND)
+find_package(Phonon)
macro_optional_find_package(Xine)
macro_optional_find_package(XCB)
-
-
-include_directories(${XINE_INCLUDE_DIR})
+include_directories(${PHONON_INCLUDES} ${XINE_INCLUDE_DIR})
@@ -97,7 +98,7 @@
if(XINE_FOUND)
- include_directories(${XINE_INCLUDE_DIR})
+ include_directories(${PHONON_INCLUDES} ${XINE_INCLUDE_DIR})
configure_file(config-xine-widget.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-xine-widget.h )
configure_file(config-xine-widget.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-xine-widget.h )
configure_file(xine.desktop.cmake ${CMAKE_CURRENT_BINARY_DIR}/xine.desktop)

View file

@ -5,16 +5,16 @@
# $FreeBSD$
PORTNAME= phonon
PORTVERSION= 4.4.2
PORTVERSION= 4.4.4
CATEGORIES= multimedia kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${PHONON_BRANCH}/${PORTNAME}/${PORTVERSION}/
MASTER_SITE_SUBDIR= ${PHONON_BRANCH}/${PORTNAME}/${PORTVERSION}/src/
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= Multimedia framework for KDE4
CONFLICTS= qt4-phonon-4* kdebase-runtime-4.1.[0-4]*
CONFLICTS= qt4-phonon-4*
PHONON_BRANCH= stable
USE_BZIP2= yes

View file

@ -1,3 +1,2 @@
MD5 (KDE/phonon-4.4.2.tar.bz2) = d9eab28383783261254f1cef3b92a3fa
SHA256 (KDE/phonon-4.4.2.tar.bz2) = f1404c3f326201b382c26ba37f2d885d30bc71ba5fd8e1479afb632f92d93486
SIZE (KDE/phonon-4.4.2.tar.bz2) = 629193
SHA256 (KDE/phonon-4.4.4.tar.bz2) = 4c1d74eb06d58757bd2d81c29a3e9e86ff2e0751c8b4beec5a3365dda34d85f6
SIZE (KDE/phonon-4.4.4.tar.bz2) = 362249

View file

@ -1,32 +0,0 @@
--- ./CMakeLists.txt.orig 2009-01-22 11:20:44.000000000 +0300
+++ ./CMakeLists.txt 2009-02-21 01:36:17.000000000 +0300
@@ -127,12 +127,12 @@
try_run(_run_result _compile_result ${CMAKE_BINARY_DIR} ${_source_file} CMAKE_FLAGS "${_include_dirs}")
- if(NOT _compile_result)
- message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
- endif(NOT _compile_result)
- if(_run_result)
- message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
- endif(_run_result)
+# if(NOT _compile_result)
+# message(FATAL_ERROR "Could not compile simple test program:\n ${_source}")
+# endif(NOT _compile_result)
+# if(_run_result)
+# message(FATAL_ERROR "Qt compiled without support for -fvisibility=hidden. This will break plugins and linking of some applications. Please fix your Qt installation.")
+# endif(_run_result)
if (GCC_IS_NEWER_THAN_4_2)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fvisibility-inlines-hidden")
@@ -260,8 +260,8 @@
endif (Q_WS_WIN)
if (Q_WS_X11)
- add_subdirectory(gstreamer)
- add_subdirectory(xine)
+# add_subdirectory(gstreamer)
+# add_subdirectory(xine)
endif (Q_WS_X11)
if(NOT WIN32) # pkgconfig file

View file

@ -1,3 +1,4 @@
Please consider to install backends for phonon:
- Xine backend (multimedia/phonon-xine) and/or
- Gstreamer backend (multimedia/phonon-gstreamer)
multimedia/phonon-gstreamer Gstreamer backend
multimedia/phonon-vlc VLC backend
multimedia/phonon-xine Xine backend

View file

@ -81,6 +81,8 @@ include/phonon/SeekSlider
include/phonon/StreamInterface
include/phonon/SubtitleDescription
include/phonon/SubtitleDescriptionModel
include/phonon/VideoCaptureDevice
include/phonon/VideoCaptureDeviceModel
include/phonon/VideoPlayer
include/phonon/VideoWidget
include/phonon/VideoWidgetInterface
@ -109,6 +111,7 @@ include/phonon/experimental/audiodataoutput.h
include/phonon/experimental/audiodataoutputinterface.h
include/phonon/experimental/audioformat.h
include/phonon/experimental/avcapture.h
include/phonon/experimental/avcaptureinterface.h
include/phonon/experimental/backendcapabilities.h
include/phonon/experimental/backendinterface.h
include/phonon/experimental/export.h
@ -156,6 +159,18 @@ lib/libphononexperimental.so.4
lib/libphononexperimental.so.4.4.0
libdata/pkgconfig/phonon.pc
share/dbus-1/interfaces/org.kde.Phonon.AudioOutput.xml
share/phonon-buildsystem/FindAutomoc4.cmake
share/phonon-buildsystem/FindPackageHandleStandardArgs.cmake
share/phonon-buildsystem/FindPhonon.cmake
share/phonon-buildsystem/FindPhononInternal.cmake
share/phonon-buildsystem/FindQt4.cmake
share/phonon-buildsystem/MacroEnsureVersion.cmake
share/phonon-buildsystem/MacroLogFeature.cmake
share/phonon-buildsystem/MacroOptionalFindPackage.cmake
share/phonon-buildsystem/MacroPushRequiredVars.cmake
share/phonon-buildsystem/PhononMacros.cmake
share/phonon-buildsystem/cmake_uninstall.cmake.in
@dirrm share/phonon-buildsystem
@dirrm include/phonon/experimental
@dirrm include/phonon
@dirrm include/KDE/Phonon/Experimental
@ -167,3 +182,5 @@ share/dbus-1/interfaces/org.kde.Phonon.AudioOutput.xml
%%QT_LIBDIR_REL%%/libphonon.so.4
%%QT_LIBDIR_REL%%/libphononexperimental.so
%%QT_LIBDIR_REL%%/libphononexperimental.so.4
share/qt4/mkspecs/modules/qt_phonon.pri
@dirrmtry share/qt4/mkspecs/modules