Upgrade to 4.2.
PR: 7452 Submitted by: Adrian Penisoara <ady@freebsd.ady.ro>
This commit is contained in:
parent
ed56b976a7
commit
cd10d0e6bf
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=12224
3 changed files with 14 additions and 15 deletions
|
@ -1,16 +1,15 @@
|
|||
# New ports collection makefile for: imap-uw
|
||||
# Version required: 4.1beta
|
||||
# Version required: 4.2
|
||||
# Date created: 9 Jan 1997
|
||||
# Whom: pst
|
||||
#
|
||||
# $Id: Makefile,v 1.13 1998/06/07 23:01:28 steve Exp $
|
||||
# $Id: Makefile,v 1.14 1998/07/17 20:19:10 steve Exp $
|
||||
#
|
||||
|
||||
DISTNAME= imap-4.1.FINAL
|
||||
PKGNAME= imap-uw-4.1
|
||||
DISTNAME= imap-4.2
|
||||
PKGNAME= imap-uw-4.2
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://www.freebsd.org/~steve/ \
|
||||
ftp://ftp.cac.washington.edu/imap/
|
||||
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/
|
||||
EXTRACT_SUFX= .tar.Z
|
||||
|
||||
MAINTAINER= imap-uw@freebsd.ady.ro
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (imap-4.1.FINAL.tar.Z) = abb8ff76cda660857ca24da68387d42f
|
||||
MD5 (imap-4.2.tar.Z) = 95931aee4838a37173e8522fb09f9f63
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- src/osdep/unix/Makefile.orig Thu May 28 19:59:35 1998
|
||||
+++ src/osdep/unix/Makefile Sun May 31 18:50:58 1998
|
||||
--- src/osdep/unix/Makefile.orig Thu Jul 16 22:12:22 1998
|
||||
+++ src/osdep/unix/Makefile Tue Jul 21 16:38:38 1998
|
||||
@@ -93,7 +93,7 @@
|
||||
dummy.o pseudo.o netmsg.o flstring.o fdstring.o \
|
||||
rfc822.o nntp.o smtp.o imap4r1.o pop3.o \
|
||||
|
@ -35,25 +35,25 @@
|
|||
BASELDFLAGS="-lcrypt"
|
||||
|
||||
bsi: # BSD/i386
|
||||
@@ -564,10 +569,17 @@
|
||||
@@ -565,10 +570,17 @@
|
||||
@cat ARCHIVE
|
||||
@$(SH) ARCHIVE
|
||||
|
||||
+$(SHLIB): $(SOFILES)
|
||||
+ ld -Bshareable -x -o $(SHLIB) $(SOFILES)
|
||||
+
|
||||
+.c.so: osdep.h
|
||||
+.c.so: osdep.h
|
||||
+ $(CC) -fpic -DPIC -c $(CFLAGS) ${@:.so=.c} -o $@
|
||||
+
|
||||
# Cleanup
|
||||
|
||||
clean:
|
||||
$(RM) auths.c flockbsd.c linkage.[ch] siglocal.c osdep*.[ch] *.o ARCHIVE *FLAGS *TYPE $(ARCHIVE) || true
|
||||
sh -c '$(RM) auths.c flockbsd.c linkage.[ch] siglocal.c osdep*.[ch] *.o ARCHIVE *FLAGS *TYPE $(ARCHIVE) || true'
|
||||
+ $(RM) *.so $(SHLIB)
|
||||
|
||||
|
||||
# Dependencies
|
||||
@@ -601,7 +613,7 @@
|
||||
@@ -602,7 +614,7 @@
|
||||
|
||||
# OS-dependent
|
||||
|
||||
|
@ -62,7 +62,7 @@
|
|||
osdep.h env_unix.h tcp_unix.h \
|
||||
osdep.c env_unix.c fs_unix.c ftl_unix.c nl_unix.c tcp_unix.c \
|
||||
auths.c flock.c flockbsd.c flcksafe.c fsync.c gethstid.c \
|
||||
@@ -613,7 +625,12 @@
|
||||
@@ -614,7 +626,12 @@
|
||||
write.c \
|
||||
strerror.c strpbrk.c strstr.c strtok.c strtoul.c \
|
||||
OSCFLAGS
|
||||
|
@ -74,4 +74,4 @@
|
|||
+ $(CC) $(CFLAGS) `cat OSCFLAGS` -c osdep.c -o $@ -fpic -DPIC
|
||||
|
||||
osdep.c: osdepbas.c osdepckp.c osdeplog.c
|
||||
$(RM) osdep.c || true
|
||||
sh -c '$(RM) osdep.c || true'
|
||||
|
|
Loading…
Reference in a new issue