Apache http server: 1.3.26
Russian patch (RA): 30.14
mod_ssl:            2.8.10

PR:		40037
Submitted by:	"Lev A. Serebryakov" <lev@serebryakov.spb.ru> (maintainer)
This commit is contained in:
Dmitry Sivachenko 2002-07-02 08:44:07 +00:00
parent bd531a7300
commit cd4aae388c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=62317
10 changed files with 609 additions and 597 deletions

View file

@ -6,38 +6,56 @@
#
PORTNAME= apache+mod_ssl
PORTVERSION= ${VERSION_APACHE}+${RA_VERSION}+${VERSION_MODSSL}
PORTVERSION= ${VERSION_APACHE}.${VERSION_RA}.${VERSION_MODSSL}
CATEGORIES= russian www security
MASTER_SITES= ftp://ftp.lexa.ru/pub/apache-rus/ \
ftp://ftp.lexa.ru/pub/apache-rus/old-versions/ \
ftp://ftp.chg.ru/pub/WWW/httpd/apache-rus/ \
http://www.modssl.org/source/ \
ftp://ftp.modssl.org/source/ \
ftp://ftp.pca.dfn.de/pub/tools/net/mod_ssl/ \
ftp://ftp.ecrc.net/pub/security/mod_ssl/ \
ftp://ftp.nvg.ntnu.no/pub/unix/mod_ssl/ \
ftp://ftp.ulpgc.es/pub/mod_ssl/ \
ftp://glock.missouri.edu/pub/mod_ssl/ \
ftp://ftp.fu-berlin.de/unix/security/mod_ssl/ \
ftp://ftp.ntrl.net/pub/mirror/ralfsw/mod_ssl/
DISTNAME= apache_${VERSION_APACHE}rusPL${RA_VERSION}
MASTER_SITES= http://www.apache.org/dist/httpd/ \
ftp://ftp.ccs.neu.edu/net/mirrors/ftp.apache.org/apache/dist/httpd/ \
ftp://ftp.rge.com/pub/infosystems/apache/dist/httpd/ \
ftp://apache.compuex.com/pub/apache/dist/httpd/ \
ftp://apache.arctic.org/pub/apache/dist/httpd/ \
ftp://ftp.epix.net/pub/apache/dist/httpd/ \
ftp://ftp.ameth.org/pub/mirrors/ftp.apache.org/apache/dist/httpd/ \
ftp://ftp.connectnet.com/pub/www/apache/httpd/ \
ftp://apache.technomancer.com/mirrors/apache/dist/httpd/ \
ftp://ftp.raver.net/pub/ftp.apache.org/httpd/ \
ftp://www3.service.digital.com/apache/dist/httpd/ \
ftp://galileo.galilei.com/pub/apache/httpd/ \
ftp://ftp.mtnranch.net/pub/apache/dist/httpd/ \
ftp://ftp.iodynamics.com/pub/mirror/apache/dist/httpd/ \
ftp://apache.nextpath.com/pub/apache/dist/httpd/ \
${MASTER_SITES_MODSSL:S/$/:modssl/} \
${MASTER_SITES_RA:S/$/:rapatches/}
MASTER_SITES_MODSSL= http://www.modssl.org/source/ \
ftp://ftp.modssl.org/source/ \
ftp://ftp.pca.dfn.de/pub/tools/net/mod_ssl/ \
ftp://ftp.ecrc.net/pub/security/mod_ssl/ \
ftp://ftp.nvg.ntnu.no/pub/unix/mod_ssl/ \
ftp://ftp.ulpgc.es/pub/mod_ssl/ \
ftp://glock.missouri.edu/pub/mod_ssl/ \
ftp://ftp.fu-berlin.de/unix/security/mod_ssl/ \
ftp://ftp.ntrl.net/pub/mirror/ralfsw/mod_ssl/
MASTER_SITES_RA= ftp://ftp.lexa.ru/pub/apache-rus/ \
ftp://ftp.lexa.ru/pub/apache-rus/old-versions/
DISTNAME= apache_${VERSION_APACHE}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
mod_ssl-${VERSION_MODSSL}-${VERSION_APACHE}${EXTRACT_SUFX}
mod_ssl-${VERSION_MODSSL}-${VERSION_APACHE}${EXTRACT_SUFX}:modssl \
patches_${VERSION_APACHE}rusPL${VERSION_RA}.tar.gz:rapatches
MAINTAINER= lev@serebryakov.spb.ru
FORBIDDEN= "Vulnerable to denial-of-service. See" \
"http://httpd.apache.org/info/security_bulletin_20020617.txt"
USE_OPENSSL= YES
.include <bsd.port.pre.mk>
LIB_DEPENDS= mm.11:${PORTSDIR}/devel/mm
VERSION_APACHE= 1.3.22
VERSION_MODSSL= 2.8.5
RA_VERSION= 30.9
VERSION_APACHE= 1.3.26
VERSION_MODSSL= 2.8.10
VERSION_RA= 30.14
USE_PERL5= yes
HAS_CONFIGURE= yes
@ -48,13 +66,14 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
--with-layout=${FILESDIR}/FreeBSD.layout:FreeBSD \
--suexec-docroot=${PREFIX}/www/data \
--without-confadjust \
--enable-shared=remain \
--enable-module=most \
--enable-module=auth_db \
--enable-module=mmap_static \
--disable-module=auth_dbm \
--enable-shared=max \
--enable-module=ssl \
--enable-module=define
--disable-shared=ssl \
--enable-module=define \
--disable-shared=define \
--disable-module=auth_dbm
OPTIM= -DHARD_SERVER_LIMIT=512 \
-DDOCUMENT_LOCATION=\\"${PREFIX}/www/data/\\" \
@ -100,6 +119,11 @@ CONFIGURE_ARGS+= ${APACHE_CONFIGURE_ARGS}
.endif
pre-patch:
@cd ${WRKDIR}/apache_${VERSION_APACHE} \
&& ${ECHO_MSG} "===> Applying Russian Apache extension" \
&& ${PATCH} ${PATCH_DIST_ARGS} < ${WRKDIR}/RA-1.3rusPL${VERSION_RA}.patch
@cd ${WRKDIR} \
&& tar cf - src conf htdocs | tar xf - -C ${WRKDIR}/apache_${VERSION_APACHE}
@cd ${WRKDIR}/mod_ssl-${VERSION_MODSSL}-${VERSION_APACHE} \
&& ${ECHO_MSG} "===> Applying mod_ssl-${VERSION_MODSSL} extension" \
&& ./configure --with-apache=../${DISTNAME} --expert
@ -125,7 +149,7 @@ pre-install:
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/apache.sh ]; then \
${ECHO} "Installing ${PREFIX}/etc/rc.d/apache.sh startup file."; \
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/rc.apache.sh ${PREFIX}/etc/rc.d/apache.sh; \
${INSTALL_SCRIPT} -m 751 ${FILESDIR}/apache.sh ${PREFIX}/etc/rc.d/apache.sh; \
fi
.if defined(WITH_SUEXEC)
@${ECHO_CMD} "sbin/suexec" >> ${TMPPLIST}

View file

@ -1,2 +1,3 @@
MD5 (apache_1.3.22rusPL30.9.tar.gz) = 9c76252ae3a97227364a027acdff6c51
MD5 (mod_ssl-2.8.5-1.3.22.tar.gz) = 5139c874e759b8410a29f9dcb4b578e5
MD5 (apache_1.3.26.tar.gz) = 52e9b875597a208fca9d393e710087b6
MD5 (mod_ssl-2.8.10-1.3.26.tar.gz) = 11260700ab52fb7ff54a25f14052eed4
MD5 (patches_1.3.26rusPL30.14.tar.gz) = 6fbe1a4dc2b14911dc1bbe9b22e639bd

View file

@ -10,7 +10,7 @@
datadir: $prefix/www
iconsdir: $datadir/icons
htdocsdir: $datadir/data
manualdir: $prefix/share/doc/apache
manualdir: $prefix/share/doc/apache/manual
cgidir: $datadir/cgi-bin
includedir: $prefix/include/apache
localstatedir: /var

View file

@ -0,0 +1,20 @@
#!/bin/sh
if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
echo "$0: Cannot determine the PREFIX" >&2
exit 1
fi
case "$1" in
start)
[ -x ${PREFIX}/sbin/apachectl ] && ${PREFIX}/sbin/apachectl startssl > /dev/null && echo -n ' apache'
;;
stop)
[ -r /var/run/httpd.pid ] && ${PREFIX}/sbin/apachectl stop > /dev/null && echo -n ' apache'
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2
;;
esac
exit 0

View file

@ -1,23 +1,19 @@
--- configure.orig Tue Nov 6 11:37:00 2001
+++ configure Tue Nov 6 11:41:25 2001
@@ -1275,8 +1275,8 @@
--- configure.orig Mon Jun 24 17:04:22 2002
+++ configure Mon Jun 24 17:04:51 2002
@@ -1263,7 +1263,7 @@
echo " DEFAULT_PIDLOG: ${runtimedir_relative}${thetarget}.pid"
echo " DEFAULT_SCOREBOARD: ${runtimedir_relative}${thetarget}.scoreboard"
echo " DEFAULT_LOCKFILE: ${runtimedir_relative}${thetarget}.lock"
- echo " DEFAULT_XFERLOG: ${logfiledir_relative}access_log"
- echo " DEFAULT_ERRORLOG: ${logfiledir_relative}error_log"
+ echo " DEFAULT_XFERLOG: ${logfiledir_relative}httpd-access.log"
+ echo " DEFAULT_ERRORLOG: ${logfiledir_relative}httpd-error.log"
echo " TYPES_CONFIG_FILE: ${sysconfdir_relative}mime.types"
echo " SERVER_CONFIG_FILE: ${sysconfdir_relative}${thetarget}.conf"
echo " ACCESS_CONFIG_FILE: ${sysconfdir_relative}access.conf"
@@ -1377,8 +1377,8 @@
@@ -1361,7 +1361,7 @@
echo "echo '-DDEFAULT_PIDLOG=\"${runtimedir_relative}${thetarget}.pid\"'" >>$src/apaci
echo "echo '-DDEFAULT_SCOREBOARD=\"${runtimedir_relative}${thetarget}.scoreboard\"'" >>$src/apaci
echo "echo '-DDEFAULT_LOCKFILE=\"${runtimedir_relative}${thetarget}.lock\"'" >>$src/apaci
-echo "echo '-DDEFAULT_XFERLOG=\"${logfiledir_relative}access_log\"'" >>$src/apaci
-echo "echo '-DDEFAULT_ERRORLOG=\"${logfiledir_relative}error_log\"'" >>$src/apaci
+echo "echo '-DDEFAULT_XFERLOG=\"${logfiledir_relative}httpd-access.log\"'" >>$src/apaci
+echo "echo '-DDEFAULT_ERRORLOG=\"${logfiledir_relative}httpd-error.log\"'" >>$src/apaci
echo "echo '-DTYPES_CONFIG_FILE=\"${sysconfdir_relative}mime.types\"'" >>$src/apaci
echo "echo '-DSERVER_CONFIG_FILE=\"${sysconfdir_relative}${thetarget}.conf\"'" >>$src/apaci

View file

@ -1,21 +1,27 @@
--- Makefile.tmpl.orig Tue Nov 6 11:37:00 2001
+++ Makefile.tmpl Tue Nov 6 11:39:12 2001
@@ -329,10 +329,12 @@
--- Makefile.tmpl.orig Mon Jun 24 17:29:52 2002
+++ Makefile.tmpl Mon Jun 24 17:41:53 2002
@@ -127,6 +127,7 @@
runtimedir = @runtimedir@
logfiledir = @logfiledir@
proxycachedir = @proxycachedir@
+doc_prefix = $(prefix)/share/doc/apache
libexecdir_relative = @libexecdir_relative@
@@ -329,10 +330,10 @@
$(MKDIR) $(root)$(sysconfdir)/ssl.csr
$(MKDIR) $(root)$(sysconfdir)/ssl.key
$(MKDIR) $(root)$(sysconfdir)/ssl.prm
- $(MKDIR) $(root)$(htdocsdir)
+ $(RM) -rf $(root)$(htdocsdir).default
+ $(MKDIR) $(root)$(htdocsdir).default
+ $(MKDIR) $(root)$(doc_prefix)
$(MKDIR) $(root)$(manualdir)
$(MKDIR) $(root)$(iconsdir)
- $(MKDIR) $(root)$(cgidir)
+ $(RM) -rf $(root)$(cgidir).default
+ $(MKDIR) $(root)$(cgidir).default
$(MKDIR) $(root)$(includedir)
$(MKDIR) $(root)$(includedir)/xml
$(MKDIR) $(root)$(sysconfdir)/tables
@@ -532,33 +534,40 @@
@@ -534,32 +535,38 @@
# icons and distributed CGI scripts.
install-data:
@echo "===> [data: Installing initial data files]"
@ -23,37 +29,37 @@
- echo "[PRESERVING EXISTING DATA SUBDIR: $(root)$(htdocsdir)/]"; \
- else \
- echo "Copying tree $(TOP)/htdocs/ -> $(root)$(htdocsdir)/"; \
+# -@if [ -f $(root)$(htdocsdir)/index.html ] || [ -f $(root)$(htdocsdir)/index.html.en ]; then \
+# echo "[PRESERVING EXISTING DATA SUBDIR: $(root)$(htdocsdir)/]"; \
+# else \
+ echo "Copying tree $(TOP)/htdocs/ -> $(root)$(htdocsdir).default/"; \
+# -@if [ -f $(root)$(htdocsdir)/index.html ] || [ -f $(root)$(htdocsdir)/index.html.en ]; then \
+# echo "[PRESERVING EXISTING DATA SUBDIR: $(root)$(htdocsdir)/]"; \
+# else \
+ echo "Copying tree $(TOP)/htdocs/ -> $(root)$(doc_prefix)/"; \
(cd $(TOP)/htdocs/ && $(TAR) $(TAROPT) - index* ra-powered.* apache_pb.* ) |\
- (cd $(root)$(htdocsdir)/ && $(TAR) -xf -); \
- find $(root)$(htdocsdir)/ -type d -exec chmod a+rx {} \; ; \
- find $(root)$(htdocsdir)/ -type f -print | xargs chmod a+r ; \
- fi
- -@if [ -d $(TOP)/htdocs/manual ]; then \
+ (cd $(root)$(htdocsdir).default/ && $(TAR) -xf -); \
+ find $(root)$(htdocsdir).default/ -type d -exec chmod a+rx {} \; ; \
+ find $(root)$(htdocsdir).default/ -type f -print | xargs chmod a+r ; \
+# fi
+# -@if [ -d $(TOP)/htdocs/manual ]; then \
+ (cd $(root)$(doc_prefix)/ && $(TAR) -xf -); \
+ find $(root)$(doc_prefix)/ -type d -exec chmod a+rx {} \; ; \
+ find $(root)$(doc_prefix)/ -type f -print | xargs chmod a+r ; \
+# fi
+# -@if [ -d $(TOP)/htdocs/manual ]; then \
echo "Copying tree $(TOP)/htdocs/manual -> $(root)/$(manualdir)/"; \
(cd $(TOP)/htdocs/manual/ && $(TAR) $(TAROPT) - *) |\
(cd $(root)$(manualdir)/ && $(TAR) -xf -); \
find $(root)$(manualdir)/ -type d -exec chmod a+rx {} \; ; \
find $(root)$(manualdir)/ -type f -print | xargs chmod a+r ; \
+# fi
+ $(LN) -sf $(root)$(manualdir) $(root)$(htdocsdir).default/manual
+ if [ ! -d $(root)$(htdocsdir)/ ]; then \
+ $(LN) -sf $(root)$(htdocsdir).default $(root)$(htdocsdir); \
fi
- fi
- -@if [ -f $(root)$(cgidir)/printenv ]; then \
- echo "[PRESERVING EXISTING CGI SUBDIR: $(root)$(cgidir)/]"; \
- else \
+# -@if [ -f $(root)$(cgidir)/printenv ]; then \
+# echo "[PRESERVING EXISTING CGI SUBDIR: $(root)$(cgidir)/]"; \
+# else \
+# fi
+ if [ ! -d $(root)$(htdocsdir) ]; then \
+ $(LN) -sf $(root)$(doc_prefix) $(root)$(htdocsdir); \
+ fi
+# -@if [ -f $(root)$(cgidir)/printenv ]; then \
+# echo "[PRESERVING EXISTING CGI SUBDIR: $(root)$(cgidir)/]"; \
+# else \
for script in printenv test-cgi; do \
cat $(TOP)/cgi-bin/$${script} |\
sed -e 's;^#!/.*perl;#!$(PERL);' \
@ -63,15 +69,13 @@
+ echo "$(INSTALL_DATA) $(TOP)/conf/$${script}[*] $(root)$(cgidir).default/$${script}"; \
+ $(INSTALL_DATA) $(TOP)/$(SRC)/.apaci.install.tmp $(root)$(cgidir).default/$${script}; \
done; \
- fi
+# fi
+ if [ ! -d $(root)$(cgidir)/ ]; then \
+# fi
+ if [ ! -d $(root)$(cgidir) ]; then \
+ $(LN) -sf $(root)$(cgidir).default $(root)$(cgidir); \
+ fi
fi
@echo "Copying tree $(TOP)/icons/ -> $(root)$(iconsdir)/"; \
(cd $(TOP)/icons/ && $(TAR) $(TAROPT) - *) |\
(cd $(root)$(iconsdir)/ && $(TAR) -xf -); \
@@ -608,15 +617,15 @@
@@ -610,10 +617,10 @@
-e 's;logs/accept\.lock;$(runtimedir)/$(TARGET).lock;' \
-e 's;logs/apache_runtime_status;$(runtimedir)/$(TARGET).scoreboard;' \
-e 's;logs/httpd\.pid;$(runtimedir)/$(TARGET).pid;' \
@ -86,9 +90,3 @@
-e 's;conf/magic;$(sysconfdir)/magic;' \
-e 's;conf/mime\.types;$(sysconfdir)/mime.types;' \
-e 's;conf/tables;$(sysconfdir)/tables;g' \
-e 's;User nobody;User $(conf_user);' \
- -e 's;Group #-1;Group $(conf_group);' \
+ -e 's;Group "#-1";Group $(conf_group);' \
-e 's;Port 80;Port $(conf_port);' \
-e 's;Listen 80;Listen $(conf_port);' \
-e 's;Listen 443;Listen $(conf_port_ssl);' \

View file

@ -1,17 +1,6 @@
--- conf/httpd.conf-dist.orig Tue Nov 6 11:37:00 2001
+++ conf/httpd.conf-dist Tue Nov 6 11:37:59 2001
@@ -92,8 +92,8 @@
# server ignore these files altogether by using "/dev/null" (for Unix) or
# "nul" (for Win32) for the arguments to the directives.
#
-#ResourceConfig conf/srm.conf
-#AccessConfig conf/access.conf
+ResourceConfig /dev/null
+AccessConfig /dev/null
#
# Timeout: The number of seconds before receives and sends time out.
@@ -383,7 +383,22 @@
--- conf/httpd.conf-dist.orig Mon Feb 21 08:30:46 2000
+++ conf/httpd.conf-dist Mon May 29 16:48:49 2000
@@ -354,7 +354,22 @@
# directory index. Separate multiple entries with spaces.
#
<IfModule mod_dir.c>
@ -35,7 +24,7 @@
</IfModule>
#
@@ -503,7 +518,7 @@
@@ -473,7 +488,7 @@
# define per-<VirtualHost> access logfiles, transactions will be
# logged therein and *not* in this file.
#
@ -44,7 +33,7 @@
#
# If you would like to have agent and referer logfiles, uncomment the
@@ -516,7 +531,7 @@
@@ -486,7 +501,7 @@
# If you prefer a single logfile with access, agent, and referer information
# (Combined Logfile Format) you can use the following directive.
#
@ -53,25 +42,4 @@
#
# Optionally add a line containing the server version and virtual host
@@ -793,13 +808,17 @@
# For example, the PHP 3.x module (not part of the Apache distribution - see
# http://www.php.net) will typically use:
#
- #AddType application/x-httpd-php3 .php3
- #AddType application/x-httpd-php3-source .phps
+ <IfModule mod_php3.c>
+ AddType application/x-httpd-php3 .php3
+ AddType application/x-httpd-php3-source .php3s
+ </IfModule>
#
# And for PHP 4.x, use:
#
- #AddType application/x-httpd-php .php
- #AddType application/x-httpd-php-source .phps
+ <IfModule mod_php4.c>
+ AddType application/x-httpd-php .php
+ AddType application/x-httpd-php-source .phps
+ </IfModule>
AddType application/x-tar .tgz

View file

@ -1,16 +0,0 @@
#!/bin/sh
case $1 in
start)
!!PREFIX!!/sbin/apachectl startssl > /dev/null && echo -n ' apache'
;;
stop)
!!PREFIX!!/sbin/apachectl stop > /dev/null
;;
*)
echo "usage: `basename $0` {start|stop}" >&2
exit 64
;;
esac

View file

@ -1,5 +1,5 @@
#!/bin/sh
# $FreeBSD: /tmp/pcvs/ports/russian/apache13-modssl/Attic/pkg-deinstall,v 1.1 2001-11-08 11:23:21 demon Exp $
# $FreeBSD: /tmp/pcvs/ports/russian/apache13-modssl/Attic/pkg-deinstall,v 1.2 2002-07-02 08:44:07 demon Exp $
#
if [ "$2" != "POST-DEINSTALL" ]; then
@ -9,12 +9,7 @@ fi
USER=www
if pw usershow "${USER}" 2>/dev/null 1>&2; then
if pw userdel ${USER}; then
echo "Delete user/group \"${USER}\"."
else
echo "Deleting user/group \"${USER}\" failed..."
exit 1
fi
echo "To delete Apache user permanently, use 'pw userdel ${USER}'"
fi
exit 0

File diff suppressed because it is too large Load diff