New port libdv version 0.9: Quasar DV codec (libdv): software codec
for DV video encoding format Reviewed by: petef
This commit is contained in:
parent
2a6375013b
commit
cd4da6b566
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=50223
21 changed files with 345 additions and 0 deletions
|
@ -141,6 +141,7 @@
|
|||
SUBDIR += libdivxdecore
|
||||
SUBDIR += libdivxdecore-devel
|
||||
SUBDIR += libdjvu++
|
||||
SUBDIR += libdv
|
||||
SUBDIR += libdvdcss
|
||||
SUBDIR += libdvdread
|
||||
SUBDIR += libflash
|
||||
|
|
43
graphics/libdv/Makefile
Normal file
43
graphics/libdv/Makefile
Normal file
|
@ -0,0 +1,43 @@
|
|||
# New ports collection makefile for: libdv
|
||||
# Date created: Sun Nov 18 19:42:02 BRST 2001
|
||||
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libdv
|
||||
PORTVERSION= 0.9
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= lioux@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
popt.0:${PORTSDIR}/devel/popt \
|
||||
SDL-1.1.3:${PORTSDIR}/devel/sdl12
|
||||
|
||||
USE_GTK= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include \
|
||||
-I${X11BASE}/include `${GTK_CONFIG} --cflags` \
|
||||
`${GDK_PIXBUF_CONFIG} --cflags`" \
|
||||
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib \
|
||||
`${GTK_CONFIG} --libs` `${GDK_PIXBUF_CONFIG} --libs`"
|
||||
CONFIGURE_ARGS= --with-sdl-prefix="${LOCALBASE}"
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= encodedv.1 playdv.1
|
||||
|
||||
GDK_PIXBUF_CONFIG?=${X11BASE}/bin/gdk-pixbuf-config
|
||||
|
||||
post-configure:
|
||||
@find ${WRKSRC} -type f -name Makefile -exec \
|
||||
${PERL} -pi.orig -ne 's!-l(gdk|glib|gtk) !!g' {} \;
|
||||
|
||||
post-install:
|
||||
.ifndef(NOPORTDOCS)
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
graphics/libdv/distinfo
Normal file
1
graphics/libdv/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (libdv-0.9.tar.gz) = f8709211c3309ba0071d1a3c4bf7ba26
|
20
graphics/libdv/files/patch-Makefile.in
Normal file
20
graphics/libdv/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- Makefile.in.orig Mon Nov 19 02:04:08 2001
|
||||
+++ Makefile.in Mon Nov 19 02:05:55 2001
|
||||
@@ -348,7 +348,7 @@
|
||||
install-exec-am:
|
||||
install-exec: install-exec-recursive
|
||||
|
||||
-install-data-am: install-pkgconfigDATA
|
||||
+install-data-am:
|
||||
install-data: install-data-recursive
|
||||
|
||||
install-am: all-am
|
||||
@@ -356,7 +356,7 @@
|
||||
install: install-recursive
|
||||
uninstall-am: uninstall-pkgconfigDATA
|
||||
uninstall: uninstall-recursive
|
||||
-all-am: Makefile $(DATA) config.h
|
||||
+all-am: Makefile config.h
|
||||
all-redirect: all-recursive-am
|
||||
install-strip:
|
||||
$(MAKE) $(AM_MAKEFLAGS) AM_INSTALL_PROGRAM_FLAGS=-s install
|
11
graphics/libdv/files/patch-configure
Normal file
11
graphics/libdv/files/patch-configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.orig Sun Jun 24 22:49:16 2001
|
||||
+++ configure Mon Nov 19 15:33:53 2001
|
||||
@@ -6381,7 +6381,7 @@
|
||||
HOST_X86_FALSE=
|
||||
fi
|
||||
|
||||
-REQUIRES='glib >= 1.2.4 gtk+ >= 1.2.4'
|
||||
+REQUIRES='gtk >= 1.2.4'
|
||||
|
||||
succeeded=no
|
||||
|
19
graphics/libdv/files/patch-encodedv:dvconnect.c
Normal file
19
graphics/libdv/files/patch-encodedv:dvconnect.c
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- encodedv/dvconnect.c.orig Sun Jun 24 13:21:45 2001
|
||||
+++ encodedv/dvconnect.c Mon Nov 19 00:53:05 2001
|
||||
@@ -24,6 +24,7 @@
|
||||
*/
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <sys/types.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/mman.h>
|
||||
#include <string.h>
|
||||
@@ -38,7 +39,7 @@
|
||||
#include <popt.h>
|
||||
#endif
|
||||
|
||||
-#include <malloc.h>
|
||||
+#include <stdlib.h>
|
||||
|
||||
#define CIP_N_NTSC 2436
|
||||
#define CIP_D_NTSC 38400
|
35
graphics/libdv/files/patch-playdv:display.c
Normal file
35
graphics/libdv/files/patch-playdv:display.c
Normal file
|
@ -0,0 +1,35 @@
|
|||
--- playdv/display.c.orig Sun Jun 24 13:06:30 2001
|
||||
+++ playdv/display.c Mon Nov 19 00:37:55 2001
|
||||
@@ -47,6 +47,8 @@
|
||||
#include <popt.h>
|
||||
#endif
|
||||
|
||||
+dv_display_t *dv_dpy_on_exit_hack;
|
||||
+
|
||||
static int dv_display_SDL_init(dv_display_t *dv_dpy, gchar *w_name, gchar *i_name );
|
||||
static gboolean dv_display_gdk_init(dv_display_t *dv_dpy, gint *argc, gchar ***argv );
|
||||
|
||||
@@ -675,6 +677,13 @@
|
||||
} /* if */
|
||||
} /* dv_display_exit_handler */
|
||||
|
||||
+static void
|
||||
+dv_display_on_exit_hack_handler()
|
||||
+{
|
||||
+ if(dv_dpy_on_exit_hack) {
|
||||
+ dv_display_exit(dv_dpy_on_exit_hack);
|
||||
+ } /* if */
|
||||
+} /* dv_display_exit_handler */
|
||||
|
||||
gboolean
|
||||
dv_display_init(dv_display_t *dv_dpy, gint *argc, gchar ***argv, gint width, gint height,
|
||||
@@ -804,7 +813,8 @@
|
||||
fprintf(stderr, " Using gtk for display\n");
|
||||
|
||||
ok:
|
||||
- on_exit(dv_display_exit_handler, dv_dpy);
|
||||
+ dv_dpy_on_exit_hack = dv_dpy;
|
||||
+ atexit(dv_display_on_exit_hack_handler);
|
||||
return(TRUE);
|
||||
|
||||
fail:
|
22
graphics/libdv/files/patch-playdv:oss.c
Normal file
22
graphics/libdv/files/patch-playdv:oss.c
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- playdv/oss.c.orig Sun Nov 18 21:50:24 2001
|
||||
+++ playdv/oss.c Sun Nov 18 21:53:48 2001
|
||||
@@ -36,6 +36,19 @@
|
||||
|
||||
#include "oss.h"
|
||||
|
||||
+#ifndef O_LARGEFILE
|
||||
+# define O_LARGEFILE 0
|
||||
+#endif
|
||||
+
|
||||
+#ifndef AFMT_S16_NE
|
||||
+# include <machine/endian.h>
|
||||
+# if BYTE_ORDER == LITTLE_ENDIAN
|
||||
+# define AFMT_S16_NE AFMT_S16_LE
|
||||
+# else
|
||||
+# define AFMT_S16_NE AFMT_S16_BE
|
||||
+# endif
|
||||
+#endif
|
||||
+
|
||||
static const gchar *default_device = "/dev/audio";
|
||||
|
||||
dv_oss_t *
|
1
graphics/libdv/pkg-comment
Normal file
1
graphics/libdv/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Quasar DV codec (libdv): software codec for DV video encoding format
|
11
graphics/libdv/pkg-descr
Normal file
11
graphics/libdv/pkg-descr
Normal file
|
@ -0,0 +1,11 @@
|
|||
The Quasar DV codec (libdv) is a software codec for DV video, the
|
||||
encoding format used by most digital camcorders, typically those
|
||||
that support the IEEE 1394 (a.k.a. FireWire or i.Link) interface.
|
||||
Libdv was developed according to the official standards for DV
|
||||
video: IEC 61834 and SMPTE 314M.
|
||||
|
||||
Please note that this software is only concerned with the DV video
|
||||
compression format, which is different from capturing the data from
|
||||
a camcorder.
|
||||
|
||||
WWW: http://libdv.sourceforge.net/
|
9
graphics/libdv/pkg-plist
Normal file
9
graphics/libdv/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
|||
bin/encodedv
|
||||
bin/playdv
|
||||
include/libdv/dv.h
|
||||
include/libdv/dv_types.h
|
||||
lib/libdv.a
|
||||
lib/libdv.la
|
||||
lib/libdv.so
|
||||
lib/libdv.so.1
|
||||
@dirrm include/libdv
|
43
multimedia/libdv/Makefile
Normal file
43
multimedia/libdv/Makefile
Normal file
|
@ -0,0 +1,43 @@
|
|||
# New ports collection makefile for: libdv
|
||||
# Date created: Sun Nov 18 19:42:02 BRST 2001
|
||||
# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libdv
|
||||
PORTVERSION= 0.9
|
||||
CATEGORIES= graphics
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
||||
MAINTAINER= lioux@FreeBSD.org
|
||||
|
||||
BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
|
||||
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
|
||||
popt.0:${PORTSDIR}/devel/popt \
|
||||
SDL-1.1.3:${PORTSDIR}/devel/sdl12
|
||||
|
||||
USE_GTK= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include \
|
||||
-I${X11BASE}/include `${GTK_CONFIG} --cflags` \
|
||||
`${GDK_PIXBUF_CONFIG} --cflags`" \
|
||||
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib \
|
||||
`${GTK_CONFIG} --libs` `${GDK_PIXBUF_CONFIG} --libs`"
|
||||
CONFIGURE_ARGS= --with-sdl-prefix="${LOCALBASE}"
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
MAN1= encodedv.1 playdv.1
|
||||
|
||||
GDK_PIXBUF_CONFIG?=${X11BASE}/bin/gdk-pixbuf-config
|
||||
|
||||
post-configure:
|
||||
@find ${WRKSRC} -type f -name Makefile -exec \
|
||||
${PERL} -pi.orig -ne 's!-l(gdk|glib|gtk) !!g' {} \;
|
||||
|
||||
post-install:
|
||||
.ifndef(NOPORTDOCS)
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
1
multimedia/libdv/distinfo
Normal file
1
multimedia/libdv/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (libdv-0.9.tar.gz) = f8709211c3309ba0071d1a3c4bf7ba26
|
20
multimedia/libdv/files/patch-Makefile.in
Normal file
20
multimedia/libdv/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- Makefile.in.orig Mon Nov 19 02:04:08 2001
|
||||
+++ Makefile.in Mon Nov 19 02:05:55 2001
|
||||
@@ -348,7 +348,7 @@
|
||||
install-exec-am:
|
||||
install-exec: install-exec-recursive
|
||||
|
||||
-install-data-am: install-pkgconfigDATA
|
||||
+install-data-am:
|
||||
install-data: install-data-recursive
|
||||
|
||||
install-am: all-am
|
||||
@@ -356,7 +356,7 @@
|
||||
install: install-recursive
|
||||
uninstall-am: uninstall-pkgconfigDATA
|
||||
uninstall: uninstall-recursive
|
||||
-all-am: Makefile $(DATA) config.h
|
||||
+all-am: Makefile config.h
|
||||
all-redirect: all-recursive-am
|
||||
install-strip:
|
||||
$(MAKE) $(AM_MAKEFLAGS) AM_INSTALL_PROGRAM_FLAGS=-s install
|
11
multimedia/libdv/files/patch-configure
Normal file
11
multimedia/libdv/files/patch-configure
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.orig Sun Jun 24 22:49:16 2001
|
||||
+++ configure Mon Nov 19 15:33:53 2001
|
||||
@@ -6381,7 +6381,7 @@
|
||||
HOST_X86_FALSE=
|
||||
fi
|
||||
|
||||
-REQUIRES='glib >= 1.2.4 gtk+ >= 1.2.4'
|
||||
+REQUIRES='gtk >= 1.2.4'
|
||||
|
||||
succeeded=no
|
||||
|
19
multimedia/libdv/files/patch-encodedv:dvconnect.c
Normal file
19
multimedia/libdv/files/patch-encodedv:dvconnect.c
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- encodedv/dvconnect.c.orig Sun Jun 24 13:21:45 2001
|
||||
+++ encodedv/dvconnect.c Mon Nov 19 00:53:05 2001
|
||||
@@ -24,6 +24,7 @@
|
||||
*/
|
||||
|
||||
#include <stdio.h>
|
||||
+#include <sys/types.h>
|
||||
#include <sys/ioctl.h>
|
||||
#include <sys/mman.h>
|
||||
#include <string.h>
|
||||
@@ -38,7 +39,7 @@
|
||||
#include <popt.h>
|
||||
#endif
|
||||
|
||||
-#include <malloc.h>
|
||||
+#include <stdlib.h>
|
||||
|
||||
#define CIP_N_NTSC 2436
|
||||
#define CIP_D_NTSC 38400
|
35
multimedia/libdv/files/patch-playdv:display.c
Normal file
35
multimedia/libdv/files/patch-playdv:display.c
Normal file
|
@ -0,0 +1,35 @@
|
|||
--- playdv/display.c.orig Sun Jun 24 13:06:30 2001
|
||||
+++ playdv/display.c Mon Nov 19 00:37:55 2001
|
||||
@@ -47,6 +47,8 @@
|
||||
#include <popt.h>
|
||||
#endif
|
||||
|
||||
+dv_display_t *dv_dpy_on_exit_hack;
|
||||
+
|
||||
static int dv_display_SDL_init(dv_display_t *dv_dpy, gchar *w_name, gchar *i_name );
|
||||
static gboolean dv_display_gdk_init(dv_display_t *dv_dpy, gint *argc, gchar ***argv );
|
||||
|
||||
@@ -675,6 +677,13 @@
|
||||
} /* if */
|
||||
} /* dv_display_exit_handler */
|
||||
|
||||
+static void
|
||||
+dv_display_on_exit_hack_handler()
|
||||
+{
|
||||
+ if(dv_dpy_on_exit_hack) {
|
||||
+ dv_display_exit(dv_dpy_on_exit_hack);
|
||||
+ } /* if */
|
||||
+} /* dv_display_exit_handler */
|
||||
|
||||
gboolean
|
||||
dv_display_init(dv_display_t *dv_dpy, gint *argc, gchar ***argv, gint width, gint height,
|
||||
@@ -804,7 +813,8 @@
|
||||
fprintf(stderr, " Using gtk for display\n");
|
||||
|
||||
ok:
|
||||
- on_exit(dv_display_exit_handler, dv_dpy);
|
||||
+ dv_dpy_on_exit_hack = dv_dpy;
|
||||
+ atexit(dv_display_on_exit_hack_handler);
|
||||
return(TRUE);
|
||||
|
||||
fail:
|
22
multimedia/libdv/files/patch-playdv:oss.c
Normal file
22
multimedia/libdv/files/patch-playdv:oss.c
Normal file
|
@ -0,0 +1,22 @@
|
|||
--- playdv/oss.c.orig Sun Nov 18 21:50:24 2001
|
||||
+++ playdv/oss.c Sun Nov 18 21:53:48 2001
|
||||
@@ -36,6 +36,19 @@
|
||||
|
||||
#include "oss.h"
|
||||
|
||||
+#ifndef O_LARGEFILE
|
||||
+# define O_LARGEFILE 0
|
||||
+#endif
|
||||
+
|
||||
+#ifndef AFMT_S16_NE
|
||||
+# include <machine/endian.h>
|
||||
+# if BYTE_ORDER == LITTLE_ENDIAN
|
||||
+# define AFMT_S16_NE AFMT_S16_LE
|
||||
+# else
|
||||
+# define AFMT_S16_NE AFMT_S16_BE
|
||||
+# endif
|
||||
+#endif
|
||||
+
|
||||
static const gchar *default_device = "/dev/audio";
|
||||
|
||||
dv_oss_t *
|
1
multimedia/libdv/pkg-comment
Normal file
1
multimedia/libdv/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
Quasar DV codec (libdv): software codec for DV video encoding format
|
11
multimedia/libdv/pkg-descr
Normal file
11
multimedia/libdv/pkg-descr
Normal file
|
@ -0,0 +1,11 @@
|
|||
The Quasar DV codec (libdv) is a software codec for DV video, the
|
||||
encoding format used by most digital camcorders, typically those
|
||||
that support the IEEE 1394 (a.k.a. FireWire or i.Link) interface.
|
||||
Libdv was developed according to the official standards for DV
|
||||
video: IEC 61834 and SMPTE 314M.
|
||||
|
||||
Please note that this software is only concerned with the DV video
|
||||
compression format, which is different from capturing the data from
|
||||
a camcorder.
|
||||
|
||||
WWW: http://libdv.sourceforge.net/
|
9
multimedia/libdv/pkg-plist
Normal file
9
multimedia/libdv/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
|||
bin/encodedv
|
||||
bin/playdv
|
||||
include/libdv/dv.h
|
||||
include/libdv/dv_types.h
|
||||
lib/libdv.a
|
||||
lib/libdv.la
|
||||
lib/libdv.so
|
||||
lib/libdv.so.1
|
||||
@dirrm include/libdv
|
Loading…
Reference in a new issue