Update to version 3.4.1.
PR: 52664 Submitted by: Ports Fury
This commit is contained in:
parent
9b6734a98e
commit
cd7ae2a8fe
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=82325
6 changed files with 31 additions and 47 deletions
|
@ -6,15 +6,14 @@
|
|||
#
|
||||
|
||||
PORTNAME= nethack
|
||||
PORTVERSION= 3.4.0
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 3.4.1
|
||||
CATEGORIES?= games
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= nethack
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER?= ports@freebsd.org
|
||||
MAINTAINER?= ports@FreeBSD.org
|
||||
COMMENT?= A dungeon explorin', slashin', hackin' game
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
@ -54,12 +53,6 @@ USE_XPM= yes
|
|||
GRAPHICS= X11_GRAPHICS
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_QT_GRAPHICS) && ${OSVERSION} >= 500113
|
||||
BROKEN= "Does not compile (bad C++ code)"
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
.if defined(WITH_GNOME_GRAPHICS) || defined(WITH_QT_GRAPHICS) \
|
||||
|| defined(WITH_TTY_GRAPHICS) || defined(WITHOUT_X11)
|
||||
|
@ -101,4 +94,4 @@ post-install:
|
|||
${INSTALL_DATA} ${WRKSRC}/doc/Guidebook.txt ${PREFIX}/${HACKDOCSDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (nethack-340.tgz) = 0093f14fbbe449d5b188bfb6aa4eae4f
|
||||
MD5 (nethack-341.tgz) = aefcbeb20210b2d64511c84bd03c3e4e
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- include/unixconf.h.orig Thu Mar 21 08:42:56 2002
|
||||
+++ include/unixconf.h Sun Jun 16 15:05:24 2002
|
||||
--- include/unixconf.h.orig Sun Feb 23 23:43:23 2003
|
||||
+++ include/unixconf.h Sun May 25 10:32:27 2003
|
||||
@@ -19,13 +19,13 @@
|
||||
*/
|
||||
|
||||
|
@ -34,3 +34,12 @@
|
|||
|
||||
/* The Andrew Message System does mail a little differently from normal
|
||||
* UNIX. Mail is deposited in the user's own directory in ~/Mailbox
|
||||
@@ -280,7 +280,7 @@
|
||||
#endif
|
||||
|
||||
#if defined(BSD) || defined(ULTRIX)
|
||||
-# if !defined(DGUX) && !defined(SUNOS4)
|
||||
+# if !defined(DGUX) && !defined(SUNOS4) && !defined(__FreeBSD__)
|
||||
#define memcpy(d, s, n) bcopy(s, d, n)
|
||||
#define memcmp(s1, s2, n) bcmp(s2, s1, n)
|
||||
# endif
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
--- sys/unix/Makefile.src.orig Thu Mar 21 08:43:54 2002
|
||||
+++ sys/unix/Makefile.src Tue Aug 13 05:44:28 2002
|
||||
--- sys/unix/Makefile.src.orig Sun May 25 10:20:20 2003
|
||||
+++ sys/unix/Makefile.src Sun May 25 10:30:45 2003
|
||||
@@ -139,19 +139,28 @@
|
||||
# directories. The ones given below is the usual spot for linux systems.
|
||||
# The paths are for glibconfig.h and gnomesupport.h respectively.
|
||||
|
@ -33,7 +33,7 @@
|
|||
#LD=g++
|
||||
|
||||
# Set the WINSRC, WINOBJ, and WINLIB lines to correspond to your desired
|
||||
@@ -204,7 +213,26 @@
|
||||
@@ -205,7 +214,26 @@
|
||||
#
|
||||
#
|
||||
WINSRC = $(WINTTYSRC)
|
||||
|
@ -60,7 +60,7 @@
|
|||
|
||||
# on some systems the termcap library is in -ltermcap or -lcurses
|
||||
# on 386 Xenix, the -ltermlib tputs() seems not to work; use -lcurses instead
|
||||
@@ -224,19 +252,19 @@
|
||||
@@ -225,19 +253,19 @@
|
||||
#
|
||||
# libraries for X11
|
||||
# If USE_XPM is defined in config.h, you will also need -lXpm here.
|
||||
|
@ -83,7 +83,7 @@
|
|||
#
|
||||
# libraries for Gem port
|
||||
WINGEMLIB = -le_gem -lgem
|
||||
@@ -245,6 +273,15 @@
|
||||
@@ -246,6 +274,15 @@
|
||||
WINBELIB = -lbe
|
||||
|
||||
WINLIB = $(WINTTYLIB)
|
||||
|
@ -99,7 +99,7 @@
|
|||
|
||||
# any other strange libraries your system needs (for Sysunix only -- the more
|
||||
# specialized targets should already be right)
|
||||
@@ -274,7 +311,7 @@
|
||||
@@ -275,7 +312,7 @@
|
||||
LIBS =
|
||||
|
||||
# make NetHack
|
||||
|
@ -108,20 +108,20 @@
|
|||
# GAME = nethack.prg
|
||||
|
||||
# if you defined RANDOM in unixconf.h/tosconf.h since your system did not come
|
||||
@@ -450,13 +487,13 @@
|
||||
@@ -451,13 +488,13 @@
|
||||
|
||||
# Qt windowport meta-object-compiler output
|
||||
qt_kde0.moc: ../include/qt_kde0.h
|
||||
- $(QTDIR)/bin/moc ../include/qt_kde0.h > qt_kde0.moc
|
||||
+ ${MOC} ../include/qt_kde0.h > qt_kde0.moc
|
||||
- $(QTDIR)/bin/moc -o qt_kde0.moc ../include/qt_kde0.h
|
||||
+ ${MOC} -o qt_kde0.moc ../include/qt_kde0.h
|
||||
|
||||
qt_win.moc: ../include/qt_win.h
|
||||
- $(QTDIR)/bin/moc ../include/qt_win.h > qt_win.moc
|
||||
+ ${MOC} ../include/qt_win.h > qt_win.moc
|
||||
- $(QTDIR)/bin/moc -o qt_win.moc ../include/qt_win.h
|
||||
+ ${MOC} -o qt_win.moc ../include/qt_win.h
|
||||
|
||||
qttableview.moc: ../include/qttableview.h
|
||||
- $(QTDIR)/bin/moc ../include/qttableview.h > qttableview.moc
|
||||
+ ${MOC} ../include/qttableview.h > qttableview.moc
|
||||
- $(QTDIR)/bin/moc -o qttableview.moc ../include/qttableview.h
|
||||
+ ${MOC} -o qttableview.moc ../include/qttableview.h
|
||||
|
||||
$(MAKEDEFS): ../util/makedefs.c $(CONFIG_H) ../include/permonst.h \
|
||||
../include/objclass.h ../include/monsym.h \
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- src/topten.c Thu Mar 21 01:43:19 2002
|
||||
+++ src/topten.c Tue Feb 11 15:36:23 2003
|
||||
@@ -855,8 +855,15 @@
|
||||
if (playerct < 1) Strcat(pbuf, "you.");
|
||||
else {
|
||||
if (playerct > 1) Strcat(pbuf, "any of ");
|
||||
- for (i = 0; i < playerct; i++) {
|
||||
- Strcat(pbuf, players[i]);
|
||||
+ for (i = 0; i < playerct && strlen(pbuf) < sizeof(pbuf) - 2;
|
||||
+ i++) {
|
||||
+ size_t len = strlen(pbuf), rest;
|
||||
+ if (strlen(players[i]) > sizeof(pbuf) - len - 2) {
|
||||
+ rest = sizeof(pbuf) - strlen(pbuf) - 2;
|
||||
+ memcpy(pbuf + len, players[i], rest);
|
||||
+ pbuf[len + rest] = '\0';
|
||||
+ } else
|
||||
+ Strcat(pbuf, players[i]);
|
||||
if (i < playerct-1) {
|
||||
if (players[i][0] == '-' &&
|
||||
index("pr", players[i][1]) && players[i][2] == 0)
|
|
@ -1,3 +1,4 @@
|
|||
@comment $FreeBSD$
|
||||
bin/%%HACKNAME%%
|
||||
%%HACKDIR%%/%%HACKNAME%%
|
||||
@exec mkdir %D/%%HACKDIR%%/save
|
||||
|
@ -115,6 +116,7 @@ bin/%%HACKNAME%%
|
|||
%%HACKDIR%%/pet_mark.xbm
|
||||
%%HACKDIR%%/quest.dat
|
||||
%%HACKDIR%%/rip.xpm
|
||||
%%HACKDIR%%/recover
|
||||
%%HACKDIR%%/rumors
|
||||
%%HACKDIR%%/sanctum.lev
|
||||
%%HACKDIR%%/soko1-1.lev
|
||||
|
|
Loading…
Reference in a new issue