- Update to 1.2.3
- Provide ports for both ipv4 and ipv6 reincarnation Submitted by: Jiri Kubicek <jiri.kubicek@kraxnet.cz> Feature safe: yes
This commit is contained in:
parent
9931f0fc7e
commit
cd7fd17a20
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=257096
13 changed files with 151 additions and 24 deletions
|
@ -59,6 +59,7 @@
|
|||
SUBDIR += bing
|
||||
SUBDIR += binkd
|
||||
SUBDIR += bird
|
||||
SUBDIR += bird6
|
||||
SUBDIR += bittwist
|
||||
SUBDIR += blam
|
||||
SUBDIR += bld
|
||||
|
|
|
@ -6,23 +6,24 @@
|
|||
#
|
||||
|
||||
PORTNAME= bird
|
||||
PORTVERSION= 1.2.1
|
||||
PORTVERSION= 1.2.3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://bird.network.cz/pub/bird/
|
||||
|
||||
MAINTAINER= pav@FreeBSD.org
|
||||
COMMENT= Dynamic IP routing daemon
|
||||
COMMENT= Dynamic IP routing daemon (IPv4 version)
|
||||
|
||||
USE_BISON= build
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-ipv6
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
USE_RC_SUBR= bird
|
||||
|
||||
post-install:
|
||||
@if [ ! -f ${PREFIX}/etc/bird6.conf ]; then \
|
||||
${CP} -p ${PREFIX}/etc/bird6.conf.example ${PREFIX}/etc/bird6.conf ; \
|
||||
@if [ ! -f ${PREFIX}/etc/bird.conf ]; then \
|
||||
${CP} -p ${PREFIX}/etc/bird.conf.example ${PREFIX}/etc/bird.conf ; \
|
||||
fi
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (bird-1.2.1.tar.gz) = e158bd0a72e345841e39764975ee1d21
|
||||
SHA256 (bird-1.2.1.tar.gz) = 72d07e28a997b59136b6ccc084c82ad86c0572a8fca709bdeb1acc922f768fe9
|
||||
SIZE (bird-1.2.1.tar.gz) = 760026
|
||||
MD5 (bird-1.2.3.tar.gz) = bf1f4b24627050eead1dceb8c1fd24c3
|
||||
SHA256 (bird-1.2.3.tar.gz) = 503f25ef676c320be3db90b69b8a78da8fda4dc2d640d3aa9dbfae0cb4e66273
|
||||
SIZE (bird-1.2.3.tar.gz) = 865144
|
||||
|
|
32
net/bird/files/bird.in
Normal file
32
net/bird/files/bird.in
Normal file
|
@ -0,0 +1,32 @@
|
|||
#!/bin/sh
|
||||
|
||||
# $FreeBSD$
|
||||
#
|
||||
# PROVIDE: bird
|
||||
# REQUIRE: LOGIN
|
||||
# KEYWORD: shutdown
|
||||
#
|
||||
# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
|
||||
# to enable this service:
|
||||
#
|
||||
# bird_enable (bool): Set to NO by default.
|
||||
# Set it to YES to enable bird.
|
||||
# bird_config (path): Set to %%PREFIX%%/etc/bird.conf
|
||||
# by default.
|
||||
#
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name="bird"
|
||||
rcvar=${name}_enable
|
||||
|
||||
command=%%PREFIX%%/sbin/${name}
|
||||
|
||||
load_rc_config $name
|
||||
|
||||
: ${bird_enable="NO"}
|
||||
: ${bird_config="%%PREFIX%%/etc/bird.conf"}
|
||||
|
||||
command_args="-c $bird_config"
|
||||
|
||||
run_rc_command "$1"
|
|
@ -1,10 +0,0 @@
|
|||
--- sysdep/unix/krt.c.orig Mon Jun 7 18:51:23 2004
|
||||
+++ sysdep/unix/krt.c Thu May 12 20:41:53 2005
|
||||
@@ -639,6 +639,7 @@
|
||||
return;
|
||||
}
|
||||
#endif
|
||||
+ ;
|
||||
}
|
||||
rte_free(e);
|
||||
}
|
|
@ -4,8 +4,11 @@ The BIRD project aims to develop a fully functional dynamic IP routing daemon.
|
|||
- Multiple routing tables
|
||||
- BGP
|
||||
- RIP
|
||||
- OSPF (IPv4 only)
|
||||
- OSPF
|
||||
- Static routes
|
||||
- Inter-table protocol
|
||||
- Command-line interface
|
||||
- Soft reconfiguration
|
||||
- Powerful language for route filtering
|
||||
|
||||
WWW: http://bird.network.cz/
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
@unexec if cmp -s %D/etc/bird6.conf.example %D/etc/bird6.conf; then rm -f %D/etc/bird6.conf; fi
|
||||
etc/bird6.conf.example
|
||||
@exec if [ ! -f %D/etc/bird6.conf ] ; then cp -p %D/%F %B/bird6.conf; fi
|
||||
sbin/bird6
|
||||
sbin/birdc6
|
||||
@unexec if cmp -s %D/etc/bird.conf.example %D/etc/bird.conf; then rm -f %D/etc/bird.conf; fi
|
||||
etc/bird.conf.example
|
||||
@exec if [ ! -f %D/etc/bird.conf ] ; then cp -p %D/%F %B/bird.conf; fi
|
||||
sbin/bird
|
||||
sbin/birdc
|
||||
|
|
31
net/bird6/Makefile
Normal file
31
net/bird6/Makefile
Normal file
|
@ -0,0 +1,31 @@
|
|||
# New ports collection makefile for: bird
|
||||
# Date created: 12th May 2005
|
||||
# Whom: Pav Lucistnik <pav@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= bird6
|
||||
PORTVERSION= 1.2.3
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://bird.network.cz/pub/bird/
|
||||
DISTNAME= bird-${PORTVERSION}
|
||||
|
||||
MAINTAINER= pav@FreeBSD.org
|
||||
COMMENT= Dynamic IP routing daemon (IPv6 version)
|
||||
|
||||
USE_BISON= build
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-ipv6
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
USE_RC_SUBR= bird6
|
||||
|
||||
post-install:
|
||||
@if [ ! -f ${PREFIX}/etc/bird6.conf ]; then \
|
||||
${CP} -p ${PREFIX}/etc/bird6.conf.example ${PREFIX}/etc/bird6.conf ; \
|
||||
fi
|
||||
|
||||
.include <bsd.port.mk>
|
3
net/bird6/distinfo
Normal file
3
net/bird6/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (bird-1.2.3.tar.gz) = bf1f4b24627050eead1dceb8c1fd24c3
|
||||
SHA256 (bird-1.2.3.tar.gz) = 503f25ef676c320be3db90b69b8a78da8fda4dc2d640d3aa9dbfae0cb4e66273
|
||||
SIZE (bird-1.2.3.tar.gz) = 865144
|
32
net/bird6/files/bird6.in
Normal file
32
net/bird6/files/bird6.in
Normal file
|
@ -0,0 +1,32 @@
|
|||
#!/bin/sh
|
||||
|
||||
# $FreeBSD$
|
||||
#
|
||||
# PROVIDE: bird6
|
||||
# REQUIRE: LOGIN
|
||||
# KEYWORD: shutdown
|
||||
#
|
||||
# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
|
||||
# to enable this service:
|
||||
#
|
||||
# bird6_enable (bool): Set to NO by default.
|
||||
# Set it to YES to enable bird6.
|
||||
# bird6_config (path): Set to %%PREFIX%%/etc/bird6.conf
|
||||
# by default.
|
||||
#
|
||||
|
||||
. /etc/rc.subr
|
||||
|
||||
name="bird6"
|
||||
rcvar=${name}_enable
|
||||
|
||||
command=%%PREFIX%%/sbin/${name}
|
||||
|
||||
load_rc_config $name
|
||||
|
||||
: ${bird6_enable="NO"}
|
||||
: ${bird6_config="%%PREFIX%%/etc/bird6.conf"}
|
||||
|
||||
command_args="-c $bird6_config"
|
||||
|
||||
run_rc_command "$1"
|
15
net/bird6/files/patch-tools-Makefile.in
Normal file
15
net/bird6/files/patch-tools-Makefile.in
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- tools/Makefile.in.orig 2009-08-16 22:42:37.000000000 +0200
|
||||
+++ tools/Makefile.in 2009-09-16 22:22:07.000000000 +0200
|
||||
@@ -60,11 +60,7 @@
|
||||
if test -n "@CLIENT@" ; then \
|
||||
$(INSTALL_PROGRAM) -s $(exedir)/birdc $(DESTDIR)/$(sbindir)/birdc@SUFFIX6@ ; \
|
||||
fi
|
||||
- if ! test -f $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf ; then \
|
||||
- $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf ; \
|
||||
- else \
|
||||
- echo "Not overwriting old bird@SUFFIX@.conf" ; \
|
||||
- fi
|
||||
+ $(INSTALL_DATA) $(srcdir)/doc/bird.conf.example $(DESTDIR)/$(sysconfdir)/bird@SUFFIX6@.conf.example ; \
|
||||
|
||||
install-docs:
|
||||
$(INSTALL) -d $(DESTDIR)/$(docdir)
|
14
net/bird6/pkg-descr
Normal file
14
net/bird6/pkg-descr
Normal file
|
@ -0,0 +1,14 @@
|
|||
The BIRD project aims to develop a fully functional dynamic IP routing daemon.
|
||||
|
||||
- Both IPv4 and IPv6
|
||||
- Multiple routing tables
|
||||
- BGP
|
||||
- RIP
|
||||
- OSPF
|
||||
- Static routes
|
||||
- Inter-table protocol
|
||||
- Command-line interface
|
||||
- Soft reconfiguration
|
||||
- Powerful language for route filtering
|
||||
|
||||
WWW: http://bird.network.cz/
|
5
net/bird6/pkg-plist
Normal file
5
net/bird6/pkg-plist
Normal file
|
@ -0,0 +1,5 @@
|
|||
@unexec if cmp -s %D/etc/bird6.conf.example %D/etc/bird6.conf; then rm -f %D/etc/bird6.conf; fi
|
||||
etc/bird6.conf.example
|
||||
@exec if [ ! -f %D/etc/bird6.conf ] ; then cp -p %D/%F %B/bird6.conf; fi
|
||||
sbin/bird6
|
||||
sbin/birdc6
|
Loading…
Reference in a new issue