- Update to 0.3.0
PR: ports/96005 Submitted by: Ports Fury
This commit is contained in:
parent
d595c88d0b
commit
cd8cd0f47f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=159899
4 changed files with 80 additions and 41 deletions
|
@ -6,23 +6,21 @@
|
|||
#
|
||||
|
||||
PORTNAME= ming
|
||||
PORTVERSION= 0.2a
|
||||
PORTVERSION= 0.3.0
|
||||
CATEGORIES= graphics perl5
|
||||
MASTER_SITES= # none
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
PKGNAMEPREFIX= p5-
|
||||
DISTFILES= # none
|
||||
DISTNAME= ${PORTNAME}-perl-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Perl5 module for Ming which allows you to create Flash 4/5 movies
|
||||
|
||||
EXTRACT_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/graphics/ming:patch
|
||||
LIB_DEPENDS= ming.3:${PORTSDIR}/graphics/ming
|
||||
LIB_DEPENDS= ming.4:${PORTSDIR}/graphics/ming
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/perl_ext
|
||||
|
||||
USE_PERL5= yes
|
||||
|
||||
MD5_FILE= ${.CURDIR}/../ming/distinfo
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/perl_ext
|
||||
PERL_CONFIGURE= yes
|
||||
CONFIGURE_ENV= LOCALBASE="${LOCALBASE}"
|
||||
|
||||
|
@ -30,23 +28,30 @@ MAN3= SWF.3 \
|
|||
SWF::Action.3 \
|
||||
SWF::Bitmap.3 \
|
||||
SWF::Button.3 \
|
||||
SWF::Constants.3 \
|
||||
SWF::DisplayItem.3 \
|
||||
SWF::Morph.3 \
|
||||
SWF::Movie.3 \
|
||||
SWF::Shape.3 \
|
||||
SWF::Sprite.3
|
||||
SWF::Sound.3 \
|
||||
SWF::Sprite.3 \
|
||||
SWF::TextField.3 \
|
||||
SWF::VideoStream.3
|
||||
|
||||
EXAMPLES= examples/*
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
do-extract:
|
||||
${MKDIR} ${WRKDIR}
|
||||
${LN} -s `cd ${PORTSDIR}/graphics/ming && ${MAKE} -V WRKDIR`/* ${WRKDIR}/
|
||||
.if ${OSVERSION} < 500000
|
||||
BROKEN= Doesn't build on < 5.x
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${ECHO_CMD} -n > ${WRKSRC}/../configure.in
|
||||
@${LN} -sf ${LOCALBASE}/include/ming ${WRKSRC}/../src
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${PREFIX}/share/examples/perl5/${PORTNAME}
|
||||
.for f in ${EXAMPLES}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/examples/perl5/${PORTNAME}/
|
||||
.endfor
|
||||
@${MKDIR} ${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/*.* ${EXAMPLESDIR}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
6
graphics/p5-ming/distinfo
Normal file
6
graphics/p5-ming/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
MD5 (ming-0.3.0.tar.gz) = 56b29eeb4fdd0b98c9ee62e25d14841d
|
||||
SHA256 (ming-0.3.0.tar.gz) = 820afbafc8697dabb34415eb86b2c589625449709f4434446c323c4d14391cd9
|
||||
SIZE (ming-0.3.0.tar.gz) = 287330
|
||||
MD5 (ming-perl-0.3.0.tar.gz) = 506acca9ca42066a97fc0b6abad6d57a
|
||||
SHA256 (ming-perl-0.3.0.tar.gz) = 44bbcec7f41f33fcf402d0e43bdf7aa61d567ab098247f114674a8786d98e2b5
|
||||
SIZE (ming-perl-0.3.0.tar.gz) = 49783
|
|
@ -1,20 +1,34 @@
|
|||
--- Makefile.PL.orig Sat Aug 18 02:05:50 2001
|
||||
+++ Makefile.PL Tue Sep 18 15:09:21 2001
|
||||
@@ -37,14 +37,14 @@
|
||||
WriteMakefile(
|
||||
'NAME' => 'SWF',
|
||||
'VERSION_FROM' => 'SWF.pm', # finds $VERSION
|
||||
- 'LIBS' => [''], # e.g., '-lm'
|
||||
+ 'LIBS' => ["-L$ENV{LOCALBASE}/lib -lming"], # e.g., '-lm'
|
||||
'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
|
||||
'INC' => '', # e.g., '-I/usr/include/other'
|
||||
--- Makefile.PL.orig Wed Feb 1 15:45:17 2006
|
||||
+++ Makefile.PL Mon Apr 17 23:31:32 2006
|
||||
@@ -78,25 +78,25 @@
|
||||
clean => {
|
||||
FILES => "@do_clean",
|
||||
},
|
||||
- 'MYEXTLIB' => $MING_DIR . '/libming.a',
|
||||
+# 'MYEXTLIB' => $MING_DIR . '/libming.a',
|
||||
'OBJECT' => "$XS_OBJECTS",
|
||||
#'LIBS' => [ "-lz" ],
|
||||
- 'LIBS' => [ $libs ],
|
||||
+ 'LIBS' => ["-L$ENV{LOCALBASE}/lib -lming"],
|
||||
);
|
||||
|
||||
sub ming_is_compiled{
|
||||
- return undef unless (-e "$MING_DIR/libming.a");
|
||||
+# return undef unless (-e "$MING_DIR/libming.a");
|
||||
return 1;
|
||||
sub MY::install {
|
||||
my $self = shift;
|
||||
write_myconfig_file($self->{INSTALLSITEARCH});
|
||||
|
||||
- for (qw(ming.h libming.a)){
|
||||
- $self->{PM}->{"$MING_DIR/$_"} = '$(INST_ARCHLIB)' . "/auto/SWF/include/$_";
|
||||
- }
|
||||
+# for (qw(ming.h libming.a)){
|
||||
+# $self->{PM}->{"$MING_DIR/$_"} = '$(INST_ARCHLIB)' . "/auto/SWF/include/$_";
|
||||
+# }
|
||||
$self->{PM}->{'perl_swf.h'} = '$(INST_ARCHLIB)' . "/auto/SWF/include/perl_swf.h";
|
||||
return $self->MM::install;
|
||||
}
|
||||
|
||||
sub ming_is_compiled{
|
||||
- return undef unless (-e "$MING_DIR/libming.a");
|
||||
+# return undef unless (-e "$MING_DIR/libming.a");
|
||||
return 1;
|
||||
}
|
||||
|
||||
|
|
|
@ -1,7 +1,9 @@
|
|||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/.cvsignore
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/Action.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/Bitmap.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/Button.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/Constants.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/DisplayItem.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/Fill.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/Font.pm
|
||||
|
@ -10,18 +12,30 @@
|
|||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/Movie.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/Shape.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/Sound.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/SoundInstance.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/SoundStream.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/Sprite.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/Text.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/TextField.pm
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/SWF
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/SWF/VideoStream.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF/.packlist
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF/SWF.bs
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF/SWF.so
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF/include/perl_swf.h
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/action.cgi
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/alphafill.cgi
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/animation.cgi
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/glyph.cgi
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/jpegfill.cgi
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/keypress.cgi
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/morph.cgi
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/shape.cgi
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/sound.cgi
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/sprite.cgi
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/text.cgi
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/textfield.cgi
|
||||
%%PORTDOCS%%%%EXAMPLESDIR%%/video.cgi
|
||||
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF/include
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/SWF
|
||||
%%PORTDOCS%%share/examples/perl5/ming/animation.cgi
|
||||
%%PORTDOCS%%share/examples/perl5/ming/jpegfill.cgi
|
||||
%%PORTDOCS%%share/examples/perl5/ming/morph.cgi
|
||||
%%PORTDOCS%%share/examples/perl5/ming/shape.cgi
|
||||
%%PORTDOCS%%share/examples/perl5/ming/sprite.cgi
|
||||
%%PORTDOCS%%@dirrm share/examples/perl5/ming
|
||||
%%PORTDOCS%%@dirrmtry share/examples/perl5
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/SWF
|
||||
|
|
Loading…
Reference in a new issue