Say goodbye to the junkbuster-zlib - its functionality has been integrated
into the main junkbuster port.
This commit is contained in:
parent
34b174ba0d
commit
cd94fb74ce
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=50372
22 changed files with 0 additions and 337 deletions
|
@ -94,7 +94,6 @@
|
|||
SUBDIR += jesred
|
||||
SUBDIR += jetty
|
||||
SUBDIR += junkbuster
|
||||
SUBDIR += junkbuster-zlib
|
||||
SUBDIR += kannel
|
||||
SUBDIR += kdreamsite
|
||||
SUBDIR += knowledgekit
|
||||
|
|
|
@ -1,44 +0,0 @@
|
|||
# New ports collection makefile for: junkbuster-zlib
|
||||
# Date created: 2 May 1998
|
||||
# Whom: Ian Struble <ian@broken.net>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= junkbuster-zlib
|
||||
PORTVERSION= 1.0
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= http://server44.hypermart.net/f2org/ \
|
||||
http://f2.org/download/
|
||||
DISTNAME= ijb-zlib-${PORTVERSION:S/.//g}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= sobomax@FreeBSD.org
|
||||
|
||||
ALL_TARGET= # yes, an empty target.
|
||||
JDIR= ${PREFIX}/etc/junkbuster-zlib
|
||||
MAN1= junkbuster-zlib.1
|
||||
|
||||
post-patch:
|
||||
@${PERL} -pi -e 's:\r::' ${WRKSRC}/*
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/junkbuster ${PREFIX}/sbin/junkbuster-zlib
|
||||
${MKDIR} -m 755 ${JDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/junkbstr.ini ${JDIR}/configfile.sample
|
||||
${INSTALL_DATA} ${WRKSRC}/sblock.ini ${JDIR}/blockfile.sample
|
||||
${INSTALL_DATA} ${WRKSRC}/saclfile.ini ${JDIR}/aclfile.sample
|
||||
${INSTALL_DATA} ${WRKSRC}/scookie.ini ${JDIR}/cookiefile.sample
|
||||
${INSTALL_DATA} ${WRKSRC}/sforward.ini ${JDIR}/forwardfile.sample
|
||||
${INSTALL_DATA} ${WRKSRC}/strust.ini ${JDIR}/trustfile.sample
|
||||
$(INSTALL_MAN) ${WRKSRC}/junkbuster.1 $(PREFIX)/man/man1/junkbuster-zlib.1
|
||||
# Create the startup script. JB will run as user nobody.
|
||||
@${SED} 's|%%JDIR%%|${JDIR}|g ; s|%%PREFIX%%|${PREFIX}|g' \
|
||||
${FILESDIR}/junkbuster.sh.in > ${WRKDIR}/junkbuster-zlib.sh
|
||||
${INSTALL_SCRIPT} ${WRKDIR}/junkbuster-zlib.sh \
|
||||
${PREFIX}/etc/rc.d/junkbuster-zlib.sh
|
||||
|
||||
post-install:
|
||||
@${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1 +0,0 @@
|
|||
MD5 (ijb-zlib-10.tgz) = 3c410f61eeb7e24641fc7eaf3dc5063e
|
|
@ -1,29 +0,0 @@
|
|||
#!/bin/sh
|
||||
# $CVSHeader$
|
||||
|
||||
case $1 in
|
||||
start)
|
||||
if [ -d %%JDIR%% \
|
||||
-a -x %%PREFIX%%/sbin/junkbuster-zlib \
|
||||
-a -f %%JDIR%%/configfile ]; then
|
||||
: seems OK
|
||||
else
|
||||
echo >&2 "$0: missing files!"
|
||||
exit 1
|
||||
fi
|
||||
cd %%JDIR%%
|
||||
su -m nobody -c "%%PREFIX%%/sbin/junkbuster-zlib configfile &" \
|
||||
>/dev/null \
|
||||
&& echo -n " junkbuster" \
|
||||
|| echo " junkbuster FAILED TO START"
|
||||
;;
|
||||
stop)
|
||||
killall junkbuster-zlib && echo -n " junkbuster"
|
||||
;;
|
||||
*)
|
||||
echo "Usage: `basename $0` {start|stop}" >&2
|
||||
exit 64
|
||||
;;
|
||||
esac
|
||||
|
||||
exit 0
|
|
@ -1,40 +0,0 @@
|
|||
--- Makefile.orig Fri Aug 4 15:40:15 2000
|
||||
+++ Makefile Fri Nov 3 12:23:48 2000
|
||||
@@ -5,20 +5,20 @@
|
||||
|
||||
# set include and library paths for the zlib compression library
|
||||
#
|
||||
-ZLIB_INC_FLAGS=-I../zlib
|
||||
-ZLIB_LIB_FLAGS=-L ../zlib
|
||||
+#ZLIB_INC_FLAGS=-I../zlib
|
||||
+#ZLIB_LIB_FLAGS=-L ../zlib
|
||||
|
||||
DEFAULT_CFLAGS = -I. $(ZLIB_INC_FLAGS) $(REGEX) -DSTDC_HEADERS -DHAVE_STRING
|
||||
|
||||
PROG = junkbuster
|
||||
O = o
|
||||
RM = rm -f
|
||||
-MORE_CFLAGS = -g
|
||||
+MORE_CFLAGS =
|
||||
LD = $(CC) $(CFLAGS) $(ZLIB_LIB)
|
||||
LDFLAGS = -lz
|
||||
|
||||
# use this for Solaris 2.x
|
||||
-#LDFLAGS = -lnsl -lsocket -lz
|
||||
+LDFLAGS += -lgnuregex
|
||||
|
||||
# use these for SunOS 4.x
|
||||
#LDFLAGS = -nsl -lz
|
||||
@@ -63,10 +63,10 @@
|
||||
#MORE_CFLAGS = -relax_pointers
|
||||
#LDFLAGS = -map junkbuster.xMAP
|
||||
|
||||
-CFLAGS = $(DEFAULT_CFLAGS) $(MORE_CFLAGS)
|
||||
+CFLAGS += $(DEFAULT_CFLAGS) $(MORE_CFLAGS)
|
||||
|
||||
OBJS = jcc.$(O) parsers.$(O) filters.$(O) loaders.$(O) bind.$(O) conn.$(O) \
|
||||
- encode.$(O) ssplit.$(O) socks4.$(O) acl.$(O) gnu_regex.$(O) win32.$(O)
|
||||
+ encode.$(O) ssplit.$(O) socks4.$(O) acl.$(O) win32.$(O)
|
||||
|
||||
$(PROG): $(OBJS)
|
||||
$(LD) -o $(PROG) $(ZLIB_LIB_FLAGS) $(OBJS) $(LDFLAGS)
|
|
@ -1,12 +0,0 @@
|
|||
diff -ruN /usr/ports/www/ijb/work/ijb20/acl.c ./acl.c
|
||||
--- /usr/ports/www/ijb/work/ijb20/acl.c Mon Feb 28 02:35:10 2000
|
||||
+++ ./acl.c Mon Feb 28 02:31:06 2000
|
||||
@@ -18,7 +18,7 @@
|
||||
#endif
|
||||
|
||||
#ifdef REGEX
|
||||
-#include "gnu_regex.h"
|
||||
+#include "gnuregex.h"
|
||||
#endif
|
||||
|
||||
#include "jcc.h"
|
|
@ -1,12 +0,0 @@
|
|||
diff -ruN /usr/ports/www/ijb/work/ijb20/conn.c ./conn.c
|
||||
--- /usr/ports/www/ijb/work/ijb20/conn.c Mon Feb 28 02:35:10 2000
|
||||
+++ ./conn.c Mon Feb 28 02:31:06 2000
|
||||
@@ -34,7 +34,7 @@
|
||||
#endif
|
||||
|
||||
#ifdef REGEX
|
||||
-#include "gnu_regex.h"
|
||||
+#include "gnuregex.h"
|
||||
#endif
|
||||
|
||||
#include "jcc.h"
|
|
@ -1,12 +0,0 @@
|
|||
diff -ruN /usr/ports/www/ijb/work/ijb20/encode.c ./encode.c
|
||||
--- /usr/ports/www/ijb/work/ijb20/encode.c Mon Feb 28 02:35:10 2000
|
||||
+++ ./encode.c Mon Feb 28 02:31:06 2000
|
||||
@@ -9,7 +9,7 @@
|
||||
#include <ctype.h>
|
||||
|
||||
#ifdef REGEX
|
||||
-#include "gnu_regex.h"
|
||||
+#include "gnuregex.h"
|
||||
#endif
|
||||
|
||||
#include "jcc.h"
|
|
@ -1,12 +0,0 @@
|
|||
diff -ruN /usr/ports/www/ijb/work/ijb20/filters.c ./filters.c
|
||||
--- /usr/ports/www/ijb/work/ijb20/filters.c Mon Feb 28 02:35:10 2000
|
||||
+++ ./filters.c Mon Feb 28 02:31:06 2000
|
||||
@@ -15,7 +15,7 @@
|
||||
#endif
|
||||
|
||||
#ifdef REGEX
|
||||
-#include <gnu_regex.h>
|
||||
+#include <gnuregex.h>
|
||||
#endif
|
||||
|
||||
#include "jcc.h"
|
|
@ -1,12 +0,0 @@
|
|||
diff -ruN /usr/ports/www/ijb/work/ijb20/gnu_regex.c ./gnu_regex.c
|
||||
--- /usr/ports/www/ijb/work/ijb20/gnu_regex.c Mon Feb 28 02:35:10 2000
|
||||
+++ ./gnu_regex.c Mon Feb 28 02:31:06 2000
|
||||
@@ -131,7 +131,7 @@
|
||||
#endif /* not emacs */
|
||||
|
||||
/* Get the interface, including the syntax bits. */
|
||||
-#include "gnu_regex.h"
|
||||
+#include "gnuregex.h"
|
||||
|
||||
/* isalpha etc. are used for the character classes. */
|
||||
#include <ctype.h>
|
|
@ -1,17 +0,0 @@
|
|||
--- jcc.c.orig Fri Nov 3 12:28:39 2000
|
||||
+++ jcc.c Fri Nov 3 12:31:58 2000
|
||||
@@ -39,11 +39,12 @@
|
||||
#endif
|
||||
|
||||
#ifdef REGEX
|
||||
-#include <gnu_regex.h>
|
||||
+#include <gnuregex.h>
|
||||
#endif
|
||||
|
||||
#include "jcc.h"
|
||||
-#include "zutil.h"
|
||||
+#include "zlib.h"
|
||||
+#define DEF_MEM_LEVEL 8
|
||||
|
||||
char *prog;
|
||||
|
|
@ -1,38 +0,0 @@
|
|||
diff -ruN /usr/ports/www/ijb/work/ijb20/loaders.c ./loaders.c
|
||||
--- /usr/ports/www/ijb/work/ijb20/loaders.c Mon Feb 28 02:35:10 2000
|
||||
+++ ./loaders.c Mon Feb 28 02:34:29 2000
|
||||
@@ -8,7 +8,7 @@
|
||||
#include <stdlib.h>
|
||||
#include <sys/types.h>
|
||||
#include <string.h>
|
||||
-#include <malloc.h>
|
||||
+#include <stdlib.h>
|
||||
#include <errno.h>
|
||||
#include <sys/stat.h>
|
||||
#include <ctype.h>
|
||||
@@ -18,7 +18,7 @@
|
||||
#endif
|
||||
|
||||
#ifdef REGEX
|
||||
-#include <gnu_regex.h>
|
||||
+#include <gnuregex.h>
|
||||
#endif
|
||||
|
||||
#include "jcc.h"
|
||||
@@ -1160,7 +1160,7 @@
|
||||
|
||||
extern char *acl_rcs, *bind_rcs, *conn_rcs, *encode_rcs,
|
||||
*jcc_rcs, *loaders_rcs, *parsers_rcs, *filters_rcs,
|
||||
- *socks4_rcs, *ssplit_rcs, *gnu_regex_rcs, *win32_rcs;
|
||||
+ *socks4_rcs, *ssplit_rcs, *win32_rcs;
|
||||
|
||||
b = strsav(b, "<h2>Source versions:</h2>\n");
|
||||
b = strsav(b, "<pre>");
|
||||
@@ -1174,7 +1174,6 @@
|
||||
sprintf(buf, "%s\n", socks4_rcs ); b = strsav(b, buf);
|
||||
sprintf(buf, "%s\n", ssplit_rcs ); b = strsav(b, buf);
|
||||
sprintf(buf, "%s\n", acl_rcs ); b = strsav(b, buf);
|
||||
- sprintf(buf, "%s\n", gnu_regex_rcs ); b = strsav(b, buf);
|
||||
sprintf(buf, "%s\n", win32_rcs ); b = strsav(b, buf);
|
||||
b = strsav(b, "</pre>");
|
||||
|
|
@ -1,10 +0,0 @@
|
|||
diff -ruN /usr/ports/www/ijb/work/ijb20/loaders.h ./loaders.h
|
||||
--- /usr/ports/www/ijb/work/ijb20/loaders.h Wed Dec 31 21:00:00 1969
|
||||
+++ ./loaders.h Mon Feb 28 02:22:47 2000
|
||||
@@ -0,0 +1,6 @@
|
||||
+#ifndef __LOADERS_H_INCLUDE__
|
||||
+#define __LOADERS_H_INCLUDE__
|
||||
+
|
||||
+void * zalloc(int);
|
||||
+
|
||||
+#endif /* __LOADERS_H_INCLUDE__ */
|
|
@ -1,12 +0,0 @@
|
|||
diff -ruN /usr/ports/www/ijb/work/ijb20/parsers.c ./parsers.c
|
||||
--- /usr/ports/www/ijb/work/ijb20/parsers.c Mon Feb 28 02:35:10 2000
|
||||
+++ ./parsers.c Mon Feb 28 02:31:06 2000
|
||||
@@ -15,7 +15,7 @@
|
||||
#endif
|
||||
|
||||
#ifdef REGEX
|
||||
-#include <gnu_regex.h>
|
||||
+#include <gnuregex.h>
|
||||
#endif
|
||||
|
||||
#include "jcc.h"
|
|
@ -1,27 +0,0 @@
|
|||
diff -ruN /usr/ports/www/ijb/work/ijb20/socks4.c ./socks4.c
|
||||
--- /usr/ports/www/ijb/work/ijb20/socks4.c Mon Feb 28 02:35:10 2000
|
||||
+++ ./socks4.c Mon Feb 28 02:31:06 2000
|
||||
@@ -19,11 +19,13 @@
|
||||
#endif
|
||||
|
||||
#ifdef REGEX
|
||||
-#include <gnu_regex.h>
|
||||
+#include <gnuregex.h>
|
||||
#endif
|
||||
|
||||
#include "jcc.h"
|
||||
|
||||
+#define DEFAULT_FALLBACK_HTTP_PORT 80
|
||||
+
|
||||
#define SOCKS_REQUEST_GRANTED 90
|
||||
#define SOCKS_REQUEST_REJECT 91
|
||||
#define SOCKS_REQUEST_IDENT_FAILED 92
|
||||
@@ -56,7 +58,7 @@
|
||||
unsigned char sbuf[BUFSIZ];
|
||||
struct socks_op *c = (struct socks_op *)cbuf;
|
||||
struct socks_reply *s = (struct socks_reply *)sbuf;
|
||||
- int web_server_addr;
|
||||
+ int web_server_addr = DEFAULT_FALLBACK_HTTP_PORT;
|
||||
int n, csiz, sfd, target_port;
|
||||
int err = 0;
|
||||
char *errstr, *target_host;
|
|
@ -1,14 +0,0 @@
|
|||
--- ssplit.c.orig Fri Aug 4 09:39:24 2000
|
||||
+++ ssplit.c Fri Nov 3 12:24:59 2000
|
||||
@@ -22,9 +22,10 @@
|
||||
* l = flag indicating whether to ignore leading field separators
|
||||
*/
|
||||
|
||||
+#include "loaders.h"
|
||||
#include <stdlib.h> /* For free() */
|
||||
#include <stdio.h> /* Required by jcc.h */
|
||||
-#include "gnu_regex.h"
|
||||
+#include "gnuregex.h"
|
||||
#include "jcc.h" /* For zalloc() */
|
||||
#undef DEBUG /* DEBUG macro use in this file is not */
|
||||
/* consistent with use in jcc.h */
|
|
@ -1,12 +0,0 @@
|
|||
diff -ruN /usr/ports/www/ijb/work/ijb20/win32.c ./win32.c
|
||||
--- /usr/ports/www/ijb/work/ijb20/win32.c Mon Feb 28 02:35:10 2000
|
||||
+++ ./win32.c Mon Feb 28 02:31:06 2000
|
||||
@@ -7,7 +7,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#ifdef REGEX
|
||||
-#include "gnu_regex.h"
|
||||
+#include "gnuregex.h"
|
||||
#endif
|
||||
#include "jcc.h"
|
||||
#include <windows.h>
|
|
@ -1,11 +0,0 @@
|
|||
--- bind.c 2000/11/03 10:27:18 1.1
|
||||
+++ bind.c 2000/11/03 10:27:22
|
||||
@@ -37,7 +37,7 @@
|
||||
#endif
|
||||
|
||||
#ifdef REGEX
|
||||
-#include <gnu_regex.h>
|
||||
+#include <gnuregex.h>
|
||||
#endif
|
||||
|
||||
#include "jcc.h" /* For atoip() */
|
|
@ -1 +0,0 @@
|
|||
An HTTP proxy server that eliminates ads and can compress pages on the fly
|
|
@ -1,7 +0,0 @@
|
|||
Junkbuster-zlib is a modified version of the Internet Junkbuster Proxy v2.0.2
|
||||
which can automatically compress text/html and text/plain documents for clients
|
||||
which support Accept-Encoding: gzip (e.g. Netscape 4.7, Internet Explorer 5,
|
||||
Lynx 2.8.3) to save downstream modem/network bandwidth. It uses the zlib
|
||||
compression library to perform on-the-fly compression of HTML documents.
|
||||
|
||||
WWW: http://f2.org/products/ijb-zlib/
|
|
@ -1,4 +0,0 @@
|
|||
Please, review the samples of the configuration files (somewhere in
|
||||
%%PREFIX%%/etc/junkbuster-zlib/*.sample) and create your own config files.
|
||||
Read the junkbuster-zlib man-page (man junkbuster-zlib) for even more
|
||||
information.
|
|
@ -1,9 +0,0 @@
|
|||
sbin/junkbuster-zlib
|
||||
etc/junkbuster-zlib/aclfile.sample
|
||||
etc/junkbuster-zlib/blockfile.sample
|
||||
etc/junkbuster-zlib/cookiefile.sample
|
||||
etc/junkbuster-zlib/configfile.sample
|
||||
etc/junkbuster-zlib/forwardfile.sample
|
||||
etc/junkbuster-zlib/trustfile.sample
|
||||
etc/rc.d/junkbuster-zlib.sh
|
||||
@dirrm etc/junkbuster-zlib
|
Loading…
Reference in a new issue