finance/quickfix: Update to 1.15.1
- Remove MAKE_JOBS_UNSAFE as it build paralelly now - Switch to GitHub PR: 238569 Submitted by: m.tsatsenko@gmail.com (maintainer)
This commit is contained in:
parent
29c07cfe7e
commit
cd999a0cf7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=504616
9 changed files with 136 additions and 86 deletions
|
@ -2,9 +2,8 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= quickfix
|
||||
PORTVERSION= 1.14.3
|
||||
PORTVERSION= 1.15.1
|
||||
CATEGORIES= finance devel
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
|
||||
|
||||
MAINTAINER= m.tsatsenko@gmail.com
|
||||
COMMENT= Free FIX Protocol Implementation
|
||||
|
@ -15,14 +14,17 @@ BROKEN_powerpc64= fails to configure: unable to find set_terminate in std or glo
|
|||
|
||||
BUILD_DEPENDS= bash:shells/bash
|
||||
|
||||
USES= gmake iconv libtool shebangfix ssl
|
||||
USES= gmake iconv libtool autoreconf shebangfix ssl
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_TAGNAME= v1.15.1
|
||||
|
||||
USE_GNOME= libxml2
|
||||
USE_LDCONFIG= yes
|
||||
SHEBANG_FILES= examples/tradeclientgui/banzai/build.sh
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ENV= CXX=${CXX} CC=${CC} LIBS=-L${LOCALBASE}/lib/
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
MAKE_JOBS_UNSAFE=yes
|
||||
CONFIGURE_ARGS+= --without-python --without-python3
|
||||
|
||||
OPTIONS_DEFINE= MYSQL PGSQL PYTHON RUBY JAVA
|
||||
OPTIONS_DEFAULT= MYSQL
|
||||
|
@ -31,10 +33,11 @@ PGSQL_USES= pgsql
|
|||
PGSQL_CONFIGURE_WITH= postgresql
|
||||
MYSQL_USES= mysql
|
||||
MYSQL_CONFIGURE_WITH= mysql
|
||||
PYTHON_USES= python
|
||||
PYTHON_CONFIGURE_WITH= python
|
||||
PYTHON_USES= python:2.7
|
||||
PYTHON_CONFIGURE_WITH= python2
|
||||
RUBY_USE= ruby=yes
|
||||
RUBY_CONFIGURE_WITH= ruby
|
||||
RUBY_LIB_DEPENDS+=libunwind.so:devel/libunwind
|
||||
JAVA_USE= java=yes
|
||||
JAVA_CONFIGURE_WITH= java
|
||||
|
||||
|
@ -45,12 +48,14 @@ post-extract:
|
|||
${WRKSRC}/src/ruby/make_ruby.sh
|
||||
@${REINPLACE_CMD} -e 's|CXX = g++|CXX = ${CXX}|' \
|
||||
${WRKSRC}/UnitTest++/Makefile
|
||||
pre-configure:
|
||||
cd ${WRKSRC} && ${sh} ${WRKSRC}/bootstrap
|
||||
@${REINPLACE_CMD} -e 's|pkgconfdir = .*|pkgconfdir=${LOCALBASE}/libdata/pkgconfig|' \
|
||||
${WRKSRC}/Makefile.in
|
||||
post-configure:
|
||||
pre-build:
|
||||
${GMAKE} -C ${WRKSRC}/UnitTest++ TestUnitTest++
|
||||
|
||||
post-install-RUBY-on:
|
||||
${STRIP_CMD} ${STAGEDIR}${RUBY_SITELIBDIR}/quickfix.so
|
||||
${STRIP_CMD} ${STAGEDIR}${RUBY_SITEARCHLIBDIR}/quickfix.so
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1519587218
|
||||
SHA256 (quickfix-1.14.3.tar.gz) = f6e8bdb004eaf45e50f63005b8c2611cb0afd42cf70f110f600c852aa572342d
|
||||
SIZE (quickfix-1.14.3.tar.gz) = 21803784
|
||||
TIMESTAMP = 1560234014
|
||||
SHA256 (quickfix-quickfix-1.15.1-v1.15.1_GH0.tar.gz) = 1c4322a68704526ca3d1f213e7b0dcd30e067a8815be2a79b2ab1197ef70dcf7
|
||||
SIZE (quickfix-quickfix-1.15.1-v1.15.1_GH0.tar.gz) = 15919362
|
||||
|
|
|
@ -1,29 +0,0 @@
|
|||
--- configure.orig 2014-09-15 06:24:18 UTC
|
||||
+++ configure
|
||||
@@ -14863,7 +14863,7 @@ freebsd* | dragonfly*)
|
||||
version_type=freebsd-$objformat
|
||||
case $version_type in
|
||||
freebsd-elf*)
|
||||
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
|
||||
+ library_names_spec='$libname$release$shared_ext$versuffix $libname$release$shared_ext$major $libname$shared_ext' soname_spec='$libname$release$shared_ext$major'
|
||||
need_version=no
|
||||
need_lib_prefix=no
|
||||
;;
|
||||
@@ -16200,7 +16200,7 @@ if test $has_ruby = true
|
||||
then
|
||||
RUBY_CFLAGS="-I${RUBY_PREFIX}"
|
||||
|
||||
- RUBY_SITE_PACKAGES=`ruby -e 'require "rbconfig"; print Config::CONFIG["sitedir"], "\n"'`
|
||||
+ RUBY_SITE_PACKAGES=`ruby -e 'require "rbconfig"; print RbConfig::CONFIG["sitelibdir"], "\n"'`
|
||||
|
||||
|
||||
$as_echo "#define HAVE_RUBY 1" >>confdefs.h
|
||||
@@ -16877,7 +16877,7 @@ timeb tb;
|
||||
}
|
||||
_ACEOF
|
||||
if ac_fn_cxx_try_compile "$LINENO"; then :
|
||||
- has_ftime=true
|
||||
+ has_ftime=false
|
||||
else
|
||||
has_ftime=false
|
||||
fi
|
11
finance/quickfix/files/patch-configure.ac
Normal file
11
finance/quickfix/files/patch-configure.ac
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- configure.ac.orig 2019-06-11 07:14:11 UTC
|
||||
+++ configure.ac
|
||||
@@ -198,7 +198,7 @@ AC_TRY_COMPILE(
|
||||
[#include <sys/timeb.h>],
|
||||
[timeb tb;
|
||||
ftime(&tb)],
|
||||
- has_ftime=true, has_ftime=false)
|
||||
+ has_ftime=false, has_ftime=false)
|
||||
|
||||
if test $has_ftime = true
|
||||
then AC_MSG_RESULT(yes)
|
43
finance/quickfix/files/patch-m4_ax__python.m4
Normal file
43
finance/quickfix/files/patch-m4_ax__python.m4
Normal file
|
@ -0,0 +1,43 @@
|
|||
--- m4/ax_python.m4.orig 2018-04-16 02:40:31 UTC
|
||||
+++ m4/ax_python.m4
|
||||
@@ -18,10 +18,13 @@ AC_ARG_WITH(python2,
|
||||
has_python3=false
|
||||
AC_ARG_WITH(python3,
|
||||
[ --with-python3 will use $PYTHON to find python],
|
||||
- [
|
||||
+ [if test $withval == "no"
|
||||
+ then
|
||||
+ has_python3=false
|
||||
+ else
|
||||
has_python=true
|
||||
has_python3=true
|
||||
- ],
|
||||
+ fi],
|
||||
has_python3=false
|
||||
)
|
||||
|
||||
@@ -44,20 +47,20 @@ AC_SUBST(PYTHON3_PREFIX)
|
||||
|
||||
if test $has_python2 = true
|
||||
then
|
||||
- PYTHON2_INCLUDE_PATH=[`python2 -c 'from distutils import sysconfig; print( sysconfig.get_python_inc(1) )'`]
|
||||
+ PYTHON2_INCLUDE_PATH=[`python2.7 -c 'from distutils import sysconfig; print( sysconfig.get_python_inc(1) )'`]
|
||||
PYTHON2_CFLAGS="-I${PYTHON2_INCLUDE_PATH}"
|
||||
AC_SUBST(PYTHON2_CFLAGS)
|
||||
- PYTHON2_SITE_PACKAGES=[`python2 -c 'from distutils import sysconfig; print( sysconfig.get_python_lib(1) )'`]
|
||||
+ PYTHON2_SITE_PACKAGES=[`python2.7 -c 'from distutils import sysconfig; print( sysconfig.get_python_lib(1) )'`]
|
||||
AC_SUBST(PYTHON2_SITE_PACKAGES)
|
||||
AC_DEFINE(HAVE_PYTHON2, 1, Define if you have python2)
|
||||
fi
|
||||
|
||||
if test $has_python3 = true
|
||||
then
|
||||
- PYTHON3_INCLUDE_PATH=[`python3 -c 'from distutils import sysconfig; print( sysconfig.get_python_inc(1) )'`]
|
||||
+ PYTHON3_INCLUDE_PATH=[`python3.6 -c 'from distutils import sysconfig; print( sysconfig.get_python_inc(1) )'`]
|
||||
PYTHON3_CFLAGS="-I${PYTHON3_INCLUDE_PATH}"
|
||||
AC_SUBST(PYTHON3_CFLAGS)
|
||||
- PYTHON3_SITE_PACKAGES=[`python3 -c 'from distutils import sysconfig; print( sysconfig.get_python_lib(1) )'`]
|
||||
+ PYTHON3_SITE_PACKAGES=[`python3.6 -c 'from distutils import sysconfig; print( sysconfig.get_python_lib(1) )'`]
|
||||
AC_SUBST(PYTHON3_SITE_PACKAGES)
|
||||
AC_DEFINE(HAVE_PYTHON3, 1, Define if you have python3)
|
||||
fi
|
20
finance/quickfix/files/patch-m4_ax__ruby.m4
Normal file
20
finance/quickfix/files/patch-m4_ax__ruby.m4
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- m4/ax_ruby.m4.orig 2018-04-16 02:40:31 UTC
|
||||
+++ m4/ax_ruby.m4
|
||||
@@ -2,7 +2,7 @@ AC_DEFUN([AX_RUBY],
|
||||
[
|
||||
RUBY=${RUBY:-"ruby"}
|
||||
|
||||
-RUBY_PREFIX=[`$RUBY -e 'require "rbconfig"; print Config::CONFIG["archdir"], "\n"'`]
|
||||
+RUBY_PREFIX=[`$RUBY -e 'require "rbconfig"; print RbConfig::CONFIG["archdir"], "\n"'`]
|
||||
AC_SUBST(RUBY_PREFIX)
|
||||
|
||||
has_ruby=false
|
||||
@@ -21,7 +21,7 @@ if test $has_ruby = true
|
||||
then
|
||||
RUBY_CFLAGS="-I${RUBY_PREFIX}"
|
||||
AC_SUBST(RUBY_CFLAGS)
|
||||
- RUBY_SITE_PACKAGES=[`ruby -e 'require "rbconfig"; print Config::CONFIG["sitedir"], "\n"'`]
|
||||
+ RUBY_SITE_PACKAGES=[`ruby -e 'require "rbconfig"; print RbConfig::CONFIG["sitearchdir"], "\n"'`]
|
||||
AC_SUBST(RUBY_SITE_PACKAGES)
|
||||
AC_DEFINE(HAVE_RUBY, 1, Define if you have ruby)
|
||||
fi
|
|
@ -1,11 +0,0 @@
|
|||
--- src/python/Makefile.in.orig 2014-09-15 06:24:20 UTC
|
||||
+++ src/python/Makefile.in
|
||||
@@ -596,7 +596,7 @@ uninstall-am: uninstall-pythonDATA uninstall-pythonLTL
|
||||
|
||||
all-local:
|
||||
mkdir -p $(local_python_lib)
|
||||
- ln -sf $(local_python_src)/.libs/_quickfix* $(local_python_lib)
|
||||
+ find $(local_python_src)/.libs/_quickfix.* -exec ln -s {} $(local_python_lib)/{} \;
|
||||
ln -sf $(local_python_src)/*.py $(local_python_lib)
|
||||
ln -sf $(top_builddir)/spec spec
|
||||
|
|
@ -1,6 +1,6 @@
|
|||
--- src/ruby/Makefile.in.orig 2014-09-15 06:24:20 UTC
|
||||
+++ src/ruby/Makefile.in
|
||||
@@ -458,9 +458,10 @@ clean-local:
|
||||
--- src/ruby/Makefile.am.orig 2018-04-16 02:40:31 UTC
|
||||
+++ src/ruby/Makefile.am
|
||||
@@ -16,9 +16,10 @@ clean-local:
|
||||
rm -rf $(local_ruby_lib)
|
||||
|
||||
install-exec-local:
|
||||
|
@ -8,9 +8,9 @@
|
|||
- cp -f $(top_builddir)/lib/ruby/quickfix.so $(RUBY_SITE_PACKAGES) || :
|
||||
- cp -f $(top_builddir)/lib/ruby/quickfix.bundle $(RUBY_SITE_PACKAGES) || :
|
||||
+ $(MKDIR_P) "$(DESTDIR)$(RUBY_SITE_PACKAGES)"
|
||||
+ cp -f $(top_builddir)/lib/ruby/*.rb $(DESTDIR)$(RUBY_SITE_PACKAGES)
|
||||
+ cp -f $(top_builddir)/lib/ruby/quickfix.so $(DESTDIR)$(RUBY_SITE_PACKAGES) || :
|
||||
+ cp -f $(top_builddir)/lib/ruby/quickfix.bundle $(DESTDIR)$(RUBY_SITE_PACKAGES) || :
|
||||
+ cp -f $(top_builddir)/lib/ruby/*.rb "$(DESTDIR)$(RUBY_SITE_PACKAGES)"
|
||||
+ cp -f $(top_builddir)/lib/ruby/quickfix.so "$(DESTDIR)$(RUBY_SITE_PACKAGES)" || :
|
||||
+ cp -f $(top_builddir)/lib/ruby/quickfix.bundle "$(DESTDIR)$(RUBY_SITE_PACKAGES)" || :
|
||||
|
||||
uninstall-local:
|
||||
rm -rf $(RUBY_SITE_PACKAGES)/quickfix*.rb
|
|
@ -42,13 +42,16 @@ include/quickfix/NullStore.h
|
|||
include/quickfix/OdbcConnection.h
|
||||
include/quickfix/OdbcLog.h
|
||||
include/quickfix/OdbcStore.h
|
||||
include/quickfix/PUGIXML_DOMDocument.h
|
||||
include/quickfix/Parser.h
|
||||
include/quickfix/PostgreSQLConnection.h
|
||||
include/quickfix/PostgreSQLLog.h
|
||||
include/quickfix/PostgreSQLStore.h
|
||||
include/quickfix/PUGIXML_DOMDocument.h
|
||||
include/quickfix/Queue.h
|
||||
include/quickfix/Responder.h
|
||||
include/quickfix/SSLSocketAcceptor.h
|
||||
include/quickfix/SSLSocketConnection.h
|
||||
include/quickfix/SSLSocketInitiator.h
|
||||
include/quickfix/Session.h
|
||||
include/quickfix/SessionFactory.h
|
||||
include/quickfix/SessionID.h
|
||||
|
@ -62,12 +65,18 @@ include/quickfix/SocketConnector.h
|
|||
include/quickfix/SocketInitiator.h
|
||||
include/quickfix/SocketMonitor.h
|
||||
include/quickfix/SocketServer.h
|
||||
include/quickfix/ThreadedSSLSocketAcceptor.h
|
||||
include/quickfix/ThreadedSSLSocketConnection.h
|
||||
include/quickfix/ThreadedSSLSocketInitiator.h
|
||||
include/quickfix/ThreadedSocketAcceptor.h
|
||||
include/quickfix/ThreadedSocketConnection.h
|
||||
include/quickfix/ThreadedSocketInitiator.h
|
||||
include/quickfix/TimeRange.h
|
||||
include/quickfix/Utility.h
|
||||
include/quickfix/UtilitySSL.h
|
||||
include/quickfix/Values.h
|
||||
include/quickfix/config-all.h
|
||||
include/quickfix/dirent_windows.h
|
||||
include/quickfix/fix40/Advertisement.h
|
||||
include/quickfix/fix40/Allocation.h
|
||||
include/quickfix/fix40/AllocationInstructionAck.h
|
||||
|
@ -663,14 +672,16 @@ include/quickfix/fixt11/SequenceReset.h
|
|||
include/quickfix/fixt11/TestRequest.h
|
||||
include/quickfix/index.h
|
||||
include/quickfix/stdafx.h
|
||||
include/quickfix/stdint_msvc.h
|
||||
include/quickfix/strptime.h
|
||||
include/quickfix/wx/sharedptr.h
|
||||
lib/libquickfix.so
|
||||
lib/libquickfix.so.16
|
||||
lib/libquickfix.so.16.0.1
|
||||
lib/libquickfix.so.17
|
||||
lib/libquickfix.so.17.0.0
|
||||
libdata/pkgconfig/quickfix.pc
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_quickfix.so
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_quickfix.so.12
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_quickfix.so.12.0.0
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_quickfix.so.13
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/_quickfix.so.13.0.0
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/quickfix.py
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/quickfix40.py
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/quickfix41.py
|
||||
|
@ -681,29 +692,18 @@ libdata/pkgconfig/quickfix.pc
|
|||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/quickfix50sp1.py
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/quickfix50sp2.py
|
||||
%%PYTHON%%%%PYTHON_SITELIBDIR%%/quickfixt11.py
|
||||
%%RUBY%%%%RUBY_SITELIBDIR%%/quickfix_fields.rb
|
||||
%%RUBY%%%%RUBY_SITELIBDIR%%/quickfix40.rb
|
||||
%%RUBY%%%%RUBY_SITELIBDIR%%/quickfix_ruby.rb
|
||||
%%RUBY%%%%RUBY_SITELIBDIR%%/quickfix50sp1.rb
|
||||
%%RUBY%%%%RUBY_SITELIBDIR%%/quickfix50.rb
|
||||
%%RUBY%%%%RUBY_SITELIBDIR%%/quickfix50sp2.rb
|
||||
%%RUBY%%%%RUBY_SITELIBDIR%%/quickfix43.rb
|
||||
%%RUBY%%%%RUBY_SITELIBDIR%%/quickfix.so
|
||||
%%RUBY%%%%RUBY_SITELIBDIR%%/quickfix41.rb
|
||||
%%RUBY%%%%RUBY_SITELIBDIR%%/quickfix42.rb
|
||||
%%RUBY%%%%RUBY_SITELIBDIR%%/quickfix44.rb
|
||||
%%RUBY%%%%RUBY_SITELIBDIR%%/quickfixt11.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix_fields.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix40.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix_ruby.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix50sp1.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix50.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix50sp2.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix43.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix41.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix42.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix44.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfixt11.rb
|
||||
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/quickfix.so
|
||||
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/quickfix40.rb
|
||||
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/quickfix41.rb
|
||||
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/quickfix42.rb
|
||||
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/quickfix43.rb
|
||||
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/quickfix44.rb
|
||||
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/quickfix50.rb
|
||||
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/quickfix50sp1.rb
|
||||
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/quickfix50sp2.rb
|
||||
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/quickfix_fields.rb
|
||||
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/quickfix_ruby.rb
|
||||
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/quickfixt11.rb
|
||||
%%DATADIR%%/FIX40.xml
|
||||
%%DATADIR%%/FIX41.xml
|
||||
%%DATADIR%%/FIX42.xml
|
||||
|
@ -713,3 +713,14 @@ libdata/pkgconfig/quickfix.pc
|
|||
%%DATADIR%%/FIX50SP1.xml
|
||||
%%DATADIR%%/FIX50SP2.xml
|
||||
%%DATADIR%%/FIXT11.xml
|
||||
%%RUBY%%%%DATADIR%%/quickfix40.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix41.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix42.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix43.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix44.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix50.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix50sp1.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix50sp2.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix_fields.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfix_ruby.rb
|
||||
%%RUBY%%%%DATADIR%%/quickfixt11.rb
|
||||
|
|
Loading…
Reference in a new issue