- Update to 0.8.6
PR: ports/116884 Submitted by: Jason E. Hale <bsdkaffee at gmail.com> (maintainer)
This commit is contained in:
parent
2866a78221
commit
cdc05a5c51
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=200820
3 changed files with 24 additions and 9 deletions
|
@ -6,8 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= gapcmon
|
||||
PORTVERSION= 0.8.4
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.8.6
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
|
@ -17,11 +16,16 @@ COMMENT= Montior apcupsd with GTK+2 GUI
|
|||
|
||||
USE_BZIP2= yes
|
||||
USE_GMAKE= yes
|
||||
USE_ICONV= yes
|
||||
USE_GNOME= gnomehack gnometarget gnomevfs2
|
||||
USE_GNOME= gconf2
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
PORTDOCS= AUTHORS ChangeLog INSTALL
|
||||
PORTDOCS= AUTHORS ChangeLog INSTALL README
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 601103
|
||||
IGNORE= needs gethostbyname_r(3)
|
||||
.endif
|
||||
|
||||
post-extract:
|
||||
@${REINPLACE_CMD} "s|/usr/share/pixmaps/|${PREFIX}/share/pixmaps/|" \
|
||||
|
@ -36,4 +40,5 @@ post-install:
|
|||
.endif
|
||||
@${CAT} pkg-message
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (gapcmon-0.8.4.tar.bz2) = fe27c144da76af5e4d41d65dfeebec05
|
||||
SHA256 (gapcmon-0.8.4.tar.bz2) = dfd39df2a0709bac23af41e082e647be85bcdf75e33eaebf1c4bfcdb10036674
|
||||
SIZE (gapcmon-0.8.4.tar.bz2) = 120468
|
||||
MD5 (gapcmon-0.8.6.tar.bz2) = c8f4c2a2cb6f863b36dbeeedbbe8e8e9
|
||||
SHA256 (gapcmon-0.8.6.tar.bz2) = fdd2227ecd82f1b9557234615e49e65f696540147ae5c2792c7c6d638a795159
|
||||
SIZE (gapcmon-0.8.6.tar.bz2) = 122337
|
||||
|
|
10
sysutils/gapcmon/files/patch-gapcmon.c
Normal file
10
sysutils/gapcmon/files/patch-gapcmon.c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/gapcmon.c.orig Wed Oct 3 19:53:05 2007
|
||||
+++ src/gapcmon.c Wed Oct 3 19:53:32 2007
|
||||
@@ -74,6 +74,7 @@
|
||||
#include <unistd.h> /* close() */
|
||||
#include <sys/types.h> /* socket() */
|
||||
#include <sys/socket.h> /* socket() */
|
||||
+#include <netinet/in.h>
|
||||
#include <arpa/inet.h> /* ntohs() */
|
||||
#include <netdb.h> /* gethostbyname() */
|
||||
#include <errno.h>
|
Loading…
Reference in a new issue