Add fldigi 1.11, a digital decoder for psk, cw, psk31, olivia.
Submitted by: Diane Bruce <db at db.net>
This commit is contained in:
parent
0a5101fcfa
commit
cdcb919220
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=180450
9 changed files with 180 additions and 0 deletions
|
@ -22,6 +22,7 @@
|
||||||
SUBDIR += ecu
|
SUBDIR += ecu
|
||||||
SUBDIR += efax
|
SUBDIR += efax
|
||||||
SUBDIR += efax-gtk
|
SUBDIR += efax-gtk
|
||||||
|
SUBDIR += fldigi
|
||||||
SUBDIR += gammu
|
SUBDIR += gammu
|
||||||
SUBDIR += garmin-utils
|
SUBDIR += garmin-utils
|
||||||
SUBDIR += gfax
|
SUBDIR += gfax
|
||||||
|
|
40
comms/fldigi/Makefile
Normal file
40
comms/fldigi/Makefile
Normal file
|
@ -0,0 +1,40 @@
|
||||||
|
# New ports collection makefile for: fldigi
|
||||||
|
# Date created: December 20 2006
|
||||||
|
# Whom: Diane Bruce <db@db.net>
|
||||||
|
#
|
||||||
|
# $FreeBSD$
|
||||||
|
#
|
||||||
|
|
||||||
|
PORTNAME= fldigi
|
||||||
|
PORTVERSION= 1.11
|
||||||
|
DISTVERSIONSUFFIX= .src
|
||||||
|
CATEGORIES= comms hamradio
|
||||||
|
MASTER_SITES= http://www.w1hkj.com/LinuxApps/
|
||||||
|
|
||||||
|
MAINTAINER= db@db.net
|
||||||
|
COMMENT= Digital decoder for psk, cw, psk31, olivia
|
||||||
|
|
||||||
|
LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk-threads \
|
||||||
|
hamlib:${PORTSDIR}/comms/hamlib
|
||||||
|
|
||||||
|
USE_GMAKE= yes
|
||||||
|
ALL_TARGET= fldigi
|
||||||
|
|
||||||
|
MAKE_ENV+= CXX="${CXX}"
|
||||||
|
|
||||||
|
post-extract:
|
||||||
|
@${SED} -e 's|%%DATADIR%%|${DATADIR}|' \
|
||||||
|
${FILESDIR}/${PORTNAME} > ${WRKSRC}/${PORTNAME}
|
||||||
|
|
||||||
|
do-install:
|
||||||
|
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/Release/${PORTNAME} \
|
||||||
|
${PREFIX}/bin/${PORTNAME}.bin
|
||||||
|
${MKDIR} ${DATADIR}
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/macros.mdf ${DATADIR}
|
||||||
|
.if(!defined(NOPORTDOCS))
|
||||||
|
${MKDIR} ${DOCSDIR}
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
|
||||||
|
.endif
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
3
comms/fldigi/distinfo
Normal file
3
comms/fldigi/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
||||||
|
MD5 (fldigi-1.11.src.tar.gz) = 32f3a4fa8f3569b8486650e60c03d538
|
||||||
|
SHA256 (fldigi-1.11.src.tar.gz) = b49f962232729cac2ffca28461de28ad1c47aef84bfef22058b5f407ae8c74f9
|
||||||
|
SIZE (fldigi-1.11.src.tar.gz) = 376827
|
18
comms/fldigi/files/fldigi
Normal file
18
comms/fldigi/files/fldigi
Normal file
|
@ -0,0 +1,18 @@
|
||||||
|
#!/bin/sh
|
||||||
|
#
|
||||||
|
# fldigi install shell script
|
||||||
|
# loosely based on original script by Dave Freese, W1HKJ
|
||||||
|
#
|
||||||
|
# $FreeBSD$
|
||||||
|
#
|
||||||
|
|
||||||
|
installdir=$HOME/.fldigi
|
||||||
|
macrofile=%%DATADIR%%/macros.mdf
|
||||||
|
|
||||||
|
if [ ! -d $installdir ]; then
|
||||||
|
mkdir $installdir
|
||||||
|
cp $macrofile $installdir
|
||||||
|
echo "You should edit $HOME/.flidi/macros.mdf"
|
||||||
|
fi
|
||||||
|
cd $installdir
|
||||||
|
fldigi.bin
|
53
comms/fldigi/files/patch-Makefile
Normal file
53
comms/fldigi/files/patch-Makefile
Normal file
|
@ -0,0 +1,53 @@
|
||||||
|
--- Makefile.orig Wed Dec 20 03:31:04 2006
|
||||||
|
+++ Makefile Fri Dec 22 00:56:54 2006
|
||||||
|
@@ -3,23 +3,19 @@
|
||||||
|
## Copyright (c) 2005 by Parinya Thipchart
|
||||||
|
#################################################################
|
||||||
|
|
||||||
|
-ifneq (,$(findstring Release, $(CFG)))
|
||||||
|
- override CFG = Release
|
||||||
|
-else
|
||||||
|
- override CFG = Debug
|
||||||
|
-endif
|
||||||
|
+CFG = Release
|
||||||
|
|
||||||
|
PROJECT = fldigi
|
||||||
|
-CC = "/usr/bin/g++"
|
||||||
|
+CXX ?= c++
|
||||||
|
+CC = ${CXX}
|
||||||
|
|
||||||
|
ifeq ($(CFG),Debug)
|
||||||
|
OBJ_DIR = Debug
|
||||||
|
OUTPUT_DIR = Debug
|
||||||
|
TARGET = fldigi
|
||||||
|
- C_INCLUDE_DIRS = -I"src" -I"src/include"
|
||||||
|
C_PREPROC =
|
||||||
|
- CFLAGS = -pipe `fltk-config --cxxflags` -Wno-deprecated -ffast-math -Wall -ggdb2 -O0 -fno-rtti -fexceptions
|
||||||
|
- LIB_DIRS = -L"src/lib /usr/local/lib" -L"../../../../../usr/local/lib"
|
||||||
|
+ CFLAGS = -pipe -I"src" -I"src/include" `fltk-config --cxxflags` -Wno-deprecated -ffast-math -Wall -ggdb2 -O0 -fno-rtti -fexceptions
|
||||||
|
+ LIB_DIRS = -L"src/lib $(PREFIX)/lib" -L"$(PREFIX)/lib"
|
||||||
|
LIBS = -lhamlib -lfltk_images -ljpeg -lpng
|
||||||
|
LDFLAGS = -pipe `fltk-config --ldflags --use-images`
|
||||||
|
endif
|
||||||
|
@@ -28,10 +24,9 @@
|
||||||
|
OBJ_DIR = Release
|
||||||
|
OUTPUT_DIR = Release
|
||||||
|
TARGET = fldigi
|
||||||
|
- C_INCLUDE_DIRS = -I"src" -I"src/include"
|
||||||
|
C_PREPROC =
|
||||||
|
- CFLAGS = -pipe `fltk-config --cxxflags` -Wno-deprecated -ffast-math -Wall -g0 -O2 -fno-rtti -fexceptions
|
||||||
|
- LIB_DIRS = -L"src/lib" -L"../../../../../usr/local/lib"
|
||||||
|
+ CFLAGS += -I"src" -I"src/include" `fltk-config --cxxflags` -Wno-deprecated -ffast-math -Wall -g0 -fno-rtti -fexceptions
|
||||||
|
+ LIB_DIRS = -L"src/lib" -L"$(PREFIX)/lib"
|
||||||
|
LIBS = -lhamlib -lfltk_images -ljpeg -lpng -lz
|
||||||
|
LDFLAGS = -pipe -s `fltk-config --ldflags --use-images`
|
||||||
|
endif
|
||||||
|
@@ -105,7 +100,7 @@
|
||||||
|
|
||||||
|
define compile_source
|
||||||
|
@echo Compiling $<
|
||||||
|
-@$(CC) $(CFLAGS) $(C_PREPROC) $(C_INCLUDE_DIRS) -c "$<" -o "$@"
|
||||||
|
+@$(CC) $(CFLAGS) $(C_PREPROC) -c "$<" -o "$@"
|
||||||
|
endef
|
||||||
|
|
||||||
|
.PHONY: print_header directories
|
10
comms/fldigi/files/patch-src_include_rigclass.h
Normal file
10
comms/fldigi/files/patch-src_include_rigclass.h
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
--- src/include/rigclass.h.orig Tue Dec 19 21:31:04 2006
|
||||||
|
+++ src/include/rigclass.h Wed Dec 20 18:38:55 2006
|
||||||
|
@@ -15,7 +15,6 @@
|
||||||
|
#include <list>
|
||||||
|
|
||||||
|
#include <hamlib/rig.h>
|
||||||
|
-#include <values.h>
|
||||||
|
#include <assert.h>
|
||||||
|
#include <errno.h>
|
||||||
|
|
30
comms/fldigi/files/patch-src_soundcard_sound.cxx
Normal file
30
comms/fldigi/files/patch-src_soundcard_sound.cxx
Normal file
|
@ -0,0 +1,30 @@
|
||||||
|
--- src/soundcard/sound.cxx.orig Tue Dec 19 21:31:04 2006
|
||||||
|
+++ src/soundcard/sound.cxx Wed Dec 20 18:46:00 2006
|
||||||
|
@@ -16,7 +16,9 @@
|
||||||
|
|
||||||
|
try {
|
||||||
|
Open(O_RDONLY);
|
||||||
|
+#if 0
|
||||||
|
getVersion();
|
||||||
|
+#endif
|
||||||
|
getCapabilities();
|
||||||
|
getFormats();
|
||||||
|
Close();
|
||||||
|
@@ -78,7 +80,7 @@
|
||||||
|
{
|
||||||
|
int sndparam;
|
||||||
|
// Try to get ~100ms worth of samples per fragment
|
||||||
|
- sndparam = (int)log2(sample_frequency * 0.1);
|
||||||
|
+ sndparam = (int)log2((unsigned int)(sample_frequency * 0.1));
|
||||||
|
// double since we are using 16 bit samples
|
||||||
|
sndparam += 1;
|
||||||
|
// Unlimited amount of buffers for RX, four for TX
|
||||||
|
@@ -120,7 +122,7 @@
|
||||||
|
void cSound::getVersion()
|
||||||
|
{
|
||||||
|
version = 0;
|
||||||
|
- if (ioctl(device_fd, OSS_GETVERSION, &version) == -1) {
|
||||||
|
+ if (ioctl(device_fd, SOUND_VERSION, &version) == -1) {
|
||||||
|
version = -1;
|
||||||
|
throw SndException("OSS Version");
|
||||||
|
}
|
19
comms/fldigi/pkg-descr
Normal file
19
comms/fldigi/pkg-descr
Normal file
|
@ -0,0 +1,19 @@
|
||||||
|
Digital modem program.
|
||||||
|
Supports the following digital modes:
|
||||||
|
|
||||||
|
CW,
|
||||||
|
DominoEX 4 DominoEX 5 DominoEX 8 DominoEX 11 DominoEX 16 DominoEX 22,
|
||||||
|
Feld-Hell FSK-Hell FSK-Hell 105,
|
||||||
|
MFSK-8 MFSK-16 MFSK-16 pix ,
|
||||||
|
PSK-31 QPSK-31 PSK-63 QPSK-63 PSK-125 QPSK-125,
|
||||||
|
OLIVIA various tones and bandwidth,
|
||||||
|
RTTY various Baud Rates, Shifts, Nbr of data bits, etc.,
|
||||||
|
Throb-1 Throb-2 Throb-4 ThrobX-1 ThrobX-2 ThrobX-4,
|
||||||
|
WWV Receive only - calibrate your sound card to WWV and
|
||||||
|
Freq Analysis Receive only - be ready for the (next)
|
||||||
|
ARRL FMT (freq meas test).
|
||||||
|
|
||||||
|
WWW: http://www.w1hkj.com/Fldigi.html
|
||||||
|
|
||||||
|
- Diane VA3DB
|
||||||
|
db@db.net
|
6
comms/fldigi/pkg-plist
Normal file
6
comms/fldigi/pkg-plist
Normal file
|
@ -0,0 +1,6 @@
|
||||||
|
bin/fldigi.bin
|
||||||
|
bin/fldigi
|
||||||
|
%%DATADIR%%/macros.mdf
|
||||||
|
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||||
|
@dirrm %%DATADIR%%
|
||||||
|
%%PORTDOCS%%@dirrm %%DOCSDIR%%
|
Loading…
Reference in a new issue