- fix compilation and installation
- synce pkg-plist - since 2.0 pfa-fonts are required, remove WITHOUT_PFA_FONTS option - don't install .info twice - make documentation optional PR: 58120 Submitted by: Patrick Atamaniuk <atamaniuk-ports@frobs.net> (maintainer) Approved by: marcus (mentor)
This commit is contained in:
parent
9869294faa
commit
cdced3add9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=94530
11 changed files with 859 additions and 715 deletions
|
@ -5,6 +5,7 @@
|
|||
#
|
||||
# $NetBSD: Makefile,v 1.1.1.1 2000/10/15 17:32:11 rh Exp $
|
||||
# $FreeBSD$
|
||||
# $Id: Makefile,v 1.11 2003/11/20 08:32:27 patrick Exp $
|
||||
#
|
||||
|
||||
PORTNAME= lilypond
|
||||
|
@ -15,52 +16,72 @@ MASTER_SITES= ftp://ftp.lilypond.org//pub/LilyPond/v2.0/
|
|||
MAINTAINER= atamaniuk-ports@frobs.net
|
||||
COMMENT= The GNU music typesetter
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/bin/latex:${PORTSDIR}/print/teTeX
|
||||
BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX \
|
||||
mftrace:${PORTSDIR}/print/mftrace
|
||||
LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
|
||||
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
|
||||
|
||||
MAN1= abc2ly.1 as2text.1 convert-ly.1 etf2ly.1 lilypond.1 lilypond-bin.1 \
|
||||
lilypond-book.1 midi2ly.1 mup2ly.1 musedata2ly.1 pmx2ly.1
|
||||
INFO= lilypond lilypond-internals
|
||||
INFO= lilypond lilypond-internals music-glossary
|
||||
|
||||
CONFLICTS= lilypond-devel-2.*
|
||||
|
||||
#INSTALLS_SHLIB not needed for phyton library midi.so
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_BISON= yes
|
||||
USE_GMAKE= YES
|
||||
USE_PYTHON= YES
|
||||
MAKEFILE= GNUmakefile
|
||||
PKGINSTALL= ${WRKDIR}/pkg-install
|
||||
|
||||
CONFIGURE_ARGS+= --with-kpathsea-include=${PREFIX}/include \
|
||||
--with-kpathsea-lib=${PREFIX}/lib
|
||||
CONFIGURE_ARGS+= --with-kpathsea-include=${LOCALBASE}/include \
|
||||
--with-kpathsea-lib=${LOCALBASE}/lib
|
||||
CONFIGURE_ENV+= "CPPFLAGS=${CPPFLAGS}"
|
||||
|
||||
# inform kpathsea.h of getopt-prototype version
|
||||
CFLAGS+= -D__GNU_LIBRARY__
|
||||
CPPFLAGS+= -I${WRKSRC}/lily/out
|
||||
CFLAGS+= ${CPPFLAGS}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
.if !defined(WITHOUT_PFA_FONTS)
|
||||
BUILD_DEPENDS+= ${PREFIX}/bin/mftrace:${PORTSDIR}/print/mftrace
|
||||
MAKE_ENV+= MAKE_PFA_FILES=1
|
||||
ALL_TARGET= all # XXX pfa-fonts
|
||||
.endif
|
||||
ALL_TARGET= all
|
||||
|
||||
.if ${OSVERSION} < 500000
|
||||
USE_GCC= 3.3
|
||||
OLD_CPP_INCLUDEDIR= /usr/include/g++
|
||||
CONFIGURE_ENV+= "CPPFLAGS=$${CPPFLAGS} -idirafter ${OLD_CPP_INCLUDEDIR}"
|
||||
.endif
|
||||
|
||||
SCRIPTS_ENV+= PORTVERSION=${PORTVERSION}
|
||||
|
||||
.if defined(NOPORTDOCS)
|
||||
PLIST_SUB+= CONDITIONAL="@comment "
|
||||
EXTRA_PATCHES+= ${FILESDIR}/extra-patch:GNUmakefile.in
|
||||
.else
|
||||
PLIST_SUB+= CONDITIONAL=""
|
||||
.endif
|
||||
|
||||
#IGNORING portlint 2.5.0 WARN: possible direct use of command "install" found at line 64. use ${INSTALL_foobaa} instead.
|
||||
INSTALL_INFO?= install-info
|
||||
|
||||
pre-everything::
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
@${ECHO_CMD} Pausing ten seconds--press control-C to cancel the build.
|
||||
@sleep 10
|
||||
|
||||
pre-configure:
|
||||
${SED} -e "s=%%LOCALBASE%%=${LOCALBASE}=g;s=%%DATADIRVERSION%%=${DATADIR}/${PORTVERSION}=g" \
|
||||
< ${FILESDIR}/pkg-install.in \
|
||||
| ${SED} -e "s=${PREFIX}=\$${PKG_PREFIX}=g" \
|
||||
> ${PKGINSTALL}
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}/scripts
|
||||
cd ${WRKSRC}/input ; \
|
||||
${TAR} -chf - --exclude=out --exclude=CVS --exclude=GNUmakefile . | \
|
||||
${TAR} -xf - -C ${EXAMPLESDIR};\
|
||||
${FIND} ${EXAMPLESDIR} -name "out" | ${XARGS} ${RM} -rf ;
|
||||
${TAR} -xf - -C ${EXAMPLESDIR};
|
||||
.for ii in login profile
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/buildscripts/out/lilypond-${ii} \
|
||||
${EXAMPLESDIR}/scripts
|
||||
|
@ -76,15 +97,11 @@ post-install:
|
|||
--exclude=dummy.dep --exclude=CVS --exclude=GNUmakefile . \
|
||||
| ${TAR} -xf - -C ${DOCSDIR}
|
||||
|
||||
.for file in ${INFO}
|
||||
${INSTALL_DATA} ${WRKSRC}/Documentation/user/out/${file}.info \
|
||||
${PREFIX}/info/
|
||||
install-info ${PREFIX}/info/${file}.info ${PREFIX}/info/dir
|
||||
.for ii in ${INFO}
|
||||
- ${INSTALL_INFO} ${PREFIX}/info/${ii}.info ${PREFIX}/info/dir
|
||||
.endfor
|
||||
.endif
|
||||
${ENV} PKG_PREFIX=${PREFIX} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
|
||||
# ${ENV} PATH=${LOCALBASE}/bin:${PREFIX}/bin:${PATH} \
|
||||
# TEXMF="{${DATADIR}/${PORTVERSION}},"`kpsexpand \\$$TEXMF`"}" texhash
|
||||
${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
|
||||
|
||||
@${ECHO_CMD} "* Look in ${EXAMPLESDIR}/scripts for needed additions to"
|
||||
@${ECHO_CMD} "* your .profile (at least the TEXMF environment variable"
|
||||
|
|
16
print/lilypond/files/extra-patch:GNUmakefile.in
Normal file
16
print/lilypond/files/extra-patch:GNUmakefile.in
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- GNUmakefile.in.orig Wed Oct 15 15:53:47 2003
|
||||
+++ GNUmakefile.in Wed Oct 15 15:54:18 2003
|
||||
@@ -9,12 +9,11 @@
|
||||
# descent order into subdirectories
|
||||
#
|
||||
SUBDIRS = buildscripts python scripts \
|
||||
- elisp \
|
||||
flower lily \
|
||||
mf ly tex ps scm \
|
||||
po make \
|
||||
cygwin debian stepmake \
|
||||
- Documentation input
|
||||
+ input
|
||||
#
|
||||
|
||||
SCRIPTS = configure aclocal.m4 autogen.sh lexer-gcc-3.1.sh
|
|
@ -1,20 +1,13 @@
|
|||
$FreeBSD$
|
||||
|
||||
--- Documentation/user/GNUmakefile.orig Fri Sep 19 13:25:01 2003
|
||||
+++ Documentation/user/GNUmakefile Fri Sep 19 13:25:16 2003
|
||||
@@ -21,12 +21,12 @@
|
||||
|
||||
PS_GZ_FILES= $(addsuffix .gz, $(PS_FILES))
|
||||
|
||||
-INFO_DOCS = lilypond lilypond-internals music-glossary
|
||||
+INFO_DOCS = lilypond lilypond-internals
|
||||
--- Documentation/user/GNUmakefile.orig Sat Sep 20 00:36:19 2003
|
||||
+++ Documentation/user/GNUmakefile Sat Sep 20 00:36:30 2003
|
||||
@@ -24,9 +24,7 @@
|
||||
INFO_DOCS = lilypond lilypond-internals music-glossary
|
||||
INFO_FILES = $(INFO_DOCS:%=$(outdir)/%.info)
|
||||
|
||||
-STEPMAKE_TEMPLATES=tex texinfo omf documentation
|
||||
+STEPMAKE_TEMPLATES=tex texinfo documentation
|
||||
|
||||
-
|
||||
-OMF_FILES += $(outdir)/lilypond-internals.html.omf
|
||||
+#OMF_FILES += $(outdir)/lilypond-internals.html.omf
|
||||
+STEPMAKE_TEMPLATES=tex texinfo documentation
|
||||
|
||||
LOCALSTEPMAKE_TEMPLATES=lilypond ly
|
||||
LILYPOND_BOOK_FLAGS=--extra-options '-e "(ly:set-option (quote internal-type-checking) \#t)"'
|
||||
|
|
19
print/lilypond/files/patch-Doc:user:lilypond.tely
Normal file
19
print/lilypond/files/patch-Doc:user:lilypond.tely
Normal file
|
@ -0,0 +1,19 @@
|
|||
--- Documentation/user/lilypond.tely.orig Sat Sep 27 11:16:47 2003
|
||||
+++ Documentation/user/lilypond.tely Mon Oct 6 16:04:34 2003
|
||||
@@ -17,16 +17,6 @@
|
||||
@direntry
|
||||
@c ;; prepend GNU for dir, must be unique
|
||||
* GNU LilyPond: (lilypond). The GNU music typesetter.
|
||||
-* lilypond: (lilypond)Invoking lilypond:: Titling LilyPond scores.
|
||||
-* Glossary: (music-glossary). Glossary of music terms.
|
||||
-* convert-ly: (lilypond)Invoking convert-ly:: Older LilyPond versions.
|
||||
-* midi2ly: (lilypond)Invoking midi2ly:: Importing MIDI.
|
||||
-* etf2ly: (lilypond)Invoking etf2ly:: Importing Finale.
|
||||
-* abc2ly: (lilypond)Invoking abc2ly:: Importing ABC.
|
||||
-* pmx2ly: (lilypond)Invoking pmx2ly:: Importing PMX.
|
||||
-* musedata2ly: (lilypond)Invoking musedata2ly::
|
||||
- Importing Musedata.
|
||||
-* mup2ly: (lilypond)Invoking mup2ly:: Importing MUP.
|
||||
@end direntry
|
||||
|
||||
|
21
print/lilypond/files/patch-Doc:user:music-glossary.tely
Normal file
21
print/lilypond/files/patch-Doc:user:music-glossary.tely
Normal file
|
@ -0,0 +1,21 @@
|
|||
--- Documentation/user/music-glossary.tely.orig Mon Oct 6 16:04:06 2003
|
||||
+++ Documentation/user/music-glossary.tely Mon Oct 6 16:04:24 2003
|
||||
@@ -2,6 +2,18 @@
|
||||
@settitle Music Glossary
|
||||
@setfilename music-glosssary.info
|
||||
|
||||
+@ignore
|
||||
+Distributions will want to install lilypond.info doing:
|
||||
+
|
||||
+ ./install-info --info-dir=/usr/share/info out/lilypond.info
|
||||
+
|
||||
+@end ignore
|
||||
+@dircategory GNU music project
|
||||
+@direntry
|
||||
+@c ;; prepend GNU for dir, must be unique
|
||||
+* Music Glossary: (music-glossary). Glossary of music terms.
|
||||
+@end direntry
|
||||
+
|
||||
|
||||
@ifhtml
|
||||
This document is also available in @uref{music-glossary.ps.gz,gzipped
|
11
print/lilypond/files/patch-make-ly-rules.make
Normal file
11
print/lilypond/files/patch-make-ly-rules.make
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- make/ly-rules.make.orig Tue Sep 23 20:50:18 2003
|
||||
+++ make/ly-rules.make Thu Sep 25 10:37:07 2003
|
||||
@@ -33,7 +33,7 @@
|
||||
|
||||
# nfo: info from non-lily texi
|
||||
$(outdir)/%.info: $(outdir)/%.nexi
|
||||
- $(MAKEINFO) --output=$(outdir)/$(*F).info $<
|
||||
+ $(MAKEINFO) --no-split --output=$(outdir)/$(*F).info $<
|
||||
|
||||
# nfo: info from non-lily texi
|
||||
#$(outdir)/%.nfo: $(outdir)/%.nexi
|
11
print/lilypond/files/patch-scm:documentation-generate.scm
Normal file
11
print/lilypond/files/patch-scm:documentation-generate.scm
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- scm/documentation-generate.scm.orig Mon Oct 6 15:28:49 2003
|
||||
+++ scm/documentation-generate.scm Mon Oct 6 15:29:09 2003
|
||||
@@ -43,7 +43,7 @@
|
||||
(display
|
||||
(string-append
|
||||
"@c -*-texinfo-*-"
|
||||
- (texi-file-head "LilyPond program-reference" outname "(lilypond-internals.info)")
|
||||
+ (texi-file-head "LilyPond program-reference" file-name "(lilypond-internals.info)")
|
||||
"
|
||||
|
||||
@ifhtml
|
10
print/lilypond/files/pkg-install.in
Normal file
10
print/lilypond/files/pkg-install.in
Normal file
|
@ -0,0 +1,10 @@
|
|||
#!/bin/sh
|
||||
LOCALBASE="%%LOCALBASE%%"
|
||||
DATADIRVERSION="%%DATADIRVERSION%%"
|
||||
case $2 in
|
||||
POST-INSTALL)
|
||||
PATH=${LOCALBASE}/bin:${PATH}
|
||||
export TEXMF="{${DATADIRVERSION},"`kpsexpand \\$TEXMF`"}"
|
||||
texhash
|
||||
;;
|
||||
esac
|
File diff suppressed because it is too large
Load diff
14
print/lilypond/scripts/post-configure
Normal file
14
print/lilypond/scripts/post-configure
Normal file
|
@ -0,0 +1,14 @@
|
|||
#!/bin/sh
|
||||
outdir=out
|
||||
cd ${WRKSRC} || exit 2
|
||||
file=lily/$outdir/lexer.cc
|
||||
echo -n "Generating and fixing $file... "
|
||||
rm -f $file
|
||||
gmake conf=$CONF -C lily $outdir/lexer.cc || true
|
||||
|
||||
mv $file $file.orig
|
||||
sed -e 's/istream\*/std::istream*/g' \
|
||||
-e 's/ostream\*/std::ostream*/g' \
|
||||
-e 's/class istream;/#include \<iostream\>/g' \
|
||||
$file.orig > $file
|
||||
echo "done"
|
16
print/lilypond/scripts/pre-configure
Normal file
16
print/lilypond/scripts/pre-configure
Normal file
|
@ -0,0 +1,16 @@
|
|||
#!/bin/sh
|
||||
outdir=out
|
||||
cd ${WRKSRC} || exit 2
|
||||
echo "Patching for FlexLexer.h <->gcc3 issues"
|
||||
|
||||
file=/usr/include/g++/FlexLexer.h
|
||||
|
||||
echo -n "Copying and fixing $file... "
|
||||
mkdir -p lily/$outdir
|
||||
rm -f lily/$outdir/FlexLexer.h
|
||||
sed \
|
||||
-e 's/istream/std::istream/' \
|
||||
-e 's/[^i]ostream/std::ostream/' \
|
||||
-e 's/iostream.h/iostream/' \
|
||||
$file > lily/$outdir/FlexLexer.h
|
||||
echo "done"
|
Loading…
Reference in a new issue