- Update MASTER_SITES

- Add LICENSE
- Add MAKE_JOBS_SAFE
- Support PORTDOCS/PLIST_FILES

Remove file:
files/extra-patch-broken-scandir
pkg-plist

PR:		ports/168590
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
Sylvio Cesar Teixeira 2012-06-05 20:38:19 +00:00
parent b04f4e89f6
commit cdfad8a937
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=298521
5 changed files with 61 additions and 57 deletions

View file

@ -8,34 +8,38 @@
PORTNAME= MuSE
PORTVERSION= 0.9.2
PORTREVISION= 12
PORTREVISION= 13
CATEGORIES= audio
MASTER_SITES= ftp://ftp.dyne.org/muse/releases/ \
http://www.ljudmila.org/~jaromil/muse/releases/
MASTER_SITES= http://files.dyne.org/muse/releases/
MAINTAINER= ports@FreeBSD.org
COMMENT= Multiple Streaming Engine
LICENSE= GPLv2
LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
ogg.7:${PORTSDIR}/audio/libogg
OPTIONS_DEFINE= X11 LAME SNDFILE DOCS
OPTIONS_DEFAULT=X11
USE_GETTEXT= yes
USE_GMAKE= yes
WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug --disable-lubrify --disable-rpath
CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT -DHAVE_SYS_UIO_H \
${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} -lintl
MAKE_JOBS_SAFE= yes
OPTIONS_DEFINE= X11 LAME SNDFILE
OPTIONS_DEFAULT= X11
CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_SYS_UIO_H ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib -lintl ${PTHREAD_LIBS}
.include <bsd.port.pre.mk>
MAN1= muse.1
PORTDOCS= AUTHORS ChangeLog NEWS KNOWN-BUGS README TODO USAGE
PLIST_FILES= bin/muse
.for lang in es it
PLIST_FILES+= share/locale/${lang}/LC_MESSAGES/muse.mo
.endfor
.if ${OSVERSION} < 800501
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-broken-scandir
.endif
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
USE_GNOME+= gtk20
@ -44,20 +48,30 @@ PKGNAMESUFFIX= -nox11
CONFIGURE_ARGS+=--without-x --with-rubik
.endif
.if ${PORT_OPTIONS:MMP3} || exists(${LOCALBASE}/lib/libmp3lame.so.0)
.if ${PORT_OPTIONS:MLAME}
LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
.else
CONFIGURE_ENV+= ac_cv_header_lame_lame_h=no
.endif
.if ${PORT_OPTIONS:MSNDFILE} || exists(${LOCALBASE}/lib/libsndfile.so.1)
.if ${PORT_OPTIONS:MSNDFILE}
LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
.endif
MAN1= muse.1
post-patch:
.if exists(/usr/include/sys/soundcard.h)
${REINPLACE_CMD} -e "s,machine/soundcard.h,sys/soundcard.h,g" \
@${REINPLACE_CMD} -e 's|machine/soundcard.h|sys/soundcard.h|' \
${WRKSRC}/src/portaudio/pa_unix_oss.c
.if empty(PORT_OPTIONS:MSNDFILE)
@${REINPLACE_CMD} -e '/sndfile >=/s|$$PKG_CONFIG|${FALSE}|' \
${WRKSRC}/configure
.endif
.include <bsd.port.post.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
.include <bsd.port.mk>

View file

@ -1,11 +0,0 @@
--- src/jmixer.cpp.orig 2004-12-16 03:04:31.000000000 -0800
+++ src/jmixer.cpp 2010-08-22 14:15:03.000000000 -0700
@@ -640,7 +640,7 @@
/* this is the function selecting files for the scandir
on freebsd systems you should change the following line to:
int selector(struct dirent *dir) { */
-int selector(const struct dirent *dir) {
+int selector(struct dirent *dir) {
if( strncasecmp(dir->d_name+strlen(dir->d_name)-4,".mp3",4)==0
#ifdef HAVE_VORBIS
|| strncasecmp(dir->d_name+strlen(dir->d_name)-4,".ogg",4)==0

View file

@ -1,11 +1,11 @@
--- Makefile.in.orig Fri Aug 4 12:11:20 2006
+++ Makefile.in Fri Aug 4 12:11:27 2006
@@ -240,7 +240,7 @@
target_vendor = @target_vendor@
SUBDIRS = po intl src
docs_DATA = README COPYING AUTHORS NEWS KNOWN-BUGS ChangeLog TODO USAGE
-docsdir = ${prefix}/doc/MuSE
+docsdir = ${prefix}/share/doc/MuSE
man_MANS = muse.1
ACLOCAL_AMFLAGS = -I . -I m4
EXTRA_DIST = autogen.sh config.rpath
--- Makefile.in.orig 2005-12-27 22:09:38.000000000 +0900
+++ Makefile.in 2012-06-02 04:45:45.000000000 +0900
@@ -690,7 +690,7 @@
info-am:
-install-data-am: install-docsDATA install-man
+install-data-am: install-man
install-exec-am:

View file

@ -1,6 +1,6 @@
--- src/jmixer.cpp.orig Fri Aug 4 11:44:33 2006
+++ src/jmixer.cpp Fri Aug 4 11:46:02 2006
@@ -20,18 +20,18 @@
--- src/jmixer.cpp.orig 2004-12-16 20:04:31.000000000 +0900
+++ src/jmixer.cpp 2012-05-29 07:39:23.000000000 +0900
@@ -20,18 +20,19 @@
*/
#include <iostream>
@ -15,6 +15,7 @@
#include <sys/ioctl.h>
#include <sys/stat.h>
-#include <errno.h>
+#include <sys/param.h>
+#include <cerrno>
#include <fcntl.h>
@ -25,3 +26,15 @@
#include <sys/types.h>
#include <sys/wait.h>
#include <termios.h>
@@ -640,7 +641,11 @@
/* this is the function selecting files for the scandir
on freebsd systems you should change the following line to:
int selector(struct dirent *dir) { */
+#if defined(__FreeBSD__) && __FreeBSD_version < 800501
+int selector(struct dirent *dir) {
+#else
int selector(const struct dirent *dir) {
+#endif
if( strncasecmp(dir->d_name+strlen(dir->d_name)-4,".mp3",4)==0
#ifdef HAVE_VORBIS
|| strncasecmp(dir->d_name+strlen(dir->d_name)-4,".ogg",4)==0

View file

@ -1,12 +0,0 @@
bin/muse
%%DOCSDIR%%/AUTHORS
%%DOCSDIR%%/COPYING
%%DOCSDIR%%/ChangeLog
%%DOCSDIR%%/KNOWN-BUGS
%%DOCSDIR%%/NEWS
%%DOCSDIR%%/README
%%DOCSDIR%%/TODO
%%DOCSDIR%%/USAGE
share/locale/es/LC_MESSAGES/muse.mo
share/locale/it/LC_MESSAGES/muse.mo
@dirrm %%DOCSDIR%%