Don't do isprint(3) filtering, just print it.
Before isprint(3) get fixed or any one knows how to use isprint(3) to identify multibytes characters, this temporary fix would remain here. PR: 23196 Reviewed by: People on tw.bbs.comp.386bsd newsgroup
This commit is contained in:
parent
e72beb0cb9
commit
ce13902f3d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=35751
2 changed files with 12 additions and 1 deletions
|
@ -12,7 +12,8 @@ MAINTAINER= yssu@CCCA.NCTU.edu.tw
|
|||
|
||||
EXTRA_PATCHES= ${.CURDIR}/files/patch-charset.c \
|
||||
${.CURDIR}/files/patch-cook.c \
|
||||
${.CURDIR}/files/patch-init.c
|
||||
${.CURDIR}/files/patch-init.c \
|
||||
${.CURDIR}/files/patch-misc.c
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
||||
|
||||
|
|
10
chinese/tin/files/patch-misc.c
Normal file
10
chinese/tin/files/patch-misc.c
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/misc.c~ Thu Aug 3 21:49:22 2000
|
||||
+++ src/misc.c Wed Nov 29 08:03:36 2000
|
||||
@@ -1169,6 +1169,7 @@
|
||||
my_isprint (
|
||||
int c)
|
||||
{
|
||||
+ return 1;
|
||||
#ifndef NO_LOCALE
|
||||
/* use locale */
|
||||
return isprint(c);
|
Loading…
Reference in a new issue