Fix build for 9.x

This commit is contained in:
Stephen Hurd 2015-11-30 04:55:14 +00:00
parent d891bad74a
commit ce2e81be83
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=402644
4 changed files with 15 additions and 8 deletions

View file

@ -21,10 +21,9 @@ USE_BDB= 5+
PKGMESSAGE= ${WRKDIR}/pkg-message
USES= cmake compiler:features pkgconfig tar:tgz
USES= cmake compiler:c++11-lib pkgconfig tar:tgz
CMAKE_ARGS= -DBDB_PREFIX=${LOCALBASE}
USE_WX= 2.8+
WX_UNICODE= yes
USE_LDCONFIG= yes
USE_OPENSSL= yes

View file

@ -5,7 +5,7 @@
option(USE_STATIC_MSVCRT "Use a static Visual C++ Runtime when building with MSVC")
+if(UNIX)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++1y")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+endif()
if(MSVC AND USE_STATIC_MSVCRT)
foreach(flag_var

View file

@ -1,4 +1,4 @@
--- apps/CMakeLists.txt.orig 2015-11-29 00:14:00 UTC
--- apps/CMakeLists.txt.orig 2015-10-21 17:26:38 UTC
+++ apps/CMakeLists.txt
@@ -148,7 +148,11 @@ if(NOT APPLE AND NOT WIN32)
add_definitions("-DCONFDIR=\"${CMAKE_INSTALL_PREFIX}/share/TrustedQSL/\"")

View file

@ -1,6 +1,14 @@
--- src/xml.h.orig 2015-10-21 17:26:38 UTC
+++ src/xml.h
@@ -28,7 +28,7 @@ namespace tqsllib {
@@ -13,6 +13,7 @@
#include <string>
#include <map>
+#include <memory>
#include <vector>
#include <utility>
#include <expat.h>
@@ -28,7 +29,7 @@ namespace tqsllib {
class XMLElement;
@ -9,7 +17,7 @@
typedef map<string, string> XMLElementAttributeList;
/** Encapsulates an XML element
@@ -62,7 +62,7 @@ class XMLElement {
@@ -62,7 +63,7 @@ class XMLElement {
*/
pair<string, bool> getAttribute(const string& key);
/// Add an element to the list of contained subelements
@ -18,7 +26,7 @@
XMLElementAttributeList& getAttributeList() { return _attributes; }
XMLElementList& getElementList() { return _elements; }
/// Parse an XML file and add its element tree to this element
@@ -134,8 +134,8 @@ XMLElement::setAttribute(const string& k
@@ -134,8 +135,8 @@ XMLElement::setAttribute(const string& k
}
inline XMLElementList::iterator
@ -29,7 +37,7 @@
return it;
}
@@ -158,9 +158,9 @@ inline bool
@@ -158,9 +159,9 @@ inline bool
XMLElement::getNextElement(XMLElement& element) {
if (_iter == _elements.end())
return false;