Modernize (LIB_DEPENDS, USES).
Support staging. Add a patch that allows building with a strict-conformance C++11 compiler. Approved by: portmgr (implicit, under "just fix it" blanket approval)
This commit is contained in:
parent
4188c2d269
commit
ce3a722ed9
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=342870
4 changed files with 20 additions and 19 deletions
|
@ -12,22 +12,19 @@ COMMENT= Read and manipulate raw images from various digital cameras
|
|||
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
|
||||
tiff:${PORTSDIR}/graphics/tiff \
|
||||
png15:${PORTSDIR}/graphics/png \
|
||||
lcms:${PORTSDIR}/graphics/lcms
|
||||
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
|
||||
libtiff.so:${PORTSDIR}/graphics/tiff \
|
||||
libpng15.so:${PORTSDIR}/graphics/png \
|
||||
liblcms.so:${PORTSDIR}/graphics/lcms
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-silent-rules --enable-extras
|
||||
USES= gettext pkgconfig
|
||||
USE_GMAKE= yes
|
||||
USES= gettext pkgconfig gmake
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
|
||||
PC_FALSE= cinepaint
|
||||
|
||||
MAN1= ufraw.1
|
||||
|
||||
OPTIONS_DEFINE= CONTRAST DST EXIV2 LENSFUN FITS GIMP GTK2 GNOME
|
||||
OPTIONS_DEFAULT=CONTRAST EXIV2 LENSFUN GTK2
|
||||
|
||||
|
@ -36,7 +33,6 @@ DST_DESC= Use local time for timestamps
|
|||
FITS_DESC= FITS output support
|
||||
GIMP_DESC= Install GIMP plugin
|
||||
|
||||
NO_STAGE= yes
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if ${PORT_OPTIONS:MCONTRAST}
|
||||
|
@ -84,7 +80,8 @@ CONFIGURE_ARGS+=--without-gtk
|
|||
|
||||
.if ${PORT_OPTIONS:MGNOME}
|
||||
CATEGORIES+= gnome
|
||||
USE_GNOME= desktopfileutils gconf2
|
||||
USE_GNOME= gconf2
|
||||
USES+= desktop-file-utils
|
||||
CONFIGURE_ARGS+= --enable-mime
|
||||
GCONF_SCHEMAS= ${PORTNAME}.schemas
|
||||
PLIST_SUB+= GNOME=""
|
||||
|
@ -109,12 +106,4 @@ pre-build:
|
|||
@${INSTALL_SCRIPT} ${LOCALBASE}/share/icu/50.1.2/mkinstalldirs \
|
||||
${WRKSRC}
|
||||
|
||||
post-install:
|
||||
.if ${PORT_OPTIONS:MGNOME}
|
||||
@${SETENV} GCONF_CONFIG_SOURCE=${GCONF_CONFIG_SOURCE} \
|
||||
gconftool-2 --makefile-install-rule \
|
||||
${PREFIX}/etc/gconf/schemas/${PORTNAME}.schemas
|
||||
@-update-desktop-database
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
11
graphics/ufraw/files/patch-dcraw.cc
Normal file
11
graphics/ufraw/files/patch-dcraw.cc
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- ./dcraw.cc.orig 2013-03-20 03:31:38.000000000 +0100
|
||||
+++ ./dcraw.cc 2014-02-05 22:11:28.000000000 +0100
|
||||
@@ -9269,7 +9269,7 @@
|
||||
strncpy (th->desc, desc, 512);
|
||||
strncpy (th->make, make, 64);
|
||||
strncpy (th->model, model, 64);
|
||||
- strcpy (th->soft, "dcraw v"DCRAW_VERSION);
|
||||
+ strcpy (th->soft, "dcraw v" DCRAW_VERSION);
|
||||
t = localtime (×tamp);
|
||||
sprintf (th->date, "%04d:%02d:%02d %02d:%02d:%02d",
|
||||
t->tm_year+1900,t->tm_mon+1,t->tm_mday,t->tm_hour,t->tm_min,t->tm_sec);
|
|
@ -6,4 +6,4 @@ apply color profiles. For Nikon users UFRaw has the advantage that it can
|
|||
read the camera's tone curves. Even if you don't own a Nikon, you can still
|
||||
apply a Nikon curve to your images.
|
||||
|
||||
WWW: http://ufraw.sourceforge.net/
|
||||
WWW: http://ufraw.sourceforge.net/
|
||||
|
|
|
@ -2,6 +2,7 @@ bin/nikon-curve
|
|||
bin/ufraw-batch
|
||||
bin/ufraw-dcraw
|
||||
%%GIMP%%libexec/gimp/2.2/plug-ins/ufraw-gimp
|
||||
man/man1/ufraw.1.gz
|
||||
share/applications/ufraw.desktop
|
||||
share/locale/ca/LC_MESSAGES/ufraw.mo
|
||||
share/locale/cs/LC_MESSAGES/ufraw.mo
|
||||
|
|
Loading…
Reference in a new issue