Update to version 2.0.5
This commit is contained in:
parent
6c80aee347
commit
ce41f95a99
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=278738
6 changed files with 94 additions and 72 deletions
|
@ -1,13 +1,13 @@
|
|||
# New ports collection makefile for: talloc
|
||||
# Date created: 18 Apr 2009
|
||||
# Date created: 1 May 2009
|
||||
# Whom: Koop Mast <kwm@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= talloc
|
||||
PORTVERSION= 2.0.1
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.0.5
|
||||
PORTREVISION= 0
|
||||
PORTEPOCH= 0
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ftp://ftp.samba.org/pub/%SUBDIR%/ \
|
||||
|
@ -18,36 +18,80 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
|
|||
MAINTAINER= timur@FreeBSD.org
|
||||
COMMENT= Hierarchical pool based memory allocator
|
||||
|
||||
CONFLICTS= samba-3.3*
|
||||
CONFLICTS= samba33-3.*
|
||||
|
||||
USE_GMAKE= yes
|
||||
USE_PYTHON_BUILD= yes
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_AUTOTOOLS= autoconf autoheader
|
||||
HAS_CONFIGURE= yes
|
||||
WAF_TOOL= buildtools/bin/waf
|
||||
CONFIGURE_SCRIPT= ${WAF_TOOL} configure
|
||||
USE_GNOME= pkgconfig
|
||||
|
||||
IPATHS= -I${WRKSRC}/libreplace
|
||||
AUTOHEADER_ARGS= ${IPATHS}
|
||||
AUTOCONF_ARGS= ${IPATHS}
|
||||
LICENSE= GPLv3
|
||||
MAKE_JOBS_SAFE= yes
|
||||
|
||||
PKGCONFIGDIR?= ${PREFIX}/libdata/pkgconfig
|
||||
PKGCONFIGDIR_REL?= ${PKGCONFIGDIR:S|^${PREFIX}/||}
|
||||
PLIST_SUB+= PKGCONFIGDIR=${PKGCONFIGDIR:S;${PREFIX}/;;}
|
||||
|
||||
CONFIGURE_ENV+= XSLTPROC="/usr/bin/true"
|
||||
OPTIONS= PYTHON "Python bindings" on
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
MAN3= talloc.3
|
||||
|
||||
PLIST_FILES= include/talloc.h \
|
||||
lib/libtalloc.a \
|
||||
lib/libtalloc.so \
|
||||
lib/libtalloc.so.2 \
|
||||
${PKGCONFIGDIR_REL}/talloc.pc
|
||||
%%PKGCONFIGDIR%%/talloc.pc
|
||||
|
||||
pre-install:
|
||||
.if !exists(${WRKSRC}/talloc.3)
|
||||
@${CP} ${FILESDIR}/talloc.3 ${WRKSRC}
|
||||
CONFIGURE_ENV+= XSLTPROC="/usr/bin/true"
|
||||
CONFIGURE_ENV+= NOCOLOR=yes
|
||||
MAKE_ENV+= NOCOLOR=yes
|
||||
|
||||
CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man
|
||||
|
||||
.if !defined(DISABLE_MAKE_JOBS)
|
||||
CONFIGURE_ARGS+= --jobs=${MAKE_JOBS_NUMBER}
|
||||
_MAKE_JOBS= --jobs=${MAKE_JOBS_NUMBER}
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
${LN} -sf libtalloc.so.2 ${PREFIX}/lib/libtalloc.so
|
||||
.if defined(WITH_PYTHON)
|
||||
USE_PYTHON_RUN= yes
|
||||
PLIST_FILES+= include/pytalloc.h \
|
||||
lib/libpytalloc-util.so \
|
||||
lib/libpytalloc-util.so.2 \
|
||||
%%PYTHON_SITELIBDIR%%/talloc.so \
|
||||
%%PKGCONFIGDIR%%/pytalloc-util.pc
|
||||
PLIST_DIRSTRY+= %%PYTHON_SITELIBDIR%% \
|
||||
%%PYTHON_LIBDIR%%
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-python
|
||||
.endif
|
||||
|
||||
ALL_TARGET= build
|
||||
INSTALL_TARGET= install
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%PKGCONFIGDIR%%|${PKGCONFIGDIR}|g' \
|
||||
${BUILD_WRKSRC}/wscript
|
||||
|
||||
pre-build:
|
||||
.for man in ${MAN3}
|
||||
@${MKDIR} ${BUILD_WRKSRC}/bin/default
|
||||
@${INSTALL_MAN} ${FILESDIR}/${man} ${BUILD_WRKSRC}/bin/default
|
||||
.endfor
|
||||
|
||||
do-build:
|
||||
@(cd ${BUILD_WRKSRC}; \
|
||||
if ! ${SETENV} ${MAKE_ENV} ${BUILD_WRKSRC}/${WAF_TOOL} ${_MAKE_JOBS} ${MAKE_ARGS} build; then \
|
||||
if [ x != x${BUILD_FAIL_MESSAGE} ] ; then \
|
||||
${ECHO_MSG} "===> Compilation failed unexpectedly."; \
|
||||
(${ECHO_CMD} ${BUILD_FAIL_MESSAGE}) | ${FMT} 75 79 ; \
|
||||
fi; \
|
||||
${FALSE}; \
|
||||
fi)
|
||||
|
||||
do-install:
|
||||
@(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${INSTALL_WRKSRC}/${WAF_TOOL} ${MAKE_ARGS} install)
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (talloc-2.0.1.tar.gz) = 5b810527405f29d54f50efd78bf2c89e318f2cd8bed001f22f2a1412fd27c9b4
|
||||
SIZE (talloc-2.0.1.tar.gz) = 242426
|
||||
SHA256 (talloc-2.0.5.tar.gz) = b949eb0c4f3467ef26bb8f6af64da3b20df5e34b4243fe2a5a0c28435ba6b32a
|
||||
SIZE (talloc-2.0.5.tar.gz) = 365388
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
--- buildtools/wafsamba/samba_install.py.orig 2010-12-21 02:00:02.000000000 +0100
|
||||
+++ buildtools/wafsamba/samba_install.py 2011-06-21 11:46:28.000000000 +0200
|
||||
@@ -109,7 +109,7 @@
|
||||
inst_name = bld.make_libname(t.target)
|
||||
elif self.vnum:
|
||||
vnum_base = self.vnum.split('.')[0]
|
||||
- install_name = bld.make_libname(target_name, version=self.vnum)
|
||||
+ install_name = bld.make_libname(target_name, version=vnum_base)
|
||||
install_link = bld.make_libname(target_name, version=vnum_base)
|
||||
inst_name = bld.make_libname(t.target)
|
||||
if not self.private_library:
|
|
@ -1,29 +0,0 @@
|
|||
--- ./talloc.mk.orig 2010-01-08 03:17:20.000000000 +0000
|
||||
+++ ./talloc.mk 2010-01-08 03:19:18.000000000 +0000
|
||||
@@ -1,6 +1,6 @@
|
||||
TALLOC_OBJ = $(tallocdir)/talloc.o
|
||||
|
||||
-TALLOC_SOLIB = libtalloc.$(SHLIBEXT).$(TALLOC_VERSION)
|
||||
+TALLOC_SOLIB = libtalloc.$(SHLIBEXT).$(TALLOC_VERSION_MAJOR)
|
||||
TALLOC_SONAME = libtalloc.$(SHLIBEXT).$(TALLOC_VERSION_MAJOR)
|
||||
TALLOC_STLIB = libtalloc.a
|
||||
|
||||
@@ -15,16 +15,14 @@
|
||||
|
||||
install:: all
|
||||
${INSTALLCMD} -d $(DESTDIR)$(libdir)
|
||||
- ${INSTALLCMD} -d $(DESTDIR)$(libdir)/pkgconfig
|
||||
+ ${INSTALLCMD} -d $(DESTDIR)$(prefix)/libdata/pkgconfig
|
||||
${INSTALLCMD} -m 755 $(TALLOC_STLIB) $(DESTDIR)$(libdir)
|
||||
${INSTALLCMD} -m 755 $(TALLOC_SOLIB) $(DESTDIR)$(libdir)
|
||||
${INSTALLCMD} -d $(DESTDIR)${includedir}
|
||||
${INSTALLCMD} -m 644 $(srcdir)/talloc.h $(DESTDIR)$(includedir)
|
||||
- ${INSTALLCMD} -m 644 talloc.pc $(DESTDIR)$(libdir)/pkgconfig
|
||||
+ ${INSTALLCMD} -m 644 talloc.pc $(DESTDIR)$(prefix)/libdata/pkgconfig
|
||||
if [ -f talloc.3 ];then ${INSTALLCMD} -d $(DESTDIR)$(mandir)/man3; fi
|
||||
if [ -f talloc.3 ];then ${INSTALLCMD} -m 644 talloc.3 $(DESTDIR)$(mandir)/man3; fi
|
||||
- which swig >/dev/null 2>&1 && ${INSTALLCMD} -d $(DESTDIR)`swig -swiglib` || true
|
||||
- which swig >/dev/null 2>&1 && ${INSTALLCMD} -m 644 talloc.i $(DESTDIR)`swig -swiglib` || true
|
||||
|
||||
doc:: talloc.3 talloc.3.html
|
||||
|
11
devel/talloc/files/patch-wscript
Normal file
11
devel/talloc/files/patch-wscript
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- wscript.orig 2011-01-08 01:43:04.000000000 +0100
|
||||
+++ wscript 2011-07-29 23:55:08.000000000 +0200
|
||||
@@ -71,7 +71,7 @@
|
||||
bld.RECURSE('lib/replace')
|
||||
|
||||
if bld.env.standalone_talloc:
|
||||
- bld.env.PKGCONFIGDIR = '${LIBDIR}/pkgconfig'
|
||||
+ bld.env.PKGCONFIGDIR = '%%PKGCONFIGDIR%%'
|
||||
bld.env.TALLOC_VERSION = VERSION
|
||||
bld.PKG_CONFIG_FILES('talloc.pc', vnum=VERSION)
|
||||
bld.INSTALL_FILES('${INCLUDEDIR}', 'talloc.h')
|
|
@ -2,12 +2,12 @@
|
|||
.\" Title: talloc
|
||||
.\" Author: [FIXME: author] [see http://docbook.sf.net/el/author]
|
||||
.\" Generator: DocBook XSL Stylesheets v1.75.2 <http://docbook.sf.net/>
|
||||
.\" Date: 12/09/2009
|
||||
.\" Date: 07/29/2011
|
||||
.\" Manual: [FIXME: manual]
|
||||
.\" Source: [FIXME: source]
|
||||
.\" Language: English
|
||||
.\"
|
||||
.TH "TALLOC" "3" "12/09/2009" "[FIXME: source]" "[FIXME: manual]"
|
||||
.TH "TALLOC" "3" "07/29/2011" "[FIXME: source]" "[FIXME: manual]"
|
||||
.\" -----------------------------------------------------------------
|
||||
.\" * set default formatting
|
||||
.\" -----------------------------------------------------------------
|
||||
|
@ -23,7 +23,7 @@ talloc \- hierarchical reference counted memory pool system with destructors
|
|||
.SH "SYNOPSIS"
|
||||
.sp
|
||||
.nf
|
||||
#include <talloc/talloc\&.h>
|
||||
#include <talloc\&.h>
|
||||
.fi
|
||||
.SH "DESCRIPTION"
|
||||
.PP
|
||||
|
@ -321,7 +321,7 @@ talloc_named(NULL, 0, fmt, \&.\&.\&.);
|
|||
.\}
|
||||
.SS "void *talloc_new(void *\fIctx\fR);"
|
||||
.PP
|
||||
This is a utility macro that creates a new memory context hanging off an exiting context, automatically naming it "talloc_new: __location__" where __location__ is the source line it is called from\&. It is particularly useful for creating a new temporary working context\&.
|
||||
This is a utility macro that creates a new memory context hanging off an existing context, automatically naming it "talloc_new: __location__" where __location__ is the source line it is called from\&. It is particularly useful for creating a new temporary working context\&.
|
||||
.SS "(\fItype\fR *)talloc_realloc(const void *\fIctx\fR, void *\fIptr\fR, \fItype\fR, \fIcount\fR);"
|
||||
.PP
|
||||
The talloc_realloc() macro changes the size of a talloc pointer\&. It has the following equivalences:
|
||||
|
@ -544,21 +544,6 @@ talloc_set_name_const(ptr, ptr)
|
|||
.if n \{\
|
||||
.RE
|
||||
.\}
|
||||
.SS "char *talloc_append_string(const void *\fIt\fR, char *\fIorig\fR, const char *\fIappend\fR);"
|
||||
.PP
|
||||
The talloc_append_string() function appends the given formatted string to the given string\&.
|
||||
.PP
|
||||
This function sets the name of the new pointer to the new string\&. This is equivalent to:
|
||||
.sp
|
||||
.if n \{\
|
||||
.RS 4
|
||||
.\}
|
||||
.nf
|
||||
talloc_set_name_const(ptr, ptr)
|
||||
.fi
|
||||
.if n \{\
|
||||
.RE
|
||||
.\}
|
||||
.SS "char *talloc_vasprintf(const void *\fIt\fR, const char *\fIfmt\fR, va_list \fIap\fR);"
|
||||
.PP
|
||||
The talloc_vasprintf() function is the talloc equivalent of the C library function vasprintf(3)\&.
|
||||
|
@ -604,7 +589,7 @@ talloc_set_name_const(ptr, ptr)
|
|||
.if n \{\
|
||||
.RE
|
||||
.\}
|
||||
.SS "(type *)talloc_array(const void *ctx, type, uint_t count);"
|
||||
.SS "(type *)talloc_array(const void *ctx, type, unsigned int count);"
|
||||
.PP
|
||||
The talloc_array() macro is equivalent to:
|
||||
.sp
|
||||
|
@ -619,10 +604,10 @@ The talloc_array() macro is equivalent to:
|
|||
.\}
|
||||
.PP
|
||||
except that it provides integer overflow protection for the multiply, returning NULL if the multiply overflows\&.
|
||||
.SS "void *talloc_array_size(const void *ctx, size_t size, uint_t count);"
|
||||
.SS "void *talloc_array_size(const void *ctx, size_t size, unsigned int count);"
|
||||
.PP
|
||||
The talloc_array_size() function is useful when the type is not known\&. It operates in the same way as talloc_array(), but takes a size instead of a type\&.
|
||||
.SS "(typeof(ptr)) talloc_array_ptrtype(const void *ctx, ptr, uint_t count);"
|
||||
.SS "(typeof(ptr)) talloc_array_ptrtype(const void *ctx, ptr, unsigned int count);"
|
||||
.PP
|
||||
The talloc_ptrtype() macro should be used when you have a pointer to an array and want to allocate memory of an array to point at with this pointer\&. When compiling with gcc >= 3 it is typesafe\&. Note this is a wrapper of talloc_array_size() and talloc_get_name() will return the current location in the source file\&. and not the type\&.
|
||||
.SS "void *talloc_realloc_fn(const void *ctx, void *ptr, size_t size)"
|
||||
|
|
Loading…
Reference in a new issue