- Add missing patch
This commit is contained in:
parent
8ad9867d9b
commit
ce5103d877
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=244824
2 changed files with 28 additions and 0 deletions
|
@ -0,0 +1,20 @@
|
|||
--- python/pykde4/kpythonpluginfactory/kpythonpluginfactory.cpp~ 2009-10-31 16:30:02.000000000 +0200
|
||||
+++ python/pykde4/kpythonpluginfactory/kpythonpluginfactory.cpp 2009-10-31 16:35:50.000000000 +0200
|
||||
@@ -18,6 +18,8 @@
|
||||
Boston, MA 02111-1307, USA.
|
||||
*/
|
||||
|
||||
+#include <dlfcn.h>
|
||||
+
|
||||
#include <QtCore/QCoreApplication>
|
||||
#include <QFileInfo>
|
||||
#include <QDir>
|
||||
@@ -295,6 +297,8 @@
|
||||
// symbols global and available for later loaded libraries/module.
|
||||
QLibrary *LoadPythonLibrary()
|
||||
{
|
||||
+ /* Promote this library (and thus libpython) to RTLD_GLOBAL) */
|
||||
+ dlopen("kpythonpluginfactory.so", RTLD_NOLOAD | RTLD_GLOBAL);
|
||||
QLibrary *pythonLib = new QLibrary();
|
||||
pythonLib->setLoadHints(QLibrary::ExportExternalSymbolsHint);
|
||||
pythonLib->setFileName(LIB_PYTHON);
|
|
@ -0,0 +1,8 @@
|
|||
--- ./knotificationitem/CMakeLists.txt.orig 2009-06-09 20:09:26.000000000 +0400
|
||||
+++ ./knotificationitem/CMakeLists.txt 2009-10-03 15:21:42.000000000 +0400
|
||||
@@ -41,4 +41,4 @@
|
||||
install(FILES
|
||||
org.kde.NotificationItem.xml
|
||||
org.kde.NotificationItemWatcher.xml
|
||||
- DESTINATION ${KDE4_DBUS_INTERFACES_DIR})
|
||||
+ DESTINATION ${DBUS_INTERFACES_INSTALL_DIR})
|
Loading…
Reference in a new issue