dwarfdump is a utility to display DWARF debugging information in ELF

files.  Needs libdwarf (and libelf in turn).
This commit is contained in:
Joerg Wunsch 2005-02-12 22:12:15 +00:00
parent 90be6507b5
commit ce7ac1a834
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=128641
7 changed files with 63 additions and 0 deletions

View file

@ -210,6 +210,7 @@
SUBDIR += doxygen
SUBDIR += dparser
SUBDIR += dprog
SUBDIR += dwarfdump
SUBDIR += e4graph
SUBDIR += ebnf2yacc
SUBDIR += eboxy

33
devel/dwarfdump/Makefile Normal file
View file

@ -0,0 +1,33 @@
# New ports collection makefile for: dwarfdump
# Date created: 11 Feb 2005
# Whom: joerg@FreeBSD.org
#
# $FreeBSD$
#
PORTNAME= dwarfdump
PORTVERSION= 20041122
CATEGORIES= devel
MASTER_SITES= http://reality.sgi.com/davea/
DISTNAME= libdwarf-${PORTVERSION}
MAINTAINER= joerg@FreeBSD.org
COMMENT= A tool to display DWARF debugging information in ELF files
BUILD_DEPENDS= ${LOCALBASE}/lib/libelf.so.0:${PORTSDIR}/devel/libelf \
${LOCALBASE}/lib/libdwarf.a:${PORTSDIR}/devel/libdwarf
RUN_DEPENDS= ${LOCALBASE}/lib/libelf.so.0:${PORTSDIR}/devel/libelf
WRKSRC= ${WRKDIR}/dwarf-${PORTVERSION}/dwarfdump
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= dwarfdump.1
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dwarfdump ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/dwarfdump.1 ${PREFIX}/man/man1
.include <bsd.port.mk>

2
devel/dwarfdump/distinfo Normal file
View file

@ -0,0 +1,2 @@
MD5 (libdwarf-20041122.tar.gz) = f326a50b103ecd9bb7884fd70d7d40cf
SIZE (libdwarf-20041122.tar.gz) = 792298

View file

@ -0,0 +1,11 @@
--- configure.orig Mon Nov 22 19:20:33 2004
+++ configure Sat Feb 12 22:55:06 2005
@@ -3029,7 +3029,7 @@
-for ac_header in elf.h getopt.h libelf.h libelf/libelf.h sgidefs.h sys/types.h
+for ac_header in getopt.h libelf.h libelf/libelf.h sgidefs.h sys/types.h
do
as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
if eval "test \"\${$as_ac_Header+set}\" = set"; then

View file

@ -0,0 +1,10 @@
--- makename.c.orig Mon Nov 22 19:20:33 2004
+++ makename.c Sat Feb 12 22:56:10 2005
@@ -45,7 +45,6 @@
*/
#include <stdio.h>
-#include <malloc.h>
#include <string.h>
#include <stdlib.h>
#include "makename.h"

View file

@ -0,0 +1,5 @@
The dwarfdump tool prints the various elements of DWARF debugging
information found in ELF object files.
WWW: http://reality.sgi.com/davea/
Author: David Anderson of SGI

View file

@ -0,0 +1 @@
bin/dwarfdump