Update to version 1.4.4.

PR:		11564
Submitted by:	maintainer
This commit is contained in:
Steve Price 1999-05-09 16:50:10 +00:00
parent 6b5c462ce2
commit ce7b19e8a7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=18661
5 changed files with 89 additions and 11 deletions

View file

@ -1,20 +1,26 @@
# New ports collection makefile for: qtarch
# Version required: 1.4-1
# Version required: 1.4-4
# Date created: 17 Oct 1998
# Whom: Frank Gruender
#
# $Id$
# $Id: Makefile,v 1.1.1.1 1998/12/26 04:30:08 steve Exp $
#
DISTNAME= qtarch-1.4-1
PKGNAME= qtarch-1.4.1
DISTNAME= qtarch-1.4-4
PKGNAME= qtarch-1.4.4
CATEGORIES= devel
MASTER_SITES= http://www.primenet.com/~jtharris/qtarch/
MAINTAINER= elwood@mc5sys.in-berlin.de
LIB_DEPENDS= kdecore.2:${PORTSDIR}/x11/kdelibs11 \
kdeui.2:${PORTSDIR}/x11/kdelibs11
USE_QT= yes
USE_GMAKE= yes
USE_XLIB= yes
WRKSRC= ${WRKDIR}/qtarch-1.4
MAKE_ENV= BUILD_RELEASE=yes
.include <bsd.port.mk>

View file

@ -1 +1 @@
MD5 (qtarch-1.4-1.tar.gz) = a9338c324dcec7baccff2cbc11d6128b
MD5 (qtarch-1.4-4.tar.gz) = 177c9a3f9a7da7d693f0646c23a699b7

View file

@ -1,11 +1,78 @@
--- bmp/Makefile.orig Fri Sep 4 00:24:06 1998
+++ bmp/Makefile Thu Dec 24 19:05:06 1998
@@ -83,7 +83,7 @@
--- Makefile.orig Sun Apr 4 01:59:09 1999
+++ Makefile Sat May 8 00:50:27 1999
@@ -128,6 +128,7 @@
ModulesPrefPage.moc.o
TARGET = qtarch
+INSTALLDIR = ${PREFIX}
include Makefile.common
@@ -160,7 +161,8 @@
@echo
@echo "Linking $(TARGET)"
@$(CC) $(OBJECTS) $(OBJMETA) -o $(TARGET) $(LFLAGS)
-
+ @echo
+ @$(MAKE) -C module/kde
efence: $(OBJECTS) $(OBJMETA)
efence: bmp_d prop_d widget_d layout_d pixmap_d
@@ -208,3 +210,5 @@
doc:
@$(MAKE) -C doc doc
+
+include Makefile.install
--- Makefile.common.orig Sat Apr 3 23:31:22 1999
+++ Makefile.common Sat May 8 00:55:23 1999
@@ -5,10 +5,10 @@
#endif
ifndef QTDIR
-QTDIR = /usr/local/lib/qt
+QTDIR = ${X11BASE}
endif
-INCDIR = -I$(QTDIR)/include -I$(TOPDIR)
+INCDIR = -I$(QTDIR)/include/X11/qt -I$(TOPDIR)
#CFLAGS = -O2 -fno-strength-reduce -W -Wtemplate-debugging -Wparentheses \
# -Wuninitialized -Wchar-subscripts -Wformat -Wtrigraphs -Wcomment \
# -Wswitch -Wunused -Wreturn-type -Wimplicit -Wpointer-arith -Wsynth \
@@ -26,7 +26,7 @@
bmp/libbmp.a \
layout/liblayout.a \
pixmap/libpixmap.a \
- -lfl -lqt -lstdc++ -ldl -rdynamic
+ -lfl -lqt -lstdc++ -lX11 -lm -rdynamic
ARFLAGS = -crs
CC = g++
AR = ar
--- bmp/Makefile.orig Fri Jan 29 04:41:35 1999
+++ bmp/Makefile Sat May 8 00:50:27 1999
@@ -85,7 +85,7 @@
include ../Makefile.common
qembed: qembed.o
- $(CC) qembed.o -o qembed -L$(QTDIR)/lib -lqt
+ $(CC) qembed.o -o qembed $(EXTRA_LFLAGS) -L$(QTDIR)/lib -lqt -lX11
+ $(CC) qembed.o -o qembed -L$(QTDIR)/lib -lqt -lX11
$(BMPSOURCE): $(BMPS) qembed
./qembed $(BMPHEADER) $(BMPSOURCE) $(BMPS)
--- module/kde/Makefile.orig Sun Apr 4 06:03:24 1999
+++ module/kde/Makefile Sat May 8 01:01:42 1999
@@ -1,4 +1,4 @@
-INCDIR = -I$(QTDIR)/include -I../.. -I/opt/kde/include
+INCDIR = -I$(X11BASE)/include/X11/qt -I../.. -I$(PREFIX)/include
ifdef BUILD_RELEASE
CFLAGS = -O2 -fno-strength-reduce -Wall -W -pipe -fPIC
@@ -6,7 +6,7 @@
CFLAGS = -g -Wall -W -pipe -fPIC
endif
-LDFLAGS = -g -shared -L$(QTDIR)/lib -L/opt/kde/lib -lqt -lkdecore -lkdeui
+LDFLAGS = -g -shared -L$(X11BASE)/lib -L$(PREFIX)/lib -lqt -lkdecore -lkdeui
CC = g++
MOC = moc
QTARCHBIN = ../../qtarch

View file

@ -4,3 +4,7 @@ dialog. Various properties for the widget can also be set. Widgets
may be mapped to variables so that you can control them once the
dialog is launched. After the dialog is created on the screen, the
files for the dialog are created.
qtarch version 1.4-4 contains a QtArch widget module for KDE 1.1.
WWW: http://www.primenet.com/~jtharris/qtarch/

View file

@ -1,8 +1,9 @@
bin/qtarch
lib/KDEModule.so
lib/qtarch/COPYING
lib/qtarch/DlgEdit.Template.Makefile
lib/qtarch/README
lib/qtarch/TODO
lib/qtarch/DlgEdit.Template.Makefile
lib/qtarch/dlgUpdate.pl
lib/qtarch/doc/AlignBottom.ps
lib/qtarch/doc/AlignLeft.ps
@ -34,6 +35,7 @@ lib/qtarch/doc/ProjectUnfolded.ps
lib/qtarch/doc/PushButton.ps
lib/qtarch/doc/PushButtonProp.gif
lib/qtarch/doc/PushButtonProp.ps
lib/qtarch/doc/QtArch.ps
lib/qtarch/doc/QtArch.tex
lib/qtarch/doc/SigSlot.gif
lib/qtarch/doc/SigSlot.ps
@ -44,7 +46,6 @@ lib/qtarch/doc/ToBeSaved.ps
lib/qtarch/doc/boxLayout.ps
lib/qtarch/doc/qtarch.gif
lib/qtarch/doc/qtarch.ps
lib/qtarch/doc/QtArch.ps
lib/qtarch/help/index.html
lib/qtarch/help/widget-Button.html
lib/qtarch/help/widget-ButtonGroup.html