sysutils/duplicity: Update to 2.2.3

- Remove setuptools_scm dependency

ChangeLog: https://gitlab.com/duplicity/duplicity/-/blob/main/CHANGELOG.md
This commit is contained in:
Nuno Teixeira 2024-03-21 07:29:46 +00:00
parent 7ede856235
commit ce8e56bbdb
3 changed files with 11 additions and 11 deletions

View File

@ -1,5 +1,5 @@
PORTNAME= duplicity
DISTVERSION= 2.2.2
DISTVERSION= 2.2.3
CATEGORIES= sysutils
MASTER_SITES= PYPI
@ -11,7 +11,6 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${PY_SETUPTOOLS} \
${PYTHON_PKGNAMEPREFIX}setuptools-scm>=8.0:devel/py-setuptools-scm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
LIB_DEPENDS= librsync.so:net/librsync
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fasteners>=0:devel/py-fasteners@${PY_FLAVOR} \

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1707206291
SHA256 (duplicity-2.2.2.tar.gz) = 833ef5fa922d559be1c4f6a0f61315e8cb26da409f2024bcf310ba3fb9486d27
SIZE (duplicity-2.2.2.tar.gz) = 1978264
TIMESTAMP = 1710967459
SHA256 (duplicity-2.2.3.tar.gz) = 4ad43f93601b1a41fb5f642bdda1706a1fb75f8ef1d6d482dd7f23107eaee87d
SIZE (duplicity-2.2.3.tar.gz) = 1978008

View File

@ -1,6 +1,6 @@
--- setup.py.orig 2023-12-25 18:14:22 UTC
--- setup.py.orig 2024-03-20 20:49:22 UTC
+++ setup.py
@@ -105,27 +105,6 @@ def get_data_files():
@@ -111,28 +111,6 @@ def get_data_files():
if os.environ.get("READTHEDOCS") == "True":
return data_files
@ -14,8 +14,8 @@
- os.mkdir(os.path.join("po", lang))
- except os.error:
- pass
- assert not os.system(f"cp po/{lang}.po po/{lang}"), lang
- assert not os.system(f"msgfmt po/{lang}.po -o po/{lang}/duplicity.mo"), lang
- subprocess.run(f"cp po/{lang}.po po/{lang}", shell=True, check=True)
- subprocess.run(f"msgfmt po/{lang}.po -o po/{lang}/duplicity.mo", shell=True, check=True)
-
- for root, dirs, files in os.walk("po"):
- for file in files:
@ -25,6 +25,7 @@
- data_files.append((f"share/locale/{lang}/LC_MESSAGES", [f"po/{lang}/duplicity.mo"]))
-
- return data_files
-
def VersionedCopy(source, dest):
def cleanup():
if os.path.exists("po/LINGUAS"):