New port: math/openmesh: Generic data structure for manipulating polygonal meshes

This commit is contained in:
Yuri Victorovich 2018-10-22 05:15:14 +00:00
parent 78fcac1ba0
commit ceaa2cafa4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=482731
17 changed files with 410 additions and 0 deletions

View file

@ -474,6 +474,7 @@
SUBDIR += openblas
SUBDIR += openfst
SUBDIR += openlibm
SUBDIR += openmesh
SUBDIR += opensolaris-libm
SUBDIR += orpie
SUBDIR += p5-AI-DecisionTree

26
math/openmesh/Makefile Normal file
View file

@ -0,0 +1,26 @@
# $FreeBSD$
PORTNAME= openmesh
DISTVERSION= 7.1
CATEGORIES= math
MASTER_SITES= http://www.openmesh.org/media/Releases/${DISTVERSION}/
DISTNAME= OpenMesh-${DISTVERSION}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Generic data structure for manipulating polygonal meshes
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake:outsource dos2unix gl qt:5
DOS2UNIX_FILES= src/OpenMesh/Tools/CMakeLists.txt
USE_QT= core concurrent gui help network opengl printsupport script scripttools sql svg x11extras xml xmlpatterns webkit widgets \
buildtools_build qmake_build uitools_build
USE_GL= gl glu glut
USE_XORG= xi xmu
USE_LDCONFIG= yes
post-install:
@${RMDIR} ${STAGEDIR}${PREFIX}/include/OpenMesh/Tools/VDPM/xpm
.include <bsd.port.mk>

3
math/openmesh/distinfo Normal file
View file

@ -0,0 +1,3 @@
TIMESTAMP = 1540164884
SHA256 (OpenMesh-7.1.tar.gz) = 4c53f284ed2a59b93a2add84fbce5873f3ab5193960db79ebb17a71163f34c9a
SIZE (OpenMesh-7.1.tar.gz) = 24860170

View file

@ -0,0 +1,12 @@
--- src/OpenMesh/Apps/Decimating/decimater.cc.orig 2018-10-21 23:36:03 UTC
+++ src/OpenMesh/Apps/Decimating/decimater.cc
@@ -58,6 +58,9 @@
#include <string>
#include <memory>
#include <map>
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
//--------------------
#include <OpenMesh/Core/IO/MeshIO.hh>
//--------------------

View file

@ -0,0 +1,12 @@
--- src/OpenMesh/Apps/Decimating/decimaterviewer.cc.orig 2018-10-21 23:51:30 UTC
+++ src/OpenMesh/Apps/Decimating/decimaterviewer.cc
@@ -63,6 +63,9 @@
#else
#include <GL/glut.h>
#endif
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
void usage_and_exit(int xcode);

View file

@ -0,0 +1,12 @@
--- src/OpenMesh/Apps/QtViewer/meshviewer.cc.orig 2018-10-21 23:50:54 UTC
+++ src/OpenMesh/Apps/QtViewer/meshviewer.cc
@@ -63,6 +63,9 @@
#else
#include <GL/glut.h>
#endif
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
#include "MeshViewerWidget.hh"

View file

@ -0,0 +1,12 @@
--- src/OpenMesh/Apps/Smoothing/smooth.cc.orig 2018-10-21 23:39:56 UTC
+++ src/OpenMesh/Apps/Smoothing/smooth.cc
@@ -53,6 +53,9 @@
#include <OpenMesh/Tools/Utils/Timer.hh>
#include <OpenMesh/Tools/Smoother/JacobiLaplaceSmootherT.hh>
#include <OpenMesh/Tools/Utils/getopt.h>
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
using namespace OpenMesh;

View file

@ -0,0 +1,12 @@
--- src/OpenMesh/Apps/Subdivider/adaptive_subdivider.cc.orig 2018-10-21 23:38:04 UTC
+++ src/OpenMesh/Apps/Subdivider/adaptive_subdivider.cc
@@ -67,6 +67,9 @@
# include <cmath>
using std::pow;
#endif
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
using OpenMesh::Subdivider::Adaptive::CompositeTraits;

View file

@ -0,0 +1,12 @@
--- src/OpenMesh/Apps/Subdivider/subdivider.cc.orig 2018-10-21 23:37:26 UTC
+++ src/OpenMesh/Apps/Subdivider/subdivider.cc
@@ -48,6 +48,9 @@
#include <iostream>
#include <sstream>
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
// ---------------------------------------- OpenMesh Stuff
#include <OpenMesh/Core/IO/MeshIO.hh>
#include <OpenMesh/Core/Mesh/TriMesh_ArrayKernelT.hh>

View file

@ -0,0 +1,12 @@
--- src/OpenMesh/Apps/VDProgMesh/Analyzer/vdpmanalyzer.cc.orig 2018-10-21 23:40:29 UTC
+++ src/OpenMesh/Apps/VDProgMesh/Analyzer/vdpmanalyzer.cc
@@ -56,6 +56,9 @@
#include <limits>
#include <exception>
#include <cmath>
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
// -------------------- OpenMesh
#include <OpenMesh/Core/IO/MeshIO.hh>
#include <OpenMesh/Core/Mesh/TriMesh_ArrayKernelT.hh>

View file

@ -0,0 +1,12 @@
--- src/OpenMesh/Apps/VDProgMesh/mkbalancedpm/mkbalancedpm.cc.orig 2018-10-21 23:38:43 UTC
+++ src/OpenMesh/Apps/VDProgMesh/mkbalancedpm/mkbalancedpm.cc
@@ -50,6 +50,9 @@
#include <iostream>
#include <sstream>
#include <cmath>
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
// -------------------- OpenMesh
#include <OpenMesh/Core/IO/MeshIO.hh>
#include <OpenMesh/Core/Mesh/TriMesh_ArrayKernelT.hh>

View file

@ -0,0 +1,12 @@
--- src/OpenMesh/Apps/mconvert/mconvert.cc.orig 2018-10-21 23:39:10 UTC
+++ src/OpenMesh/Apps/mconvert/mconvert.cc
@@ -50,6 +50,9 @@
#include <iterator>
#include <fstream>
#include <string>
+#if defined(__FreeBSD__)
+#include <unistd.h>
+#endif
//
#include <OpenMesh/Core/IO/MeshIO.hh>
#include <OpenMesh/Core/Mesh/TriMesh_ArrayKernelT.hh>

View file

@ -0,0 +1,11 @@
--- src/OpenMesh/Core/CMakeLists.txt.orig 2018-10-22 04:57:49 UTC
+++ src/OpenMesh/Core/CMakeLists.txt
@@ -45,7 +45,7 @@ if (WIN32)
endif()
else ()
- acg_add_library (OpenMeshCore SHAREDANDSTATIC ${sources} ${headers})
+ acg_add_library (OpenMeshCore SHARED ${sources} ${headers})
set_target_properties (OpenMeshCore PROPERTIES VERSION ${OPENMESH_VERSION_MAJOR}.${OPENMESH_VERSION_MINOR}
SOVERSION ${OPENMESH_VERSION_MAJOR}.${OPENMESH_VERSION_MINOR} )

View file

@ -0,0 +1,29 @@
--- src/OpenMesh/Tools/CMakeLists.txt.orig 2017-01-08 22:09:58 UTC
+++ src/OpenMesh/Tools/CMakeLists.txt
@@ -46,7 +46,7 @@ if (WIN32)
endif()
else ()
- acg_add_library (OpenMeshTools SHAREDANDSTATIC ${sources} ${headers})
+ acg_add_library (OpenMeshTools SHARED ${sources} ${headers})
set_target_properties (OpenMeshTools PROPERTIES VERSION ${OPENMESH_VERSION_MAJOR}.${OPENMESH_VERSION_MINOR}
SOVERSION ${OPENMESH_VERSION_MAJOR}.${OPENMESH_VERSION_MINOR} )
endif ()
@@ -54,7 +54,7 @@ endif ()
target_link_libraries (OpenMeshTools OpenMeshCore)
IF( NOT WIN32 )
- target_link_libraries (OpenMeshToolsStatic OpenMeshCoreStatic)
+ #target_link_libraries (OpenMeshToolsStatic OpenMeshCoreStatic)
ENDIF(NOT WIN32)
if ( (${PROJECT_NAME} MATCHES "OpenMesh") AND BUILD_APPS )
@@ -70,7 +70,7 @@ if ( (${PROJECT_NAME} MATCHES "OpenMesh"
if (APPLE)
# let bundle generation depend on target
add_dependencies (fixbundle OpenMeshTools)
- add_dependencies (fixbundle OpenMeshToolsStatic)
+ #add_dependencies (fixbundle OpenMeshToolsStatic)
endif()
endif()

View file

@ -0,0 +1,29 @@
--- src/OpenMesh/Tools/Utils/Timer.cc.orig 2018-10-21 23:42:34 UTC
+++ src/OpenMesh/Tools/Utils/Timer.cc
@@ -46,6 +46,8 @@
* *
\*===========================================================================*/
+#include <sys/time.h>
+
#ifndef DOXY_IGNORE_THIS
// ----------------------------------------------------------------------------
#include <OpenMesh/Core/System/config.h>
@@ -188,7 +190,7 @@ protected:
};
// ----------------------------------------------------------- gettimeofday ----
-#elif (defined(__GNUC__) || (defined(__INTEL_COMPILER) && !defined(WIN32))) && !defined(__MINGW32__)
+#elif 0 && (defined(__GNUC__) || (defined(__INTEL_COMPILER) && !defined(WIN32))) && !defined(__MINGW32__)
# include <sys/time.h>
# include <sys/resource.h>
@@ -276,7 +278,7 @@ Timer::Timer(void) :
# else
impl_ = new TimerImplPosix<CLOCK_REALTIME>;
# endif
-#elif (defined(__GNUC__) || (defined(__INTEL_COMPILER) && !defined(WIN32)) ) && !defined(__MINGW32__)
+#elif 0 && (defined(__GNUC__) || (defined(__INTEL_COMPILER) && !defined(WIN32)) ) && !defined(__MINGW32__)
impl_ = new TimerImplGToD;
#else
impl_ = new TimerImplStd;

11
math/openmesh/pkg-descr Normal file
View file

@ -0,0 +1,11 @@
OpenMesh is a generic and efficient data structure for representing and
manipulating polygonal meshes.
The main features of the underlying data structure are:
* No restriction to triangles meshes, handle general polygonal meshes.
* Explicit representation of vertices, halfedges, edges, and faces.
* Efficient access to the one-ring neighborhood of a vertex.
* Ability to handle non-manifold vertices (like two faces meeting in only one
vertex).
WWW: https://www.openmesh.org/

192
math/openmesh/pkg-plist Normal file
View file

@ -0,0 +1,192 @@
bin/Analyzer
bin/DecimaterGui
bin/Dualizer
bin/ProgViewer
bin/QtViewer
bin/Smoothing
bin/SubdividerGui
bin/Synthesizer
bin/commandlineAdaptiveSubdivider
bin/commandlineDecimater
bin/commandlineSubdivider
bin/mconvert
bin/mkbalancedpm
include/OpenMesh/Core/Geometry/Config.hh
include/OpenMesh/Core/Geometry/LoopSchemeMaskT.hh
include/OpenMesh/Core/Geometry/MathDefs.hh
include/OpenMesh/Core/Geometry/NormalConeT.cc
include/OpenMesh/Core/Geometry/NormalConeT.hh
include/OpenMesh/Core/Geometry/Plane3d.hh
include/OpenMesh/Core/Geometry/QuadricT.hh
include/OpenMesh/Core/Geometry/Vector11T.hh
include/OpenMesh/Core/Geometry/VectorT.hh
include/OpenMesh/Core/Geometry/VectorT_inc.hh
include/OpenMesh/Core/IO/BinaryHelper.hh
include/OpenMesh/Core/IO/IOInstances.hh
include/OpenMesh/Core/IO/IOManager.hh
include/OpenMesh/Core/IO/MeshIO.hh
include/OpenMesh/Core/IO/OFFFormat.hh
include/OpenMesh/Core/IO/OMFormat.hh
include/OpenMesh/Core/IO/OMFormatT.cc
include/OpenMesh/Core/IO/Options.hh
include/OpenMesh/Core/IO/SR_binary.hh
include/OpenMesh/Core/IO/SR_binary_spec.hh
include/OpenMesh/Core/IO/SR_binary_vector_of_bool.inl
include/OpenMesh/Core/IO/SR_binary_vector_of_fundamentals.inl
include/OpenMesh/Core/IO/SR_binary_vector_of_string.inl
include/OpenMesh/Core/IO/SR_rbo.hh
include/OpenMesh/Core/IO/SR_store.hh
include/OpenMesh/Core/IO/SR_types.hh
include/OpenMesh/Core/IO/StoreRestore.hh
include/OpenMesh/Core/IO/exporter/BaseExporter.hh
include/OpenMesh/Core/IO/exporter/ExporterT.hh
include/OpenMesh/Core/IO/importer/BaseImporter.hh
include/OpenMesh/Core/IO/importer/ImporterT.hh
include/OpenMesh/Core/IO/reader/BaseReader.hh
include/OpenMesh/Core/IO/reader/OBJReader.hh
include/OpenMesh/Core/IO/reader/OFFReader.hh
include/OpenMesh/Core/IO/reader/OMReader.hh
include/OpenMesh/Core/IO/reader/PLYReader.hh
include/OpenMesh/Core/IO/reader/STLReader.hh
include/OpenMesh/Core/IO/writer/BaseWriter.hh
include/OpenMesh/Core/IO/writer/OBJWriter.hh
include/OpenMesh/Core/IO/writer/OFFWriter.hh
include/OpenMesh/Core/IO/writer/OMWriter.hh
include/OpenMesh/Core/IO/writer/PLYWriter.hh
include/OpenMesh/Core/IO/writer/STLWriter.hh
include/OpenMesh/Core/IO/writer/VTKWriter.hh
include/OpenMesh/Core/Mesh/ArrayItems.hh
include/OpenMesh/Core/Mesh/ArrayKernel.hh
include/OpenMesh/Core/Mesh/ArrayKernelT.cc
include/OpenMesh/Core/Mesh/AttribKernelT.hh
include/OpenMesh/Core/Mesh/Attributes.hh
include/OpenMesh/Core/Mesh/BaseKernel.hh
include/OpenMesh/Core/Mesh/BaseMesh.hh
include/OpenMesh/Core/Mesh/Casts.hh
include/OpenMesh/Core/Mesh/CirculatorsT.hh
include/OpenMesh/Core/Mesh/FinalMeshItemsT.hh
include/OpenMesh/Core/Mesh/Handles.hh
include/OpenMesh/Core/Mesh/IteratorsT.hh
include/OpenMesh/Core/Mesh/PolyConnectivity.hh
include/OpenMesh/Core/Mesh/PolyMeshT.cc
include/OpenMesh/Core/Mesh/PolyMeshT.hh
include/OpenMesh/Core/Mesh/PolyMesh_ArrayKernelT.hh
include/OpenMesh/Core/Mesh/Status.hh
include/OpenMesh/Core/Mesh/Traits.hh
include/OpenMesh/Core/Mesh/TriConnectivity.hh
include/OpenMesh/Core/Mesh/TriMeshT.cc
include/OpenMesh/Core/Mesh/TriMeshT.hh
include/OpenMesh/Core/Mesh/TriMesh_ArrayKernelT.hh
include/OpenMesh/Core/Mesh/gen/circulators_header.hh
include/OpenMesh/Core/Mesh/gen/circulators_template.hh
include/OpenMesh/Core/Mesh/gen/footer.hh
include/OpenMesh/Core/Mesh/gen/iterators_header.hh
include/OpenMesh/Core/Mesh/gen/iterators_template.hh
include/OpenMesh/Core/System/OpenMeshDLLMacros.hh
include/OpenMesh/Core/System/compiler.hh
include/OpenMesh/Core/System/config.h
include/OpenMesh/Core/System/config.hh
include/OpenMesh/Core/System/mostream.hh
include/OpenMesh/Core/System/omstream.hh
include/OpenMesh/Core/Utils/AutoPropertyHandleT.hh
include/OpenMesh/Core/Utils/BaseProperty.hh
include/OpenMesh/Core/Utils/Endian.hh
include/OpenMesh/Core/Utils/GenProg.hh
include/OpenMesh/Core/Utils/Noncopyable.hh
include/OpenMesh/Core/Utils/Property.hh
include/OpenMesh/Core/Utils/PropertyContainer.hh
include/OpenMesh/Core/Utils/PropertyManager.hh
include/OpenMesh/Core/Utils/RandomNumberGenerator.hh
include/OpenMesh/Core/Utils/SingletonT.cc
include/OpenMesh/Core/Utils/SingletonT.hh
include/OpenMesh/Core/Utils/color_cast.hh
include/OpenMesh/Core/Utils/vector_cast.hh
include/OpenMesh/Core/Utils/vector_traits.hh
include/OpenMesh/Tools/Decimater/BaseDecimaterT.cc
include/OpenMesh/Tools/Decimater/BaseDecimaterT.hh
include/OpenMesh/Tools/Decimater/CollapseInfoT.hh
include/OpenMesh/Tools/Decimater/DecimaterT.cc
include/OpenMesh/Tools/Decimater/DecimaterT.hh
include/OpenMesh/Tools/Decimater/McDecimaterT.cc
include/OpenMesh/Tools/Decimater/McDecimaterT.hh
include/OpenMesh/Tools/Decimater/MixedDecimaterT.cc
include/OpenMesh/Tools/Decimater/MixedDecimaterT.hh
include/OpenMesh/Tools/Decimater/ModAspectRatioT.cc
include/OpenMesh/Tools/Decimater/ModAspectRatioT.hh
include/OpenMesh/Tools/Decimater/ModBaseT.hh
include/OpenMesh/Tools/Decimater/ModEdgeLengthT.cc
include/OpenMesh/Tools/Decimater/ModEdgeLengthT.hh
include/OpenMesh/Tools/Decimater/ModHausdorffT.cc
include/OpenMesh/Tools/Decimater/ModHausdorffT.hh
include/OpenMesh/Tools/Decimater/ModIndependentSetsT.hh
include/OpenMesh/Tools/Decimater/ModNormalDeviationT.hh
include/OpenMesh/Tools/Decimater/ModNormalFlippingT.hh
include/OpenMesh/Tools/Decimater/ModProgMeshT.cc
include/OpenMesh/Tools/Decimater/ModProgMeshT.hh
include/OpenMesh/Tools/Decimater/ModQuadricT.cc
include/OpenMesh/Tools/Decimater/ModQuadricT.hh
include/OpenMesh/Tools/Decimater/ModRoundnessT.hh
include/OpenMesh/Tools/Decimater/Observer.hh
include/OpenMesh/Tools/Dualizer/meshDualT.hh
include/OpenMesh/Tools/Kernel_OSG/ArrayKernelT.hh
include/OpenMesh/Tools/Kernel_OSG/AttribKernelT.hh
include/OpenMesh/Tools/Kernel_OSG/PropertyKernel.hh
include/OpenMesh/Tools/Kernel_OSG/PropertyT.hh
include/OpenMesh/Tools/Kernel_OSG/Traits.hh
include/OpenMesh/Tools/Kernel_OSG/TriMesh_OSGArrayKernelT.hh
include/OpenMesh/Tools/Kernel_OSG/VectorAdapter.hh
include/OpenMesh/Tools/Kernel_OSG/bindT.hh
include/OpenMesh/Tools/Kernel_OSG/color_cast.hh
include/OpenMesh/Tools/Smoother/JacobiLaplaceSmootherT.cc
include/OpenMesh/Tools/Smoother/JacobiLaplaceSmootherT.hh
include/OpenMesh/Tools/Smoother/LaplaceSmootherT.cc
include/OpenMesh/Tools/Smoother/LaplaceSmootherT.hh
include/OpenMesh/Tools/Smoother/SmootherT.cc
include/OpenMesh/Tools/Smoother/SmootherT.hh
include/OpenMesh/Tools/Smoother/smooth_mesh.hh
include/OpenMesh/Tools/Subdivider/Adaptive/Composite/CompositeT.cc
include/OpenMesh/Tools/Subdivider/Adaptive/Composite/CompositeT.hh
include/OpenMesh/Tools/Subdivider/Adaptive/Composite/CompositeTraits.hh
include/OpenMesh/Tools/Subdivider/Adaptive/Composite/RuleInterfaceT.hh
include/OpenMesh/Tools/Subdivider/Adaptive/Composite/RulesT.cc
include/OpenMesh/Tools/Subdivider/Adaptive/Composite/RulesT.hh
include/OpenMesh/Tools/Subdivider/Adaptive/Composite/Traits.hh
include/OpenMesh/Tools/Subdivider/Uniform/CatmullClarkT.cc
include/OpenMesh/Tools/Subdivider/Uniform/CatmullClarkT.hh
include/OpenMesh/Tools/Subdivider/Uniform/Composite/CompositeT.cc
include/OpenMesh/Tools/Subdivider/Uniform/Composite/CompositeT.hh
include/OpenMesh/Tools/Subdivider/Uniform/Composite/CompositeTraits.hh
include/OpenMesh/Tools/Subdivider/Uniform/CompositeLoopT.hh
include/OpenMesh/Tools/Subdivider/Uniform/CompositeSqrt3T.hh
include/OpenMesh/Tools/Subdivider/Uniform/LongestEdgeT.hh
include/OpenMesh/Tools/Subdivider/Uniform/LoopT.hh
include/OpenMesh/Tools/Subdivider/Uniform/MidpointT.hh
include/OpenMesh/Tools/Subdivider/Uniform/ModifiedButterFlyT.hh
include/OpenMesh/Tools/Subdivider/Uniform/Sqrt3InterpolatingSubdividerLabsikGreinerT.hh
include/OpenMesh/Tools/Subdivider/Uniform/Sqrt3T.hh
include/OpenMesh/Tools/Subdivider/Uniform/SubdividerT.hh
include/OpenMesh/Tools/Utils/Config.hh
include/OpenMesh/Tools/Utils/GLConstAsString.hh
include/OpenMesh/Tools/Utils/Gnuplot.hh
include/OpenMesh/Tools/Utils/HeapT.hh
include/OpenMesh/Tools/Utils/MeshCheckerT.cc
include/OpenMesh/Tools/Utils/MeshCheckerT.hh
include/OpenMesh/Tools/Utils/NumLimitsT.hh
include/OpenMesh/Tools/Utils/StripifierT.cc
include/OpenMesh/Tools/Utils/StripifierT.hh
include/OpenMesh/Tools/Utils/TestingFramework.hh
include/OpenMesh/Tools/Utils/Timer.hh
include/OpenMesh/Tools/Utils/conio.hh
include/OpenMesh/Tools/Utils/getopt.h
include/OpenMesh/Tools/VDPM/MeshTraits.hh
include/OpenMesh/Tools/VDPM/StreamingDef.hh
include/OpenMesh/Tools/VDPM/VFront.hh
include/OpenMesh/Tools/VDPM/VHierarchy.hh
include/OpenMesh/Tools/VDPM/VHierarchyNode.hh
include/OpenMesh/Tools/VDPM/VHierarchyNodeIndex.hh
include/OpenMesh/Tools/VDPM/VHierarchyWindow.hh
include/OpenMesh/Tools/VDPM/ViewingParameters.hh
lib/libOpenMeshCore.so
lib/libOpenMeshCore.so.7.1
lib/libOpenMeshTools.so
lib/libOpenMeshTools.so.7.1