Fix breakage and avoid installing useless .la file

Reviewed by:	maintainer
This commit is contained in:
Patrick Li 2001-11-23 03:34:39 +00:00
parent fd318ea17c
commit cf020d6135
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=50391
6 changed files with 58 additions and 8 deletions

View file

@ -22,11 +22,12 @@ PATCH_SITES+= http://kva.paranoia.ru/~troff/
PATCH_DIST_STRIP= -p1
.endif
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= ${MACHINE_ARCH}-unknown-freebsd${OSREL}
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
CONFIGURE_ARGS= --with-sigc-prefix=${LOCALBASE} \
--with-gtkmm-prefix=${X11BASE}
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I/usr/src/contrib/libstdc++" \
LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>

View file

@ -0,0 +1,25 @@
--- ltmain.sh.orig Sat Sep 22 20:10:52 2001
+++ ltmain.sh Tue Nov 20 21:14:55 2001
@@ -2444,6 +2444,9 @@
*-*-openbsd*)
# Do not include libc due to us having libc/libc_r.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test $build_libtool_need_lc = "yes"; then
@@ -4210,10 +4213,12 @@
fi
# Install the pseudo-library for information purposes.
+ if false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -12,7 +12,6 @@ include/ickle/events.h
include/ickle/exceptions.h
include/ickle/socket.h
lib/libicq2000.a
lib/libicq2000.la
lib/libicq2000.so
lib/libicq2000.so.1
@dirrm include/ickle

View file

@ -22,11 +22,12 @@ PATCH_SITES+= http://kva.paranoia.ru/~troff/
PATCH_DIST_STRIP= -p1
.endif
USE_LIBTOOL= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= ${MACHINE_ARCH}-unknown-freebsd${OSREL}
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
CONFIGURE_ARGS= --with-sigc-prefix=${LOCALBASE} \
--with-gtkmm-prefix=${X11BASE}
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I/usr/src/contrib/libstdc++" \
LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>

View file

@ -0,0 +1,25 @@
--- ltmain.sh.orig Sat Sep 22 20:10:52 2001
+++ ltmain.sh Tue Nov 20 21:14:55 2001
@@ -2444,6 +2444,9 @@
*-*-openbsd*)
# Do not include libc due to us having libc/libc_r.
;;
+ *-*-freebsd*)
+ # FreeBSD doesn't need this...
+ ;;
*)
# Add libc to deplibs on all other systems if necessary.
if test $build_libtool_need_lc = "yes"; then
@@ -4210,10 +4213,12 @@
fi
# Install the pseudo-library for information purposes.
+ if false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View file

@ -12,7 +12,6 @@ include/ickle/events.h
include/ickle/exceptions.h
include/ickle/socket.h
lib/libicq2000.a
lib/libicq2000.la
lib/libicq2000.so
lib/libicq2000.so.1
@dirrm include/ickle