Add fbpanel, a lightweight, netwm compliant desktop panel. It includes
taskbar, pager, launchbar and more. Works nicely with Metacity, kwm, xfce4... PR: ports/68917 Submitted by: Tobias Roth <ports@fsck.ch>
This commit is contained in:
parent
5250efe2de
commit
cf25cf8916
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=113508
8 changed files with 99 additions and 0 deletions
|
@ -43,6 +43,7 @@
|
|||
SUBDIR += erun
|
||||
SUBDIR += eterm
|
||||
SUBDIR += eweather
|
||||
SUBDIR += fbpanel
|
||||
SUBDIR += fbsd-icons
|
||||
SUBDIR += fixesext
|
||||
SUBDIR += fluxbg
|
||||
|
|
27
x11/fbpanel/Makefile
Normal file
27
x11/fbpanel/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
# New ports collection makefile for: fbpanel
|
||||
# Date created: Sat Jun 26 13:43:50 CEST 2004
|
||||
# Whom: Tobias Roth <ports@fsck.ch>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= fbpanel
|
||||
PORTVERSION= 3.8
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
EXTRACT_SUFX= .tgz
|
||||
|
||||
MAINTAINER= ports@fsck.ch
|
||||
COMMENT= A desktop panel that includes a taskbar, pager, launchbar and more
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GNOME= gtk20
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX}
|
||||
USE_GMAKE= yes
|
||||
|
||||
MAN1= fbpanel.1
|
||||
MANCOMPRESSED= yes
|
||||
|
||||
.include <bsd.port.mk>
|
2
x11/fbpanel/distinfo
Normal file
2
x11/fbpanel/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
MD5 (fbpanel-3.8.tgz) = 95e43a2c201feb5e272bbd9a4f78ad6e
|
||||
SIZE (fbpanel-3.8.tgz) = 72121
|
13
x11/fbpanel/files/patch-Makefile
Normal file
13
x11/fbpanel/files/patch-Makefile
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- man/Makefile.orig Sat Jun 26 12:37:59 2004
|
||||
+++ man/Makefile Sat Jun 26 12:38:14 2004
|
||||
@@ -20,8 +20,8 @@
|
||||
|
||||
|
||||
install: all
|
||||
- install -d $(PREFIX)/share/man/man1
|
||||
- install -m 644 $(TARGET) $(PREFIX)/share/man/man1
|
||||
+ install -d $(PREFIX)/man/man1
|
||||
+ install -m 644 $(TARGET) $(PREFIX)/man/man1
|
||||
|
||||
uninstall:
|
||||
rm -f $(PREFIX)/share/man/man1/$(TARGET)
|
14
x11/fbpanel/files/patch-Makefile.common
Normal file
14
x11/fbpanel/files/patch-Makefile.common
Normal file
|
@ -0,0 +1,14 @@
|
|||
--- Makefile.common.orig Sat Jun 26 14:00:42 2004
|
||||
+++ Makefile.common Sat Jun 26 14:03:02 2004
|
||||
@@ -15,10 +15,9 @@
|
||||
endif
|
||||
endif
|
||||
|
||||
-CC = gcc
|
||||
+CC ?= gcc
|
||||
LIBS = $(shell pkg-config --libs gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0) -L/usr/X11R6/lib -lXmu
|
||||
INCS = $(shell pkg-config --cflags gtk+-2.0 gdk-pixbuf-2.0 gdk-pixbuf-xlib-2.0)
|
||||
-CFLAGS = -O2 # overwriten by command line or env. variable
|
||||
CFLAGS += -Wall # always nice to have
|
||||
ifneq (,$(DEVEL))
|
||||
CFLAGS := -g -Wall
|
15
x11/fbpanel/files/patch-default.cfg
Normal file
15
x11/fbpanel/files/patch-default.cfg
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- config/default.cfg.orig Sat Jun 26 13:37:20 2004
|
||||
+++ config/default.cfg Sat Jun 26 13:37:27 2004
|
||||
@@ -190,9 +190,9 @@
|
||||
Plugin {
|
||||
type = taskbar
|
||||
expand = true
|
||||
- ShowIconified = true
|
||||
- ShowMapped = true
|
||||
- ShowAllDesks = false
|
||||
+ #ShowIconified = true
|
||||
+ #ShowMapped = true
|
||||
+ #ShowAllDesks = false
|
||||
config {
|
||||
tooltips = true
|
||||
iconsonly = false
|
12
x11/fbpanel/pkg-descr
Normal file
12
x11/fbpanel/pkg-descr
Normal file
|
@ -0,0 +1,12 @@
|
|||
Fbpanel is a lightweight desktop panel that works with any
|
||||
NETWM (http://www.freedesktop.org/) compliant window manager.
|
||||
It features:
|
||||
o taskbar - show list of open windows
|
||||
o pager - thumbnailed view of the desktop(s)
|
||||
o launchbar - buttons to launch applications
|
||||
o show desktop - button to iconify or shade all windows
|
||||
o image - display an image
|
||||
o clock - show the current time and/or date
|
||||
o sytem tray - tray for XEMBED icons (aka docklets)
|
||||
|
||||
WWW: http://fbpanel.sourceforge.net/
|
15
x11/fbpanel/pkg-plist
Normal file
15
x11/fbpanel/pkg-plist
Normal file
|
@ -0,0 +1,15 @@
|
|||
bin/fbpanel
|
||||
share/fbpanel/default
|
||||
share/fbpanel/pager
|
||||
share/fbpanel/images/Desktop2.png
|
||||
share/fbpanel/images/Editor.png
|
||||
share/fbpanel/images/Emacs.png
|
||||
share/fbpanel/images/GNOME-Terminal.png
|
||||
share/fbpanel/images/Menu.png
|
||||
share/fbpanel/images/Networking.png
|
||||
share/fbpanel/images/bottom-left.xpm
|
||||
share/fbpanel/images/bottom-right.xpm
|
||||
share/fbpanel/images/top-left.xpm
|
||||
share/fbpanel/images/top-right.xpm
|
||||
@dirrm share/fbpanel/images
|
||||
@dirrm share/fbpanel
|
Loading…
Reference in a new issue