1: Stagify.

2: new syntax of LIB_DEPENDS.
3: use option helper.

Approved by:	portmgr@
This commit is contained in:
Vanilla I. Shu 2014-06-23 09:59:45 +00:00
parent 15128d1d38
commit cf508b5e75
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=358916
2 changed files with 20 additions and 11 deletions

View file

@ -15,17 +15,9 @@ GNU_CONFIGURE= yes
USE_OPENSSL= yes
OPTIONS_DEFINE= SNMP
SNMP_LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp
SNMP_CONFIGURE_WITH= snmp
MAN1= ifstat.1
PLIST_FILES= bin/ifstat
NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSNMP}
LIB_DEPENDS+= netsnmp.30:${PORTSDIR}/net-mgmt/net-snmp
.else
CONFIGURE_ARGS+= --without-snmp
.endif
PLIST_FILES= bin/ifstat man/man1/ifstat.1.gz
.include <bsd.port.mk>

View file

@ -0,0 +1,17 @@
--- Makefile.in.orig 2014-06-23 17:54:49.793422514 +0800
+++ Makefile.in 2014-06-23 17:56:06.824418432 +0800
@@ -65,10 +65,10 @@ libifstat-config: libifstat-config.in
install: install-$(TARGET) install-@LIBTARGET@
install-$(TARGET): $(TARGET)
- $(INSTALL) -d -m 755 $(bindir)
- $(INSTALL) -s -m 755 $(TARGET) $(bindir)/$(TARGET)
- $(INSTALL) -d -m 755 $(mandir)/man1
- $(INSTALL) -m 644 ifstat.1 $(mandir)/man1/ifstat.1
+ $(INSTALL) -d -m 755 $(DESTDIR)$(bindir)
+ $(INSTALL) -s -m 755 $(TARGET) $(DESTDIR)$(bindir)/$(TARGET)
+ $(INSTALL) -d -m 755 $(DESTDIR)$(mandir)/man1
+ $(INSTALL) -m 644 ifstat.1 $(DESTDIR)$(mandir)/man1/ifstat.1
install-$(LIBTARGET): $(LIBTARGET) libifstat-config
$(INSTALL) -d -m 755 $(bindir)