misc/py-SoapySDR: Simplify the port.
Based on the upstream author's advice now most patches are removed.
This commit is contained in:
parent
9aeec13ffc
commit
cf83d880fb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=473285
4 changed files with 2 additions and 46 deletions
|
@ -23,11 +23,9 @@ USE_GITHUB= yes
|
|||
GH_ACCOUNT= pothosware
|
||||
USE_PYTHON= flavors
|
||||
|
||||
CMAKE_ARGS= -DFREEBSD_PYTHON_VERSION:INTEGER=${PYTHON_VER:S/.//} \
|
||||
-DFREEBSD_PYTHON_VER2:STRING=${PYTHON_VER}
|
||||
CMAKE_OFF= ENABLE_DOCS
|
||||
CMAKE_ARGS= -DPYTHON_EXECUTABLE:STRING=${PYTHON_CMD}
|
||||
|
||||
WRKSRC_SUBDIR= python${PYTHON_VER:R:R:S/2//} # WARNING There are handcrafted paths in patches with '../' added to match this WRKSRC_SUBDIR for all python flavors
|
||||
WRKSRC_SUBDIR= python
|
||||
|
||||
PLIST_FILES= ${PYTHON_SITELIBDIR}/SoapySDR.py \
|
||||
${PYTHON_SITELIBDIR}/_SoapySDR.so
|
||||
|
|
|
@ -1,11 +0,0 @@
|
|||
--- ../python3/CMakeLists.txt.orig 2018-05-13 06:02:48 UTC
|
||||
+++ ../python3/CMakeLists.txt
|
||||
@@ -55,7 +55,7 @@ endif()
|
||||
########################################################################
|
||||
include(FeatureSummary)
|
||||
include(CMakeDependentOption)
|
||||
-cmake_dependent_option(ENABLE_PYTHON3 "Enable python bindings" ON "ENABLE_LIBRARY;SWIG_FOUND;PYTHON3INTERP_FOUND;PYTHON3LIBS_FOUND;PYTHON3_DEBUG_OK;BUILD_PYTHON3" OFF)
|
||||
+option(ENABLE_PYTHON3 "Enable python bindings" ON)
|
||||
add_feature_info(Python3 ENABLE_PYTHON3 "python3 bindings")
|
||||
if (NOT ENABLE_PYTHON3)
|
||||
return()
|
|
@ -1,20 +0,0 @@
|
|||
--- ../python3/FindPython3Interp.cmake.orig 2018-06-19 06:38:27 UTC
|
||||
+++ ../python3/FindPython3Interp.cmake
|
||||
@@ -39,7 +39,7 @@
|
||||
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
|
||||
FIND_PROGRAM(PYTHON3_EXECUTABLE
|
||||
- NAMES python3.2mu python3.2m python3.2u python3.2 python3.1 python3.0 python3
|
||||
+ NAMES python${FREEBSD_PYTHON_VER2}
|
||||
PATHS
|
||||
[HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\3.2\\InstallPath]
|
||||
[HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\3.1\\InstallPath]
|
||||
@@ -47,7 +47,7 @@ FIND_PROGRAM(PYTHON3_EXECUTABLE
|
||||
)
|
||||
|
||||
FIND_PROGRAM(PYTHON3_DBG_EXECUTABLE
|
||||
- NAMES python3.2dmu python3.2dm python3.2du python3.2d python3.1-dbg python3.0-dbg python3-dbg
|
||||
+ NAMES python${FREEBSD_PYTHON_VER2}-dbg
|
||||
PATHS
|
||||
[HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\3.2\\InstallPath]
|
||||
[HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\3.1\\InstallPath]
|
|
@ -1,11 +0,0 @@
|
|||
--- ../python3/FindPython3Libs.cmake.orig 2018-06-19 06:36:21 UTC
|
||||
+++ ../python3/FindPython3Libs.cmake
|
||||
@@ -46,7 +46,7 @@ INCLUDE(CMakeFindFrameworks)
|
||||
# Search for the python framework on Apple.
|
||||
# CMAKE_FIND_FRAMEWORKS(Python)
|
||||
|
||||
-FOREACH(_CURRENT_VERSION 3.5 3.4 3.3 3.2 3.1 3.0)
|
||||
+FOREACH(_CURRENT_VERSION ${FREEBSD_PYTHON_VER2})
|
||||
IF(_CURRENT_VERSION GREATER 3.1)
|
||||
SET(_32FLAGS "m" "u" "mu" "dm" "du" "dmu" "")
|
||||
ELSE()
|
Loading…
Reference in a new issue