Upgrade, 2.6.2 -> 3.5.2
Change the maintainer from graphite@taurus.bekkoame.or.jp to jseger@scds.com. (I have received a personal note from the old maintainer and he approves this change.) Also, install the sample scripts into share/examples/suck instead of into etc/rc.d. PR: 4131 Submitted by: the new maintainer <jseger@scds.com>
This commit is contained in:
parent
9f71cde6e5
commit
cfb35583cc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=7730
5 changed files with 48 additions and 246 deletions
|
@ -1,25 +1,27 @@
|
|||
# New ports collection makefile for: suck
|
||||
# Version required: 2.6.2
|
||||
# Version required: 3.5.2
|
||||
# Date created: 30 Mar 1996
|
||||
# Whom: graphite@taurus.bekkoame.or.jp
|
||||
#
|
||||
# $Id: Makefile,v 1.2 1996/04/07 08:15:23 asami Exp $
|
||||
# $Id: Makefile,v 1.3 1996/11/18 11:38:13 asami Exp $
|
||||
#
|
||||
|
||||
DISTNAME= suck-2.6.2
|
||||
DISTNAME= suck-3.5.2
|
||||
CATEGORIES= news
|
||||
MASTER_SITES= ftp://tsx-11.mit.edu/pub/linux/sources/sbin/ \
|
||||
ftp://ftp.iis.u-tokyo.ac.jp/pub2/Linux/sources/sbin/
|
||||
|
||||
MAINTAINER= graphite@taurus.bekkoame.or.jp
|
||||
MAINTAINER= jseger@scds.com
|
||||
|
||||
USE_GMAKE= yes
|
||||
MAN1= suck.1 rpost.1 testhost.1
|
||||
GNU_CONFIGURE= yes
|
||||
MAN1= suck.1 rpost.1 testhost.1 lmove.1 lpost.1
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/sample/get.news.innxmit ${PREFIX}/sbin
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/sample/get.news.rnews ${PREFIX}/sbin
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/sample/put.news ${PREFIX}/bin
|
||||
install -c -o bin -g bin -m 640 ${WRKSRC}/sample/*.sample ${PREFIX}/etc
|
||||
${MKDIR} ${PREFIX}/share/examples/suck
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/sample/get.news.innxmit ${PREFIX}/share/examples/suck
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/sample/get.news.rnews ${PREFIX}/share/examples/suck
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/sample/put.news ${PREFIX}/share/examples/suck
|
||||
${INSTALL_DATA} ${WRKSRC}/sample/*.sample ${PREFIX}/share/examples/suck
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (suck-2.6.2.tar.gz) = e85997fff0da233a80764095770fa214
|
||||
MD5 (suck-3.5.2.tar.gz) = d349b94a7341fc67102c7bfedcf47781
|
||||
|
|
|
@ -1,109 +1,20 @@
|
|||
--- Makefile.orig Sat Mar 30 06:01:40 1996
|
||||
+++ Makefile Fri Apr 5 22:50:49 1996
|
||||
@@ -5,15 +5,15 @@
|
||||
CC=gcc
|
||||
--- Makefile.in.orig Fri Aug 1 20:59:01 1997
|
||||
+++ Makefile.in Mon Aug 4 19:04:25 1997
|
||||
@@ -128,7 +128,7 @@
|
||||
|
||||
#stuff related to the executables (suck rpost testhost)
|
||||
-INSTALLDIR = /home/boby/doNews # location for the executables
|
||||
-INSTALL_OWNER=boby # user of the installed files
|
||||
-INSTALL_GROUP=users # group for the installed files
|
||||
+INSTALLDIR = ${PREFIX}/bin # location for the executables
|
||||
+INSTALL_OWNER=bin # user of the installed files
|
||||
+INSTALL_GROUP=bin # group for the installed files
|
||||
INSTALL_MODE=755 # mode for the installed files
|
||||
install_bin: suck rpost testhost lmove
|
||||
- mkdir -p $(bindir)
|
||||
- - strip -s suck rpost testhost lmove
|
||||
+ - strip -x suck rpost testhost lmove
|
||||
$(INSTALL_PROGRAM) suck $(bindir)/suck
|
||||
$(INSTALL_PROGRAM) rpost $(bindir)/rpost
|
||||
$(INSTALL_PROGRAM) testhost $(bindir)/testhost
|
||||
@@ -149,7 +149,7 @@
|
||||
$(MAKE) -C $(SMAN)
|
||||
|
||||
#stuff related to the man pages
|
||||
-MANDIR=/usr/man/man1 # location for the man pages
|
||||
-MAN_OWNER=root # owner of the man pages
|
||||
-MAN_GROUP=root # group for the man pages
|
||||
+MANDIR=${PREFIX}/man/man1 # location for the man pages
|
||||
+MAN_OWNER=bin # owner of the man pages
|
||||
+MAN_GROUP=bin # group for the man pages
|
||||
MAN_MODE=644 # mode for the man pages
|
||||
|
||||
#XXGDB=1 # uncomment this to get it ready for use by xxgdb or gdb
|
||||
@@ -27,8 +27,8 @@
|
||||
#USE_INNDBZ=1 # if your DBZ routines are part of libinn.a, also check INN_ stuff
|
||||
|
||||
# If the INNDBZ stuff is not in the following locations, change this
|
||||
-INN_DBINC=-I/usr/src/inn/include
|
||||
-INN_LIBDIR=-L/usr/src/inn/lib
|
||||
+INN_DBINC=-I${PORTSDIR}/news/inn/work/include
|
||||
+INN_LIBDIR=-L${PORTSDIR}/news/inn/work/lib
|
||||
INN_DBLIBS=-linn
|
||||
|
||||
#---------------DON'T TOUCH BELOW HERE--------------------------------------
|
||||
@@ -85,7 +85,7 @@
|
||||
LINK = $(CC)
|
||||
LIBS = -lm $(DBLIB) $(GPROFLIB)
|
||||
OPTS = $(CFLAGS) $(GCC_FLAGS) $(DVERSION) $(DBOPTION) $(DBINC)
|
||||
-INSTALL = install
|
||||
+INSTALL = install -c
|
||||
|
||||
MAN = ./man
|
||||
SAMPLE = ./sample
|
||||
@@ -122,13 +122,13 @@
|
||||
|
||||
installbin: $(TARGETS)
|
||||
mkdir -p $(INSTALLDIR)
|
||||
- $(INSTALL) -o $(INSTALL_OWNER) -g $(INSTALL_GROUP) -m $(INSTALL_MODE) $(TARGETS) $(INSTALLDIR)
|
||||
+ $(INSTALL) -s -o $(INSTALL_OWNER) -g $(INSTALL_GROUP) -m $(INSTALL_MODE) $(TARGETS) $(INSTALLDIR)
|
||||
|
||||
installman: $(MANPGS)
|
||||
- $(INSTALL) -o $(MAN_OWNER) -g $(MAN_GROUP) -m $(MAN_MODE) $(MANPGS) $(MANDIR)
|
||||
install_lpost: lpost
|
||||
- - strip -s lpost
|
||||
+ - strip -x lpost
|
||||
$(INSTALL_PROGRAM) lpost $(bindir)/lpost
|
||||
|
||||
installall: install lpost
|
||||
- $(INSTALL) -o $(INSTALL_OWNER) -g $(INSTALL_GROUP) -m $(INSTALL_MODE) $(LPOST_TARGET) $(INSTALLDIR)
|
||||
+ $(INSTALL) -s -o $(INSTALL_OWNER) -g $(INSTALL_GROUP) -m $(INSTALL_MODE) $(LPOST_TARGET) $(INSTALLDIR)
|
||||
- $(INSTALL) -o $(MAN_OWNER) -g $(MAN_GROUP) -m $(MAN_MODE) $(LPOST_MANPGS) $(MANDIR)
|
||||
|
||||
clean:
|
||||
--- config.h.orig Sat Mar 30 11:57:59 1996
|
||||
+++ config.h Fri Apr 5 22:56:24 1996
|
||||
@@ -12,6 +12,10 @@
|
||||
/* #define DEBUG2 */
|
||||
/* #define DEBUG3 */
|
||||
|
||||
+/* BSD Option */
|
||||
+/* If system has no sys/param.h, comment this out */
|
||||
+#define _HAVE_PARAM_H
|
||||
+
|
||||
/* TIMER Option */
|
||||
/* To see the approximate BPS while downloading articles, uncomment this */
|
||||
/* If you don't like it, or want a tiny speed increase, comment this out */
|
||||
@@ -19,7 +23,7 @@
|
||||
|
||||
/* If you don't EVER plan to use the KILLFILE stuff, comment this out for a slight speed increase */
|
||||
/* If you want to, or plan to, use the KILLFILE stuff, uncomment this */
|
||||
-/* #define KILLFILE */
|
||||
+#define KILLFILE /**/
|
||||
|
||||
/* If you want the kill/keep file routine to keep articles that are both flagged as */
|
||||
/* delete and keep (either by matching both a delete group and a keep group, or by not matching */
|
||||
@@ -44,7 +48,7 @@
|
||||
/* as number of seconds before timeout */
|
||||
/* else, comment it out. If you comment it out, if link goes down */
|
||||
/* we'll just sit, twiddling our bits, until whenever. */
|
||||
-#define TIMEOUT 30
|
||||
+#define TIMEOUT 90
|
||||
|
||||
/* signal which will interrupt us DON'T USE SIGKILL OR SIGSTOP */
|
||||
/* if you don't want to be able to abort, and a miniscule speed */
|
||||
@@ -66,7 +70,7 @@
|
||||
#define CHECK_HISTORY_EXP
|
||||
|
||||
/* don't comment this out */
|
||||
-#define HISTORY_FILE "/usr/lib/news/history"
|
||||
+#define HISTORY_FILE "/usr/local/news/lib/history"
|
||||
|
||||
/* If your system doesn't like the lock file stuff in suck.c */
|
||||
/* comment this out */
|
||||
@@ -106,7 +110,7 @@
|
||||
#define RPOST_MAXARGS 128
|
||||
|
||||
/* RNEWS program called by lpost */
|
||||
-#define RNEWS "/usr/lib/news/rnews"
|
||||
+#define RNEWS "/usr/local/bin/rnews"
|
||||
|
||||
/* character used as a comment in sucknewsrc */
|
||||
#define SUCKNEWSRC_COMMENT_CHAR '#'
|
||||
|
|
|
@ -1,125 +1,10 @@
|
|||
--- suck.c.orig Sat Mar 30 11:27:51 1996
|
||||
+++ suck.c Fri Apr 5 23:01:42 1996
|
||||
@@ -11,6 +11,10 @@
|
||||
#include "suck.h"
|
||||
#include "suckutils.h"
|
||||
--- lmove.c.orig Fri May 23 08:16:38 1997
|
||||
+++ lmove.c Mon Aug 25 16:43:04 1997
|
||||
@@ -27,6 +27,7 @@
|
||||
#include <sys/stat.h>
|
||||
#include <errno.h>
|
||||
#include <signal.h>
|
||||
+#include <sys/syslimits.h>
|
||||
|
||||
+#ifdef _HAVE_PARAM_H
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
+
|
||||
#ifdef KILLFILE
|
||||
#include "killfile.h"
|
||||
#endif
|
||||
@@ -511,7 +515,9 @@
|
||||
}
|
||||
#endif
|
||||
}
|
||||
- fclose(ifp);
|
||||
+ if( ifp != NULL ){
|
||||
+ fclose(ifp);
|
||||
+ }
|
||||
}
|
||||
#ifdef KILLFILE
|
||||
free_killfile(killp);
|
||||
@@ -783,7 +789,11 @@
|
||||
}
|
||||
if(retval == RETVAL_OK) {
|
||||
/* first put #! rnews size */
|
||||
+#if (defined(BSD) && (BSD >= 199306))
|
||||
+ fprintf(fptr, "#! rnews %qd\n", sbuf.st_size);
|
||||
+#else
|
||||
fprintf(fptr, "#! rnews %ld\n", sbuf.st_size);
|
||||
+#endif
|
||||
|
||||
/* use fread/fwrite in case lines are longer than MAXLINLEN */
|
||||
while((i = fread(buf, 1, MAXLINLEN, fpin)) > 0) {
|
||||
--- suckutils.c.orig Wed Mar 6 14:48:18 1996
|
||||
+++ suckutils.c Fri Apr 5 23:01:42 1996
|
||||
@@ -13,6 +13,10 @@
|
||||
#include "suck_config.h"
|
||||
#include "both.h"
|
||||
#include "suckutils.h"
|
||||
|
||||
+#ifdef _HAVE_PARAM_H
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
+
|
||||
/*------------------------------------------------------------------------*/
|
||||
/* check if directory exists, if not, try to create it. */
|
||||
/* return TRUE if made/exists and can write to it */
|
||||
@@ -148,7 +152,11 @@
|
||||
lockfile = full_path(FP_GET, FP_TMPDIR, N_LOCKFILE);
|
||||
if((f_lock = fopen(lockfile, "r")) != NULL) {
|
||||
/* okay, let's try and see if this sucker is truly alive */
|
||||
+# if (defined(BSD) && (BSD >= 199306))
|
||||
+ fscanf(f_lock, "%ld", &pid);
|
||||
+# else
|
||||
fscanf(f_lock, "%d", &pid);
|
||||
+# endif
|
||||
fclose(f_lock);
|
||||
if(pid <= 0) {
|
||||
error_log(ERRLOG_REPORT, "Lock File %s , Invalid PID, aborting.\n", lockfile);
|
||||
@@ -160,21 +168,37 @@
|
||||
else if(kill(pid, 0) == -1 && errno == ESRCH) {
|
||||
/* no pid found */
|
||||
if(unlink(lockfile) == 0) {
|
||||
+# if (defined(BSD) && (BSD >= 199306))
|
||||
+ error_log(ERRLOG_REPORT, "Lock File %s , stale PID %ld removed.\n", lockfile, pid);
|
||||
+# else
|
||||
error_log(ERRLOG_REPORT, "Lock File %s , stale PID %d removed.\n", lockfile, pid);
|
||||
+# endif
|
||||
}
|
||||
else {
|
||||
+# if (defined(BSD) && (BSD >= 199306))
|
||||
+ error_log(ERRLOG_REPORT, "Unable to remove Lock File %s , stale PID %d, Aborting.\n", lockfile, pid);
|
||||
+# else
|
||||
error_log(ERRLOG_REPORT, "Unable to remove Lock File %s , stale PID %d, Aborting.\n", lockfile, pid);
|
||||
+# endif
|
||||
retval = RETVAL_ERROR;
|
||||
}
|
||||
}
|
||||
else {
|
||||
+# if (defined(BSD) && (BSD >= 199306))
|
||||
+ error_log(ERRLOG_REPORT, "Lock File %s , PID %ld exists, aborting.\n", lockfile, pid);
|
||||
+# else
|
||||
error_log(ERRLOG_REPORT, "Lock File %s , PID %d exists, aborting.\n", lockfile, pid);
|
||||
+# endif
|
||||
retval = RETVAL_ERROR;
|
||||
}
|
||||
}
|
||||
if(retval == RETVAL_OK) {
|
||||
if((f_lock = fopen(lockfile, "w")) != NULL) {
|
||||
+# if (defined(BSD) && (BSD >= 199306))
|
||||
+ fprintf(f_lock, "%ld", getpid());
|
||||
+# else
|
||||
fprintf(f_lock, "%d", getpid());
|
||||
+# endif
|
||||
fclose(f_lock);
|
||||
}
|
||||
else {
|
||||
--- both.c.orig Wed Mar 6 14:48:28 1996
|
||||
+++ both.c Fri Apr 5 23:01:42 1996
|
||||
@@ -12,6 +12,10 @@
|
||||
#include "config.h"
|
||||
#include "both.h"
|
||||
|
||||
+#ifdef _HAVE_PARAM_H
|
||||
+#include <sys/param.h>
|
||||
+#endif
|
||||
+
|
||||
#ifdef TIMEOUT
|
||||
#include <sys/time.h>
|
||||
#include <sys/types.h>
|
||||
@@ -238,7 +242,12 @@
|
||||
if(i < 1) {
|
||||
if(i == 0) {
|
||||
/* in case recv has no data */
|
||||
+#if (defined(BSD) && (BSD >= 199306))
|
||||
+ /* I don't know, is this appropriate conversion */
|
||||
+ errno = ENOTCONN;
|
||||
+#else
|
||||
errno = ENODATA;
|
||||
+#endif
|
||||
}
|
||||
MyPerror("Socket error");
|
||||
ret = -1;
|
||||
|
|
|
@ -1,12 +1,16 @@
|
|||
bin/suck
|
||||
bin/lmove
|
||||
bin/rpost
|
||||
bin/suck
|
||||
bin/testhost
|
||||
bin/put.news
|
||||
sbin/get.news.innxmit
|
||||
sbin/get.news.rnews
|
||||
etc/suckkillfile.sample
|
||||
etc/sucknewsrc.sample
|
||||
etc/suckothermsgs.sample
|
||||
man/man1/suck.1.gz
|
||||
man/man1/lmove.1.gz
|
||||
man/man1/lpost.1.gz
|
||||
man/man1/rpost.1.gz
|
||||
man/man1/suck.1.gz
|
||||
man/man1/testhost.1.gz
|
||||
share/examples/suck/get.news.innxmit
|
||||
share/examples/suck/get.news.rnews
|
||||
share/examples/suck/put.news
|
||||
share/examples/suck/suckkillfile.sample
|
||||
share/examples/suck/sucknewsrc.sample
|
||||
share/examples/suck/suckothermsgs.sample
|
||||
@dirrm share/examples/suck
|
||||
|
|
Loading…
Reference in a new issue