science/afni: Upgrade to 20.1.02

Added some common R-cran run dependencies
Removed obsolete reinplace patches
Improved do-install to better fit filesystem hierarchy
Releasing maintainership as I no longer work with any AFNI users

Reported by:    portscout
This commit is contained in:
Jason W. Bacon 2020-04-20 12:21:49 +00:00
parent 7302ae89ec
commit d01911ded0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=532202
5 changed files with 205 additions and 105 deletions

View file

@ -2,19 +2,22 @@
PORTNAME= afni
DISTVERSIONPREFIX= AFNI_
DISTVERSION= 19.1.20
PORTREVISION= 4
DISTVERSION= 20.1.01
CATEGORIES= science biology graphics perl5 python
MAINTAINER= jwb@FreeBSD.org
MAINTAINER= ports@FreeBSD.org
COMMENT= Advanced Functional Neuro Imaging
LICENSE= GPLv2
BROKEN_sparc64= Does not compile: "undefined reference to '_mcount'"
CRAN_DEPENDS= R-cran-lme4>0:math/R-cran-lme4 \
R-cran-snow>0:science/R-cran-snow \
R-cran-psych>0:math/R-cran-psych
BUILD_DEPENDS= gm4:devel/m4 \
R:math/R
R:math/R \
${CRAN_DEPENDS}
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libf2c.so:lang/f2c \
libgsl.so:math/gsl \
@ -22,18 +25,23 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libxml2.so:textproc/libxml2 \
libXm.so:x11-toolkits/open-motif \
libnetpbm.so:graphics/netpbm
# Remote execution of suma. Also needed for glxinfo.
LIB_PC_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/dri.pc:graphics/mesa-dri
RUN_DEPENDS= endian:sysutils/endian \
mpeg_encode:multimedia/mpeg_encode \
qhull:math/qhull5 \
R:math/R
R:math/R \
${CRAN_DEPENDS}
USES= compiler:openmp gettext gl gmake gnome iconv jpeg:run motif \
perl5 python shebangfix tar:xz xorg
USES= compiler:openmp gettext gl gmake gnome iconv jpeg:run motif
USES+= perl5 python shebangfix tar:xz xorg
USE_GNOME= glib20
USE_GITHUB= yes
USE_GL= gl
SHEBANG_FILES= scripts_install/* \
python_scripts/afni_python/*.py \
python_scripts/afnipy/*.py \
python_scripts/scripts/*.py \
jzosky/*.py \
jzosky/lib_RetroTS/*.py \
discoraj/ClusterExplorer/*.py \
@ -70,16 +78,7 @@ CONFLICTS= im-[0-9]* \
open-usp-tukubai-[0-9]*
X11R6_FILES= coxplot/Makefile \
coxplot/Makefile.f2c \
3DEdge/src/Makefile \
SUMA/SUMA_Makefile \
edt_blur.c \
suma_datasets.c \
SUMA/SUMA_Load_Surface_Object.c \
SUMA/SUMA_MiscFunc.c \
SUMA/SUMA_ParseCommands.c \
SUMA/GLUT/libglut/glut_event.c \
SUMA/SUMA_Surface_IO.c
coxplot/Makefile.f2c
post-extract:
.for f in ${X11R6_FILES}
@ -91,36 +90,23 @@ post-extract:
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
@${RM} ${WRKSRC}/3DEdge/src/Makefile.orig
# shebangfix misses /bin/python on 10.1
# @${REINPLACE_CMD} -e "s|/bin/python|${PYTHON_CMD}|g" \
# ${WRKSRC}/python_scripts/afni_python/lib_fat_Rfactor.py
pre-configure:
@${REINPLACE_CMD} -e "s|-lglib|-lglib-2.0|g" \
${WRKSRC}/SUMA/SUMA_Makefile
@${REINPLACE_CMD} \
-e 's|os\.path\.dirname(sys\.argv\[0\])|"${DATADIR}"|g' \
-e 's|os\.path\.dirname(os\.path\.abspath(os\.path\.expanduser(sys\.argv\[0\])))|"${DATADIR}"|g' \
${WRKSRC}/pkundu/meica.py
@${REINPLACE_CMD} \
-e 's|g_info|afni_g_info|g' \
${WRKSRC}/rickr/Dimon.c \
${WRKSRC}/rickr/Dimon1.c \
${WRKSRC}/afni_history_rickr.c \
${WRKSRC}/mri_dicom_stuff.c \
${WRKSRC}/mri_process_siemens.c \
${WRKSRC}/mri_read_dicom.c \
${WRKSRC}/to3d.c \
${WRKSRC}/mri_dicom_stuff.h
do-install:
# AFNI install just dumps everything into one flat directory
# Preserve original install dir and make a sacrificial temp copy
# ${WRKSRC}/BSD == ${INSTALL_WRKSRC}.
# Preserve ${INSTALL_WRKSRC} and make a sacrificial temp copy
# to be pruned and rearranged for easy staging
@${RM} -r ${INSTALL_TMP}
@${CP} -R ${INSTALL_WRKSRC} ${INSTALL_TMP}
# Clean up and organize files into ${PRESTAGE}, destroying
# temp copy in the process
# ${INSTALL_TMP} in the process
@${RM} -rf ${PRESTAGE}
@${MKDIR} ${PRESTAGE}/bin \
${PRESTAGE}/scripts \
@ -128,12 +114,12 @@ do-install:
${PRESTAGE}/include \
${PRESTAGE}/trash \
${PRESTAGE}/doc \
${PRESTAGE}/share
${PRESTAGE}/share \
${PRESTAGE}/pylib
@${RM} ${INSTALL_TMP}/libf2c.a
@${MV} ${INSTALL_TMP}/meica.libs \
${INSTALL_TMP}/shiny \
${INSTALL_TMP}/lib_RetroTS \
${INSTALL_TMP}/afniInterfaceRT \
${INSTALL_TMP}/funstuff \
${INSTALL_TMP}/AFNI.*rc \
${INSTALL_TMP}/afnigui* \
@ -142,6 +128,7 @@ do-install:
${INSTALL_TMP}/*.so \
${PRESTAGE}/lib
@${MV} ${INSTALL_TMP}/*.h ${PRESTAGE}/include
@${MV} ${INSTALL_TMP}/afnipy ${INSTALL_TMP}/afniRTI ${PRESTAGE}/pylib
@${CP} ${WRKDIR}/afni-AFNI_${PORTVERSION}/doc/README/* ${PRESTAGE}/doc
@for binary in `${FILE} ${INSTALL_TMP}/* | fgrep 'ELF' | ${AWK} -F ':' ' { print $$1 }'` ; do \
${MV} $${binary} ${PRESTAGE}/bin ; \
@ -157,6 +144,8 @@ do-install:
${STAGEDIR}${PREFIX}/etc/mri
${INSTALL_PROGRAM} ${PRESTAGE}/bin/* ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${PRESTAGE}/scripts/* ${STAGEDIR}${PREFIX}/bin
(cd ${PRESTAGE}/pylib && \
${COPYTREE_SHARE} . ${STAGEDIR}${PYTHON_SITELIBDIR})
${INSTALL_DATA} ${PRESTAGE}/lib/* ${STAGEDIR}${PREFIX}/lib/afni
${INSTALL_DATA} ${PRESTAGE}/include/* ${STAGEDIR}${PREFIX}/include/afni
(cd ${PRESTAGE}/share && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1560861068
SHA256 (afni-afni-AFNI_19.1.20_GH0.tar.gz) = d9d63e3c8f4d38b28c4ceb71ee5537e66f400a6f2b2e0443fa58f2cf7a112007
SIZE (afni-afni-AFNI_19.1.20_GH0.tar.gz) = 38939294
TIMESTAMP = 1587212753
SHA256 (afni-afni-AFNI_20.1.01_GH0.tar.gz) = 8512f1d1d9c2a5c8224d222577249b1bfa280adb4f647c96f08e933f5f1b1a0c
SIZE (afni-afni-AFNI_20.1.01_GH0.tar.gz) = 43164312

View file

@ -1,6 +1,6 @@
--- Makefile.INCLUDE.orig 2019-05-23 14:10:15 UTC
--- Makefile.INCLUDE.orig 2020-04-15 00:56:29 UTC
+++ Makefile.INCLUDE
@@ -67,7 +67,7 @@ MISC = AFNI_atlas_spaces.niml AFNI.Xdefaults AFNI.a
@@ -92,7 +92,7 @@ MISC = AFNI_atlas_spaces.niml AFNI.Xdefaults AFNI.a
## AFNI package, but included because they are useful. Some of
## them are Open Source programs, not from the AFNI group at all.
@ -9,7 +9,7 @@
# mpegtoppm in above list
@@ -80,7 +80,7 @@ EXTRAS = cjpeg djpeg whirlgif mpeg_encode myget Xpha
@@ -105,7 +105,7 @@ EXTRAS = cjpeg djpeg whirlgif mpeg_encode myget Xpha
PROGS_1 = afni to3d from3d abut 3dclust nsize 3dinfo 3dproject 3dmerge count \
sfim tfim ftosh 3dttest 3ddup imrotate imreg imstat 3dnvals \
fim2 imand FD2 sqwave immask imdump imaver 3dhistog 3dfim 3daxialize \
@ -18,7 +18,7 @@
waver 3dnewid 3dcalc ccalc imcalc 1dmatcalc 3drefit 3dbucket \
3dNLfim 3dTSgen AlphaSim 3dFWHM plugout_tt 3dnoise plugout_ijk \
3dMannWhitney 3dWilcoxon 3dKruskalWallis 3dFriedman 3dRegAna \
@@ -93,7 +93,7 @@ PROGS_2 = 3dTshift 3dDetrend 1dfft 1dcat 3drename 1dn
@@ -118,7 +118,7 @@ PROGS_2 = 3dTshift 3dDetrend 1dfft 1dcat 3drename 1dn
3dWavelets 3dfim+ imcutup imcat 3dWinsor 3dZeropad 3dTagalign \
3dMean 3dAttribute cat_matvec 3dOverlap 3dClipLevel 3dZregrid \
3dEntropy 3ddelay ent16 3dRowFillin 1dgrayplot 3dToutcount 1dsum \
@ -27,7 +27,7 @@
3dTcorrelate 3dAnatNudge 3dcopy Vecwarp 3dMINCtoAFNI 3dCM fdrval \
3dAFNItoANALYZE siemens_vision ge_header mayo_analyze 3dAFNItoNIFTI \
3dAutoTcorrelate 3dFDR rtfeedme 3dAutomask 3dAFNItoMINC 3dBrickStat \
@@ -115,7 +115,7 @@ PROGS_3 = 3dDeconvolve_f 3dAnhist 3dAFNIto3D 3dUnifor
@@ -141,7 +141,7 @@ PROGS_3 = 3dDeconvolve_f 3dAnhist 3dAFNIto3D 3dUnifor
PROGS_4 = 3dBlurInMask 3dRank 3dFFT 1dgenARMA11 3dPeriodogram 1dAstrip \
3dLocalPV 3dBandpass 3dSetupGroupInCorr 3dGroupInCorr 3dTcorr1D \
3dClustSim 3dRetinoPhase 3dMaskToASCII 3dttest++ 3dDTtoDWI \
@ -36,7 +36,7 @@
1dCorrelate 3dCountSpikes 3dNwarpCalc dicom_hinfo apsearch 1dBport \
3dNormalityTest 3dmask_tool FIRdesign help_format 2perm 3dClustCount \
column_cat 3dUnifize 3dNwarpCat 3dQwarp 3dLocalHistog 3dNwarpAdjust \
@@ -141,7 +141,7 @@ PROGRAMS = $(PROGS_1) $(PROGS_2) $(PROGS_3) $(PROGS_4)
@@ -167,7 +167,7 @@ PROGRAMS = $(PROGS_1) $(PROGS_2) $(PROGS_3) $(PROGS_4)
PROGRAMS_NOPLUG = afni to3d from3d abut 3dclust nsize 3dinfo 3dproject 3dmerge \
sfim tfim ftosh 3dttest 3ddup imrotate imreg imstat 3dnoise count \
fim2 imand FD2 sqwave immask imdump imaver 3dhistog 3dfim imupsam \
@ -45,7 +45,7 @@
waver 3dnewid 3dcalc ccalc imcalc 2dImReg 3dmaskave adwarp fdrval \
3dMannWhitney 3dWilcoxon 3dKruskalWallis 3dFriedman 3dRegAna \
imstack byteorder 3dDeconvolve 3dTcat 3drotate 3dvolreg 1dplot \
@@ -184,7 +184,7 @@ PROGRAMS_NOPLUG = afni to3d from3d abut 3dclust nsize
@@ -210,7 +210,7 @@ PROGRAMS_NOPLUG = afni to3d from3d abut 3dclust nsize
PROGRAMS_EXE = afni.exe to3d from3d abut 3dclust nsize 3dinfo 3dproject 3dmerge \
sfim tfim ftosh 3dttest 3ddup imrotate imreg imstat 3dnvals count \
fim2 imand FD2 sqwave immask imdump imaver 3dhistog 3dfim 3dGetrow \
@ -54,12 +54,10 @@
waver 3dnewid 3dcalc ccalc imcalc 1dmatcalc 3drefit 3dbucket \
3dAFNItoNIML AlphaSim 3dFWHM plugout_tt 3dnoise plugout_ijk \
3dMannWhitney 3dWilcoxon 3dKruskalWallis 3dFriedman 3dRegAna \
@@ -3927,9 +3927,10 @@ toyR: toyR.c AFNI_embeddedRCall.o
####
R_io.so:R_io.c $(LIBMRI_OBJ)
@@ -4093,7 +4093,10 @@ R_Makevars_mod_linux:
R_io.so: R_io.c $(LIBMRI_OBJ) $(R_MAKEVARS_DEP)
( if which R >/dev/null ; then \
- echo PKG_CPPFLAGS = $(INFLAGS) > Makevars ;\
- echo PKG_LIBS = $(LFLAGS) $(LLIBS) $(RLIB_CONVERT) >> Makevars ;\
- R CMD SHLIB -o R_io.so R_io.c ; \
+ echo PKG_CPPFLAGS = $(INFLAGS) -I${LOCALBASE}/lib/R/include > Makevars ;\
+ echo PKG_LIBS = $(LFLAGS) $(LLIBS) $(RLIB_CONVERT) -L${LOCALBASE}/lib/R/lib >> Makevars ;\

View file

@ -0,0 +1,15 @@
--- machdep.c.orig 2020-04-18 13:02:47 UTC
+++ machdep.c
@@ -2,7 +2,11 @@
#include "mrilib.h"
#ifndef DARWIN
-# include <malloc.h>
+# ifdef __FreeBSD__
+# include <stdlib.h>
+# else
+# include <malloc.h>
+# endif
#endif
#include <unistd.h>

View file

@ -33,6 +33,7 @@ bin/1dsvd
bin/1dtranspose
bin/24swap
bin/2dImReg
bin/2dcat
bin/2perm
bin/2swap
bin/3dABoverlap
@ -68,6 +69,7 @@ bin/3dClipLevel
bin/3dClustCount
bin/3dClustSim
bin/3dClusterize
bin/3dCompareAffine
bin/3dConformist
bin/3dConvolve
bin/3dCountSpikes
@ -104,8 +106,11 @@ bin/3dGrayplot
bin/3dGroupInCorr
bin/3dHist
bin/3dICA.R
bin/3dICC
bin/3dICC.R
bin/3dICC_REML.R
bin/3dISC
bin/3dISC.R
bin/3dIntracranial
bin/3dInvFMRI
bin/3dKS.R
@ -113,6 +118,8 @@ bin/3dKruskalWallis
bin/3dLFCD
bin/3dLME
bin/3dLME.R
bin/3dLMEr
bin/3dLMEr.R
bin/3dLRflip
bin/3dLSS
bin/3dLocalACF
@ -289,7 +296,6 @@ bin/@DO.examples
bin/@DTI_studio_reposition
bin/@DeblankFileNames
bin/@DiceMetric
bin/@DoPerRoi.py
bin/@DriveAfni
bin/@DriveSuma
bin/@ElectroGrid
@ -316,6 +322,7 @@ bin/@Install_FATCAT_DEMO
bin/@Install_FATCAT_DEMO2
bin/@Install_FATMVM_DEMO
bin/@Install_InstaCorr_Demo
bin/@Install_MACAQUE_DEMO
bin/@Install_MEICA_Demo
bin/@Install_NIH_Marmoset
bin/@Install_RSFMRI_Motion_Group_Demo
@ -354,9 +361,11 @@ bin/@VolCenter
bin/@afni.run.me
bin/@afni_R_package_install
bin/@afni_refacer_make_master
bin/@afni_refacer_make_master_addendum
bin/@afni_refacer_make_onebigA12
bin/@afni_refacer_run
bin/@align_partial_oblique
bin/@animal_warper
bin/@auto_align
bin/@auto_tlrc
bin/@build_afni_Xlib
@ -370,14 +379,12 @@ bin/@diff.files
bin/@diff.tree
bin/@djunct_4d_imager
bin/@djunct_4d_slices_to_3d_vol
bin/@djunct_calc_mont_dims.py
bin/@djunct_combine_str.py
bin/@djunct_anonymize
bin/@djunct_dwi_selector.tcsh
bin/@djunct_edgy_align_check
bin/@djunct_is_label.py
bin/@djunct_glue_imgs_vert
bin/@djunct_json_value.py
bin/@djunct_montage_coordinator
bin/@djunct_select_str.py
bin/@djunct_slice_space
bin/@djunct_vol_3slice_select
bin/@escape-
@ -405,6 +412,7 @@ bin/@simulate_motion
bin/@snapshot_volreg
bin/@snapshot_volreg3
bin/@statauxcode
bin/@suma_acknowledge
bin/@suma_reprefixize_spec
bin/@surf_to_vol_spackle
bin/@thickness_master
@ -422,6 +430,7 @@ bin/AnalyzeTrace
bin/BayesianGroupAna.R
bin/BayesianGroupAna.py
bin/BrainSkin
bin/CMakeLists.txt
bin/ClustExp_HistTable.py
bin/ClustExp_StatParse.py
bin/CompareSurfaces
@ -432,6 +441,7 @@ bin/CreateIcosahedron
bin/DTIStudioFibertoSegments
bin/Dimon
bin/Dimon1
bin/DoPerRoi.py
bin/DriveSuma
bin/ExamineXmat
bin/ExamineXmat.R
@ -482,31 +492,33 @@ bin/Vecwarp
bin/Xphace
bin/abids_json_info.py
bin/abids_json_tool.py
bin/abids_lib.py
bin/abids_tool.py
bin/abut
bin/adjunct_calc_mont_dims.py
bin/adjunct_combine_str.py
bin/adjunct_is_label.py
bin/adjunct_make_script_and_rst.py
bin/adjunct_select_str.py
bin/adwarp
bin/afni
bin/afni_base.py
bin/afni_check_omp
bin/afni_fs_aparc+aseg_2000.txt
bin/afni_fs_aparc+aseg_2009.txt
bin/afni_history
bin/afni_open
bin/afni_proc.py
bin/afni_python_wrapper.py
bin/afni_restproc.py
bin/afni_run_R
bin/afni_seeds_per_space.txt
bin/afni_skeleton.py
bin/afni_system_check.py
bin/afni_util.py
bin/afni_vcheck
bin/afni_xmat.py
bin/aiv
bin/align_epi_anat.py
bin/apqc_make_html.py
bin/apqc_make_tcsh.py
bin/apsearch
bin/ask_me.py
bin/auto_warp.py
bin/byteorder
bin/cat_matvec
@ -514,7 +526,6 @@ bin/ccalc
bin/cifti_tool
bin/column_cat
bin/count
bin/db_mod.py
bin/dcm2niix_afni
bin/demo.fixed.niml.do
bin/demo.mobile.niml.do
@ -522,6 +533,7 @@ bin/demoExpt.py
bin/dicom_hdr
bin/dicom_hinfo
bin/dicom_to_raw
bin/dsetstat2p
bin/eg_main_chrono.py
bin/ent16
bin/fat_lat_csv.py
@ -559,11 +571,6 @@ bin/get_afni_model_PRF
bin/get_afni_model_PRF_6
bin/get_afni_model_PRF_6_BAD
bin/gifti_tool
bin/gui_uber_align_test.py
bin/gui_uber_skel.py
bin/gui_uber_subj.py
bin/gui_uber_ttest.py
bin/gui_xmat.py
bin/help_format
bin/im2niml
bin/images_equal
@ -580,35 +587,6 @@ bin/imstack
bin/imstat
bin/imupsam
bin/inspec
bin/lib_RR_plot.py
bin/lib_afni1D.py
bin/lib_apqc_html.py
bin/lib_apqc_html_css.py
bin/lib_apqc_html_helps.py
bin/lib_apqc_io.py
bin/lib_apqc_tcsh.py
bin/lib_decay_timing.py
bin/lib_dti_sundry.py
bin/lib_fat_Rfactor.py
bin/lib_fat_funcs.py
bin/lib_fat_plot_sel.py
bin/lib_matplot.py
bin/lib_plot_1D.py
bin/lib_qt_gui.py
bin/lib_rand_timing.py
bin/lib_realtime.py
bin/lib_ss_review.py
bin/lib_subjects.py
bin/lib_surf_clustsim.py
bin/lib_system_check.py
bin/lib_textdata.py
bin/lib_timing.py
bin/lib_uber_align.py
bin/lib_uber_skel.py
bin/lib_uber_subject.py
bin/lib_uber_ttest.py
bin/lib_vars_object.py
bin/lib_wx.py
bin/lpc_align.py
bin/make_pq_script.py
bin/make_random_timing.py
@ -616,7 +594,6 @@ bin/make_stim_times.py
bin/map_TrackID
bin/mayo_analyze
bin/meica.py
bin/module_test_lib.py
bin/mritopgm
bin/mycat
bin/myget
@ -628,7 +605,6 @@ bin/nifti_tool
bin/niml_feedme
bin/niprobe
bin/nsize
bin/option_list.py
bin/p2dsetstat
bin/parse_fs_lt_log.py
bin/plugout_drive
@ -668,7 +644,6 @@ bin/uber_proc.py
bin/uber_skel.py
bin/uber_subject.py
bin/uber_ttest.py
bin/ui_xmat.py
bin/unWarpEPI.py
bin/uniq_images
bin/waver
@ -807,19 +782,74 @@ lib/afni/plug_vol2surf.so
lib/afni/plug_volreg.so
lib/afni/plug_wavelets.so
lib/afni/plug_zeropad.so
%%PYTHON_SITELIBDIR%%/afniRTI/__init__.py
%%PYTHON_SITELIBDIR%%/afniRTI/experiment.py
%%PYTHON_SITELIBDIR%%/afniRTI/realtime.py
%%PYTHON_SITELIBDIR%%/afniRTI/receiver.py
%%PYTHON_SITELIBDIR%%/afnipy/__init__.py
%%PYTHON_SITELIBDIR%%/afnipy/abids_lib.py
%%PYTHON_SITELIBDIR%%/afnipy/afni_base.py
%%PYTHON_SITELIBDIR%%/afnipy/afni_util.py
%%PYTHON_SITELIBDIR%%/afnipy/afni_xmat.py
%%PYTHON_SITELIBDIR%%/afnipy/ask_me.py
%%PYTHON_SITELIBDIR%%/afnipy/check_dset_for_fs.py
%%PYTHON_SITELIBDIR%%/afnipy/db_mod.py
%%PYTHON_SITELIBDIR%%/afnipy/epi_b0_correct.py
%%PYTHON_SITELIBDIR%%/afnipy/gui_uber_align_test.py
%%PYTHON_SITELIBDIR%%/afnipy/gui_uber_proc.py
%%PYTHON_SITELIBDIR%%/afnipy/gui_uber_skel.py
%%PYTHON_SITELIBDIR%%/afnipy/gui_uber_subj.py
%%PYTHON_SITELIBDIR%%/afnipy/gui_uber_ttest.py
%%PYTHON_SITELIBDIR%%/afnipy/gui_xmat.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_RR_plot.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_afni1D.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_ap_examples.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_apqc_html.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_apqc_html_css.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_apqc_io.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_apqc_tcsh.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_b0_corr.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_decay_timing.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_dti_sundry.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_fat_Rfactor.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_fat_funcs.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_fat_plot_sel.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_fs.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_gershgorin.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_info_dict.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_matplot.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_msar.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_plot_1D.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_qt_gui.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_rand_timing.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_realtime.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_ss_review.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_subjects.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_surf_clustsim.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_system_check.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_textdata.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_timing.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_uber_align.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_uber_proc.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_uber_skel.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_uber_subject.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_uber_ttest.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_vars_object.py
%%PYTHON_SITELIBDIR%%/afnipy/lib_wx.py
%%PYTHON_SITELIBDIR%%/afnipy/module_test_lib.py
%%PYTHON_SITELIBDIR%%/afnipy/niml_parsing.py
%%PYTHON_SITELIBDIR%%/afnipy/option_list.py
%%PYTHON_SITELIBDIR%%/afnipy/ui_xmat.py
%%DATADIR%%/AFNI.afnirc
%%DATADIR%%/AFNI.sumarc
%%DATADIR%%/afniInterfaceRT/__init__.py
%%DATADIR%%/afniInterfaceRT/experiment.py
%%DATADIR%%/afniInterfaceRT/realtime.py
%%DATADIR%%/afniInterfaceRT/receiver.py
%%DATADIR%%/afniInterfaceRT/testOS.py
%%DATADIR%%/afnigui.html
%%DATADIR%%/afnigui_cursor1030.jpg
%%DATADIR%%/afnigui_cursor1100.jpg
%%DATADIR%%/afnigui_logo.jpg
%%DATADIR%%/funstuff/afnimusic.au
%%DATADIR%%/funstuff/face_15k_jjlr.jpg
%%DATADIR%%/funstuff/face_7Tesla.jpg
%%DATADIR%%/funstuff/face_ABtwins.jpg
%%DATADIR%%/funstuff/face_AuroraRamos.jpg
%%DATADIR%%/funstuff/face_CassieK.jpg
%%DATADIR%%/funstuff/face_Eddie.jpg
@ -1017,6 +1047,7 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/funstuff/face_isaac.jpg
%%DATADIR%%/funstuff/face_jaehun.jpg
%%DATADIR%%/funstuff/face_jaehun2.jpg
%%DATADIR%%/funstuff/face_jane_ad.jpg
%%DATADIR%%/funstuff/face_javier_gonzalez-castillo.jpg
%%DATADIR%%/funstuff/face_jbacon.jpg
%%DATADIR%%/funstuff/face_jbinder.jpg
@ -1149,6 +1180,7 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/funstuff/face_patbedard.jpg
%%DATADIR%%/funstuff/face_patziad.jpg
%%DATADIR%%/funstuff/face_paul_taylor.1.jpg
%%DATADIR%%/funstuff/face_paul_taylor.2.jpg
%%DATADIR%%/funstuff/face_paul_taylor.jpg
%%DATADIR%%/funstuff/face_pba5.jpg
%%DATADIR%%/funstuff/face_pbdet.jpg
@ -1164,6 +1196,7 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/funstuff/face_phoebechan.jpg
%%DATADIR%%/funstuff/face_pilyoung_kim.jpg
%%DATADIR%%/funstuff/face_pkochunov.jpg
%%DATADIR%%/funstuff/face_plaid.jpg
%%DATADIR%%/funstuff/face_potomac.jpg
%%DATADIR%%/funstuff/face_prantik.jpg
%%DATADIR%%/funstuff/face_prowser.jpg
@ -1231,6 +1264,8 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/funstuff/face_rwcoxT.jpg
%%DATADIR%%/funstuff/face_rwcoxU.jpg
%%DATADIR%%/funstuff/face_rwcoxV.jpg
%%DATADIR%%/funstuff/face_rwcoxW.jpg
%%DATADIR%%/funstuff/face_rwcoxX.jpg
%%DATADIR%%/funstuff/face_rwcox_di_milano.jpg
%%DATADIR%%/funstuff/face_s_torrisi.jpg
%%DATADIR%%/funstuff/face_saccanch.jpg
@ -1260,6 +1295,7 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/funstuff/face_ssaad.jpg
%%DATADIR%%/funstuff/face_ssmall.jpg
%%DATADIR%%/funstuff/face_steverao.jpg
%%DATADIR%%/funstuff/face_stovetop.jpg
%%DATADIR%%/funstuff/face_stu_white.jpg
%%DATADIR%%/funstuff/face_sudre_gustavo.jpg
%%DATADIR%%/funstuff/face_sule_tinaz.jpg
@ -1300,6 +1336,7 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/funstuff/face_yaqiong_xiao.jpg
%%DATADIR%%/funstuff/face_yarik_halchenko.jpg
%%DATADIR%%/funstuff/face_yingyingwang.jpg
%%DATADIR%%/funstuff/face_yoichi.jpg
%%DATADIR%%/funstuff/face_zman.jpg
%%DATADIR%%/funstuff/face_zsaad.jpg
%%DATADIR%%/funstuff/face_zsaad2.jpg
@ -1328,12 +1365,57 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/funstuff/poem_ww2.txt
%%DATADIR%%/funstuff/splash_12Apostles.jpg
%%DATADIR%%/funstuff/splash_3monkeys.jpg
%%DATADIR%%/funstuff/splash_AFNIbasque.jpg
%%DATADIR%%/funstuff/splash_Airplane.Wing.BG.jpg
%%DATADIR%%/funstuff/splash_Bldg35A_BG.jpg
%%DATADIR%%/funstuff/splash_Bpark.jpg
%%DATADIR%%/funstuff/splash_CanalA_BG.jpg
%%DATADIR%%/funstuff/splash_CanalB_BG.jpg
%%DATADIR%%/funstuff/splash_Canal_BG.jpg
%%DATADIR%%/funstuff/splash_DCdome.jpg
%%DATADIR%%/funstuff/splash_Escalator_BG.jpg
%%DATADIR%%/funstuff/splash_Feb2016.jpg
%%DATADIR%%/funstuff/splash_GFalls.jpg
%%DATADIR%%/funstuff/splash_HKferris_BG.jpg
%%DATADIR%%/funstuff/splash_KUMC.jpg
%%DATADIR%%/funstuff/splash_LeaveX3_BG.jpg
%%DATADIR%%/funstuff/splash_Lincoln.BG.jpg
%%DATADIR%%/funstuff/splash_Lincoln.Mem.Sunset.BG.jpg
%%DATADIR%%/funstuff/splash_Lincoln.Mem.Sunset2.BG.jpg
%%DATADIR%%/funstuff/splash_Lucca.Cafe2.BG.jpg
%%DATADIR%%/funstuff/splash_Lucca.Dinner.VBG.jpg
%%DATADIR%%/funstuff/splash_Monastery_BG.jpg
%%DATADIR%%/funstuff/splash_NIH.B1.frontB.jpg
%%DATADIR%%/funstuff/splash_NIH.B10.southdoors.BG.jpg
%%DATADIR%%/funstuff/splash_NIH.B33.cut.jpg
%%DATADIR%%/funstuff/splash_NIH.B49_trees_BG.jpg
%%DATADIR%%/funstuff/splash_NIH.Natcher.sideBG.jpg
%%DATADIR%%/funstuff/splash_NIHB40.jpg
%%DATADIR%%/funstuff/splash_NIH_Bld50_Weird_VG.jpg
%%DATADIR%%/funstuff/splash_NIH_Bldg50A_Weird_VG.jpg
%%DATADIR%%/funstuff/splash_NIH_fenceB_VG.jpg
%%DATADIR%%/funstuff/splash_NIH_fenceZ.jpg
%%DATADIR%%/funstuff/splash_NIHwalk_VG.jpg
%%DATADIR%%/funstuff/splash_NMcloud.jpg
%%DATADIR%%/funstuff/splash_Patan_VGGc.jpg
%%DATADIR%%/funstuff/splash_Pisa_BG.jpg
%%DATADIR%%/funstuff/splash_Potomac1_VG.jpg
%%DATADIR%%/funstuff/splash_Roma.Legs.BG.jpg
%%DATADIR%%/funstuff/splash_Singapore-MBSday.jpg
%%DATADIR%%/funstuff/splash_Singapore-MBSnight.jpg
%%DATADIR%%/funstuff/splash_Singapore-NUS.jpg
%%DATADIR%%/funstuff/splash_Singapore-Skyline.jpg
%%DATADIR%%/funstuff/splash_SmithFountain_VG.jpg
%%DATADIR%%/funstuff/splash_Strollers_VG.jpg
%%DATADIR%%/funstuff/splash_Sunset_VG.jpg
%%DATADIR%%/funstuff/splash_Traffic_VG.jpg
%%DATADIR%%/funstuff/splash_UWash.kayakBG.jpg
%%DATADIR%%/funstuff/splash_Utah_Dog.jpg
%%DATADIR%%/funstuff/splash_Utah_Tree.jpg
%%DATADIR%%/funstuff/splash_Wave_VG.jpg
%%DATADIR%%/funstuff/splash_Window_VG.jpg
%%DATADIR%%/funstuff/splash_aboot_nih_nov_2019.jpg
%%DATADIR%%/funstuff/splash_aboot_nih_nov_2019b.jpg
%%DATADIR%%/funstuff/splash_afnicake20.jpg
%%DATADIR%%/funstuff/splash_afnicalling.jpg
%%DATADIR%%/funstuff/splash_afniegypt.jpg
@ -1344,6 +1426,7 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/funstuff/splash_afnisun2.jpg
%%DATADIR%%/funstuff/splash_afnitree.jpg
%%DATADIR%%/funstuff/splash_airplane.jpg
%%DATADIR%%/funstuff/splash_airplane_blue.jpg
%%DATADIR%%/funstuff/splash_allfaces.jpg
%%DATADIR%%/funstuff/splash_angkorwat.jpg
%%DATADIR%%/funstuff/splash_arno.jpg
@ -1355,6 +1438,7 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/funstuff/splash_barcelona.jpg
%%DATADIR%%/funstuff/splash_bawiti.jpg
%%DATADIR%%/funstuff/splash_beijingnormal.jpg
%%DATADIR%%/funstuff/splash_bethesda_storm.jpg
%%DATADIR%%/funstuff/splash_betshean.jpg
%%DATADIR%%/funstuff/splash_birds.jpg
%%DATADIR%%/funstuff/splash_blackdesert.jpg
@ -1435,6 +1519,7 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/funstuff/splash_karski.jpg
%%DATADIR%%/funstuff/splash_kebb.jpg
%%DATADIR%%/funstuff/splash_kissing.jpg
%%DATADIR%%/funstuff/splash_korea2019.jpg
%%DATADIR%%/funstuff/splash_lasvegas.jpg
%%DATADIR%%/funstuff/splash_laworder.jpg
%%DATADIR%%/funstuff/splash_leaves2018.jpg
@ -1456,6 +1541,7 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/funstuff/splash_monastery.jpg
%%DATADIR%%/funstuff/splash_monks.jpg
%%DATADIR%%/funstuff/splash_monumentvalley.jpg
%%DATADIR%%/funstuff/splash_moria.jpg
%%DATADIR%%/funstuff/splash_mteverest.jpg
%%DATADIR%%/funstuff/splash_mtyale.jpg
%%DATADIR%%/funstuff/splash_nashville.jpg
@ -1463,22 +1549,29 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/funstuff/splash_nepalbridge.jpg
%%DATADIR%%/funstuff/splash_nepalmani.jpg
%%DATADIR%%/funstuff/splash_nepalphortse.jpg
%%DATADIR%%/funstuff/splash_nih_angel.jpg
%%DATADIR%%/funstuff/splash_nih_towers.jpg
%%DATADIR%%/funstuff/splash_nihb31.jpg
%%DATADIR%%/funstuff/splash_nihb50.jpg
%%DATADIR%%/funstuff/splash_nihfall2014.jpg
%%DATADIR%%/funstuff/splash_nihfence.jpg
%%DATADIR%%/funstuff/splash_nihwalk.jpg
%%DATADIR%%/funstuff/splash_nimhans2020dti.jpg
%%DATADIR%%/funstuff/splash_njit_2019.jpg
%%DATADIR%%/funstuff/splash_okazaki_A.jpg
%%DATADIR%%/funstuff/splash_onprc_2019.jpg
%%DATADIR%%/funstuff/splash_palenque.jpg
%%DATADIR%%/funstuff/splash_palk.jpg
%%DATADIR%%/funstuff/splash_pba5.jpg
%%DATADIR%%/funstuff/splash_petra.jpg
%%DATADIR%%/funstuff/splash_petratreasury.jpg
%%DATADIR%%/funstuff/splash_pgimer2020dti.jpg
%%DATADIR%%/funstuff/splash_pinkrock.jpg
%%DATADIR%%/funstuff/splash_pisa.jpg
%%DATADIR%%/funstuff/splash_pisa2010.jpg
%%DATADIR%%/funstuff/splash_pot.jpg
%%DATADIR%%/funstuff/splash_potomac.jpg
%%DATADIR%%/funstuff/splash_potomac2.jpg
%%DATADIR%%/funstuff/splash_prayerflags.jpg
%%DATADIR%%/funstuff/splash_qufu.jpg
%%DATADIR%%/funstuff/splash_rapture.jpg
@ -1492,11 +1585,13 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/funstuff/splash_sdyb.jpg
%%DATADIR%%/funstuff/splash_seoul.jpg
%%DATADIR%%/funstuff/splash_seoul2011.jpg
%%DATADIR%%/funstuff/splash_sgfountain.jpg
%%DATADIR%%/funstuff/splash_shadowbob.jpg
%%DATADIR%%/funstuff/splash_sharksign.jpg
%%DATADIR%%/funstuff/splash_shenzhen.jpg
%%DATADIR%%/funstuff/splash_sixpoles.jpg
%%DATADIR%%/funstuff/splash_skullarch.jpg
%%DATADIR%%/funstuff/splash_sky2_VG.jpg
%%DATADIR%%/funstuff/splash_snowzilla.jpg
%%DATADIR%%/funstuff/splash_soren.jpg
%%DATADIR%%/funstuff/splash_squidding.jpg
@ -1518,9 +1613,11 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/funstuff/splash_thewave3.jpg
%%DATADIR%%/funstuff/splash_titicaca.jpg
%%DATADIR%%/funstuff/splash_todaiji.jpg
%%DATADIR%%/funstuff/splash_trees5_VG.jpg
%%DATADIR%%/funstuff/splash_troll.jpg
%%DATADIR%%/funstuff/splash_tuebingen.jpg
%%DATADIR%%/funstuff/splash_tulips.jpg
%%DATADIR%%/funstuff/splash_tulips_VG.jpg
%%DATADIR%%/funstuff/splash_tulsa2011.jpg
%%DATADIR%%/funstuff/splash_tulsa2016.jpg
%%DATADIR%%/funstuff/splash_twinkies.jpg
@ -1834,6 +1931,7 @@ lib/afni/plug_zeropad.so
%%DATADIR%%/shiny/FATCAT_matplot_shiny/stat_methods.csv
%%DATADIR%%/shiny/FATCAT_matplot_shiny/ui.R
%%DATADIR%%/shiny/misc/OmicCircos_pkg_install.R
%%PORTDOCS%%%%DOCSDIR%%/CMakeLists.txt
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.Ifile
%%PORTDOCS%%%%DOCSDIR%%/README.afnigui