The xview "props" program. It allows users to interactively

customise workspace properties such as colours, icon placement, menus etc.
This commit is contained in:
James Raynard 1998-01-04 22:31:26 +00:00
parent 0e551374f3
commit d01b5f5650
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=9264
8 changed files with 82 additions and 0 deletions

25
x11/props/Makefile Normal file
View file

@ -0,0 +1,25 @@
# New ports collection makefile for: props
# Version required: 1.0
# Date created: 3 January 1998
# Whom: jraynard
#
# $Id$
#
DISTNAME= props-1.0
CATEGORIES= x11
MASTER_SITES= http://www.freebsd.org/~jraynard/ports/distfiles/
MAINTAINER= jraynard@@freebsd.org
WRKSRC= ${WRKDIR}/props
LIB_DEPENDS= xview\\.3\\.:${PORTSDIR}/x11/xview-lib
USE_IMAKE= yes
post-install:
${MKDIR} ${X11BASE}/lib/X11/locale/C/props; \
${INSTALL_DATA} ${WRKSRC}/C/* ${X11BASE}/lib/X11/locale/C/props
.include <bsd.port.mk>

1
x11/props/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (props-1.0.tar.gz) = 5101b277c26dcfc368b23f65c79c6fc7

12
x11/props/files/patch-aa Normal file
View file

@ -0,0 +1,12 @@
--- l10n_props.h.orig Tue Nov 4 20:36:07 1997
+++ l10n_props.h Tue Nov 4 20:36:31 1997
@@ -13,6 +13,9 @@
*/
#define LOCALE_NAME_LEN 20
+#ifndef LC_MESSAGES
+#define LC_MESSAGES 0
+#endif
typedef struct _l10n_config_list_item {
/*

22
x11/props/files/patch-ab Normal file
View file

@ -0,0 +1,22 @@
--- l10n_read.c.orig Sat Nov 8 01:21:25 1997
+++ l10n_read.c Sun Nov 9 01:44:10 1997
@@ -18,7 +18,7 @@
#include "l10n_props.h"
-#define MAX_LINE_LENGTH 256
+#define MAX_LINE_LENGTH 2560
#define NAME_SEPARATOR '='
#define FIELD_SEPARATOR '|'
@@ -72,8 +72,9 @@
/*
* Find path for localization configuration files under
* $OPENWINHOME/share/locale/<locale>/props
+ * $OPENWINHOME/lib/X11/locale/<locale>/props
*/
- sprintf(fullpath, "%s/share/locale/%s/props/%s",
+ sprintf(fullpath, "%s/lib/X11/locale/%s/props/%s",
getenv("OPENWINHOME"), locale, file_name);
if ((config_file = fopen(fullpath, "r")) == NULL)

11
x11/props/files/patch-ac Normal file
View file

@ -0,0 +1,11 @@
--- props.c.orig Sun Nov 9 01:18:50 1997
+++ props.c Sun Nov 9 01:24:50 1997
@@ -816,7 +816,7 @@
else
{
strcpy(localepath, openwin_dir);
- strcat(localepath, "/lib/locale/");
+ strcat(localepath, "/lib/X11/locale/C/");
bindtextdomain("props", localepath);
}

1
x11/props/pkg-comment Normal file
View file

@ -0,0 +1 @@
The OpenLook props application.

3
x11/props/pkg-descr Normal file
View file

@ -0,0 +1,3 @@
The XView properties editor allows the user to customise and
configure many workspace properties (colour, icons, menus,
mouse and localisation).

7
x11/props/pkg-plist Normal file
View file

@ -0,0 +1,7 @@
bin/props
lib/X11/locale/C/props/C
lib/X11/locale/C/props/basic_setting
lib/X11/locale/C/props/en_AU
lib/X11/locale/C/props/en_CA
lib/X11/locale/C/props/en_UK
lib/X11/locale/C/props/en_US