Add libgmp 2001.08.07, a library for arbitrary precision arithmetic.
Note: This package contains version the the library just before it was removed from the FreeBSD base system (5-CURRENT, mid-August 2001) and it is provided solely for compatibility with packages that require it.
This commit is contained in:
parent
c420e56452
commit
d03c908f0d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=47025
13 changed files with 133 additions and 0 deletions
|
@ -39,6 +39,7 @@
|
||||||
SUBDIR += guppi
|
SUBDIR += guppi
|
||||||
SUBDIR += hexcalc
|
SUBDIR += hexcalc
|
||||||
SUBDIR += lapack
|
SUBDIR += lapack
|
||||||
|
SUBDIR += libgmp
|
||||||
SUBDIR += libgmp3
|
SUBDIR += libgmp3
|
||||||
SUBDIR += libneural
|
SUBDIR += libneural
|
||||||
SUBDIR += libranlib
|
SUBDIR += libranlib
|
||||||
|
|
28
math/libgmp-freebsd/Makefile
Normal file
28
math/libgmp-freebsd/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
||||||
|
# New ports collection makefile for: libgmp
|
||||||
|
# Date created: 28 August 2001
|
||||||
|
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||||
|
#
|
||||||
|
# $FreeBSD$
|
||||||
|
#
|
||||||
|
|
||||||
|
PORTNAME= libgmp
|
||||||
|
PORTVERSION= 2001.08.07
|
||||||
|
CATEGORIES= math
|
||||||
|
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||||
|
MASTER_SITE_SUBDIR= sobomax
|
||||||
|
|
||||||
|
MAINTAINER= ports@FreeBSD.org
|
||||||
|
|
||||||
|
USE_BZIP2= yes
|
||||||
|
INSTALLS_SHLIB= yes
|
||||||
|
MAKE_FLAGS= INCDIR=${PREFIX}/include \
|
||||||
|
LIBDIR=${PREFIX}/lib \
|
||||||
|
INFODIR=${PREFIX}/info
|
||||||
|
|
||||||
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
|
.if ${OSVERSION} < 500000
|
||||||
|
IGNORE= "is in the base system"
|
||||||
|
.endif
|
||||||
|
|
||||||
|
.include <bsd.port.post.mk>
|
1
math/libgmp-freebsd/distinfo
Normal file
1
math/libgmp-freebsd/distinfo
Normal file
|
@ -0,0 +1 @@
|
||||||
|
MD5 (libgmp-2001.08.07.tar.bz2) = 2309c9bb312c68a7aa2a957197104b0b
|
14
math/libgmp-freebsd/files/patch-Makefile
Normal file
14
math/libgmp-freebsd/files/patch-Makefile
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
|
||||||
|
$FreeBSD$
|
||||||
|
|
||||||
|
--- Makefile 2001/08/28 16:21:28 1.1
|
||||||
|
+++ Makefile 2001/08/28 16:21:41
|
||||||
|
@@ -145,7 +145,7 @@
|
||||||
|
|
||||||
|
beforeinstall:
|
||||||
|
${INSTALL} -C -o ${BINOWN} -g ${BINGRP} -m 444 \
|
||||||
|
- ${GMPDIR}/gmp.h ${DESTDIR}/usr/include
|
||||||
|
+ ${GMPDIR}/gmp.h ${DESTDIR}${INCDIR}
|
||||||
|
|
||||||
|
.include "Makefile.inc"
|
||||||
|
.include <bsd.lib.mk>
|
1
math/libgmp-freebsd/pkg-comment
Normal file
1
math/libgmp-freebsd/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
||||||
|
A library for arbitrary precision arithmetic
|
17
math/libgmp-freebsd/pkg-descr
Normal file
17
math/libgmp-freebsd/pkg-descr
Normal file
|
@ -0,0 +1,17 @@
|
||||||
|
GNU MP is a library for arbitrary precision arithmetic, operating on signed
|
||||||
|
integers, rational numbers, and floating point numbers. It has a rich set
|
||||||
|
of functions, and the functions have a regular interface.
|
||||||
|
|
||||||
|
GNU MP is designed to be as fast as possible, both for small operands and for
|
||||||
|
huge operands. The speed is achieved by using fullwords as the basic
|
||||||
|
arithmetic type, by using fast algorithms, by carefully optimized assembly
|
||||||
|
code for the most common inner loops for a lots of CPUs, and by a general
|
||||||
|
emphasis on speed (instead of simplicity or elegance).
|
||||||
|
|
||||||
|
The speed of GNU MP is believed to be faster than any other similar library.
|
||||||
|
The advantage for GNU MP increases with the operand sizes for certain
|
||||||
|
operations, since GNU MP in many cases has asymptotically faster algorithms.
|
||||||
|
|
||||||
|
Note: This package contains version the the library just before it was
|
||||||
|
removed from the FreeBSD base system (5-CURRENT, mid-August 2001) and it is
|
||||||
|
provided solely for compatibility with packages that require it.
|
5
math/libgmp-freebsd/pkg-plist
Normal file
5
math/libgmp-freebsd/pkg-plist
Normal file
|
@ -0,0 +1,5 @@
|
||||||
|
include/gmp.h
|
||||||
|
info/gmp.info.gz
|
||||||
|
lib/libgmp.a
|
||||||
|
lib/libgmp.so
|
||||||
|
lib/libgmp.so.3
|
28
math/libgmp/Makefile
Normal file
28
math/libgmp/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
||||||
|
# New ports collection makefile for: libgmp
|
||||||
|
# Date created: 28 August 2001
|
||||||
|
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
|
||||||
|
#
|
||||||
|
# $FreeBSD$
|
||||||
|
#
|
||||||
|
|
||||||
|
PORTNAME= libgmp
|
||||||
|
PORTVERSION= 2001.08.07
|
||||||
|
CATEGORIES= math
|
||||||
|
MASTER_SITES= ${MASTER_SITE_LOCAL}
|
||||||
|
MASTER_SITE_SUBDIR= sobomax
|
||||||
|
|
||||||
|
MAINTAINER= ports@FreeBSD.org
|
||||||
|
|
||||||
|
USE_BZIP2= yes
|
||||||
|
INSTALLS_SHLIB= yes
|
||||||
|
MAKE_FLAGS= INCDIR=${PREFIX}/include \
|
||||||
|
LIBDIR=${PREFIX}/lib \
|
||||||
|
INFODIR=${PREFIX}/info
|
||||||
|
|
||||||
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
|
.if ${OSVERSION} < 500000
|
||||||
|
IGNORE= "is in the base system"
|
||||||
|
.endif
|
||||||
|
|
||||||
|
.include <bsd.port.post.mk>
|
1
math/libgmp/distinfo
Normal file
1
math/libgmp/distinfo
Normal file
|
@ -0,0 +1 @@
|
||||||
|
MD5 (libgmp-2001.08.07.tar.bz2) = 2309c9bb312c68a7aa2a957197104b0b
|
14
math/libgmp/files/patch-Makefile
Normal file
14
math/libgmp/files/patch-Makefile
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
|
||||||
|
$FreeBSD$
|
||||||
|
|
||||||
|
--- Makefile 2001/08/28 16:21:28 1.1
|
||||||
|
+++ Makefile 2001/08/28 16:21:41
|
||||||
|
@@ -145,7 +145,7 @@
|
||||||
|
|
||||||
|
beforeinstall:
|
||||||
|
${INSTALL} -C -o ${BINOWN} -g ${BINGRP} -m 444 \
|
||||||
|
- ${GMPDIR}/gmp.h ${DESTDIR}/usr/include
|
||||||
|
+ ${GMPDIR}/gmp.h ${DESTDIR}${INCDIR}
|
||||||
|
|
||||||
|
.include "Makefile.inc"
|
||||||
|
.include <bsd.lib.mk>
|
1
math/libgmp/pkg-comment
Normal file
1
math/libgmp/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
||||||
|
A library for arbitrary precision arithmetic
|
17
math/libgmp/pkg-descr
Normal file
17
math/libgmp/pkg-descr
Normal file
|
@ -0,0 +1,17 @@
|
||||||
|
GNU MP is a library for arbitrary precision arithmetic, operating on signed
|
||||||
|
integers, rational numbers, and floating point numbers. It has a rich set
|
||||||
|
of functions, and the functions have a regular interface.
|
||||||
|
|
||||||
|
GNU MP is designed to be as fast as possible, both for small operands and for
|
||||||
|
huge operands. The speed is achieved by using fullwords as the basic
|
||||||
|
arithmetic type, by using fast algorithms, by carefully optimized assembly
|
||||||
|
code for the most common inner loops for a lots of CPUs, and by a general
|
||||||
|
emphasis on speed (instead of simplicity or elegance).
|
||||||
|
|
||||||
|
The speed of GNU MP is believed to be faster than any other similar library.
|
||||||
|
The advantage for GNU MP increases with the operand sizes for certain
|
||||||
|
operations, since GNU MP in many cases has asymptotically faster algorithms.
|
||||||
|
|
||||||
|
Note: This package contains version the the library just before it was
|
||||||
|
removed from the FreeBSD base system (5-CURRENT, mid-August 2001) and it is
|
||||||
|
provided solely for compatibility with packages that require it.
|
5
math/libgmp/pkg-plist
Normal file
5
math/libgmp/pkg-plist
Normal file
|
@ -0,0 +1,5 @@
|
||||||
|
include/gmp.h
|
||||||
|
info/gmp.info.gz
|
||||||
|
lib/libgmp.a
|
||||||
|
lib/libgmp.so
|
||||||
|
lib/libgmp.so.3
|
Loading…
Reference in a new issue