dns/dnsmasq: update to 2.81, unlink dnsmasq-devel

Update dns/dnsmasq to the new upstream version 2.81.
The Makefile has been rearranged with portfmt, except the
LDFLAGS+=..._intllibs... line that portfmt does not recognize.

Changelog:
<http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=blob;f=CHANGELOG;h=60b08d015b2d5a979f39b8ad43633b419135cb64;hb=7ddb99d251c3f5870c8c308a98bb8f283c831872#l1>
(or see CHANGELOG in the package)

Unlink dnsmasq-devel from the build, but keep the sources,
and mark it IGNORE and list dnsmasq-devel in MOVED.
This commit is contained in:
Matthias Andree 2020-04-12 01:59:59 +00:00
parent 2da3f1a9f1
commit d09a1f90f6
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=531473
7 changed files with 66 additions and 94 deletions

1
MOVED
View file

@ -14523,3 +14523,4 @@ devel/rubygem-cucumber-tag_expressions|devel/rubygem-cucumber-tag-expressions|20
devel/p5-Glib2|devel/p5-Glib|2020-04-07|Rename to match our p5- port naming
devel/jucipp|editors/jucipp|2020-04-07|Remove duplicate
www/py-django_polymorphic|www/py-django-polymorphic|2020-04-11|Match canonical/registered (PyPI/CHEESESHOP) name
dns/dnsmasq-devel|dns/dnsmasq|2020-04-12|dnsmasq is newer than dnsmasq-devel

View file

@ -48,7 +48,6 @@
SUBDIR += dnshistory
SUBDIR += dnsjava
SUBDIR += dnsmasq
SUBDIR += dnsmasq-devel
SUBDIR += dnsmax-perl
SUBDIR += dnsperf
SUBDIR += dnsproxy

View file

@ -14,37 +14,45 @@ COMMENT= Lightweight DNS forwarder, DHCP, and TFTP server
LICENSE= GPLv2
IGNORE= please use dns/dnsmasq, which is newer, instead
USES= cpe shebangfix tar:xz
CONFLICTS_INSTALL=dnsmasq-2*
CONFLICTS_INSTALL= dnsmasq-2*
PORTDOCS= CHANGELOG CHANGELOG.archive FAQ doc.html setup.html
SUB_FILES= pkg-message
CFLAGS+= -Wall -Wno-unused-value -Wno-unused-parameter -Wno-unused-variable -Wno-unused-function
CFLAGS+= -Wall -Wno-unused-function -Wno-unused-parameter \
-Wno-unused-value -Wno-unused-variable
CPPFLAGS+= -I${LOCALBASE}/include
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" PREFIX="${PREFIX}" COPTS="${CFLAGS}" LIBS="${LDFLAGS}" RPM_OPT_FLAGS="${CPPFLAGS}"
MAKE_ARGS= CC="${CC}" \
CFLAGS="${CFLAGS}" \
COPTS="${CFLAGS}" \
LIBS="${LDFLAGS}" \
PREFIX="${PREFIX}" \
RPM_OPT_FLAGS="${CPPFLAGS}"
OPTIONS_DEFINE= IPSET IPV6 DBUS LUA DNSSEC DOCS
OPTIONS_DEFINE= DBUS DNSSEC DOCS IPSET IPV6 LUA
OPTIONS_DEFAULT= DNSSEC IPSET
OPTIONS_EXCLUDE+= EXAMPLES
OPTIONS_RADIO= INTL
OPTIONS_RADIO_INTL= IDN NLS
INTL_DESC= Internationalization Support Level
NLS_DESC= IDN+NLS: Int'l Domain Names & National Language support
IDN_DESC= IDN: Int'l Domain Names WITHOUT full NLS
IPSET_DESC= Dynamic firewall management of resolved names (needs PF)
LUA_DESC= Support lease-change scripts written in Lua
DNSSEC_DESC= Enable DNSSEC caching and validation
SHEBANG_FILES= contrib/dynamic-dnsmasq/dynamic-dnsmasq.pl \
contrib/dnslist/dnslist.pl
CPE_VENDOR= thekelleys
CPE_VERSION= ${DISTVERSION:C/r.*//}
CPE_UPDATE= ${DISTVERSION:C/.*rc/rc/}
INTL_DESC= Internationalization Support Level
NLS_DESC= IDN+NLS: Int'l Domain Names & National Language support
IDN_DESC= IDN: Int'l Domain Names WITHOUT full NLS
IPSET_DESC= Dynamic firewall management of resolved names (needs PF)
LUA_DESC= Support lease-change scripts written in Lua
DNSSEC_DESC= Enable DNSSEC caching and validation
SHEBANG_FILES= contrib/dnslist/dnslist.pl \
contrib/dynamic-dnsmasq/dynamic-dnsmasq.pl
CPE_VENDOR= thekelleys
CPE_VERSION= ${DISTVERSION:C/r.*//}
CPE_UPDATE= ${DISTVERSION:C/.*rc/rc/}
IPV6_CFLAGS_OFF=-DNO_IPV6
IPSET_CFLAGS_OFF=-DNO_IPSET
IPV6_CFLAGS_OFF= -DNO_IPV6
IPSET_CFLAGS_OFF= -DNO_IPSET
.include <bsd.port.options.mk>
@ -84,15 +92,15 @@ USES+= lua pkgconfig
.if ${PORT_OPTIONS:MDNSSEC}
CFLAGS+= -DHAVE_DNSSEC -I${LOCALBASE}/include
USES+= pkgconfig
LIB_DEPENDS+= libnettle.so:security/nettle
LIB_DEPENDS+= libgmp.so:math/gmp
LIB_DEPENDS+= libgmp.so:math/gmp \
libnettle.so:security/nettle
.endif
USE_RC_SUBR= dnsmasq
.include <bsd.port.pre.mk>
LDFLAGS+= -L${LOCALBASE}/lib ${_intllibs} ${ICONV_LIB}
LDFLAGS+= ${_intllibs} ${ICONV_LIB} -L${LOCALBASE}/lib
pre-configure: pretty-print-config
.if ${PORT_OPTIONS:MIDN}

View file

@ -2,8 +2,9 @@
# $FreeBSD$
PORTNAME= dnsmasq
DISTVERSION= 2.80
PORTREVISION= 4 # leave this in even if 0 to avoid PORTEPOCH bumps
DISTVERSION= 2.81
# Leave the PORTREVISION in even if 0 to avoid accidental PORTEPOCH bumps:
PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= dns
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/ \
@ -14,34 +15,43 @@ COMMENT= Lightweight DNS forwarder, DHCP, and TFTP server
LICENSE= GPLv2
CONFLICTS_INSTALL=dnsmasq-devel-*
USES= cpe shebangfix tar:xz
CPE_VENDOR= thekelleys
PORTDOCS= CHANGELOG CHANGELOG.archive FAQ doc.html setup.html
SHEBANG_FILES= contrib/dnslist/dnslist.pl \
contrib/dynamic-dnsmasq/dynamic-dnsmasq.pl
MAKE_ARGS= CC="${CC}" \
CFLAGS="${CFLAGS}" \
COPTS="${CFLAGS}" \
LIBS="${LDFLAGS}" \
PREFIX="${PREFIX}" \
RPM_OPT_FLAGS="${CPPFLAGS}"
CFLAGS+= -Wall -Wno-unused-function -Wno-unused-parameter \
-Wno-unused-value -Wno-unused-variable
CPPFLAGS+= -I${LOCALBASE}/include
CONFLICTS_INSTALL= dnsmasq-devel-*
SUB_FILES= pkg-message
CFLAGS+= -Wall -Wno-unused-value -Wno-unused-parameter -Wno-unused-variable -Wno-unused-function
CPPFLAGS+= -I${LOCALBASE}/include
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" PREFIX="${PREFIX}" COPTS="${CFLAGS}" LIBS="${LDFLAGS}" RPM_OPT_FLAGS="${CPPFLAGS}"
PORTDOCS= CHANGELOG CHANGELOG.archive FAQ doc.html setup.html
OPTIONS_DEFINE= IPSET IPV6 DBUS LUA DNSSEC DOCS
OPTIONS_DEFINE= DBUS DNSSEC DOCS IPSET IPV6 LUA
OPTIONS_DEFAULT= DNSSEC IPSET
OPTIONS_EXCLUDE+= EXAMPLES
OPTIONS_RADIO= INTL
OPTIONS_RADIO_INTL= IDN NLS
INTL_DESC= Internationalization Support Level
NLS_DESC= IDN+NLS: Int'l Domain Names & National Language support
OPTIONS_EXCLUDE+= EXAMPLES
DNSSEC_DESC= Enable DNSSEC caching and validation (needs nettle)
IDN_DESC= IDN: Int'l Domain Names WITHOUT full NLS
INTL_DESC= Internationalization Support Level
IPSET_DESC= Dynamic firewall management of resolved names (needs PF)
LUA_DESC= Support lease-change scripts written in Lua
DNSSEC_DESC= Enable DNSSEC caching and validation
USES= cpe shebangfix tar:xz
SHEBANG_FILES= contrib/dynamic-dnsmasq/dynamic-dnsmasq.pl \
contrib/dnslist/dnslist.pl
CPE_VENDOR= thekelleys
NLS_DESC= IDN+NLS: Int'l Domain Names & National Language support
IPV6_CFLAGS_OFF=-DNO_IPV6
IPSET_CFLAGS_OFF=-DNO_IPSET
IPSET_CFLAGS_OFF= -DNO_IPSET
IPV6_CFLAGS_OFF= -DNO_IPV6
.include <bsd.port.options.mk>
@ -75,14 +85,14 @@ LDFLAGS+= `pkg-config --libs dbus-1`
CPPFLAGS+= -I${LUA_INCDIR}
CFLAGS+= -DHAVE_LUASCRIPT
LDFLAGS+= -L${LUA_LIBDIR} -llua-${LUA_VER}
USES+= lua
USES+= lua pkgconfig
.endif
.if ${PORT_OPTIONS:MDNSSEC}
CFLAGS+= -DHAVE_DNSSEC -I${LOCALBASE}/include
USES+= pkgconfig
LIB_DEPENDS+= libnettle.so:security/nettle
LIB_DEPENDS+= libgmp.so:math/gmp
LIB_DEPENDS+= libgmp.so:math/gmp \
libnettle.so:security/nettle
.endif
USE_RC_SUBR= dnsmasq
@ -91,6 +101,9 @@ USE_RC_SUBR= dnsmasq
LDFLAGS+= -L${LOCALBASE}/lib ${_intllibs} ${ICONV_LIB}
post-patch:
${REINPLACE_CMD} -e '/^lua_/s/lua5\.2/lua-${LUA_VER}/' ${WRKSRC}/Makefile
pre-configure: pretty-print-config
.if ${PORT_OPTIONS:MIDN}
.if empty(PORT_OPTIONS:MNLS)

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1539932660
SHA256 (dnsmasq-2.80.tar.xz) = cdaba2785e92665cf090646cba6f94812760b9d7d8c8d0cfb07ac819377a63bb
SIZE (dnsmasq-2.80.tar.xz) = 501072
TIMESTAMP = 1586652751
SHA256 (dnsmasq-2.81.tar.xz) = 749ca903537c5197c26444ac24b0dce242cf42595fdfe6b9a5b9e4c7ad32f8fb
SIZE (dnsmasq-2.81.tar.xz) = 510648

View file

@ -1,31 +0,0 @@
--- src/crypto.c.orig 2018-10-18 18:21:55 UTC
+++ src/crypto.c
@@ -275,6 +275,10 @@ static int dnsmasq_ecdsa_verify(struct blockdata *key_
static struct ecc_point *key_256 = NULL, *key_384 = NULL;
static mpz_t x, y;
static struct dsa_signature *sig_struct;
+#if NETTLE_VERSION_MAJOR == 3 && NETTLE_VERSION_MINOR < 4
+#define nettle_get_secp_256r1() (&nettle_secp_256r1)
+#define nettle_get_secp_384r1() (&nettle_secp_384r1)
+#endif
if (!sig_struct)
{
@@ -294,7 +298,7 @@ static int dnsmasq_ecdsa_verify(struct blockdata *key_
if (!(key_256 = whine_malloc(sizeof(struct ecc_point))))
return 0;
- nettle_ecc_point_init(key_256, &nettle_secp_256r1);
+ nettle_ecc_point_init(key_256, nettle_get_secp_256r1());
}
key = key_256;
@@ -307,7 +311,7 @@ static int dnsmasq_ecdsa_verify(struct blockdata *key_
if (!(key_384 = whine_malloc(sizeof(struct ecc_point))))
return 0;
- nettle_ecc_point_init(key_384, &nettle_secp_384r1);
+ nettle_ecc_point_init(key_384, nettle_get_secp_384r1());
}
key = key_384;

View file

@ -1,18 +0,0 @@
X-Git-Url: http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=blobdiff_plain;f=src%2Ftftp.c;h=c618a2c1eeb73de147ade0cf75de24cbc3cb3f38;hp=435b21687ffa366a7bebf1bfc7905997be5b8f7d;hb=936bd82755e8f75fc09c1e9a67fb390175b157d4;hpb=13a58f9590a7071ad4a8c8f7e4178c29a6b66be3
--- src/tftp.c.orig 2018-10-18 18:21:55 UTC
+++ src/tftp.c
@@ -74,9 +74,11 @@ void tftp_request(struct listener *listen, time_t now)
#if defined(HAVE_LINUX_NETWORK)
char control[CMSG_SPACE(sizeof(struct in_pktinfo))];
#elif defined(HAVE_SOLARIS_NETWORK)
- char control[CMSG_SPACE(sizeof(unsigned int))];
+ char control[CMSG_SPACE(sizeof(struct in_addr)) +
+ CMSG_SPACE(sizeof(unsigned int))];
#elif defined(IP_RECVDSTADDR) && defined(IP_RECVIF)
- char control[CMSG_SPACE(sizeof(struct sockaddr_dl))];
+ char control[CMSG_SPACE(sizeof(struct in_addr)) +
+ CMSG_SPACE(sizeof(struct sockaddr_dl))];
#endif
} control_u;