AntiWM is a small and simple window manager with a focus on
productivity and utility. Inspired by ratpoison, AntiWM is keyboard driven and handles all windows fullscreen. WWW: http://sourceforge.net/projects/antiwm PR: ports/131246 Submitted by: Dennis Herrmann <adox at mcx2.org>
This commit is contained in:
parent
b701c8380f
commit
d0bd9acc95
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=227877
5 changed files with 94 additions and 0 deletions
|
@ -10,6 +10,7 @@
|
|||
SUBDIR += ahwm
|
||||
SUBDIR += amaterus
|
||||
SUBDIR += amiwm
|
||||
SUBDIR += antiwm
|
||||
SUBDIR += awesome
|
||||
SUBDIR += badwm
|
||||
SUBDIR += bbconf
|
||||
|
|
38
x11-wm/antiwm/Makefile
Normal file
38
x11-wm/antiwm/Makefile
Normal file
|
@ -0,0 +1,38 @@
|
|||
# New ports collection makefile for: antiwm
|
||||
# Date created: 2009-01-30
|
||||
# Whom: Dennis Herrmann <adox@mcx2.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= antiwm
|
||||
PORTVERSION= 0.0.3
|
||||
CATEGORIES= x11-wm
|
||||
MASTER_SITES= SF
|
||||
|
||||
MAINTAINER= adox@mcx2.org
|
||||
COMMENT= A minimalist window manager inspired by Ratpoison
|
||||
|
||||
USE_XORG= x11
|
||||
|
||||
PLIST_FILES= bin/antiwm
|
||||
PORTDOCS= README LICENSE
|
||||
|
||||
pre-everything::
|
||||
@${ECHO_MSG} "You can build antiwm with your own conf.h using the ANTIWM_CONF knob:"
|
||||
@${ECHO_MSG} "make ANTIWM_CONF=/path/to/antiwm/conf.h install clean"
|
||||
|
||||
post-extract:
|
||||
.if defined(ANTIWM_CONF)
|
||||
@${ECHO_MSG} "creating conf.h from ${ANTIWM_CONF}"
|
||||
@${CP} ${ANTIWM_CONF} ${WRKSRC}/conf.h
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
|
||||
.endif
|
||||
|
||||
.include <bsd.port.mk>
|
3
x11-wm/antiwm/distinfo
Normal file
3
x11-wm/antiwm/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
|||
MD5 (antiwm-0.0.3.tar.gz) = 5764f780e1a0004e5f2f16053636ed59
|
||||
SHA256 (antiwm-0.0.3.tar.gz) = 5167fbba12dec38f9065ad9a2c2c5dbce0e9c37a593f4ea186cbbf470dc3c7e7
|
||||
SIZE (antiwm-0.0.3.tar.gz) = 8373
|
47
x11-wm/antiwm/files/patch-Makefile
Normal file
47
x11-wm/antiwm/files/patch-Makefile
Normal file
|
@ -0,0 +1,47 @@
|
|||
--- Makefile.orig 2008-08-01 02:59:17.000000000 +0200
|
||||
+++ Makefile 2009-02-01 10:00:20.000000000 +0100
|
||||
@@ -1,22 +1,36 @@
|
||||
# install directory
|
||||
-INSTALL_DIR=/usr/local/bin
|
||||
+PREFIX?= /usr/local/
|
||||
|
||||
# enable debug messages
|
||||
DEBUG = -DDEBUG
|
||||
|
||||
-CC = gcc
|
||||
-LIBS = -lX11
|
||||
-LDFLAGS = -L/usr/lib
|
||||
-CFLAGS = -O2 -Wall -I/usr/X11R6/include
|
||||
+# compiler and linker
|
||||
+CC?= gcc
|
||||
+
|
||||
+# paths
|
||||
+X11INC = $(LOCALBASE)/include
|
||||
+X11LIB = $(LOCALBASE)/lib
|
||||
+
|
||||
+# includes and libs
|
||||
+INCS = -I. -I/usr/include -I${X11INC}
|
||||
+LIBS = -L/usr/lib -lc -L${X11LIB} -lX11
|
||||
+
|
||||
+# flags
|
||||
+LDFLAGS+= ${LIBS}
|
||||
+CFLAGS+= ${INCS}
|
||||
|
||||
SRC = main.o events.o manage.o list.o bar.o
|
||||
HEADERS = bar.h conf.h data.h events.h list.h manage.h antiwm.h
|
||||
|
||||
+all: antiwm
|
||||
+
|
||||
antiwm: $(SRC)
|
||||
- gcc $(SRC) -o $@ $(CFLAGS) $(LDFLAGS) $(LIBS)
|
||||
+ gcc $(SRC) -o $@ $(CFLAGS) $(LDFLAGS)
|
||||
|
||||
-install: antiwm
|
||||
- cp antiwm $(INSTALL_DIR)
|
||||
+install: all
|
||||
+ @mkdir -p ${DESTDIR}${PREFIX}/bin
|
||||
+ @cp -f antiwm ${PREFIX}/bin
|
||||
+ @chmod 755 ${DESTDIR}${PREFIX}/bin/antiwm
|
||||
|
||||
%.o : %.c $(HEADERS)
|
||||
$(CC) -c $(CFLAGS) $(DEBUG) $< -o $@
|
5
x11-wm/antiwm/pkg-descr
Normal file
5
x11-wm/antiwm/pkg-descr
Normal file
|
@ -0,0 +1,5 @@
|
|||
AntiWM is a small and simple window manager with a focus on
|
||||
productivity and utility. Inspired by ratpoison, AntiWM is
|
||||
keyboard driven and handles all windows fullscreen.
|
||||
|
||||
WWW: http://sourceforge.net/projects/antiwm
|
Loading…
Reference in a new issue