Upgrade to 1.40
Submitted by: Masanori Kiriake <seiken@os.rim.or.jp>
This commit is contained in:
parent
3de18703d0
commit
d0d34a0e3e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=16050
4 changed files with 94 additions and 56 deletions
|
@ -1,21 +1,19 @@
|
|||
# New ports collection makefile for: gn(Gon's Newsreader with gnspool)
|
||||
# Version required: 1.36
|
||||
# Version required: 1.40
|
||||
# Date created: 14 Feb. 1997
|
||||
# Whom: Kiroh HARADA <kiroh@kh.rim.or.jp>
|
||||
#
|
||||
# $Id: Makefile,v 1.4 1998/06/04 14:47:24 kuriyama Exp $
|
||||
# $Id$
|
||||
#
|
||||
|
||||
DISTNAME= gn-1.36
|
||||
PKGNAME= ja-gn-gnspool-1.36
|
||||
DISTNAME= gn-1.40
|
||||
PKGNAME= ja-gn-gnspool-1.40
|
||||
CATEGORIES= japanese news
|
||||
MASTER_SITES= ftp://ftp.omronsoft.co.jp/pub/misc/gn/
|
||||
|
||||
MAINTAINER= kiroh@kh.rim.or.jp
|
||||
|
||||
BROKEN= infinite loop
|
||||
|
||||
WRKSRC= ${WRKDIR}/gn-1.36/src
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/src
|
||||
|
||||
pre-configure:
|
||||
@${CP} ${WRKDIR}/${DISTNAME}/mkfiles/unix/common ${WRKSRC}/Makefile
|
||||
|
@ -37,7 +35,8 @@ post-install:
|
|||
@${CP} ${FILESDIR}/Changes.FreeBSD.port ${PREFIX}/share/doc/gn-gnspool
|
||||
.endif
|
||||
.if !defined(NOMANCOMPRESS)
|
||||
@gzip -9nf ${PREFIX}/man/ja/cat1/gn.1 ${PREFIX}/man/ja/cat1/gnspool.1
|
||||
@gzip -9nf ${PREFIX}/man/ja/cat1/gn.1 \
|
||||
${PREFIX}/man/ja/cat1/gnspool.1 ${PREFIX}/man/ja/cat1/gnloops.1
|
||||
.endif
|
||||
@${MKDIR} ${PREFIX}/share/examples/gn-gnspool
|
||||
@${CP} ${FILESDIR}/_gnrc ${PREFIX}/share/examples/gn-gnspool
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (gn-1.36.tar.gz) = 710c4fb59a494166af20b237fa5fd683
|
||||
MD5 (gn-1.40.tar.gz) = e0c350dab71fa7d78ad9fa08f68ada65
|
||||
|
|
|
@ -1,37 +1,65 @@
|
|||
--- Makefile.orig Wed Feb 4 16:39:44 1998
|
||||
+++ Makefile Wed Feb 4 16:42:02 1998
|
||||
@@ -13,11 +13,11 @@
|
||||
COLUMNS = 80
|
||||
|
||||
BINDIR = /usr/local/bin
|
||||
-MANDIR = /usr/local/man/man1
|
||||
+MANDIR = /usr/local/man/ja/cat1
|
||||
MANEXT = .1
|
||||
|
||||
-NEWSSPOOL = /usr/spool/news
|
||||
-NEWSLIB = /usr/lib/news
|
||||
+NEWSSPOOL = /var/spool/gnspool
|
||||
+NEWSLIB = /usr/local/news/lib
|
||||
|
||||
NEWSRC = .newsrc
|
||||
SIGNATURE = .signature
|
||||
@@ -30,7 +30,7 @@
|
||||
MAILER = /usr/lib/sendmail -t
|
||||
|
||||
CC = cc
|
||||
-OPTCFLAGS = -O
|
||||
+OPTCFLAGS = -UHAS_MALLOC_H
|
||||
OPTGNOBJS =
|
||||
OPTGNSPOOLOBJS =
|
||||
OPTLFLAGS =
|
||||
@@ -38,7 +38,9 @@
|
||||
|
||||
SHELL = /bin/sh
|
||||
DEFINES = -DUNIX
|
||||
-HEADER_DEFINES =
|
||||
+HEADER_DEFINES = -DHAS_STRING_H -DHAS_STDLIB_H -DHAS_MALLOC_H -DHAS_UNISTD_H \
|
||||
+ -DHAS_NETDB_H -DHAS_SYS_IOCTL_H -DHAS_SYS_SOCKET_H -DHAS_NETINET_IN_H \
|
||||
+ -DHAS_ARPA_INET_H
|
||||
CFLAGS = $(DEFINES) $(HEADER_DEFINES) $(OPTCFLAGS)
|
||||
LFLAGS = $(OPTLFLAGS)
|
||||
LIBS = $(OPTLIBS)
|
||||
*** Makefile.orig Fri Jan 30 00:12:32 1998
|
||||
--- Makefile Sat Jun 20 07:05:19 1998
|
||||
***************
|
||||
*** 12,23 ****
|
||||
LINES = 24
|
||||
COLUMNS = 80
|
||||
|
||||
! BINDIR = /usr/local/bin
|
||||
! MANDIR = /usr/local/man/man1
|
||||
MANEXT = .1
|
||||
|
||||
! NEWSSPOOL = /usr/spool/news
|
||||
! NEWSLIB = /usr/lib/news
|
||||
|
||||
NEWSRC = .newsrc
|
||||
SIGNATURE = .signature
|
||||
--- 12,23 ----
|
||||
LINES = 24
|
||||
COLUMNS = 80
|
||||
|
||||
! BINDIR = ${PREFIX}/bin
|
||||
! MANDIR = ${PREFIX}/man/ja/cat1
|
||||
MANEXT = .1
|
||||
|
||||
! NEWSSPOOL = /var/spool/gnspool
|
||||
! NEWSLIB = ${PREFIX}/news/lib
|
||||
|
||||
NEWSRC = .newsrc
|
||||
SIGNATURE = .signature
|
||||
***************
|
||||
*** 30,36 ****
|
||||
MAILER = /usr/lib/sendmail -t
|
||||
|
||||
CC = cc
|
||||
! OPTCFLAGS = -O
|
||||
OPTGNOBJS =
|
||||
OPTGNSPOOLOBJS =
|
||||
OPTLFLAGS =
|
||||
--- 30,36 ----
|
||||
MAILER = /usr/lib/sendmail -t
|
||||
|
||||
CC = cc
|
||||
! OPTCFLAGS = -UHAS_MALLOC_H
|
||||
OPTGNOBJS =
|
||||
OPTGNSPOOLOBJS =
|
||||
OPTLFLAGS =
|
||||
***************
|
||||
*** 38,44 ****
|
||||
|
||||
SHELL = /bin/sh
|
||||
DEFINES = -DUNIX
|
||||
! HEADER_DEFINES =
|
||||
CFLAGS = $(DEFINES) $(HEADER_DEFINES) $(OPTCFLAGS)
|
||||
LFLAGS = $(OPTLFLAGS)
|
||||
LIBS = $(OPTLIBS)
|
||||
--- 38,46 ----
|
||||
|
||||
SHELL = /bin/sh
|
||||
DEFINES = -DUNIX
|
||||
! HEADER_DEFINES = -DHAS_STRING_H -DHAS_STDLIB_H -DHAS_MALLOC_H -DHAS_UNISTD_H \
|
||||
! -DHAS_NETDB_H -DHAS_SYS_IOCTL_H -DHAS_SYS_SOCKET_H -DHAS_NETINET_IN_H \
|
||||
! -DHAS_ARPA_INET_H
|
||||
CFLAGS = $(DEFINES) $(HEADER_DEFINES) $(OPTCFLAGS)
|
||||
LFLAGS = $(OPTLFLAGS)
|
||||
LIBS = $(OPTLIBS)
|
||||
|
|
|
@ -1,15 +1,25 @@
|
|||
bin/gn
|
||||
bin/gnspool
|
||||
bin/gnloops
|
||||
bin/gninews
|
||||
bin/gnmail
|
||||
man/ja/cat1/gn.1.gz
|
||||
man/ja/cat1/gnspool.1.gz
|
||||
man/ja/cat1/gnloops.1.gz
|
||||
share/examples/gn-gnspool/_gnrc
|
||||
share/doc/gn-gnspool/Changes.FreeBSD.port
|
||||
share/doc/gn-gnspool/bin-dist
|
||||
share/doc/gn-gnspool/change.log
|
||||
share/doc/gn-gnspool/copyrigh.t
|
||||
share/doc/gn-gnspool/define
|
||||
share/doc/gn-gnspool/history
|
||||
share/doc/gn-gnspool/info
|
||||
share/doc/gn-gnspool/install
|
||||
share/doc/gn-gnspool/jnames
|
||||
share/doc/gn-gnspool/mime
|
||||
share/doc/gn-gnspool/new
|
||||
share/doc/gn-gnspool/readme
|
||||
share/doc/gn-gnspool/wanted
|
||||
share/doc/gn-gnspool/dos/etherppp
|
||||
share/doc/gn-gnspool/dos/inetbios
|
||||
share/doc/gn-gnspool/dos/lanwp
|
||||
|
@ -30,33 +40,33 @@ share/doc/gn-gnspool/faq/index
|
|||
share/doc/gn-gnspool/faq/newsrc
|
||||
share/doc/gn-gnspool/faq/old
|
||||
share/doc/gn-gnspool/faq/unix
|
||||
share/doc/gn-gnspool/gnspool/gnspool.gon
|
||||
|
||||
share/doc/gn-gnspool/gnloops/readme
|
||||
share/doc/gn-gnspool/gnspool/gnus
|
||||
share/doc/gn-gnspool/gnspool/mh
|
||||
share/doc/gn-gnspool/gnspool/mnews
|
||||
share/doc/gn-gnspool/gnspool/readme
|
||||
share/doc/gn-gnspool/gnspool/winvn
|
||||
share/doc/gn-gnspool/history
|
||||
share/doc/gn-gnspool/gon/1993
|
||||
share/doc/gn-gnspool/gon/1995
|
||||
share/doc/gn-gnspool/gon/1996_1
|
||||
share/doc/gn-gnspool/gon/1996_5
|
||||
share/doc/gn-gnspool/gon/1997_4
|
||||
share/doc/gn-gnspool/gon/1997_8
|
||||
share/doc/gn-gnspool/gon/readme
|
||||
share/doc/gn-gnspool/human68k/espx
|
||||
share/doc/gn-gnspool/human68k/offline
|
||||
share/doc/gn-gnspool/human68k/readme
|
||||
share/doc/gn-gnspool/info
|
||||
share/doc/gn-gnspool/install
|
||||
share/doc/gn-gnspool/jnames
|
||||
share/doc/gn-gnspool/log/100-110
|
||||
share/doc/gn-gnspool/log/110-120
|
||||
share/doc/gn-gnspool/log/120-130
|
||||
share/doc/gn-gnspool/mime
|
||||
share/doc/gn-gnspool/new
|
||||
share/doc/gn-gnspool/os2/mime
|
||||
share/doc/gn-gnspool/os2/readme
|
||||
share/doc/gn-gnspool/os2/spool
|
||||
share/doc/gn-gnspool/os2/tcpip16
|
||||
share/doc/gn-gnspool/os2/tcpip32
|
||||
share/doc/gn-gnspool/readme
|
||||
share/doc/gn-gnspool/unix/mvux
|
||||
share/doc/gn-gnspool/unix/readme
|
||||
share/doc/gn-gnspool/wanted
|
||||
share/doc/gn-gnspool/windows.31/readme
|
||||
share/doc/gn-gnspool/windows.31/winsock.qw
|
||||
share/doc/gn-gnspool/windows.31/winsock.vc
|
||||
|
@ -65,11 +75,12 @@ share/doc/gn-gnspool/windows.95/winsock.vc
|
|||
@dirrm share/examples/gn-gnspool
|
||||
@dirrm share/doc/gn-gnspool/dos
|
||||
@dirrm share/doc/gn-gnspool/faq
|
||||
@dirrm share/doc/gn-gnspool/gnloops
|
||||
@dirrm share/doc/gn-gnspool/gnspool
|
||||
@dirrm share/doc/gn-gnspool/gon
|
||||
@dirrm share/doc/gn-gnspool/human68k
|
||||
@dirrm share/doc/gn-gnspool/log
|
||||
@dirrm share/doc/gn-gnspool/os2
|
||||
@dirrm share/doc/gn-gnspool/unix
|
||||
@dirrm share/doc/gn-gnspool/windows.31
|
||||
@dirrm share/doc/gn-gnspool/windows.95
|
||||
@dirrm share/doc/gn-gnspool
|
||||
|
|
Loading…
Reference in a new issue