Fix on 64bit platforms

Approved by:	maintainer
This commit is contained in:
Tilman Keskinoz 2004-01-23 10:17:36 +00:00
parent bdf202c987
commit d155c9f32e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=98875
2 changed files with 30 additions and 6 deletions

View file

@ -15,14 +15,24 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= shoesoft@gmx.net
COMMENT= Command-line player/decoder for musepack audio
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
LIB_DEPENDS= esd.2:${PORTSDIR}/audio/esound
MAKEFILE= Makefile.bsd
USE_BZIP2= yes
ONLY_FOR_ARCHS= i386
USE_REINPLACE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == i386
BUILD_DEPENDS= nasm:${PORTVERSION}/devel/nasm
.endif
post-patch:
.if ${ARCH} != i386
${REINPLACE_CMD} -e "s,#define USE_ASM,//define USE_ASM," ${WRKSRC}/mpp.h
.endif
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/mppdec ${PREFIX}/bin/
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View file

@ -1,11 +1,11 @@
--- Makefile.bsd.orig Mon May 12 07:55:51 2003
+++ Makefile.bsd Mon May 12 07:56:15 2003
--- Makefile.bsd.orig Wed Jul 31 00:19:57 2002
+++ Makefile.bsd Fri Jan 23 10:47:12 2004
@@ -10,11 +10,11 @@
#LDADD += -lossaudio
include version
-OPTIM = -O3 -march=pentiumpro -ffast-math -s
+OPTIM = -O3 -ffast-math -s
+#OPTIM = -O3 -ffast-math -s
WARN =
@ -14,3 +14,17 @@
TARGETS = mppdec
@@ -38,9 +38,11 @@
tools.o \
wave_out.o \
stderr.o \
- cpu_feat.o \
- synthasm.o \
_setargv.o \
+
+.if ${ARCH} == i386
+OBJ+= cpu_feat.o synthasm.o
+.endif
all: $(TARGETS)