a dockapp that displays the time in different time zones

PR:		11297
Submiited by:	Jim Mock <jim@phrantic.phear.net>
This commit is contained in:
Satoshi Taoka 1999-04-30 06:00:15 +00:00
parent b9c3376da8
commit d1812891ae
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=18204
6 changed files with 96 additions and 0 deletions

36
x11-clocks/wmtz/Makefile Normal file
View file

@ -0,0 +1,36 @@
# New ports collection makefile for: wmtz
# Version required: 0.2
# Date created: 24 Apr 1999
# Whom: Jim Mock <jim@phrantic.phear.net>
#
# $Id$
#
DISTNAME= wmtz-0.2
CATEGORIES= x11-clocks windowmaker afterstep
MASTER_SITES= http://www.algonet.se/~jlin/
MAINTAINER= jim@phrantic.phear.net
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/wmtz
USE_X_PREFIX= yes
post-install:
@${ECHO} " "
@${ECHO} "-----------------------------------------------------------"
@${ECHO} "===> Installing wmtzrc in ${PREFIX}/share/examples/wmtz"
@${ECHO} "===> Modify to your config and copy to ~/.wmtzrc"
@${ECHO} "-----------------------------------------------------------"
@${ECHO} " "
@${MKDIR} ${PREFIX}/share/examples/wmtz && chmod a+rx ${PREFIX}/share/examples/wmtz
${INSTALL_DATA} ${WRKSRC}/wmtzrc ${PREFIX}/share/examples/wmtz
@${ECHO} " "
@${ECHO} "-----------------------------------------------------------"
@${ECHO} "===> Run wmtz --help for usage instructions"
@${ECHO} "-----------------------------------------------------------"
@${ECHO} " "
.include <bsd.port.mk>

1
x11-clocks/wmtz/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (wmtz-0.2.tar.gz) = 966b00f5867801e7b21fde307f5aaf7a

View file

@ -0,0 +1,47 @@
--- Makefile.orig Sat Apr 24 09:24:32 1999
+++ Makefile Sat Apr 24 09:26:34 1999
@@ -1,7 +1,7 @@
CC = gcc
LIBDIR = -L/usr/X11R6/lib
LIBS = -lXpm -lXext -lX11 -lm
-FLAGS = -O2
+CFLAGS = -Wall -O2
OBJS = wmtz.o \
../wmgeneral/wmgeneral.o \
../wmgeneral/misc.o \
@@ -9,10 +9,10 @@
.c.o:
- $(CC) -I/usr/X11R6/share/include $(FLAGS) -c -Wall $< -o $*.o
+ $(CC) -I/usr/X11R6/include $(CFLAGS) -c $< -o $*.o
wmtz: $(OBJS)
- $(CC) $(FLAGS) -o wmtz $^ -lXext $(LIBDIR) $(LIBS)
+ $(CC) $(CFLAGS) -o wmtz $^ -lXext $(LIBDIR) $(LIBS)
all:: wmtz
@@ -24,18 +24,11 @@
rm -f *~
install:: wmtz
- cp -f wmtz /usr/local/bin/
- chmod 755 /usr/local/bin/wmtz
- chown root:root /usr/local/bin/wmtz
- cp wmtzrc $(HOME)/.wmtzrc
- chmod 600 $(HOME)/.wmtzrc
- cp wmtzrc /etc/wmtzrc
- chmod 644 /etc/wmtzrc
+ cp -f wmtz /usr/X11R6/bin/
+ chmod 755 /usr/X11R6/bin/wmtz
+ chown root.wheel /usr/X11R6/bin/wmtz
@echo "wmtz: Installation finished..."
uninstall::
- rm -i /usr/local/bin/wmtz
- rm -i /etc/wmtzrc
- chmod 666 $(HOME)/.wmtzrc
- rm -i $(HOME)/.wmtzrc
+ rm -i /usr/X11R6/bin/wmtz
@echo "wmtz: Uninstall completed..."

View file

@ -0,0 +1 @@
wmtz is a dockapp that displays the time in different time zones.

View file

@ -0,0 +1,7 @@
wmtz is a dockapp for the Window Maker that displays the time in
different time zones as defined in it's configuration file. It can
also display the current Julian Day Number.
WWW Homepage: http://www.algonet.se/~jlin/wmtz.html
- Jim <jim@phrantic.phear.net>

View file

@ -0,0 +1,4 @@
bin/wmtz
share/examples/wmtz/wmtzrc
@dirrm share/examples/wmtz