Adding libj2dplot version 0.6.5.
A 2D plotting library for the JX toolkit. PR: 19285 Submitted by: Mario S F Ferreira <lioux@linf.unb.br>
This commit is contained in:
parent
029a4adcbd
commit
d18cdcd7e5
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=30426
8 changed files with 233 additions and 0 deletions
145
x11-toolkits/libj2dplot/Makefile
Normal file
145
x11-toolkits/libj2dplot/Makefile
Normal file
|
@ -0,0 +1,145 @@
|
|||
# New ports collection makefile for: libj2dplot
|
||||
# Date created: 14 June 2000
|
||||
# Whom: Mario S F Ferreira <lioux@linf.unb.br> et al.
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libj2dplot
|
||||
PORTVERSION= 0.6.5
|
||||
CATEGORIES= x11-toolkits
|
||||
MASTER_SITES= ftp://ftp.newplanetsoftware.com/pub/glove/source/ \
|
||||
ftp://ftp.newplanetsoftware.com/pub/thx/source/
|
||||
DISTNAME= J2DPlot_source-${PORTVERSION}
|
||||
|
||||
MAINTAINER= lioux@linf.unb.br
|
||||
|
||||
BUILD_DEPENDS= nonexistent:${JXPORT}:configure \
|
||||
makemake:${JXPORT}
|
||||
LIB_DEPENDS= jx-1_5_3.1:${JXPORT} \
|
||||
jparser-1_1_8.1:${PORTSDIR}/x11-toolkits/libjparser
|
||||
|
||||
WRKSRC= ${WRKDIR}/JX-1.5.3
|
||||
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_GMAKE= yes
|
||||
MAKE_ARGS= CC="${CC}" CXX="${CXX}" \
|
||||
CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
|
||||
MAKE_ENV= JX_INSTALL_ROOT="${PREFIX}/bin" \
|
||||
JX_LIB_ROOT="${PREFIX}/lib"
|
||||
PLIST_SUB= PORTNAME="${PORTNAME}" \
|
||||
LIBNUMBER="${LIBNUMBER}" \
|
||||
LIBVERSION="${LIBVERSION}" \
|
||||
EXTRALIBFILES_MAKE_FILES="${EXTRALIBFILES_MAKE_FILES}" \
|
||||
INCLUDEDIR="${INCLUDEDIR}"
|
||||
|
||||
# Make environment
|
||||
PORTINCLUDES= -I${X11BASE}/include/jcore -I${X11BASE}/include/jx \
|
||||
-I${X11BASE}/include/jparser
|
||||
|
||||
# Installs dir with proper permissions
|
||||
INSTALL_DATA_DIR= ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755
|
||||
# New version number
|
||||
LIBVERSION= 0_6_5
|
||||
# the libraries
|
||||
LIBFILES= ${PORTNAME}-${LIBVERSION}.a ${PORTNAME}-${LIBVERSION}.so
|
||||
# header files
|
||||
INCLUDEDIR= j2dplot
|
||||
# documentation
|
||||
DOCDIR_PREFIX= ${PREFIX}/share/doc/jx
|
||||
DOCDIRS= ${PORTNAME}
|
||||
DOCDIRFILES= LICENSE
|
||||
# additional configuration and header files
|
||||
EXTRALIB_PREFIX= ${PREFIX}/lib/jx
|
||||
EXTRALIBDIRS= lib make
|
||||
EXTRALIBFILES_MAKE_WRKSRC= include/make
|
||||
EXTRALIBFILES_MAKE_FILES= j2dplot_constants
|
||||
# main jx distribution port wrksrc
|
||||
JXPORT= ${PORTSDIR}/x11-toolkits/jx
|
||||
JXPORT_WRKSRC= ${JXPORT}/work/JX-1.5.3
|
||||
# main jx distribution files needed for building
|
||||
COPY_JXDIRS= include
|
||||
COPY_JXFILES= Makefile
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 300000
|
||||
ALL_TARGET= freebsd3.x
|
||||
LIBNUMBER= 0
|
||||
.else
|
||||
ALL_TARGET= freebsd2.x
|
||||
LIBNUMBER= 0.6
|
||||
.endif
|
||||
|
||||
.if defined(NOPORTDOCS)
|
||||
PLIST_SUB+= PORTDOCS:="@comment "
|
||||
.else
|
||||
PLIST_SUB+= PORTDOCS:=
|
||||
.endif # !defined(NOPORTDOCS)
|
||||
|
||||
post-extract:
|
||||
.for i in ${COPY_JXDIRS}
|
||||
@${CP} -Rp ${JXPORT_WRKSRC}/${i} ${WRKSRC}
|
||||
.endfor
|
||||
.for i in ${COPY_JXFILES}
|
||||
@${CP} -p ${JXPORT_WRKSRC}/${i} ${WRKSRC}
|
||||
.endfor
|
||||
|
||||
post-patch:
|
||||
@${ECHO} "SEARCHDIRS += ${PORTINCLUDES}" >> \
|
||||
${WRKSRC}/${EXTRALIBFILES_MAKE_WRKSRC}/jx_constants
|
||||
|
||||
post-build:
|
||||
@cd ${WRKSRC}/${PORTNAME}; ${SETENV} ${MAKE_ENV} makemake; \
|
||||
${SETENV} ${MAKE_ENV} ${GMAKE} \
|
||||
${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS}
|
||||
|
||||
do-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
# Install all documentation
|
||||
.for i in ${DOCDIRS}
|
||||
@for j in ${DOCDIRFILES} ; \
|
||||
do \
|
||||
if [ -f ${WRKSRC}/programs/${i}/$${j} ]; \
|
||||
then \
|
||||
${INSTALL_DATA} ${WRKSRC}/programs/${i}/$${j} \
|
||||
${DOCDIR_PREFIX}/$${j}_${i} ; \
|
||||
elif [ -f ${WRKSRC}/${i}/$${j} ]; \
|
||||
then \
|
||||
${INSTALL_DATA} ${WRKSRC}/${i}/$${j} \
|
||||
${DOCDIR_PREFIX}/$${j}_${i} ; \
|
||||
fi ; \
|
||||
done
|
||||
.endfor
|
||||
.endif # !defined(NOPORTDOCS)
|
||||
# Install all header files
|
||||
.for i in ${INCLUDEDIR}
|
||||
@${INSTALL_DATA_DIR} ${PREFIX}/include/${i} ; \
|
||||
for j in ${WRKSRC}/include/${i}/*.h ; \
|
||||
do \
|
||||
${INSTALL_DATA} $${j} ${PREFIX}/include/${i} ; \
|
||||
done
|
||||
.endfor
|
||||
# Install all libraries
|
||||
.for i in ${LIBFILES}
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/lib/${i} ${PREFIX}/lib
|
||||
.endfor
|
||||
# Install additional library files
|
||||
.for i in ${EXTRALIBDIRS}
|
||||
@${INSTALL_DATA_DIR} ${EXTRALIB_PREFIX}/${i}
|
||||
.endfor
|
||||
.for i in ${EXTRALIBFILES_MAKE_FILES}
|
||||
@${INSTALL_DATA} ${WRKSRC}/${EXTRALIBFILES_MAKE_WRKSRC}/${i} \
|
||||
${EXTRALIB_PREFIX}/make/${i}
|
||||
.endfor
|
||||
|
||||
post-install:
|
||||
@${LN} -sf ${PORTNAME}-${LIBVERSION}.so \
|
||||
${PREFIX}/lib/${PORTNAME}-${LIBVERSION}.so.${LIBNUMBER}
|
||||
.for i in ${LIBFILES}
|
||||
@${LN} -sf ../../${i} ${EXTRALIB_PREFIX}/lib/${i}
|
||||
.endfor
|
||||
|
||||
.include <bsd.port.post.mk>
|
1
x11-toolkits/libj2dplot/distinfo
Normal file
1
x11-toolkits/libj2dplot/distinfo
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (J2DPlot_source-0.6.5.tar.gz) = 0f54607beb08280246039be45a432d41
|
28
x11-toolkits/libj2dplot/files/patch-aa
Normal file
28
x11-toolkits/libj2dplot/files/patch-aa
Normal file
|
@ -0,0 +1,28 @@
|
|||
--- Makefile.orig Sat Sep 11 17:44:38 1999
|
||||
+++ Makefile Wed Jun 14 01:07:15 2000
|
||||
@@ -262,25 +262,11 @@
|
||||
freebsd2.x: prep
|
||||
@ln -s sys/FreeBSD-2.x_g++ \
|
||||
include/make/jx_config
|
||||
- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
|
||||
- include/jcore/jMissingProto.h
|
||||
- @ln -s config-freebsd.h \
|
||||
- ACE/ACE_wrappers/ace/config.h
|
||||
- @ln -s platform_freebsd.GNU \
|
||||
- ACE/ACE_wrappers/include/makeinclude/platform_macros.GNU
|
||||
- @${INSTALL_CMD}
|
||||
|
||||
.PHONY : freebsd3.x
|
||||
freebsd3.x: prep
|
||||
@ln -s sys/FreeBSD-3.x_g++ \
|
||||
include/make/jx_config
|
||||
- @ln -s ../../include/missing_proto/jMissingProto_empty.h \
|
||||
- include/jcore/jMissingProto.h
|
||||
- @ln -s config-freebsd-pthread.h \
|
||||
- ACE/ACE_wrappers/ace/config.h
|
||||
- @ln -s platform_freebsd_pthread.GNU \
|
||||
- ACE/ACE_wrappers/include/makeinclude/platform_macros.GNU
|
||||
- @${INSTALL_CMD}
|
||||
|
||||
#
|
||||
# SunOS 4.x
|
11
x11-toolkits/libj2dplot/files/patch-ab
Normal file
11
x11-toolkits/libj2dplot/files/patch-ab
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- include/make/sys/FreeBSD-2.x_g++.orig Wed Jun 14 01:44:51 2000
|
||||
+++ include/make/sys/FreeBSD-2.x_g++ Wed Jun 14 01:45:00 2000
|
||||
@@ -35,7 +35,7 @@
|
||||
# Comment this out if ACE or other code gives you warnings that
|
||||
# you can't avoid.
|
||||
|
||||
-J_DIE_ON_WARNING := -Werror
|
||||
+#J_DIE_ON_WARNING := -Werror
|
||||
|
||||
# Uncomment this if istrstream is broken. One way to check is to run
|
||||
# testjcore/testJFileArray.
|
11
x11-toolkits/libj2dplot/files/patch-ac
Normal file
11
x11-toolkits/libj2dplot/files/patch-ac
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- include/make/sys/FreeBSD-3.x_g++.orig Wed Jun 14 01:44:51 2000
|
||||
+++ include/make/sys/FreeBSD-3.x_g++ Wed Jun 14 01:45:00 2000
|
||||
@@ -35,7 +35,7 @@
|
||||
# Comment this out if ACE or other code gives you warnings that
|
||||
# you can't avoid.
|
||||
|
||||
-J_DIE_ON_WARNING := -Werror
|
||||
+#J_DIE_ON_WARNING := -Werror
|
||||
|
||||
# Uncomment this if istrstream is broken. One way to check is to run
|
||||
# testjcore/testJFileArray.
|
1
x11-toolkits/libj2dplot/pkg-comment
Normal file
1
x11-toolkits/libj2dplot/pkg-comment
Normal file
|
@ -0,0 +1 @@
|
|||
A 2D plotting library for the JX toolkit
|
8
x11-toolkits/libj2dplot/pkg-descr
Normal file
8
x11-toolkits/libj2dplot/pkg-descr
Normal file
|
@ -0,0 +1,8 @@
|
|||
JX is a full-featured application framework and widget library for
|
||||
use with the X Window System. It provides support for all facets
|
||||
of application development, including distributed applications,
|
||||
and aims to combine the best of MacOS and NeXTSTEP. It is built
|
||||
directly on top of Xlib and has been carefully optimized for
|
||||
performance.
|
||||
|
||||
WWW: http://www.newplanetsoftware.com/jx/
|
28
x11-toolkits/libj2dplot/pkg-plist
Normal file
28
x11-toolkits/libj2dplot/pkg-plist
Normal file
|
@ -0,0 +1,28 @@
|
|||
include/j2dplot/J2DDataPoint.h
|
||||
include/j2dplot/J2DPlotData.h
|
||||
include/j2dplot/J2DPlotLibVersion.h
|
||||
include/j2dplot/J2DPlotWidget.h
|
||||
include/j2dplot/J2DVectorData.h
|
||||
include/j2dplot/J2DVectorPoint.h
|
||||
include/j2dplot/JCurveInfo.h
|
||||
include/j2dplot/JPlotDataBase.h
|
||||
include/j2dplot/JPlotFunctionBase.h
|
||||
include/j2dplot/JPlotJFunction.h
|
||||
include/j2dplot/JX2DPlotWidget.h
|
||||
include/j2dplot/JXCursorMarkTable.h
|
||||
include/j2dplot/JXCursorMarkTableDir.h
|
||||
include/j2dplot/JXCurveNameList.h
|
||||
include/j2dplot/JXCurveOptionsDialog.h
|
||||
include/j2dplot/JXPlotLabelDialog.h
|
||||
include/j2dplot/JXPlotRangeDialog.h
|
||||
include/j2dplot/JXPlotScaleDialog.h
|
||||
include/j2dplot/fitplot.h
|
||||
lib/jx/lib/%%PORTNAME%%-%%LIBVERSION%%.a
|
||||
lib/jx/lib/%%PORTNAME%%-%%LIBVERSION%%.so
|
||||
lib/jx/make/%%EXTRALIBFILES_MAKE_FILES%%
|
||||
lib/%%PORTNAME%%-%%LIBVERSION%%.a
|
||||
lib/%%PORTNAME%%-%%LIBVERSION%%.so
|
||||
lib/%%PORTNAME%%-%%LIBVERSION%%.so.%%LIBNUMBER%%
|
||||
%%PORTDOCS:%%share/doc/jx/LICENSE_%%PORTNAME%%
|
||||
%%PORTDOCS:%%@unexec rmdir %D/share/doc/jx 2>/dev/null || true
|
||||
@dirrm include/%%INCLUDEDIR%%
|
Loading…
Reference in a new issue