Update harfbuzz to 1.0.1. [1]
Fix build on mips. [2] PR: 202176 [1], 201681 [2] Submitted by: olivierd@ [1], Carlos J Puga Medina <cpm@fbsd.es> [2]
This commit is contained in:
parent
0c3232e0ce
commit
d1db3c49d3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=394056
3 changed files with 20 additions and 4 deletions
|
@ -2,7 +2,7 @@
|
|||
# $FreeBSD$
|
||||
|
||||
PORTNAME= harfbuzz
|
||||
PORTVERSION= 0.9.41
|
||||
PORTVERSION= 1.0.1
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= http://www.freedesktop.org/software/harfbuzz/release/
|
||||
|
||||
|
@ -20,7 +20,7 @@ GNU_CONFIGURE= yes
|
|||
CONFIGURE_ARGS= --with-graphite2
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
PLIST_SUB+= LIBVER=0.941.0
|
||||
PLIST_SUB+= LIBVER=0.10000.1
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (harfbuzz-0.9.41.tar.bz2) = d81aa53d0c02b437beeaac159d7fc16394d676bbce0860fb6f6a10b587dc057c
|
||||
SIZE (harfbuzz-0.9.41.tar.bz2) = 1188176
|
||||
SHA256 (harfbuzz-1.0.1.tar.bz2) = 32a1a7ad584a2f2cfba5c1d234d046c0521e86e7a21d403e15e89aa509ef0ea8
|
||||
SIZE (harfbuzz-1.0.1.tar.bz2) = 1211877
|
||||
|
|
16
print/harfbuzz/files/patch-src_hb-atomic-private.hh
Normal file
16
print/harfbuzz/files/patch-src_hb-atomic-private.hh
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- src/hb-atomic-private.hh.orig 2015-04-10 02:16:57 UTC
|
||||
+++ src/hb-atomic-private.hh
|
||||
@@ -103,8 +103,12 @@ typedef int hb_atomic_int_impl_t;
|
||||
#define hb_atomic_int_impl_add(AI, V) __sync_fetch_and_add (&(AI), (V))
|
||||
|
||||
#define hb_atomic_ptr_impl_get(P) (void *) (__sync_synchronize (), *(P))
|
||||
+#if defined(__FreeBSD__) && defined(__mips__)
|
||||
+#include <machine/atomic.h>
|
||||
+#define hb_atomic_ptr_impl_cmpexch(P,O,N) atomic_cmpset_rel_32 ((uint32_t *)(P), (uint32_t)(O), (uint32_t)(N))
|
||||
+#else
|
||||
#define hb_atomic_ptr_impl_cmpexch(P,O,N) __sync_bool_compare_and_swap ((P), (O), (N))
|
||||
-
|
||||
+#endif
|
||||
|
||||
#elif !defined(HB_NO_MT) && defined(HAVE_SOLARIS_ATOMIC_OPS)
|
||||
|
Loading…
Reference in a new issue