Fix install.
PR: 43499 Submitted by: Tilman Linneweh <tilman@arved.de> (with slight modification)
This commit is contained in:
parent
5ade57f205
commit
d200ec4eeb
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=67257
3 changed files with 30 additions and 4 deletions
|
@ -15,11 +15,13 @@ MAINTAINER= ports@FreeBSD.org
|
|||
|
||||
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
|
||||
LIB_DEPENDS= musicbrainz.2:${PORTSDIR}/audio/musicbrainz \
|
||||
gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
|
||||
ttf.4:${PORTSDIR}/print/freetype
|
||||
ttf.4:${PORTSDIR}/print/freetype \
|
||||
id3:${PORTSDIR}/audio/id3lib
|
||||
|
||||
USE_PERL5= yes
|
||||
USE_GNOMENG= yes
|
||||
USE_GNOME= gtk12
|
||||
USE_GNOME= gtk12 gdkpixbuf gnomehier
|
||||
USE_X_PREFIX= yes
|
||||
WANT_GNOME= yes
|
||||
USE_GMAKE= yes
|
||||
USE_AUTOCONF_VER=213
|
||||
|
@ -45,7 +47,7 @@ PLIST_SUB+= ESOUND="@comment "
|
|||
.endif
|
||||
|
||||
.if defined(WITH_LIBARTS) || defined(WITH_ALL_PLUGINS)
|
||||
LIB_DEPENDS+= artsc.0:${PORTSDIR}/x11/kdelibs2
|
||||
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
|
||||
PLIST_SUB+= LIBARTS=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-arts
|
||||
|
@ -81,6 +83,12 @@ post-install:
|
|||
@${MKDIR} ${PREFIX}/etc/sdr/plugins
|
||||
${INSTALL_DATA} ${FILESDIR}/sdr2.plugin.S100.audio.rtp.mpa.zinf \
|
||||
${PREFIX}/etc/sdr/plugins
|
||||
-${MKDIR} ${PREFIX}/share/gnome/apps/Audio
|
||||
${INSTALL_DATA} ${WRKSRC}/installer/unix/linux/Zinf.desktop \
|
||||
${PREFIX}/share/gnome/apps/Audio/
|
||||
-${MKDIR} ${PREFIX}/share/pixmaps
|
||||
${INSTALL_DATA} ${WRKSRC}/installer/unix/linux/zinf.png \
|
||||
${PREFIX}/share/pixmaps/zinf.png
|
||||
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/zinf
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
16
audio/zinf/files/patch-Makefile.in
Normal file
16
audio/zinf/files/patch-Makefile.in
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- Makefile.in.orig Mon Sep 30 01:27:04 2002
|
||||
+++ Makefile.in Mon Sep 30 01:29:57 2002
|
||||
@@ -142,13 +142,6 @@
|
||||
install-zinf: zinf
|
||||
$(mkinstalldirs) $(DESTDIR)$(bindir)
|
||||
$(INSTALL_PROGRAM) zinf $(DESTDIR)$(bindir)
|
||||
- $(mkinstalldirs) /usr/share/pixmaps
|
||||
- $(INSTALL_DATA) installer/unix/linux/zinf.png $(GTK_PREFIX)/share/pixmaps
|
||||
- $(mkinstalldirs) /usr/share/gnome/apps/Audio
|
||||
- $(INSTALL_DATA) installer/unix/linux/Zinf.desktop $(GTK_PREFIX)/share/gnome/apps/Audio
|
||||
- if test -f "MakeTheme"; then \
|
||||
- $(INSTALL_PROGRAM) MakeTheme $(DESTDIR)$(bindir);\
|
||||
- fi;
|
||||
|
||||
uninstall-zinf:
|
||||
-${RM} $(DESTDIR)$(bindir)/zinf
|
|
@ -31,6 +31,8 @@ lib/zinf/plugins/wavout.pmo
|
|||
lib/zinf/plugins/winamp.ftf
|
||||
lib/zinf/plugins/winamp_theme.xml
|
||||
lib/zinf/plugins/xingmp3.lmc
|
||||
share/gnome/apps/Audio/Zinf.desktop
|
||||
share/pixmaps/zinf.png
|
||||
share/zinf/themes/Aquatica.fat
|
||||
share/zinf/themes/Zinf.fat
|
||||
share/zinf/themes/ZinfClassic.fat
|
||||
|
|
Loading…
Reference in a new issue