- Correct pkg-plist - don't use absolute pathnames there;
- don't install useless .la file; - use libgnugetopt in rioutil(1).
This commit is contained in:
parent
f60b96b772
commit
d29487312e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=48681
4 changed files with 57 additions and 9 deletions
|
@ -17,9 +17,9 @@ LIB_DEPENDS= id3:${PORTSDIR}/audio/id3lib \
|
|||
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
|
||||
|
||||
USE_GMAKE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
MAN1= rioutil.1
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
18
audio/rioutil/files/patch-ltmain.sh
Normal file
18
audio/rioutil/files/patch-ltmain.sh
Normal file
|
@ -0,0 +1,18 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- ltmain.sh 2001/10/11 11:48:44 1.1
|
||||
+++ ltmain.sh 2001/10/11 11:49:30
|
||||
@@ -4175,10 +4175,12 @@
|
||||
fi
|
||||
|
||||
# Install the pseudo-library for information purposes.
|
||||
+ if false; then
|
||||
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
|
||||
instname="$dir/$name"i
|
||||
$show "$install_prog $instname $destdir/$name"
|
||||
$run eval "$install_prog $instname $destdir/$name" || exit $?
|
||||
+ fi
|
||||
|
||||
# Maybe install the static library, too.
|
||||
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
|
32
audio/rioutil/files/patch-src::Makefile.in
Normal file
32
audio/rioutil/files/patch-src::Makefile.in
Normal file
|
@ -0,0 +1,32 @@
|
|||
|
||||
$FreeBSD$
|
||||
|
||||
--- src/Makefile.in.orig Mon Sep 17 21:41:29 2001
|
||||
+++ src/Makefile.in Thu Oct 11 15:04:39 2001
|
||||
@@ -204,7 +204,7 @@
|
||||
INCLUDES = -I$(top_srcdir)/include -I/usr/local/include
|
||||
|
||||
riofck_SOURCES = fckrio.c
|
||||
-rioutil_SOURCES = main.c getopt.c getopt1.c main.h getopt.h
|
||||
+rioutil_SOURCES = main.c main.h
|
||||
@MACOSX_TRUE@rioutil_LDADD = -L/usr/local/lib $(top_srcdir)/librioutil/librioutil.la -lIOKit -lstdc++
|
||||
@MACOSX_FALSE@rioutil_LDADD = -L/usr/local/lib $(top_srcdir)/librioutil/librioutil.la -lstdc++
|
||||
@MACOSX_TRUE@riofck_LDADD = -L/usr/local/lib $(top_srcdir)/librioutil/librioutil.la -lIOKit -lstdc++
|
||||
@@ -223,7 +223,7 @@
|
||||
CPPFLAGS = @CPPFLAGS@
|
||||
LDFLAGS = @LDFLAGS@
|
||||
LIBS = @LIBS@
|
||||
-rioutil_OBJECTS = main.$(OBJEXT) getopt.$(OBJEXT) getopt1.$(OBJEXT)
|
||||
+rioutil_OBJECTS = main.$(OBJEXT)
|
||||
rioutil_LDFLAGS =
|
||||
riofck_OBJECTS = fckrio.$(OBJEXT)
|
||||
@MACOSX_TRUE@riofck_DEPENDENCIES = \
|
||||
@@ -382,7 +382,7 @@
|
||||
../include/usbdevfs.h ../include/usbdrv.h ../include/rio_usb.h
|
||||
getopt.o: getopt.c ../include/config.h
|
||||
getopt1.o: getopt1.c ../include/config.h
|
||||
-main.o: main.c ../include/config.h ../include/rio.h main.h getopt.h
|
||||
+main.o: main.c ../include/config.h ../include/rio.h main.h
|
||||
|
||||
info-am:
|
||||
info: info-am
|
|
@ -1,8 +1,6 @@
|
|||
/usr/local/bin/rioutil
|
||||
/usr/local/bin/riofck
|
||||
/usr/local/man/man1/rioutil.1.gz
|
||||
/usr/local/include/rio.h
|
||||
/usr/local/lib/librioutil.so.0
|
||||
/usr/local/lib/librioutil.so
|
||||
/usr/local/lib/librioutil.la
|
||||
/usr/local/lib/librioutil.a
|
||||
bin/riofck
|
||||
bin/rioutil
|
||||
include/rio.h
|
||||
lib/librioutil.a
|
||||
lib/librioutil.so
|
||||
lib/librioutil.so.0
|
||||
|
|
Loading…
Reference in a new issue